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Flood Control District of Maricopa County
Announces a FREE Seminar On

Drainage Design Management system Software for Windows
(DDMSW)

Seminar

A free, four-hour seminar on the completely revised DDMSW software including: revised user interface, new
features, software overview, hydrology elements, and a working example will be held twice at the Maricopa
County Public Works Computer Learning Center (see map below). The first session will be 8:30 am - 12:30
pm on Tuesday June 21,2005 and the second session will be 8:30 am - 12:30 pm on Wednesday June 22, 2005.

Each seminar will be presented by Kenneth Lewis ofKVL Consultants Inc. Mr. Lewis is President ofKVL
Consultants, Inc., a firm specializing in Stormwater and Flood Control Master Planning and developing
computer applications for GIS/System modeling integration. Before establishing his own firm in 1994, Mr.
Lewis served as: Director of GIS for Boyle Engineering Corporation in the US; Manager ofPlanning for
Europe, the Middle East and Africa for Ingersoll Rand Company in London, UK; Manager, Malaysia for
Sinclair Knight Consulting Engineers, in Kuala Lumpur, Malaysia and Project Engineer for Sinclair Knight
Consulting Engineers in Sydney, Australia. He is the author and programmer for DDMSW.

To Register
Please contact Harry Hollander, Organizational Development and Training Manager, Maricopa County Public
Works, at hah@mail.maricopa.gov .
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8:30 am -10:15 am
System Overview
Program Installation
General Features
File
Tools
Admin
Help

10:15 am -10:30 am
Break

10:30 am -11:30 am
Hydrology
Agency Defaults
Project Defaults
Rainfall
Soils
Land Use
HEC-l Diversions, Routing and Storage
HEC-l Network
HEC-l Model
HEC-l Graphs

11:30 am -12:30 pm
HEC-l Example

For Technical Questions
Please contact Bing Zhao, Engr. Application
Development Branch Manager, Engineering Division,
FCDMC at biz@mail.maricopa.gov, or
Joel Finkel, Engr. Application Developer/Programmer,
Engineering Division, FCDMC, at
ilf@mail.maricopa.gov .
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• Chapter 1

System Overview

Introduction

•

The Drainage Design Management System for Windows (DDMSW) has been written to facilitate data
management and computational procedures required for drainage analysis in Maricopa County. This manual
serves as a guide in the use of the program and is intended to be used in conjunction with the County's
Drainage Design Manuals.

The program is written in Microsoft Visual FoxPro and currently includes modules for File, Edit, Hydrology,
Tools, Admin, Agency and Help. Agency is only available with a password.

DDMSW is a relational database that can manage multiple projects from one single location. The System is
a multi-tasking window based application that enables the user to open several 'windows' simultaneously.
New features include pull-down menus, user-friendly screens which the user can arrange on the desktop, and
windows editing tools to facilitate data entry. DDMSW utilizes a relational database that includes tables for
data entry and editing. Each table appears as a separate '.DBF' file on disk. The tables are related to each
other based on the key field 'ProjectlD' which is established when starting a new project. Model runs are
automated from a menu and the data for running the models is extracted from the various tables in the
database.

Basic Database Terminology
The application stores data (values) in a relational Database. This data is organized into tables, fields, and
records to make it more meaningful. For example, 01 by itself is meaningless. However, in a table called
'Basins', in a field called 'Basinld', in a record corresponding to 'EXAMPLE1', we now understand that 01 is a
major basin in project EXAMPLE1.

A table is a grouping of data. The data is dynamic because it can be modified, deleted, added to and used in
other relations. The following is an example of a table:

Table: Basins

ProjectlD
00002
00002

BasinlD
01
02

Description
Major Basin 01
Major Basin 02

Sort
10
20

•

A table is composed of one or more fields. In the example, the fields are ProjectlD, BasinlD, Description, and
Sort. Fields are similar to columns in a spreadsheet. All fields in a table have the same format (e.g. text of
maximum 70 characters, numeric 12 places with 2 decimals) and they share the same characteristics.

A table also consists of one or more records. Records are similar to rows in a spreadsheet. In the example,
"00002, 01, Major Basin 01, 10' compose one record in the table 'Basins'. The example shows a total of two
records and four fields.

In DDMSW, the database is composed of tables that organize and store information. A common field in
each table, ProjectlD, ties all the table data together for each individual project.

---------------- - -
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Program Installation

DDMSW
The software used in DDMSW requires:

DDMSW
HEC-1
Prefre
MCUHP1

PFE
Acrobat Reader

Compiled application
Most recent HEC-1 with modifications
Rainfall model
FCDMC's DOS program to calculate time of concentration and storage
coefficient for Clark unit hydrograph

Text editor (Programmer's File Editor)
PDF file reader

All required software for DDMSW is included except Acrobat Reader, which can be downloaded from the
Web.

Insert the DDMSW CD in the CD drive (here denoted as X). Run X:\DDMSW\Setup from the RUN command
(substitute your CD drive letter for X). Follow the instructions on the screen.

The user can choose the program's location, but assuming C:\DDMSW, the following directory structure will
be created:

•
C:\DDMSW
C:\DDMSW\Backup
C:\DDMSW\Data
C:\DDMSW\Help
C:\DDMSW\Models
C:\DDMSW\ModIRuns
C:\DDMSW \Reports
C:\DDMSW\Temp

Program files
Directory for archiving data
Data Files
Help files
Model programs
Default directory for model runs
Reports
Directory for temp files

•

The procedure will notify the user when the installation is complete.

Adobe Acrobat Reader
Adobe Acrobat Reader is required to print the user manual and view other files. If Adobe Acrobat Reader is
not currently installed on your computer, then it will be necessary to install the program. The latest version
can be downloaded from Adobe's website at www.Adobe.Com. Follow their instructions to download and
install 'Acrobat Reader'.

Starting the Software
DDMSW is started by running 'STL.EXE'. The program can be accessed from the Windows Startup menu or
other selected folder or by double-clicking on the icon. The Startup directory should be 'C:\ST\Data' or
wherever the data files are located.

When the software is first installed, it is necessary to access:

1. 'File/Select Project' to establish project defaults.
2. 'File/Project' Paths to establish project paths.
3. 'Tools/Options' to establish system settings and paths.

The following is a sample of the desktop icon to run the application and the properties of the program are
shown on the following page. These may vary depending on the installation directory selected.

Drainage Design Management System - Users' Manual
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• f(DM( DDM5W Properties • F

General Shortcut ISecurity I
s
~ <VL FCDMC DDMSW
~

Targettype: Application

Targetlocation: St

Targel: IC: \S t\sll. exe

P' Rllr,ln eparate memory pace r Run as different user

Start in: 1C:\St\Oata

Shortcut key: INone

-!.L~.l

Run: fNormal window

•

•

Comment: II
Find Target... I Change Icon...

OK I Cancel Apply
. --------

Drainage Design Management System - Users' Manual
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Network Installation
For Users wishing to manage their projects on a network, the following procedure should be followed:

1. Install the application on all computers that will be running the application.

2. Install the application on the network drive (Shown as K: on the figure below).

S
T(VL

3. Right click on the icon ~ used to start the software and select properties.

4. Modify the Start in property to point to the "Data" subdirectory on the Network Drive. For example,
assume that the network installation for DDMSW is located at "K:\DDMSW" where "K" is a mapped
directory to the local network, and then modify the "Start in:" field of the DDMSW properties to
"K:\DDMSW\Data".

DDMSW Properties -. ":,}

General Shortcut ISecurity I
S

~(VL DDMSW
)

Targettype: Application

Targetlocation: St

Target: IC:\Ddmsw\sU.exe

Run WI "pdr<ltF> memury spact: r Run as different user

Start in: MeiM..

Shortcut key: INone

Run: INormal window

Comment:

Find Target... I Change Icon...

OK Cancel Apply

•

When software patches become available, it is ONLY NECESSARY TO UPDATE THE NETWORK
INSTALLATION. When individual users access the network data, a check of the Network's application
version, reports, models and help files is carried out and any necessary updates to the local machine
are carried out automatically.

------------ -- - - ---- - -
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• Chapter 2

Main Menu

General Features

•

•

File Edit Hydrology Tools Admin Agency Window Help

The Main Menu is the center of the application. This is the screen that is displayed when the user starts the
application. It is also the screen the user is always returned to after closing a submenu or screen.

Specific actions can be accessed through the pull-down menus shown on the Main Menu bar. This manual
will explain the functions available on each menu and will describe the individual elements shown on data
entry screens. Depending on the type of application installed, some of these menu options may not be
available.

Standard Buttons
There is a toolbar of standard buttons, which is identical on each data entry screen. The buttons become
available/unavailable depending on the current action.

Goes to the first record in the table.

Moves to the previous record.

Moves to the next record.

Goes to the last record in the table.

Save the changes to the current record.

19 Undoes the last command or action.

Prints a report of the current table to the screen.

Searches for the first record based on the typed selection criterion.

Deletes the current record. Use this with caution! Deleted records cannot be retrieved.

Use this to add a new record. When this button is clicked, a blank record appears for the user to enter
values. Select Save to keep the data, or Cancel to discard the addition.
Closes the current screen and returns the user to the Main Menu or previous screen. Pressing [Esc]
will also close the screen and return the user to the previous screen. However, changes to the current
record may not take effect.

Drainage Design Management System - Users' Manual
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•
Common Buttons
The following buttons appear on several forms and basically perform the same function:

•

•

Cop~

IMajor Basin I
1lpdate

Renumt!er

Print...

Copies the existing record to a new record so that only changes need to be edited.

Shows a screen of all available major basins in the current project. Data on open forms will
be filtered to the selected major basin.

There are two types of update:
On a default form, it updates default data from agency data. Check the options to be
updated.

Update Defaults from Ageoncy

r
Update

F7 Rainfall I
'" Land Use
rSolis

l,lpdate QK

On a non-default form, it updates the data by performing calculations. The user selects the
record, major basin or entire project to be updated.

Select Update Option

[

rAil =l
r. This Major Basin

r This Record J

I 1lPdate I Qancel I

This renumbers the current 'sort' data in tens.

Prints the corresponding report for this data.

Saves the record with the current edits. This is only visible in "Edit" mode.

Discards all current edits. This is only visible in "Edit" mode.

Drainage Design Management System - Users' Manual
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Edit Menu
The Edit menu is available to the user during data entry or editing. The menu comprises the following
functions. Some or all may be available depending on the action currently being executed.

Undo
Redo
Cut
Copy
Paste
Clear
Select All
Find
Replace

Window

Undoes the last command or action.
Repeats the last command or action.
Removes the selection and places it onto the Clipboard.
Copies the selection onto the Clipboard.
Pastes the contents of the Clipboard.
Removes the selection and does not place it onto the Clipboard.
Selects all text or items in the current window.
Not available
Not available

This menu item is available when a screen is opened.

Arrange All
Cascade
Close All

1Ranal Data

., ZSoils ·MB: 01

Arranges the open screens tiled on the desktop.
Arranges the open screens in a cascading from left to right on the desktop.
Closes all open screens.
Lists all open screens with a checkmark next to the current one.

•

•

Data Screens
Screens display multiple records on a grid and details of the current record. Only data for the current record
can be edited. Use the vertical scroll bar to move through records on the grid and highlight a record to edit.

The user can move and resize screens according to preference. Changes made to window position are
retained in the application.

On tabbed forms, right clicking on the tab of the grid or details screen will display information about the form.
On regular forms. the user can right click on the body of the form to display information.

Drainage Design Management System - Users' Manual
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• Chapter 3 File

fFjle Edit Hydrology Tools Admin Help

B.eports

Project Management

Import Data

~xport Data

Select Project

E~it Alt+X

•
Select PrOject _ ••

List

Look for I
Details

Reference

EXAMPLE1
EXAMPLE2
EXAMPLE3
EXAMPLE4

10 Tille

00114 Clark, Green Amp~ Single, 6 Hour
00115 S-Graph, Green-Ampt, Single, 24 Hour
00116 S-Graph, Green-Ampt, MUltiple, 6 Hour
00117 Clark, Init and Uniform, Single, 6 Hour

Print... Q.elete Add l,lpdate I QK

•
The selection of Select Project from the File Menu is used to select, edit or create a new project. To add a
new Project, click on the 8dd button. To delete a Project, click on the Qelete button.

New Project
The selection of New Project from the File Menu is the same as Select Project except that a new record is
automatically added to the Projects table.

Drainage Design Management System - Users' Manual
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Selec' rlOled EI:

• I.lst

Project 10 100076 Reference

TiDe S-Oraph, Oreen-Amp~ Multiple, 6 Hour

location IMaricopa County, AI. -

Agency IFCDMC

Project Oefaults
Model r-IH-E-c1-----03..,

Land Use Agency IFCDMC .-:J
Rainfall INOM .d

Delalls

HEC-1 Oefaul

Untt Hydrograph S-Oraph

Loss Method ,i-o-re-en--Am-Pt---=:o:J=i

Storms IMultiple :o:J

Duration 16 Hour 3
Tab Inleoval (NMIN) I 5 :±J
No Ordinates (NO) 12000 3

output 00) I 5 :±J

•

•

P[1nl I Qelete I Add I lJ.pdate I QK

When adding a new Project, it is necessary to fill in the data for the Reference. The Reference field can be
letters or numbers and should not contain spaces. The reference is used in the header for reports and in
naming the backup "zip" file. The Project ID will be used throughout the application for all files that refer to
this project. It is automatically created when adding a project. To select a project, use the mouse to highlight
a project from the list and click OK.

The defaults entered are used to establish available forms throughout the application. Click on the 'Details'
tab to enter or edit defaults for the project.

• The selection of HEC-1 or Rational for the Model will determine available options for this project.
• 'Land Use Agency' establishes the agency land use default data to be used.
• 'Rainfall' establishes the Rainfall data (if custom) or method to develop the data.

If the HEC-1 model is selected, then additional hydrology defaults need to be set. These include: Unit
Hydrograph, Loss Method, Storms, Duration, Tabulation Interval, Number of Ordinates and Output.

Updating this form opens a screen to 'Update Defaults'. By checking any or all of the options, the default data
will be imported into the project. The 'Update Defaults' screen is available on all default data forms.

To add a new project, click the Add button to display a blank record. After entering all project data, click

gave

When deleting a record from this form, all records in all tables for this project will be deleted.

Project Paths
Use the Project Paths screen to input the location of model runs. This is machine dependent and may be
different for each computer. Use the~ button to locate the folder or file and then save the change.

The Model Runs Path should be a separate subdirectory for each project to prevent one project's model runs
overwriting the model runs from another project.

Reports
The Reports screen lists all reports or a sub-group of reports.

Drainage Design Management System - Users' Manual
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LocatJOn

r. Screen

r Printer

Section

r. File

r Hydrology

r f rj I

r IJ tI<l1

r Agency

TItle ...
I

Table Descriptions

Field Descriptions

Error Log

...
II d

Print... QK

Select the report to be printed, and choose the output location (Screen or Printer), and click Plin. I.

• Page 1

Area ID

1A

18

FCDMC
DrainaRe DesiRn M3naRement System

SO ILS
Project Reference: E XAMPL E1

SoillD Area Area XKSAT Rock Effective
(sq mi) ('1) Percent Rock ('1)

('1)

64612 1.720 25.70 0.01 100

6'1619 0.460 6.70 0.19 100
64612 0.270 4.00 0.01 100

64672 0.890 13.30 0.09 30.00 100
64622 0.670 10.00 0.04 100
64677 0.220 3.30 0.05 100

64622 1.120 16.80 0.04 100
64624 1.340 20.10 0.02 100

64612 1.380 24.20 0.01 100
84.'11a 1 ?~n ?1 ~n DIg .nn

•

Keep in mind that when a report outputs to the screen, the user is able to select to print or export it by using

the Reports toolbar at the top of the report. By clicking ~, the user can choose to print all or selected pages

of the report. Click the Export Icon ~ to select a format and destination for the export file. This enables the
user to exchange project data with other applications. Always close the current report view when you are
finished, otherwise the report generator will remain open.

------------------ -
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The following options are available to the user for managing project files:

Project Management

•

•

•

Adion
Co" Copy Proloct

r BIt~up Project

r Import Project

r CI.an Up Orphan Rt<onl.

AdJon
r Copy Project

Co" Backup PIOJ.ct

r Import ProJliC"1

r Clean Up O,phin Records

AdJ••
r Copy PrOject

r Backup Project

(:' Import Project

r Clean Up Orphan Records

Look n I ...!J Backl.p

ProJe" I PLEI

To proJectlTEST COpy

ProJett IEXAMPLEI

~opy

Import

OK

~ Copy Project

Creates a new project and copies all records in
the in the selected From Project to the new "To
Project". Model files are not copied. Select the
current project from the drop-down list and enter
the name of the new project in the 'To' field. Click
the Copy button.

.E Backup

As a security measure, backups should be
performed on a regular basis. The selected files
are backed up into a compressed file in the
'Backup' subdirectory of the main program. For
additional insurance, these .zip files can be copied
onto a CD and taken offsite.

.E Import

When the 'Import' button is clicked, a dialogue box
appears for the user to select a project backup file
(.zip extension). If the project already exists in
the database, a message appears to warn the
user that all data in the current project will be
deleted and replaced with the imported data. The
user has the choice to continue or cancel.

Drainage Design Management System - Users' Manual
126-o013.doc

3-4



• Actlon
r CopyProle<t

(" B~tkupProJet1

r !mparlProjett

(; Clean Up Orphan Records

~1••nUp QK

Note ~:

2:!.1 Clean Up Orphan Records

Occasionally there are records left in tables that
are not associated with a project. This option
deletes the 'orphan records' in tables that do not
have a Project 10 in the Projects table.

No

•

•

('1•
This program deletes orphan records in tables
that do not have a Project ID in Projects and do not
have a major basin In Major Basins.

Do you want to continue?

Yes II__ 1.....--_

Drainage Design Management System - Users' Manual
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Import Data
The selection of 'Import Data' from the 'File' menu is used to import data originating from another source,
such as a spreadsheet, text file or database, into a selected table. The file formats supported include DBF,
XLS, TXT and CSV, as described in 'Export Data'. There are two options:

Append Data This option adds the data to the existing data. The results will include the current and the
newly imported data.

Replace Data This option deletes the current data in the table, and then replaces it with the new data.

It is important that the data to be imported has the same structure as the importing table, otherwise fields will
be truncated and records rejected. For this reason, a good practice is to first export a table and then use the
exported file as a template for the acceptable format.

•

Sedloll
(!)AII

o Hydrology

File Type
(!)DBF

OXLS

OIXT
OCSV

Import Type

(!)Append

OReplace

--- - ---
Section Description {

Hydrology Hec1 Diversions
Hydrology Hec1 Modei Network

Hydrology Hec1 Routing Data

Hydrology Hec1 Storage Basins

Hydrology Land Use Data
Hydrology Land Use Defaults
Hydrology Manual S-Graph
Hydrology Soli Data

Hydrology Subbasin Data

~

I I
I I

I
v

< I [>:' I-

I jmport II QK

, It is crucial that data is Imported using the Import Data tool only and not through any other
• means, otherwise primary keys are lost and the database loses its referential integrity.

•

The user can view the list of tables pertaining to a
specific section by clicking on the appropriate
Section button. Highlight the table to append or
replace, select the file type and click Import. The
following dialogue box appears for the user to
select the file to import. Highlight the filename
and click OK.

Drainage Design Management System - Users' Manual
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- TEMPtEClDATA.D8F

..; xTmp.DEIF

" xTlT¢I\velopeOrves.DeF
:. xTmpHedO«a.DtF

xTnP1e<1<ifopI-Data.1Jllf
xT~IModet«:twork.DeF

xTnP1e<l~t.ll6F

xTnP1e<lModeRlnSunmoty.1Jllf
, xTnP1e<lScolterGroph.OOF

xTnP1e<lSchematic.DeF

ITeblelDBF

~, .d.!.J~

iJ I!J cH~·

Ii1J xTmpl..-dJseDat•. ll6F
Iii! xTmpScalterGroph.DBF
Ill! xTmpSubBosirDate,1Jllf
rn xTmplJrIq, IJllf

rn xTmpLJr;tHydoo<;,ephTempFle.OOF
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Export Data
The selection of Export Data from the Utilities menu is used to export a Table from the Database to a file in a
different format. All the record data in the Table are exported. Note that the Table contents are not removed,
but are copied to a different file format. The file formats supported include:

DBF Exports data into a format that can be read by a Database program such as Dbase or FoxPro.
Please note that this DBF format is not the same file structure as the DBF files in this application.

XLS Select this type to create a spreadsheet that can be opened in Microsoft Excel.

TXT Data is exported one record per line in ASCII text that can be read by any text editor. The data is in
fixed format (columns). For example:
BETA010 H Dry 25.0 0 0.250.050 Max Mountain 0.0010
BETA010 H Dry 30.0 0 0.150.040 Hi Hillslope 0.0020

CSV Data is exported into a file one record per line, with each field separated by a comma. Character
fields are enclosed in quotes. For example:
"BETA010","M","Dry",25.0,O,O.25,O.050,"Max","","MOUNTAIN",O.OO,"",10
"BETAO10","H","Dry",30.0,0,0.15,0.040,"Hi","HILLSLOPE",0.00,'''',20

Selecl d Table l~ Export ~

l

"I

." xTmpUrltHycirographTempFie.OBF

Savein: G: Temp

~ tempZip

~ I~~: TEMPHECIDATA.DBF
My Recent "'" xTmp.OBF
Documents ,,' xTmpEnvelopeCurves.OBF

•• xTmpHeclData,DBF

, xTmpHeclGraphData,OBF

Desktop '" xTmpHeclModelNetwork.OBF
... xTmpHecIModelRunlmport.OBF

";, xTmpHeclModelRunSummary.OBF

--l "ii xTmpHeclScatterGraph.OBF

My Documents '" xTmpHeclSchematic.OBF
.l.i xTmpLandUseData.OBF

. xTmpScatterGraph.OBF

= xTmpSUbBasinData.D8F

'" xTmpUnlq.OBF
MyComputef

lsection
I

Hydrology Hec1 Diversions

Hydrology Hec1 Model Network

Hydrology Hec1 Routing Data

Hydrology Hec1 Storage Basins------
Sdve As

Section

OAiI

@Hydrology

File Type

@DBF

OXLS

On<r
OCSV

•

My Network

Fae name

Save as type:

Save

Cancel

•
Use the mouse to highlight a Table, select an export type from the 'File Type' selection box and click Export.
The contents (all records) of the selected Table are saved on disk in the chosen format. The user is
prompted to enter a filename and location for the export file.

Exit
Closes all open database files and exits the application. Programs such as Acrobat, Crystal Reports, and the
Text editor must be closed separately.
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• Chapter 4

Overview

Hydrology

Hydrology H9dr~ufl Tools

£lain/all

~oiIs

soa Qefaults

hand Use

Land Use Defaults

Major Basins

Sub~asins

.!::1Ee-, ~

The options available for Hydrology depend on whether the HEC-1 Model or Rational Method was selected
as the project default model in 'Select Project'. Rainfall, Land Use, Land Use Defaults, Major Basins and Sub
Basins are common for both models. Soils, Soil Defaults and HEC-1 are only available for the HEC-1 model
selection.

• 10 Naming Convention
Although not required, it is recommended that a systematic naming convention be used to designate the
unique ID's of sub basins. A typical naming convention is as follows:

•

010005 The first two characters (01) designate the major basin and the last four characters
designate the sub basin .
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•
Rainfall

jJsl

Hon Adjusted Point Rainfall (In)

l:.YUr ~

Delalls

6-Hour ~I~~~~
24-Hour I 999.00

3.30

2.00

~

PrJ"!... I Qraph I J.lpdale I QK

•

•

When first going into the module, if rainfall data is not available, the user is informed to update the data from
the agency default values (by pressing Update). These should be changed depending on the project
location.

The choices for the rainfall default (in 'Select Project') are NOAA or Custom. If NOAA is selected as the
default rainfall then precipitation data is required for the 2-Year, 6-Hour; 2-Year, 24-Hour; 100-year, 6-Hour,

and 100-Year, 24-Hour storm events. Once the data has been entered, click .I,lpdate Ito run the Prefre
model. Prefre populates the data for all of the remaining return periods and durations.

The precipitation data for an area can be determined by clicking on~ and going to the appropriate

location.

If 'Custom' is selected as the default rainfall, no updating takes place and the rainfall data must be entered
manually.

Intensity-Ouration-Frequency (IOF) curves are developed for each minute by a log interpolation of the point

rainfall data. The curves can be viewed in graphic format by clicking I Qraph I.
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•
Soils

This screen is only available for the HEC-1 model option.

l'nSods 1018 01 III~£J

Delails

25.7

Sub Basln

Major Basin 10 I01 ~

Sub Basin 10 rI1-"---'--..d
801110 I 64512 ~

Area (sq mi) I MEl

1<Iea(%) I

Soli Data 1~ l21!i.lIlI wmm
XKSAT r-D01 ro:o;- r

Rock Outcrop (%) r- r
E1Yecllve (%) 100

•

•

Soli DescrlpIJ0r-Il _
Book Number 1645

DescrtpUon r:lc:-a-re-:-fre-e-co-b~bly-C-lay-:-lo-am-,-1-10-e-p-er-ce-nt-s-Io-pe-s---------

Matched XK8AT and Rock Outcrop % to establish equivalent 80iliD
when importing Project.

Copt

The Soils screen is used to enter soils data for the sub basin areas. Soil data is comprised of 'Value',
'Default' and 'Custom' fields. The 'Value' fields are used for the analysis. These fields are populated with the
Default values available in Soil Defaults. To enter a new value, check 'Custom' and input the value. When

llPdale Iis clicked, the area percents are calculated. Note that 'Custom' must be checked for non-default
values to be used, otherwise the default value will automatically override it. When a non-default value is
used, describe the reason in the 'Comments' field.

Generally, the data for this table can be populated by intersecting soils and sub basin area polygons in a
Geographic Information System (GIS) and saving the results to a table with the same format. (Export this
table to see the format). The data can then be imported using the 'Import' function.
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•
Soil Defaults

This screen is only available for the HEC-1 model option.

r:.~ 5011 Deldulls I!II~

Soli

List Details

•

•

Soli 10 !I'''''~
Book Number 1645 ~

XKSAT I 0.41

Rock Outcrop (%) I
oesc~pllon r-IA-nt-ho-s-an-d-Yj-oa-m-s-------------------'

Copy Print I Qelele I ~dd I !.!pdale I QK

Each project has specific soil defaults saved with the project. When I J.!pdale Iis clicked, the agency soil

defaults are imported and saved with the project. This form is used to modify default soil values, although this
is not advisable. Rather, it is recommended that the user create custom values in 'Soils' data.

It is important to enter appropriate values for all fields, as soil calculations for the entire project will be based
on these values. When first entering this form for the project, if soil default data does not exist, the Agency's
default data is loaded into the system.
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•
Land Use

HEC-1
x

l ndUM

USI Oelallo

Atea (sq mQ 2.2200

Area ('to) I 321

landUu Oat

Imllal Loss (lAl , 0 30 I 0 30

Percent Impervous (RTiMP) I 5 I
VegetaIJon Cover I 20 0 1j---'2~0""'0

Mo'sture Oenco (OTHETA) INORMAL ::J INORMAL

Hydraulic Emclency (KnJ I 0 050 I 0050

kliImm
r
r

r
r

Commen'a

Co~ Ppnt I Qelete I 6dd , "alOfBasln I !'/pdate I. ~l

•
Rational Method

\.Ist

land Use

Area (acres) I 'M
Area (%) 11"000

Delalls

land Use O.t.
~ ~ ~

Hear C I I 030 r
SoYearC ;-'---1 030 r

10·YearC I 0.54 , 030 P
25·YearC I I 033 r
50·YearC I I 036 r

100·YearC I 038 r
ReSistance Coemclenl (Kb) IMIN ::J ILOW P

Comments

Co~

•

The 'Land Use' screen is used to enter land use data for the sub basin areas. Enter the major basin, sub
basin and land use code using the selection buttons. Land Use is comprised of 'Value', 'Default' and
'Custom' fields. The 'Value' fields are used for the analysis. These fields are populated with the Default
values available in Land Use Defaults. To enter a new value, check 'Custom' and input the value.

When liPdale Iis clicked, the area percents are calculated. Note that 'Custom' must be checked for non­
default values to be used, otherwise the default value will automatically override it. When a non-default value
is used, describe the reason in the 'Comments' field.

Generally, the data for this table can be populated by intersecting land use and sub basin area polygons in a
Geographic Information System (GIS) and saving the results to a table with the same format. (Export this
table to see the format). The data can then be imported using the 'Import' function.
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•
Land Use Defaults

HEC·1

Usl Oelalls

land Use

l.llnd Us. Code ~~~======:!- _
Group IResidential

Description Ivery Low Density Residential

son I 30 ±l

l nd Use Data

In'tial Loss (IA) 0.30

Pe"ent Impervous (RTIMP) I
Vegelation Cover ;--1---2-0.0....

Moisture Oenen (OTHeT~ INORMAL ::1
HydraUliC Ellicleney (Kn) I 0.050

land Use

l.llndUse Code ~~~====~=::l- _
Group IOpen Space

Description IDesert

Sort 1"'---,0-:8
71
:

•
Rational Method

Renum~er I Co~

List

Ppnt Qelete I ~d I J.lpdale I QK

Oelalls

land Use Data

2-Vear C I 0.54

5-VearC 10:54
1O-VearC I 0.54

25-VearC~

So-Vear C I 0.65

1Oo-Vear C jD.6B
Resistance Coellielenl (l<b) ILOW ::1

Renum!ler I Co~ Print.. Qelete I ~d I J.lpdate I QK

•

Each project has specific land use defaults saved with the project. When Update is clicked, the agency land
use defaults are imported and saved with the project. This form is used to modify default land use values,
although this is not advisable. Rather, it is recommended that the user create custom values in 'Land Use'
data.
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•
Major Basins

HEC-1
x'

Lis'

M 10.8 n

MalorBasrnIO;;...'==----------­
OeSCription IMajor Basin 01

8MI 10±J

"'e. (80 mQ I 23 2400

Commanls Modollng Options

Model ThIs "'.Jor Bas'n F7 klIIIWD

Slo.m IMultiple ::::J r
Tabulabon Interval I 5 ±J r

No Orolnates 12000 ::::J r

Output 1 5 ::3 r

Oel'~'

Alo.. for Dlltrlbudon

&II BE
1 ro;ooo I 099aa

2 10'5 I 0 9940

3 128" I 09750

4 r;6O I 0.9220

5 f900 I Oal00

sr-r­

7r-r­

ar-r­

9r-r-

Custom Areas r

fmer

Rational Method

•
lJsl

II.Jo.8....

MaJor9nlniO

Descoptlon Ir.:M.=:=jo=':r8:=.s':-ln"::"0'--------

8MI 10 ±l
Area (acres) I 26 eo

Comments

DOlaWs

•

Renumber I Copy I Print I Qelete I 6dd I UPdate I .QK

The Major Basins screen is used to enter Major Basin data and defaults for modeling. Major Basins within a
project are drainage basins that generally have a major outfall. Major Basins for HEC-1 models will have
separate HEC-1 input files and a two-character field designates their 10. Single digit numbers must therefore
be preceded by a zero. Within a project, the first Major Basin 10 is designated as "01", the second as "02"
etc. until Basin "99" is reached. If the number of basins exceeds ninety-nine, letters can be used. It is
necessary to have at least one Major Basin (01) in a project.

For HEC-1, check 'Model This Major Basin' to include it when modeling 'All Basins'. To override the default
HEC-1 modeling parameters for Storm, Tabulation Interval, No. of Ordinates and Output, check the
associated 'Custom' and enter a new value. Note that 'Custom' must be checked for non-default values to
be used, otherwise the default value in Project Setup (File=>Select Project=>Oetails) will automatically
override it. When a non-default value is used, describe the reason in the 'Comments' field.

When the \.1pdate Ibutton is clicked, all sub basin areas are summed to obtain the major basin area. For

HEC-1 the appropriate distribution and reduction factor for a single storm or distributions and reduction
factors for multiple storms are established..
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•
Sub Basins
This screen is used to enter sub basin data required for hydrological analysis of the sub basin. It is
necessary to enter the sub basin ID and area. Other parameters are required depending on the model used.

HEC-1
Composite values for land use and soils will be developed from data in the land use and soil tables when
'Update' is clicked. When updating the screen, information on the soils and land use tables are consolidated
for each sub basin and either the time of concentration or lag is calculated. The calculated values become
the defaults for the sub basin. To override these and enter a new value, check 'Custom' and input the value.
Note that 'Custom' must be checked for non-default values to be used, otherwise the default value will
automatically override it. When a non-default value is used, describe the reason in the 'Comments' field.

J;~'1lJblJ.lSm!l MH 01 I!lIiJ x

List

Sub BllIIn

Majo, easln'-I0-1--..d
Sub aasin~=~

SortI 1D:B

Rainfalllo_ • Gr••n-Arnpt

'llllIl llJ!iIIJl klWQm
IA On) ,---o;g r-o.;9 r

DTHElA 0.13 j013 r
PSIF On> J1010 J1010 r

XJ<SATfOOS fOOS r
RTlMP ( )139J39 r

Dela,ls

•
Sub Bn/n Param.t.... S-Gr ph

~ea (sq mQI 5.700 S-Oroph Ivalley ::J
Length (mQI 3.750 Lca(mQ I 0.87

USGel 2284.0 Lag(mln) I 61

DSGel 2195.0 Velocity (fls) I
Slope (llImlll 231 Knl 0049

Renumlle,

Rational Method
When 'Update' is clicked, composite C values, time of concentration and rainfall intensity are established.
From this data, the sub basin Q is calculated. To override the time of concentration methodology for the
County, check 'Custom Tc' and enter an appropriate value. When a non-default value is used, describe the
reason in the 'Comments' field.

~ Sub BdS,"' . Mil 01 1~[ri]!Xl

!.,ist Delalls

Sub Basin Sub Basin Hyd,ology SUlllmary

Major Basin 10 01 12J 1:iI ~ li!.n 2UI ~ 1J1l!:iI

SUb Basin 10 Q (cis) 61 J 92 109 15.1 185
J

2t 9

Sort 10 : C o 251 [ 015 o"25J 018 0301 031

CA(acl,
- r

2eolf
-

2.80 280 3.14 336 341

Snb Basln Parallle,e.. CustomTc 0 0 0 0 0 0
Area (acres) L 11.20

Tc(mlnl
18t jl 160 f 15.0] 13.8lf 13 t ] 125

1Length (Il) r 1,1~0 i I Onlhr) [ 2.4 [ 33 39J 4.8 5.5 1[ 63

Up Grnd Elov
984

Down Grnd Elov 981.5 Comments

Siopo (IlImQ t tl

r

~

Kb 0.030

l~• IRonumllo, II Copy Print.. !leleto Add IIlllalo, Basin II \lPdato .QK
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•
Manual S-Graph

t!Mdnual S-Graph ~.~

Percent Manual .
0 0.0
2 23.0
4 30.0
6 36.0

I
10 45.7
12 50.0
14 54.1
16 58.0
18 61.7 -
20 65.2
22 68.5
24 71.6
26 74.6
28 77.5
30 80.2
32 82.7

34 85.0
36 87.2
38 89.0
40 91.1

Xl -- - .~

..JQLEI

Time In Percent of lag

Percent I 8

Time in Percent Lag I 41.0

Print QK

•

•

The Manual S-Graph option in the HEC-1 menu only shows up if the user selects S-Graph as the default Unit
Hydrograph. It is only necessary to populate the data in this form if "MANUAL" is selected as the S-Graph in
the Sub-Basins form.
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•
HEC-1
The HEC-1 option appears on the Hydrology Menu if it selected as the default model for the project. The
HEC-1 submenu includes the following functions:

Model

!::iEC·' ~

I

Model
NetWOlk

!lata

F~Summary

~IeW OUlput

yraphs

Diyersions

ROU!ing

SlOlaQe

t': Run HEel Model 'I!I~EI

•
Ret...nPeriod

P 2Year
W5Year
P 10Year
P 25 Year
P 50 Year
W100Year

Options

r All Basins

Major Basin 101

WUpdate HEC-l

P Delele Prior Results

Qchematic Qulput Results Run Model It- ~.!<

•

The model screen is used to run the HEC-1 model for the selected return period(s) and major basin. All
major basins selected to model in "Major Basins" can be modeled if the 'All Basins' box is checked. Options
for running the model include:

Update HEC-1
This updates HEC-1 data from sub basins, routing, storage and diversion data. It requires the appropriate
data to be available in the management system.

Delete Prior Results
This deletes all model results for the selected major basin(s) in the Flow Summary table before running the
model.

After making selections, click I Run Model ' to run the HEC-1 model. To view results, click the Results

button. Note, that clicking this button prior to running the model will display the previous model run results. If
there are any errors when modeling multiple runs, it will be necessary to model one basin and a single return
period to help determine the problem. To view the HEC-1 schematic for the 1DO-Year model, click Qchematlc .
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•
Network

t:~ tlEC-1 Model Network - ,,-

Lookfor I
Sort II) Type Route Type Combine Area &

, I
20 R1-2 Route Normal Depth

30 1B Basin
40 C2 Combine 2

50 R2-4 Route Normal Depth

60 1C Basin

70 R3-4 Route Normal Depth

80 1D Basin
90 C4 Combine 3

100 R4-7 Route Normal Depth

110 1E Basin

I
120 R5-7 Route Normal Depth

130 1F Basin

140 R6-7 Route Normal Depth

150 10 Basin
160 C7 Combine 4

170 ST1 Storage

180 DIV1 Divert

·1 ~r

Model Netwoltl

Major Basin 10 ,..'0-1----~
Type IBasin ~ ~

ID 11A ,..
KO Outpu1 I 1 ±l

Renum!!er

•

•

This form is used to establish draft data for the HEC-1 model.

Select the major basin, type and 10. Depending on the type selected, appropriate IDs for basins, divert,
retrieve, route and storage are available for selection. The data needs to be available in their respective
tables to be available. If 'Combine' is entered as the type, it is necessary to enter an 10 and the number of
Combines. If 'Route' is entered as the type, it is necessary to enter the 'Routing Type'.

At any location a KG output number between 1 and 5 can be selected. See the HEC-1 manual for a
description of the outputs for each number.

~reate Draft will place draft data for running the HEC-1 model in 'HEC-1 Data' and also a model input file in the

Model Runs Path directory. The model (with assumed data) can then be run without updating data to check
for network errors. If there are no errors, then update the data with correct information from project tables
(refer to the next section, Data, in this Manual).

Click ~Ito display descriptions for the HEC-1 cards in PDF format.

Drainage Design Management System - Users' Manual
126-Q013.doc

4-11



•
Data
This screen is used to manage data to run the HEC-1 model. It allows the user to import a HEC-1 file or to
edit an existing Major Basin HEC-1 file within a project.

If a file is imported without associated sub basin, land use, soils or routing data, the 'Update' option should
not be used.

Updating the data will search all the appropriate tables for the latest data and replace the existing data in this
file. The same option is available when running the model. When updating from this section, the Return
Period is requested. This way the appropriate rainfall data can be inserted. Use this function together with
"Export" to give another user the HEC-1 file.

An example of importing a "Stand Alone" HEC-1 model is provided in the Help menu for DDMSW.

t~HH: 1 Ditla MB 01 II!I~EJ

Ust Details

•

FO Fl F2 F3 F4 F5 F6 F7 Fe F9 F10 Sort .
10 EXAMPLE3 - S-Gra ph. Gree -Ampt, Multiple ,6 Hour 20
10 2 YEAR 30
10 6 HourS torm 40

I
10 05130/20 03 60
IT 5 1JAN99 1200 2000 70
IN 15 BO
10 5 90
·0 lAGRAM 100. 110
JO 1.29B 0.1000 120
PC 0.000 O.OOB 0.016 0.025 0.033 0.041 0.050 0.05B 0.066 0.074 130
PC 0.OB7 0.099 0.11 B 0.13B 0.216 0.377 0.B34 0.911 0.931 0.950 140
PC 0.962 0.972 0.9B3 0.991 1.000 150

.Ij 1 ?Q? n ~nnn 1 ~n

.~

Renum!l.er

•

Data can normally be established by creating a draft model or by importing an existing HEC-1 model file.
When importing a "Stand Alone" HEC-1 file, the labels for the F2 field of the KK card are automatically added.

The data in this file can be exported to an ASCII file to facilitate editing by clicking on the 'Export' button and
following the instructions on the screen. When finished editing, the file can be imported by clicking on the
'Import' button. Importing replaces the existing data for the selected Major Basin. To view a different Major
Basin's data, click on the 'Major Basin' button and select a new major basin.

llpdate ! replaces HEC-1 model data with data from appropriate sub basin, diversion, routing or storage
tables in the project.
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•

Flow Summary
Flow Summary displays summary results of HEC-1 model runs. The data cannot be edited. This is the same

screen that is displayed when the Results button is clicked on the 'Run HEC-1 Model'screen.

~29

Look'Or I
SOrt Il Type Area 02 05 010 025 050 Ql00 .
20 R1-2 Routed 6.6900 1036 lBB2 2479 3579 4462 5300
30 18 Hydrograph 5.7000 127B 2007 250B 3342 3669 4785
40 C2 Combined 12.3900 2011 3558 4845 6577 7976 9580
50 R2-4 Routed 12.3900 1975 3511 4590 6503 7915 9493
60 1C Hydrograph 0.8100 92 181 268 387 484 580
70 R3-4 Routed 0.8100 91 179 262 382 477 567
80 lD Hydrograph 3.2700 779 1334 1726 22BO 2715 3143
90 C4 Combined 16.4700 2415 4173 5471 7733 9414 11411
100 R4-7 Rou1ed 16.4700 2382 4148 5428 7692 8389 11314
110 lE Hydrograph 1.1100 148 292 417 595 736 B79
120 R5-7 Routed 1.1100 146 287 412 586 739 870
130 IF Hydrograph 3.0800 0 621 335 658 1014 1448
140 R6-7 Routed 3.0800 0 481 331 658 1006 1437
150 10 Hydrograph 2.5800 651 1107 1445 1906 2264 2610
160 C7 Combined 23.2400 2619 4544 6126 B830 10B37 13240

170 STl Routed 23.2400 520 B60 1114 14B4 1772 2069

1~0 DlVl Hydrograph 23.2400 272 540 750 1072 1323 1583 .r
I IMajor BasIn I I\1ow IFIOWS ::J ~,port I Prim fllter QK

The natural order of the model run can be viewed by double clicking on 'Sort' in the grid header. The data
can also be sorted by'ID'.

Use the drop down list to select an appropriate view.

•

View Flo..."... ';

Volumes (IN)

Volumes (AF)
AttenuationNelocity
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•
View Output

This option enables the user to view the HEC-1 ASCII output file. Select the output file by highlighting the file
name and pressing OK or by double clicking on the specific file name. The text editor (as specified in
'Tools/Options') displays the file on the screen. When finished viewing, close the window by clicking [E),
otherwise the text editor program will remain loaded in memory.

x xxxxxxx xxxxx x
x x x x xx

x x x x x
xxxxxxx xxxx x xxxxx x
x x x x x
x x x x x x
x x xxxxxxx xxxxx xxx

THIS PROGRAM REPllCES ALL PREVIOUS VEIlSIONS OF HEC-l lQlOWN AS HECI (JAN 73). HECIGS. HECIDE. AND HECIKW.

THE DEFINITIONS OF VlRIABLES -RTIHP- AND -RTIOR- HA.VE CHANGED FROM THOSE USED tHTH THE 1973-STYI.E INPUT STRUCTURE.
THE DEFINITION OF -AMSKK- ON RH-CARD W'AS CHANGED VITH REVISIONS DA.TED 28 SEP 81. THIS IS THE FORTRIlN77 VERSION
NEV OPTIONS: DAI!I3REAK OUTFLOW SUBMERGENCE. SINGLE EVENT DAllJll;E CAlCULATION, DSS:VRITE STAGE FREQUENCY.
DSS:READ TIME SERIES AT DESIRED CA!.CULATION INTERVAl LOSS RATE:GREEN AND AHPT INFILTRATION
l<INElIA,TIC 'WAVE: NEV FINITE DIFFERENCE ALGORITHM

•

•

LINE

5
6
7
8
9

10
11
12
13
14
15

HEC-l INPUT PAGE 1

ID. . 2. ... 3 . .... ...... 5 . . 6. . 7 . .. . 8 . .. 9 . . ... 10

ID Project ID: lRYTOliN - Majar Basin: 02 - Return Pericx:l: 10 Years
ID 10 YEAR 6 HOUR
IT 1 5FEE99 1200 2000
10 5

XX 020505 EASIN
EA 0.025
PE 2.019
IN 15
PC 0.000 0.014 0.027 0.039 0.058 0.074 0.089 0.106 0.122 0.137
PC 0.154 0.174 0.200 O. U8 0.331 o.... So( 0.665 0.786 0.856 0.901
PC 0.938 0.953 0.969 0.985 1. 000
IG 0.20 0.15 9.70 o.OS ..
UC 0.450 0.200
UA 0 5.0 16.0 30. a 65.0 77.0 84.0 90.0 94. a 97.0
UA 100
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•
Graphs
The 'Graphs' option has been developed to facilitate the review of hydrological results and data input.
Graphs that facilitate the review of hydrological results include envelope curves for USGS, Malvick and
Boughton. These curves are compared to peak or unit discharge model results. Graphs that facilitate the
review of input data include channel cross-sections, diversions, stage-discharge and stage-volume
relationships.

Click U:Miii:l to view the map of the USGS region.

•

Graph I Graph IEnvelope Curves

QK IMajor Basin 101 ::oJ

Graphs Toolbar
The following tools are available on the graph screen:

Type r. Peak

(' Unit

.:lQJ29
Envelope IUSGS :3~

Region 1-1-2c-e-n-tra-I-Ar-iz-on-a---:3-

Copies the graph to the clipboard as a bitmap, metafile, text or OLE object.

93.60

7

1612

•

Data Editor. This displays the data values at the bottom of the screen.
can be edited, and the graph dynamically reflects these changes.

2 3 4 15 6

510 1510 1565 1596 1600'
-

99.70 94.10 93.60' 92.20 92.20

Zoom tool. Click this icon and draw an area of the graph to be magnified.

Prints the graph.

These values

6

1662 2262

94.90 99.70

Please note that the data for the graphs has been rounded to facilitate the graphing function. Therefore the
data is not as precise as the data in the application.
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Select the type of graph, a Major Basin ID, Type, Envelope and Region from the pull-down lists.

• Graph I
:=======~~

Major Basin Envelope Curves

HEC-1 Diversion
HEC-1 Stage-Discharge
HEC-1 Stage-Volume

Envelope r= ~- ~==

Region

G

12 r: entral ,II.t1zona

Major Basin 1-3
~
~

Envelope IUSGS

Region ~
;:::::.:.==========;
11 Northeastern Arizona

Click the Graph button to display the graph on the screen.

mHEC-I Graphs _.: :r."

100 Year Peak Discharge. Drainage Area
USGS Comparative Graphs. 12 Central Arizona Region

Basin: 01

•
~ Graph IEnvelope Curves

QK IMajor Basin 101 :::J

Ijj~ ~IQ~~I

I

Type .. Peak

r Unit

..:J.gJ~

Envelope IUSGS 03~
I
-----~

Region 12 Central Arizona ~
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Envelope Curves (USGS, Malvick and Boughton)

• Type r. Peak

r Unit

Envelope I
Region

Select USGS, Malvick or Boughton data. The USGS data was derived manually from the data contained in
"Methods for Estimating Magnitude and Frequency of Floods in the Southwestern United States", United
States Geological Survey Water-Supply Paper 2433. Northeastern Arizona - Figure 39, Central Arizona ­
Figure 41, Southern Arizona - Figure 42 and Upper Gila Bend - Figure 44. The legend on each of the
graphs is as follows:

Envelope
Region
Low-Mid Elevation

Envelope Curve for Study Area
100-Year Peak Discharge Relation for Region
100-Year peak Discharge Relation for Low to Middle-Elevation Study Area

The Malvick data was derived from "A Magnitude-Frequency-Area relation for Floods in Arizona", Allan J.
Malvick, January 1980, Figure 6 - 1OO-year curve. The Boughton data was derived from "Highway Drainage
Design Manual Hydrology", Report Number FHWA-AZ93-281, March 1993, Figure 10-1 Curve H.

The selection of Envelope Curves from the Graphs pull-down provides the following choices.

~HEC-I Graphs - _.f

• Graph I Graph IEnvelope Curves

QK IMajor Basin 101 ::I
Type to Peak

(' Un~

Envelope _I II ii I
Region

Malvick
Boughton

.dQj~

iiiii3~

If USGS is selected from the Envelope pull-down, then the user can select the appropriate Region as shown.

tjHEC-1 Graphs ""-.:

Graph I Graph IEnvelope Curves

QK IMajor Basin 101 3
Type to Peak

(' Unit

Envelope IUSGS

Region r.i....iI
11 Northeastern Arizona

13 Southern Arizona
14 Upper Gila Basin

.:J.Q.I~

3~
El

•
All of the envelope curves can be graphed in either Peak (Peak Discharge in cfs) or Unit (Unit Discharge in
cfs/sq mil.
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•
Peak Discharges Scatter Graph

The Peak Discharges Graph is a graph of drainage area verses peak discharge (or unit discharges) for sub­
basins and combined flows. The data is generated when running HEC-1 and is saved in Table
HEC1SUMM.DBF. For this analysis, only the 100-year flows are graphed. From within a specific Project, the
user selects a major basin. If the major basin has been modeled, the 100-year area and discharges for
"Hydrographs" (sub-basins) and "Routed" (routed flows) are copied to a temporary file for graphing.

Selection of Major Basin 01, USGS Envelope with Central Region and Peak will produce the following graph:

100 Year Peak Discharge - Drainage Area
USGS Comparative Graphs -12 Central Arizona Region

8asln: 01

I

I
I
I

1000.01000

_. Low-Mid Elev8llon

~

Envelope IUSGS ::3~
Region r11-2 -ce-n-tra-'Ar-jz-o-na---::3'

::3 Type r. Peak

r Unit

10.0

Drainage Area (sq mil

Region

1.0
10

0.1

-Envelope

Gl
,~

'"'ii
.ft!

10...
~

Co

I Graph I Graph IEnvelope Curves

QK I"'ajor Basin 101 ::3

fH Iitill !Ill I q ~ ~ I

I
1000ooo J

!1lXXnll

t!HEC-1 Graphs

•
Note that the toolbar can moved anywhere on the graph screen.

Rating Curves Plot

Rating curves are for Stage-Discharge, Stage-Volume and Diversions. The data is developed from the HEC­
1 input file as follows:

Stage-Discharge
Stage-Volume
Diversions

SE and SQ cards
SE and SV cards
01 and DQ cards

When the user selects a new Major Basin, the HEC-1 input file for the Major Basin is scanned for SE and 01
cards. The KK value for all found SE and 01 cards establishes the available ID's to graph. The ID's are
saved to a temporary file and the data for the graphs (SE-SQ, SE-SV and DI-DQ) are saved to a separate
temporary file. The user must also select an 10.

~HE(-l Graphs -.::-: _

•
Graph I Graph I

QK IMajor Basin '-0-1--3
G 10 10lV1
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•
The following three Rating Curve graphs are available:

Stage-Discharge Plot

~HE(-1 Graphs _~ -~

I Graph I Graph IHEC-1 Stage-DiSCharge::::J ID IST1

QK IMajor Basin I01 ::J

•
Stage-Volume Plot

22

~r
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: r
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o
o
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I Graph I Graph IHEC-1 Stage-Volume ::J ID IST1 ::J
QK IMajor Basin 101 ::::J

III'" IlIl IQ [). I!l'
HEC-1 Stage.Volume

Basin: 01
Section 10: ST1

22

t
20

18

16 I
€ 14 J -
Ol 12

1 t + t-el

J-:l
en 10

i 1 "l-

f t •

i I21 1
I

0
0 1000 2000 3000 4000 5000 6000 7000 8000 9000 10000 11000

• Volume (ac.ttl
~

Drainage Design Management System - Users' Manual
126-0013.doc

4-19



•
Diversion Plot

I Graph I Graph IHEC-1 Diversion

QK Major Basin 01

:::J 10 IDIV1

HEC-1 Diversion
Hasin: 01

Section 10: DIV1

'~I1500

1350

1200

~ 1050

~ 900
c= 750
.:

600

450

300

150

0
0

t

t f
1000 2000 3000 4000 5000 6000 7000 8000 9000 10000 11000

Divefllion (cfil)

• Channel Section Plot
Channel section plots are for RX-RY cards developed from the HEC-1 input file. When the user selects a
new Major Basin, the HEC-1 input file for the Major Basin is scanned for RX cards. The KK value for all found
RX cards establishes the available 10's to graph. The 10's are saved to a temporary file and the data for the
graphs (RX-RY) are saved to a separate temporary file. The user selects an 10 for the following typical
graph.

~Hf(-1 G,aphs ""!.

GraPh' Graph IHEC-1 Channel Section :::J 10 I :::J
QK IMajor8asln 101 o:J

HEC.1 Channel Section
Basin: 01

Section 10: R1-2

1036

100 [

99 -

98 ....

g 97 I

1;
96 rell

'm
:l: 95 I

94 r
93 r
92l

91 I

• 335 510 685 860 1211 1386

Distance(ft)
----

1561 1736 1912 2087 2262

II

I2437
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•
Diversions

t:Il£C I (J,velS,ons MO 01 IIII~EI

Ust Delalls

I 0,0

I 50,0

I 180,0

I 350,0

1500,0

2 100.0

3. 200.0

1000.0

10000.0

6

7

~ 8

9.

10

::J

MaxImum Diversions

Volume (aeoll) I
Flow (ets) I;...---'

Diversion Faclllly l"flow'Olversion Oat

Majo, Basin 10 ...,0-1---~ Inftow Diversion
I (era) (ers)

Diversion 10
1 I 0.0

Renumller

•
This is used to enter diversion data for the HEC-1 model. Enter an appropriate Diversion ID and diversion
data. For the Update to run correctly in the HEC-1 model, the Diversion ID must be the same as F1 for the
KK record in the HEC-1 file.

•
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•
Routing

Kinematic Wave and Muskingum-Cunge

t~ttEC-l RoutmgData ~ ~.~ ..

Looklorl

10 Type .
I

R2-4 MUSKINGUM-CUNGE

R3-4 MUSKINGUM-CUNGE

R4-7 MUSKINGUM-CUNGE

R5-7 MUSKINGUM-CUNGE

R6-7 MUSKINGUM-CUNGE

-

'1 .r

Musldngum-Cunge ~

Shape ICHANNEL ::oJ r
Length (II) I 4224.0 r
Slope (Ml) I 0.0012 r

Man'g N I 0.038 r
Width (fl) I 22.00 r

Side Slope (11M I r

• Normal Depth
k.

Look lor I

Copy

...:J

Pont. I Qelete 8dd IMajor Basin I QK

10 Type .
I

R2-4 NORMAL DEPTH

R3-4 NORMAL DEPTH

R4-7 NORMAL DEPTH

R5-7 NORMAL DEPTH

R6-7 NORMAL DEPTH

-

J .f'

...:J

Route

Normal Depth
, LOB N ID.035
ChanN~

ROBN ID.035
Length f4224.iJ
Slope jli:iiiii2

MaxElev~

RSType IFLOW :.:J~
stepsl2 f7

~. from t£C.11

Cop~ Print. I Qelete Md IMajor Basin I QK I I

•
The Routing screen is used to enter data required for the routing of flows in the HEC-1 model. Select the
routing type for each section using the drop down list.

Depending on the routing type selected, different data will be required. It is important that the routing type and
data match the data in the HEC-1 model for the associated 10.

For Normal Depth Routing, the steps can be established by clicking Update from HEC-1. An example of this
procedure can be found in the Help Menu for this application.
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•
Storage

~ttE(-1 Storage FaCIlities ~ MB: 01 ; •

List De/ails

r
Storage Fadlily rStorageJDlsdtarge Data jIPeak Storaga and Stage I
Major Basin 10 101 ,.., 'I storage Discharge Elevation Year Volume Btager-..--., .L:.I (aeoll) (ers) (ft) (aeoft) (11)

Blorage Basin JD I 1 0.00 0.00 0 0 I 2 I5i9O j"733

10.00 10.00 =====1=0 I 5 f8600 j922Top of Dam OveJflow r
r-;;;;-;;;:- 3 100.00 100.00 5 0 I 10 f111"6.O [1ii13

Elevation Top orDam I 20.00 I
LengthTOPOrDamf15D.OO I 4 1000.00 1000.00 I 25~ r-;o54

Discharge coernelentlJ.OO J 5 10000.00 10000.00 I 50 ['""'i781'O r-;osr
r-:-:::;- 6 I I 100 I207iii r-:;;-;g

Weir Equation Exponent I 1.50 I: j-__ j-__ I <u, I U I " "

I

:o::J I 9 jr--- j-- r-----I

ro I j
.:J

Renumller

•

•

This is used to enter storage data for the HEC-1 model. Enter an appropriate Storage Basin ID and storage
data. For the Update to run correctly in the HEC-1 model, the Storage Basin ID must be the same as F1 for
the KK record in the HEC-1 file. Peak Storage and Stage data is automatically populated when running the
HEC-1 model.

A graph of Storage-Discharge, Elevation-Discharge or Elevation-Storage can be viewed by clicking
I Qraph Iand selecting the appropriate option.

Select Oplion Ei

Option ...
I

Elevation - Discharge

Elevation - Storage

-

...

QK I Cancel I
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• Chapter 5 Tools

~FCDMC - EXAMPlEl

File Edit Hydrology Tools Admin Submittals Help

•

Iable Descriptions

Eield Descriptions

!.mport DOS Family

Edit ~rror log

Options

Setup optIon. • ' ...u;

Required Paths lind Flies

Machine 10 106z6xvo1 ., KENNETH V LEWIS

CompanyfAgency IKIlL Consultants, Inc

Help Reader IC:\UtilitieslAdobelAcrobat\Acrobatexe

EditorID:IAPPS\CCRFCD\SnHELPIPFE32.EXE

Startup Options

r Update Tables

17 Show Agreement on Startup

17 Show Select Project on Startup

17 Show more records in grid

QK

The selection of Options from the Tools Menu is used to edit System settings. Enter the Company or Agency
name and the paths to Acrobat Reader and the text editor (i.e. Notepad). The default text editor is 'pfe32.exe'
but the user can change to another preferred text editor.

Check which Startup Options should apply.

•

Update Tables

Show Agreement

Show Select Project

Show More records in Grid

Forces an update to the tables the next time the user enters the system.

Displays the Flood Control District of Maricopa County
Drainage Design Management System agreement window.

Automatically loads the "Select Project Form on startup. If not selected, the
system will default to the last project edited when exiting the system.

If selected, the grid font size will not change when making the form larger
enabling more records to be shown.
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•
Table Descriptions

- I

Look for

x

SettloR

r. All

r File

r Hydrology

r Hydraulics

r Agency

T.......IM Descnpbon .
,- I

AREAPATTERNS Area Patterns
AREAREDUCTIONFACTORS Area Reducfion Factors I

DEFAULTDATES Defautt Tables Modification Dates
FIELDDESCRIPnONS Field Descriptions
HEC1DATA Hec1 Data
HEC1 DIVERSIONS Hec1 Diversions
HEC1MODELNEnNORK Hec1 Model Network
HEC1MODELRUNSUMMARY Hec1 Model Run Summary
HEC1 ROUTINGDATA Hec1 Routing Data
HEC1 STORAGEBASiNS Hec1 storage Basins
HELPFILES Help Files
KBPARAMETERS Kb Parameters
LANDUSEDATA Land Use Data
LANDUSEDEFAULTS Land Use Defaults
LANDUSEDEFAULTSAGENCY Land Use Defaults Agency

MAJORBASINS Major Basins
]UCCnCE:'AIII'T'l/Jo.IIICO ,.."."" ..... n,..".....I.\I... Io".....

.
.1'

Print..

•

•

The selection of Table Descriptions from the Tools menu is used to view the name and description of tables
used in the application. This data is for viewing only and cannot be edited. Use the 'Section' radio buttons to
view tables pertaining to a specific function. The user can print a table description using the Print button.
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•
Field Descriptions

. I 1-

look for

x

S.ctlon
r. All

(" File

r Hydrology

(" Hydraulics

(" Agency

ro1ble Naill. Field Name Type Size Decimals Description .
~ I-J

AGENCIES CODE C 3 0

AREAPATTERNS AREA N 5 1

AREAPATTERNS PATTERN N 5 2
AREAREDUCTIONFACTORS AREA N5 1

AREAREDUCTIONFACTORS RF N5 3

AREAREDUCnONFACTORS DURATION C 10 0

AREAREDUCnONFACTORS SORT N 10 0

DEFAUlTDATES TA8lENAME C 15 0

DEFAUlTDATES AlIASNAME C 30 0

DEFAUlTDATES DESCRIPT C 50 0

DEFAUlTDATES ARCHIVE C 8 0

DEFAUlTDATES MODIFDATE 08 0

FIElDDESCRIPTIONS TA8lENAME C8 0 Table name

FIElDDESCRIPTIONS ALIASNAME C 50 0 Alias name

FIELDDESCRIPTIONS FIELDNUM N 3 0 Field Number

FIELDDESCRIPTIONS FIELDNAME C 50 0 Field name

~'r r""lnCCf"OIDTI",IO ClCI,",'TYOe: (', n CI ...I,.j~.... .f
Print.. QK

•

•

The selection of Field Descriptions from the Utilities menu is used to view the structure of each table used in
the application. This data is for viewing only and cannot be edited. Use the 'Section' radio buttons to view
fields pertaining to a specific function. The user can print the field description using the Print button.
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•
Import DOS Family
The selection of Import DOS Family from the Tools menu is used to import data developed in the DOS
version of DDMS.

~Imporl DOS Family . I!lIiIEJ

I
J

QK I

Import New Project~_._--------­

Reference ISNQ24

==-~-----====----TiUe ISample import for DOS family

Enter a Reference and title to the project being imported similar to when starting a new project in Select
Project. Click Import Iand navigate to the appropriate file with an .SBR extension.

Open .~

Look n. I~ DosFamily

•
The program will import data as follows:

Sub Basin Area data
Default Land Use data
Sub Basin Land Use data
Sub Basin Soil data
Hydrograph Type
Precipitation data
Storms, duration, Timearea, NMIN

From a file with an .SBR extension
From a file with an .LDF extension
From a file with an .SUB extension
From a file with an .SUB extension
From a file with an .SUB extension
From a file with an .PFI extension
From either *M11 or *M21

If the above files are not available for the "family", then not all of the required data will be imported and the
remaining required data will have to be entered manually.

•
When importing a DOS family with HEC-1 data, the appropriate labels for the F2 field of the KK card are
automatically added.
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•
Edit Error Log
Whenever an error occurs in the Application, an Error Log is automatically placed in the Error Log Table.
This is used to explain what happened and to send the report to the Agency for problem resolution.

t~[tror Loq - ~.

The User should enter the appropriate information in the bottom box and print a report of the incident. In

Crystal Reports, Click the ~ to export the report to a PDF file. This should be emailed to the Agency with
any other explanations to help resolve the issue.

Error

Program section

line Number 0

.:J

QK IPrint. . I Dilete All I Qelete I Becall Log I Help

~
We would like to prevenlthls trom happening again. Please take a rew moments to
describe what you were doing when this error occurred, what activities you were doing Just
betore this happened, and anything else you can think otthal might be ot help

Problem code SET CLASSU8 TO (lcClassUb) &lclnModule ADDITIVE

A system error has occurred; please report this problem Complete error has been logged,
but here is the Important information

Date and Time ..
I

011171200304:47:25
011171200304:48:01

0210512003 11 :38:22

021051200311 :41 :18

0210512003 11 :42:29
021251200304:07:14

021251200305:59:18

0212512003 06:01 :46

0212512003 06:06:01

0212512003 06:09:04

0212512003 06:11 :09

0212512003 06:13:42

021251200306:15:30
0212512003 06:24:15

0212512003 06:35:19

021251200306:36:44

0212512003 06:53:43

0212512003 07:40:25

~Jr?"nnn1 n7'A,"1 Q , r

:.
I

•
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• Chapter 6 Admin

•

The Pull down menu for Admin is different depending on the type of installation.

• Application installed on a single computer.

Help

8.eindex Data

• Application data accessed over a network with security options

Help

8.eindex Data

~urrent User

hog off

Cb.ange Password

U~ers

User Permissions

~etwork Security

~gency Password

• Application data accessed over a network without security options.

Help

8.eindex Data

~gency Password

•

Reindex Data and Agency Password are available for all options. Change Agency Password is only available
after entering a valid Agency Password.

----- ----
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Reindex Data

• ,
•

Caution: Reindexing and packing tables take a few minutes to complete.
Interrupting the process once it has begun will result in data corruption.

•

•

This function can only be used when there are no other users accessing the application. The option is used
for two purposes. In the event of a corrupt index, the administrator needs to reindex tables and rebuild the
table indexes.

The option also packs all tables in the database. When a record is deleted, it is not physically erased from
disk until the database is packed. Packing permanently removes deleted records and restores disk space
occupied by those deleted records. The database should be packed occasionally to restore disk space.

Agency Password
Access to the Agency menu is restricted. Enter the password to access the Agency menu. Passwords are
not case sensitive.

Change Agency Password
This is only visible if an appropriate Agency password has been entered. This enables the user to change
the password. A window appears confirming the new password. If this is correct, click OK to confirm the
change.
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• Chapter 7 Help and Window

Help

tlelp

About

Beadme

Help
The Help menu offers 3 options:

Help
This option on the Help menu displays a list of manuals that the user can view. Highlight a manual and click

!:!elp File I. Acrobat reader opens the manual on the screen. When finished viewing, close the Acrobat
screen otherwise it will remain open on the desktop. The correct path to Acrobat Reader must be entered on
the 'Setup Options' screen available on the Tools menu.

•

About

Manual

Help File

Help File

Hydrology Manual

Hydraulics Manual

HEC-l Model

HEC-l Model

USGS Regions

NOM Rainfall

<

Description

Howto Compute Routing NSTEPS Values

Procedure for Using DDMSW with Stand-Alone HEC-l Models

FCDMC Hydrology Manual

FCDMC Hydraulics Manual

HEC-l Model cards

HEC-l Manual

USGS Regions for Scalier Graph

NOAA Rainfall data

I Help File II QK

v

•
This displays the informational screen for the application.

Readme
Displays the Readme.txt file to view a cumulative record of updates. When finished viewing, close the editor
screen otherwise it will remain open on the desktop. The correct path to the text editor must be entered on
the 'Setup Options' screen available on the Tools menu.
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• How to Compute Routing NSTEPS Values

This procedure is for models with data in the application and is not for stand alone models.

1. Open an existing project (File => Select Project). Press "OK" to close the menu.

2. Go to the Routing Menu (Hydrology => HEC-1 => Routing). Check the cu~tom checkbox to the
right of the 'Steps' field. This allows you to enter an initial step value into the current routing card.
Type an initial steps value into the 'Steps' field. Now, uncheck the custo~ .checkbox and press
"Save". Repeat for every routing card. When finished, press "OK" to close the Routing Menu.

3. Go to the Data Menu (Hydrology => HEC-1 => Data). Press the "Update" button. Select a return
period. Press the "OK" button. This will update the HEC-1 data with the latest parameters from
the data entry menus, including the initial routing NSTEP values. Press "OK" to close the Data
Menu.

4. Go to the Routing Menu (Hydrology => HEC-1 => Routing). Press the "Update from HEC-1"
button. A pop-up message will appear stating that HEC-1 will run 3 times and update Steps, but
only if the custom checkbox is unchecked. Press "Yes". After the third HEC-1 run finishes, the
'Steps' values for the routing cards will be updated. Press "OK" to close the Routing Menu.*

5. After all steps are final, you can run the model to obtain results (Hydrology => HEC-1 => Model).
Afterwards, you can view the output file, see summary results (peak flows, etc), and create
graphs. Please refer to the appropriate sections in the manual for more information.

• *NOTES:
A. When you press the "Custom" checkbox next to the "Steps" field, it will lock the value so it cannot

be changed with the "Update from HEC-1" button.

B. If you receive 'output file not found' messages after pressing the "Update from HEC-1" button in
the Routing Menu, check the model runs path. It may not be set for the project.

•
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•

•

Procedure for Using DDMSW with Stand-Alone HEC-1
Models
This procedure outlines the method for importing an existing HEC-1 model to use the reporting and graphing
features of DDMSW without the supporting land use, soils, sub-basin and network data.

1. Create a new project (File => New Project). Put a short name for the project in the Reference
field. The Reference field can be letters and numbers (no space) and can hold 20 characters.
Press the "Save" button to save the new project information. Press the "OK" button to close the
menu.

2. Set the model run path (File => Project Paths). Press "OK" when prompted about checking the
default paths and files before proceeding. Fill in the 'Model Runs Path' field by pressing the "... "
button to the right of it and selecting the path where the HEC-1 output file will be stored. After
finding the folder, press "Select" to choose it. Then, press "Save" and "OK".

3. Go to the HEC-1 Data Menu (Hydrology => HEC-1 => Data). Press the "Import" Button. Find the
HEC-1 input file, highlight it, and press "OK". DDMSW will warn you that you will replace any
existing data for the current project. Select "Yes" to continue.

4. Review the model data and make modifications if necessary. Press "OK" to close the Data
Menu.*

5. Now it is time to run the model. Go to the Model Menu (Hydrology => HEC-1 => Model).
Uncheck the "Update HEC-1" option. Check the 100-year return period and uncheck the other
return periods. Press "Save". Then, execute the model by pressing "Run Model". If the model
run is successful, DDMSW will display the message "Model Run Complete!".

6. You can now view the output file, see summary results (peak flows, etc), and create graphs.
Please refer to the appropriate sections in the manual for more information.

*NOTE:

To perform a modification to the standalone HEC-1 model at Step 4) above go to the Data Menu (Hydrology
=> HEC-1 => Data). Highlight the line to change by left clicking on it. Use the "find" and "next" buttons to
search for a specific line. Press the "find" button. A 'Find Value' pop-up window will appear. The find
function looks only in the F1 column, so type in a value such as a basin name (1A), a routing channel name
(R1-2), or a specific number like the IA value for a Green-Ampt Parameter (0.28). Press "Save" and then
"OK" to perform the search. The "next" button looks for the next line that contains the same F1 content.
When you find and highlight the specific line to change, click the 'Details' Tab (or double-click on the line).
Edit the HEC-1 field(s) by typing into the appropriate column(s) labeled by'F1'-'F10'. Press "Save" to save
your changes. You can get back to the line-by-line view of the data by left clicking to the "List" Tab. When
you are finished making changes, press "OK" to exit the data menu.

FOR STANDALONE HEC-1 MODELS, DO NOT PRESS THE "Update" BUTTON! THE MODEL DATA MAY
BE DAMAGED OR LOST!
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• kvlExample1
Introduction
This document is a guide to lead you through the creation of an example HEC-1 Model. After its completion,
you should be familiar with the following concepts:

•

•

1 Create a Project Models Folder
2 Using the Help Feature of DDMSW
3 Establish a New Project and Set Defaults
4 Setting the Model Runs Path
5 Establish Rainfall Data for Project
6 Review Soil Defaults
7 Review Land Use Defaults
8 Establish Major Basin Id's
9 Establish Preliminary Sub Basin Data
10 Update Major Basin Data
11 Establish Soil Data
12 Establish Land Use Data
13 Update Sub Basin Data
14 Establish Preliminary Routing Data
15 Establish Draft HEC1 Input File
16 Run Draft HEC1 Model
17 Initialize Routing Steps Values (Normal Depth only)
18 Run HEC-1 Model and Update Data
19 Compute the Routing Steps for the Final Model (Normal Depth only)
20 Verify the Final HEC-1 Model Data
21 Run Final HEC-1 Model for All Return Periods
22 Graph HEC-1 Results
23 Backup Project

DDMSW has many capabilities not covered in this tutorial and it is recommended that you spend the time to
read through the user manual and other supporting documents as well as explore the environment through the
use of the pre-packaged example projects.

1. Create a Project Models Folder
Before starting the DDMSW Program, create a unique folder for the example HEC-1 model files. All projects
use the same naming convention for the input and output HEC-1 files. As a consequence, two or more
projects in the same folder can have data overwritten. For this example, use Windows Explorer to make a
new folder 'C:\Fcdmc\St\Modlruns\kvIExample1\'.

KVL Consultants, Inc.
Drainage Design Management System - kvlExample1
126-0040.doc



• 2. Using the Help Feature of DDMSW
Now, open DDMSW. Go to the Help Menu and go to the Help Submenu. For the remainder of this tutorial,
this will be abbreviated through the use of the following convention (Help => Help). You can read the DDMSW
user manual by selecting the manual titled 'Drainage Design Management System' and pressing the 'Help
File' button. This will launch Adobe Acrobat Reader and open the DDMSW user manual. If your computer
does not have Adobe Acrobat or Adobe Acrobat Reader installed, please contact your IT Department. After
they install it, they must point the DDMSW Program to the Acrobat executable file, under Tools => Options =>
Help Reader. Additionally, there is a text editing program (e.g. Notepad, PFE Editor, Textpad) listed under
Tools => Options => Editor. It will be used to read text files used by DDMSW.

1------------1-----------------+---:..,

•

Help File

Help File

Help File

Hydrology Manual

Hydraulics Manual

HEC-1 Model

HEC-1 Model

USGS Regions

NOM Rainfall

<

Description

Instructions for creating a new project using HEC-1

How to Compute Routing NSTEPS Values

Procedure for Using DDMSW with Stand-Alone HEC-1 Models

FCDMC Hydrology Manual
FCDMC Hydraulics Manual

HEC-1 Model cards

HEC-1 Manual

USGS Regions for Scatter Graph

NOM Rainfall data

!:lelp File QK

•

Setup opllons ®
Required Paths and Flies

Machine 10 DELL·6l0 # KENNETH V LEWIS

CompanylAgency KVL Consultants, Inc.

Help Reader C\Program FileslAdobelAcrobat 6.OIAcrobaMcrobat exe

Editor OWPS\FCDMC\ST\Helplpfe32 exe

Startup Options

o Update Tables

~ Show Agreement on Startup

o Show More Records In Grtd

o Show Select Project on Startup

QK

KVL Consultants, Inc.
Drainage Design Management System - kvlExample1
126-0040.doc
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3. Establish a New Project and Set Defaults
Select File => New Project. Fill in the fields using the data shown in the screen capture below. Each project
must have a unique Reference (without spaces), a formal Title, a project Location and an Agency name (this
can be your firm's name if a consultant). Then select the appropriate Model (HEC1 or Rational, but select
HEC-1 for this example), Land Use Agency and Rainfall Method. Finally select the appropriate HEC-1
parameters: Unit Hydrograph, Loss Method, Storms, Duration, Tab Interval, No of Ordinates and default
Output. Also add any appropriate comments.

bist

ProjectlD 00119 Reference I(Vt=~""P...l,="E'~~~

Title Example 1 tutorial project

Location Mancopa County

Agency KVL Consultants, Inc.

Delails

HEC-1 Oef.lul15

Unit Hydrograph Clark

Loss Method Green-Ampt

Storms Multiple

Duration 6 Hour

Tab Interval (NMIN) 5 •

This project is the tutorial example for
establishing a new project for a HEC1
model.

ProJect Defaults

Model HEC1

Land Use Agency FCOMC

Rainfall NOAA Comments

No Ordinates (NQ)

Output (10)

2000

5

• Print.. II Delete Add II Update II QK

•

After entering the data, press 'Save'. Then, press 'Update'to open the Update Defaults from Agency Window.
Make sure that the 'Rainfall', 'Land Use', and 'Soils' options are checked and press the 'Update' button. This
will establish Project Defaults for Rainfall, Land Use and Soils. Default values can be edited at a later stage
in the various menus (e.g. Rainfall, Land Use Defaults, and Soil Defaults).

Update Defaults from Agency

Ululate

~ Rainfall

~Land Use

~8oils

!,lpdate It QK

When the update is complete, click 'OK'to exit the Select Project form.

KVL Consultants, Inc.
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4. Setting the Model Runs Path
Next, go to File => Project Paths to establish the model runs path. Press the elipse button ('. ..') to the right of
the 'Model Runs Path' field and navigate to the 'C:\Fcdmc\St\Modlruns\kvIExample1\' folder. Press 'Select' to
choose this folder as the model runs path. Press 'Save' to save the change to the model runs path location
and press 'OK' to close the Project Paths form.

Project Paths £5<1

•

•

Machine ID DELL-610" KENNETH V LEWIS

Agency KVL Consultants. Inc

Projecl Example 1 tutorial project

Model Runs Path [C:IFCDMClSnMODLRUNS\

KVL Consultants, Inc.
Drainage Design Management System - kvlExample1
126-0040.doc
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5. Establish Rainfall Data for Project
Select Hydrology => Rainfall and click on the 'Details' tab to edit the Non Adjusted Point Rainfall data as
necessary. It is important that the data reflect the location of the project.

t: Rainfall Data l;]@[E)

!"ist

Non Adjusted Point Rainfall (In)

1.18

1.401

1.Q.Q:Ye.2r

3.251

3.95 1

~

•
I Print.. II Qraph II J.lpdate II QK

Appropriate values for the Maricopa County 2-Year and 100-Year 6 and 24-Hour can be determined by
clicking on 'Map' and locating to the project site.

"'.boo ',.,.tl..III,of.,.._.1 ,,.,. ,. w...1.rlc.~I.","l"JI r:"IC

1_ It - '_'Jr#. ~

(T II.";. • .

1 -I' V1" •

h ,: 'l .,'", .~ ';' 1,;': .! ',:: :1.. I
-1,\,', ," .... :

II ". '.a t '. ". '. .~ oil'

t· !lr.

. I' .

•
Once the correct values have been entered, press 'Save'. Then press 'Update'to update the rainfall data for
all other durations and return periods.

KVL Consultants, Inc.
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I

Update Defaults from Agency

UIHlate

~Rainfall

~Land Use
~Soils

!,,!Pdate][ QK

Make sure that the rainfall checkbox has been selected and press the 'update' button to initiate the new table
computation. The final data can be viewed by clicking the 'Ust'tab on this form.

ttl Rainfall Data LJrgJ~

blst I Delails

Duratron
-~ -

2-Yea, 5-Yea, 10-Yea, 25-Year 50·Year 100-Year Rainfall "
I I

10 MIN 0.47 0.64 0.75 0.91 1.03 1.16 NOM

15 MIN 0.57 0.80 0.95 1.16 1.32 1.48 NOM

30 MIN 0.76 1.07 1.28 1.57 1.79 2.01 NOM

1 HOUR 0.93 1.32 1.59 1.95 2.23 2.51 NOM

2HOUR 1.01 1.45 1.74 2.15 2.46 2.76 NOM

3HOUR 1.07 1.54 1.85 2.28 2.60 2.93 NOM

6HOUR 1.18 1.70 2.05 2.52 2.89 3.25 NOM

12 HOUR 1.29 1.87 2.26 2.79 3.19 3.60 NOM
24 HOUR 1.40 2.04 2.47 3.05 3.50 3.95 NOM

I
I ...
1< )

--- -

I Print... II Qraph II Update II OK I

The data can be graphed (generally for use in the Rational method) by clicking on the 'Graph' button.
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... Rainfdll Inlensily r:l~@

35 40 45 50 55 60 65

Ouration (minutesl

KVl Consultants, Inc­
Rainfall Intensity

Projed 10: KVlEXAMPlE1
"§" 12 00

i ;~.:
ii 9.00
.§. 6.00
~ 7.00
.~ 600

~ 500 ~§~§§~§§~§~~~~~~
.= 400

! 3.00
::: 200
~ 1.00

000
10 15 20 25 30 70 75 60 65 90

• 100 Year +50 Yea" ~25Year "'1-10 Year ..... s Year .... 2 Year

QK

•

•

When the Rainfall data has been updated, click on the 'OK' button to close the Rainfall Intensity Graph and
'OK' to close the Rainfall Data form.
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6. Review Soil Defaults
Select Hydrology => Soil Defaults to access the soil defaults data. Since we are using FCDMC default data,
none of the records will be modified. If you ever decided to change or add a soil default record, it is done
here.

r8 Soil Defaults GJ[QJ~

bisl I Delails

Lookfor

Sc>illO Bc>c>k Ntlnbel XKSAT Rock Percent Description ...
I

6452 645 0.41 0.00 Antho gravelly sandy loams

6453 645 0.58 0.00 Antho-Carrizo-Marlpo complex

I6454 645 0.58 0.00 Antho-Carrlzo-Maripo complex, low precipitation

6455 645 0.43 0.00 Anthony sandy loam

6456 645 0.62 0.00 Anthony-Ariza complex I6457 645 0.62 0.00 Anthony-Ariza complex, low precipitation

6458 645 0.96 0.00 Ariza cobbly sandy loam

6459 645 0.27 0.00 Beeline-Cipriano complex, 3 to 45 percent slopes

6531 653 0.00 0.00 Agualt and Ripley soils

6532 653 0.00 0.00 Agualt and Ripley soils, saline-sodic

6533 653 0.66 0.00 Ajo-Gunsight-Pompeil complex, 3 to 25 percent siopes

16534 653 0.00 0.00 Akela-Rock outcrop complex, 15 to 65 percent slopes

16535 653 0.82 0.00 Carrizo-Dateland complex, 0 to 3 percent slopes

6536 653 1.20 0.00 Carrizo-Momoli complex. 0 to 3 percent slopes
I( ) j

I Cop~ II Print... II Qelete II Md II J.lpdate II QK I

Click on the 'OK' button to close the form.
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7. Review Land Use Defaults
Select Hydrology => Land Use Defaults to access the land use defaults data. Since we are using FCDMC
default data, none of the records will be modified. To see all the default values use the horizontal scroll bar to
scroll to the right on the form or maximize the form. If you ever decided to change or add a land use default
record, it is done here.

tlland Use Defaults - FCDMC r:liElrRJ
I.lst I De!ails

lookfor[ 1
SOlt COile - -

Group Description IA Rtimp Cover Dtheta A

I
20 120 Residential Estate Residential (1/5 du per acre to 1 du per acre) 0.30 5 30.0 NORMAL

30 130 Residential large lot Residential- Single Family (1-2 du per acre) 0.30 15 50.0 NORMAL

40 140 Residential Medium Lot Residential- Single Family (2-4 du per acre) 0.25 30 50.0 NORMAL

50 150 Residential Small Lot Residential- Single Family (4-6 du per acre) 0.25 30 50.0 NORMAL

60 160 Residential Very Small Lot Residential- Single Family (>6 du per acre) 0.25 40 50.0 NORMAL

70 170 Residential Medium Density Resldentiai - Mull Family (5-1 0 du per acre) 0.25 45 50.0 NORMAL

80 180 Residential High Density Residential- Multi Family (1 0-15 du per acre) 0.25 45 50.0 NORMAL

90 190 Residential Very High Density Residential- Multi Family (>15 du per ac) 0.25 45 50.0 NORMAL

100 200 Commercial General Commercial (Commercial where no detail available) 0.10 80 60.0 NORMAL

110 210 Commercial Specially Commercial «=50,000 sq. ft.) 0.10 80 65.0 NORMAL

120 220 Commercial Neighborhood Commercial (50,000 to 100,000 sq. ft.) 0.10 80 65.0 NORMAL

130 230 Commercial Community Commercial (1 00,000 to 500,000 sq. ft) 0.10 80 75.0 NORMAL

140 240 Commercial Regional Commercial (500,000 to 1,000,000 sq. ft.) 0.10 80 65.0 NORMAL

150 250 Commercial Super-Regional Commercial (>= 1,000,000 sq. ft.) 0.10 80 70.0 NORMAL

1
160 300 Industrial General Industrial (Industrial where no detail available) 0.15 55 60.0 NORMAL

< I > I
---

I Renum!!er II Cop~ II Print... II .Qelele II Md II llpdate II QK I

Click on the 'OK' button to close the form.
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8. Establish Major Basin Id's
Select Hydrology => Major Basins to access the Major Basins data. The software automatically establishes at
least one Major Basin (01) when creating a new project. Since we will only have one major basin in this
project, there is no need for further modification at this time. After the sub basins have been established, we
will return here to update Major Basin 01.

t! Major Basins L;]f5I@

Model This MajorBasln 0~

Storm rMultiple l 0
Tabulation Interval I ; 1 0

No. Drdinates 2000 J 0
Output J 0

].Ist

Major Basin

Major Basin ID "

Description [ M;jOr Basin 01

sort[ 10 • J
Area (sq mil f J

Comments Modeling Options

J

Delalls

Areas for Distribution

~ BE
1. r JI
2 i IL
3. I J[ ]
4. I l ]
5. If ]
6 I r 1
7 I f J
8 [ I[ 1

l ]
Custom Areas 0

•

•

filter II Renum!!er II Cop~

Click on the 'OK' button to close the form.

KVL Consuitants, Inc.
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9. Establish Preliminary Sub Basin Data
Select Hydrology => Sub Basins to access the sub basin data. Click on 'Add'to add the first record. Enter the
following:

Sub Basin
Area
Length
USGE
DSGE
Time-Area

010105
6.690
5.060
2760
2200
URBAN

~l Sub 8",ln, MO 01 "J&11Xl
Us, Details

RTIMP(%)

1A0n) I
OTHETA

PSIF On)

XKSAT

Sub 0..1"

M.Jor 8.sln 01 [2J
Sub Basin 01010fi

Sort 2 ::

Sub Basin Parameters. Clark

"'e. (so mil 6.690

Length(ml) 5.060

USOE 2760.0

OSOE 2200.0
~

Slope (1\tmi)

Tlme·Afea URBAN

Ralll'o1l1losses - Green-Ampt
YiJlla lWilill ~

o
o
o
o
o

Return Period Parameters
1..l! .ur !2.n :fur ~ w.n

Custom Tc 0 0 0 0 0 0
Te (hIS)

VOl (Us)

R (hrs)

Click 'Save'to save the data and then click 'Add'to add a second record.
Enter the following:

Sub Basin
Area
Length
USGE
DSGE
Time-Area

010110
5.700
3.75
2584
2195
URBAN

hls1 Delails

Click 'Save'to save the data and then click 'OK'to exit this form.

lA(in)

OTHETA

PSIF On)

XKSAT

RaInfall Losse•. Gr.en.Amp.
YiJlla lWilill ~

o
o
o
o
o

Return Period Paramet.rs

2.:iI .ur ~ li>I ~ w.n
Custom Tc 0 0 0 0 0 0
Te (hIS)

Vel (f1S)

R(hrs)

RTlMP(%)

Yi!lIl !2l!iY!! ~
Kb 0

Time-Area URBAN

Major Basin 01 ~

Sub BaSin 01011

Sort

Sub Basin

Sub Basin Parameters. Clark

Area (sq mil 5.100

Length (mi) 3.150

USOE 25B4.O

OSOE 2195.0 &lJ
Slope (nfmi)

•
KVL Consultants, Inc.
Drainage Design Management System - kvIExample1
126-0040.doc

11



•
10. Update Major Basin Data
Select Hydrology => Major Basins to access the Major Basin data. Click on the 'Details'tab and then click on
'Update' to update the data. Updating the data will sum the sub basin areas and establish the Areas and
Reduction factors a ro riate for Multi Ie Storms anal sis.

Major Basin

Major Basin 10 ~

Description IMajor Basin 01

sort! - 10:r
Area (sq mi) 1239001

6

9.

5. l

Custom Areas 0

~ fiE
1 I 0'(100]' 0.9988 J
2. 05] I 09940 ]

3. I 2.8] 0.9750 1
4 I 160] I 0.92201

][ ]

It 1
][ ]
j[ 1

7 l
8. [

De!ails

Areas for Distribution

Modeling Options

Model This Major Basin 0~

Storm [MUltiPle ] 0
Tabulation Inte.....al [ 5 1 0

No. Ordinates r2000 J 0
Output r 5 J 0

bist

Comments

Eilter II Renum.!ler II Copy II PtinL " Qelete II ~dd II .!.lpdate II QK

•
The 'Update' button in the Major Basins form will open a 'Select Update Option' form. The first choice, 'All',
can be used when there are multiple major basins within a project. The second choice, 'This Major Basin',
only updates the current major basin. For this example project, it does not matter which option you select.
Choose an option and press 'Update'. When this is complete the Major Basin data will look like the following:

Select Update Option

()AII

(!) This Major Basin

1I:::::~:~:~:~j:~:::::JI[ Qan eel

After the Update is complete, click on the 'OK' button to close the form.

•
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11. Establish Soil Data

Select Hydrology => Soils to access the Soils data. Click on 'Add'to add the first record. Enter the following:

Sub Basin 010105 (Click on adjacent icon to select)
Soil 10 64512 (Click on adjacent icon to select)
Area 1.73

~j Soils Mil: 01 LJ@~

j.ist

Sub Basin

Major 8asln ID [01 (2)
Sub 8asin ID r01 01 05 1(2)

SolllD 64512 (2)
Area (sq mQ [ 1.7300J

Area(%) [

Soil Data

XKSAT l
Rock Outcrop (%J l

Effective (%J [

De!alls

.Q.mu!! .QlL§lQm

001 0

r 10
I

•

Soli Description
800k Number [645 J

Description I Carefree cobbly clay loam, I 108 percenl slopes

Copy Print.. II Qelete It Add il Major 8asin II !'!pdale II QK

When you press 'Save', the Soil Description and Soil Data values will auto populate.

Click 'Add'to add a second record. Enter the following:

Sub Basin 010105 (Click on adjacent icon to select)
Soil 10 64522 (Click on adjacent icon to select)
Area 4.96

tl SOIls MB: 01 !TI@!?<l

List

Sub Basin

Major 8asln ID 01 [2]
Sub Basin ID 010105 [2]

SoillD 64522 [2]
Area (sq mil 4.9600

Area (%)

Soli Description
800k Number 645

Description Contine clay loam

Soli Data

XKSAT

Rock Outcrop (%)

Effective (%)

Details

Q.lliY!I .Q..u.mm

004 0

o

• ,--_C_OP_Y_Jl-_P_r_int_"---J11 Qelete ICMii--ijl Major Basin II J,1pdate II QK

KYL Consultants, Inc.
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• Click 'Save'to save the data and then click 'Add'to add a third record. Enter the following:

Sub Basin 010110 (Click on adjacent icon to select)
SoillD 64512 (Click on adjacent icon to select)
Area 5.70

tfSoils . MB: 01 . r;]@JfR1

Major Basin 10 01

bist

Sub Basin

1[2)
SUbBasinlD 010110 [2)

Soil 10 [ 6.512 (2]
Area (sq mi) I 5.7000 I

Area(%) I

Soli Data

XKSAT

Rock Outcrop (%) I
Effective (%) r

Details

~~

r 001 0
o

Soil Description

Book Number 16.5

DeSCription ICarefree cobbly clay loam, 1 to 8 percent slopes

v

Click 'Save'. Click on 'Update'to update the Soils Data. Select 'This Major Basin' or 'All' and press 'Update'.•
Cop~ II Print... Delete II Add II Major Basin II .!.!.pdate ICQK-l

•

Select Update Option

o All

(V This Major Basin

OThis Record

L::g:r.:~:~j:~::::J [ QanceI

KVL Consultants, Inc.
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A typical updated record will look like the following:

~ Soils· MB: 01 - GJ©JfXl

hist Delails

Sub Basin Soil Data
~ QlliJ,ill ~

Major Basin 10 01 [2J XKSAT 001l 001 0
Sub Basin 10 010105 [2] Rock Outcrop (%) 0

Soil 10 64512 [2] EffectIVe (%) 100
Area (sq mO

Area(%) 259

Soil Description

Book Number r645

Description Care(ree cobbly clay loam, 1 to 8 percent slopes

Copy II Print. J[ Qelele II 8dd II Major 8asin II J.!pdate QK

•

•

After all Soils data has been entered and updated, click on the 'OK' button to close the form.
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12. Establish Land Use Data

Select Hydrology => Land Use to access the Land Use data. Click on 'Add'to add the first record. Enter the
following:

Sub Basin 010105 (Click on adjacent icon to select)
Land Use Code 110 (Click on adjacent icon to select)
Area 2.00

tll and Usc MB: 01 LJ[g]1RJ
kist

land Use

Major Basin 10 [01 1[2]

Sub Basin 10 ~ 010105 1[2]
Land Use Code 1110 (2)

land Use Data

Area (sq ml)

Area(%)

2.0000J

De!ails

~

Initial Loss (IA) 030

Percent Impervious (RTIMP)

Vegetation Cover 30 0

Moisture Deficit (DTHETA) NORMAL

ReSistance Coemeient (Kb) MIN

Dm.lI!! ~
Comments

030 D
51 0

300 D
NORMAl 0
MIN 0

Cop~ Print.. Qelete IIL8dd 11Major Basin II J.ipdate QK

•

Click 'Save'to save the data.

Click 'Add'to add a second record. Enter the following:

Sub Basin 010105 (Click on adjacent icon to select)
Land Use Code 130 (Click on adjacent icon to select)
Area 4.69

KVL Consultants, Inc.
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tl Land Usc Mil: 01 LJ[Q]1?Sl

• blst

land Use

Major Basin 10 [ 01

Sub Basin 10 1010105

Land Use Code l130

land Use Data

Area (sq mO r
Area ('!O) r

4.6900 ]

De!alls

~ ~ Custom
Comments

Initial Loss (IA) [ 0.30 ] 0.30J 0 'IPercent Impervious (RTIMP) r
151l 15l 0

Vegetation Cover 500 1 50.01 0
Moisture Deficit (DTHETA) [NORMAL ] fNORMAL 0 v

Resistance Coefficient (Kb) IMIN ]IMIN 0

Copy Print.. II Q.elete !t-····l\dt:J1 Major Basin II !lpdate II QK

t1 Land Usc· Mil: 01 CJ(QJrEl
bist De!ails

land Use

Major Basin ID 01 1[2] Area (sq mil 5.7000

Sub Basin ID 010110 (2J Area ('!O) I

Land Use Code 140 (2J
land Use Data

~ Q.gf@!! .Q.!rnQm
Comments

...
Initial Loss (IA) I 0.25 0.25 0 I

I

Percent Impervious (RTIMP) I 30 30 0
Vegetation Cover 50.0 I 50.0 0

Moisture Deficit (DTHETA) NORMAL

1 fNORMAL 0 v

Resistance Coefficient (Kb) IMIN J MIN 0

•

Click 'Save'to save the data.

Click 'Add'to add a third record.

Sub Basin
Land Use Code
Area

Enter the following:

010110 (Click on adjacent icon to select)
140 (Click on adjacent icon to select)
5.700

Copy Print.. Qelete It -~ijd---'lll Major Basin II !lpdate II QK

•
Click 'Save'to save the data.

Now that all of the Land Use data has been entered click on 'Update'to update the Soils Data. Select 'This
Major Basin' or 'All' and press 'Update'.
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•
Select Update Option

o All

0This Major Basin

OThis Record

.Q.ancel

A typical updated record will look like the following:

~ Land Use Mil: 01 LJ(QJ~

list

Land Use

Major Basin 10 101 Ira

Sub Basin 10 010105 j~
Land Use Code 130

Area (sq m~

A,ea(%)

4.69001
101

•
land Use Data

'mY§. ~ ~
Comments

Inibal Loss (IA) 030 030 0
Percenl Impervious (RTIMP) 15 15 0

Vegelation Cover 500 500 0
Moisture Deficit (DTHETA) NORMAL NORMAL 0

Resistance Coefficient (Kb) MIN MIN 0

Cop~ PrinL Qelete II Md II Major Basin II l1pdate II QK

•

After all Land Use data has been entered and updated, click on the 'OK' button to close the form.
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•
13. Update Sub Basin Data
Select Hydrology => Sub Basins. Click on the 'Details' tab to view all the data for a record. Click 'Update'to
Update the data, select either update option and press 'Update'.

~lSubHdS,"S MB 01 GJQ~

j"Jsl

Sub B.sln

Major 8asln 01 [2]
Sub 8asln 10105

Sortr 2 •

Sub Basin Parameters - Clalk

:::::q(:~r ::::
USOE 27600

---;
DSOE 22000 ~

Slope (1IIml) 1107 '10.7

Time-Area lURBAN .., ]

~ l2mlIll ~

Kb 0.017JI 0.011 0

Delalls

R.lnf.lIlosse. - Green-Ampl

~1~ Q.m.!l!l ~

IA(in) o30J 030] 0
DTHETA 013 0.13] 0
PSIF (In) 10.10 t 1010j 0

XKSAT 00' r 00' 0

IRTIMP (%) 12 I 121 0

Return Period Parameters

2..'11~~~~~

Custom Tc 0 0 0 0 0 0
TC(hrs) 0061073311 0.6581 0592 055' t 0521

Vel (Os) 109 [1012 ,128'1 125' /13.0 [102.

R(hrS) r0.482 0.3251 0.2881, 0.256 0238 r0.222

I Renumller II Cop~ Print... Qetele (,dd II Major Basin II \ipdate .QK

•
Select Update Option

o All

<!)This Major Basin

Following the Update, the following warning message is developed from the data and calculations. In this
example, the tabulation interval of 5 is outside of the preferred range. Since it is close, and is for the 2-Year
storm, the data is considered acceptable. Note that the Tc value for the 2-Year storm is shown in red,
indicating an issue. Enter a comment in the comment field to explain the issue and press 'Save' when
finished.

WI lemp\kvlWdrning Ixl ~ ~:J;5]~

Sub Basin data problems
03/17/2005 at 05:40:10

•

Sub Basin ID: 010105 Tabulation Interval of 5 is out of range 0.1 Tc2 6 and 0.25 Tc2 16
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~ Sub H.s,n' MH' O. Gir21X1

Return Period Parameters

llr ~ ~ lin ~ 1illl.n
CustomTc 0 0 0 0 0 0
Te (hrs) 04 J 0733 0.658 0592 0554 0521

Vel (0.) 709 1012 11 18 1254 1340 14 24

R (hrS) 0482 0325 o18B 0256 o13B 0121

• \.1.,

Sub Basln

Major Basin 01

Sub BasIn

Sort

Sub Basin Parameters ~ Clark

Area (sq mi) 6.690

Length (mQ 5.060

USGE 2760.0

DSGE 2200.0 M1
Slope (ftImQ 1101' 1107

Time-Area URBAN

~ l2mlLIl QlWQ.m
Kb 0017 0017 0

Delalls

Ralnfalllo8S" - Groon.Amp.
~ l2mlLIl ~

tAlIn) 030 0301 0
DTHETA 013 013 0
PSIF(,n) 1010 '010 0

XJ<SAT 004 004 0
RTIMP(%) 12 11 0

Tab Interval of 5 is
below preferred 6 for
the 2-Year storm
when calculating the
Te value. Tllis Is
consIdered
acceptable.

IRenumli.er II Cop~ Print... Qelete II Major Basin " l.!pdate QK

•

•

Click 'OK' to close the Sub Basins form and continue.
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• 14. Establish Preliminary Routing Data
Select Hydrology => HEC-1 => Routing to access the Routing data. Click on 'Add'to add the first record.
Enter the data as shown on the following for Route 10 010105.

~ H£C 1 Routing Ddld . MB: 01 r:l@®
Look for

I I
~01 011 0 NORMAL DEPTH

I

I I
I

1 10 Type Route

Major Basin 10 101

Route 10 010105

Type NORMAL DEPTH (2J

2 l
LB f
4.

(

y

Normal Depth

LOB N l 0.035J
ChanN [ ~38l

ROB N r 0.035]

Length [ 4224.0]

Slope [ 0.00121

MaxElev 99.701~
Sleps 0 RB

[Update from HEC-l I

.5lil!2n f!mJ!2n

510.0] L 997~

1510.0 J r- 94.10J

1585.0] [ 9360l

1596.0 ) [ 9220J
16000 L 9220]
1612.0 93.60 J

1662.0 94.901

2262.0 99.70 ]

rnll£C 1 Rouling Ddtd . MB: 01 - - LJrQ]~

After data has been entered click 'Save' and the 'Add'to add another record. Enter the following data in the
new record for Route 10 010110.•

Cop~ II Print.. II .Qelete II~.!- JII Major Basin I QK

Look for

Cop~ II Print.. II .Qelete II 8dd II Major Basin I

010105 NORMAL DEPTH

I

I

I

I
I

Route

Major Basin lOOt '(2)
Route 10 01011 0

Type INORMAL DEPTH

5.

[2]

.5lil!2n ~
510.0 99.70

1510.0 94.10

1585.0 93.60

1596.0 92.20

1600.0 92.20

1612.0 93.60

1662.0 94.90

2262.0 99.70

QK

LB

99.70 ~
RBo

IUpdaie from HEC-l!

Normal Depth

LOB N [ 0035J

Chan N 0.0381

ROB N 0.035

Length 6917.0

Slope 0.0020

MaxElev

Steps

)

Type10

•
DO NOT UPDATE FROM HEC-1 FOR THE STEPS AT THIS TIME BECAUSE THE HEC-1 MODEL HAS NOT YET BEEN

ESTABLISHED!

Press 'Save' when finished entering the data for 010110. Press 'OK' to close the HEC-1 Routing Data form.
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15. Establish Draft HEC-1 Model
• Select Hydrology => HEC-1 => Network to access the model Network data.

t~ H£e.1 Model N~lwork . MB: 01 r-lral~

Look for r l
SOIt 10 Type Route Type Combine Area ,.. Model Network

10 010105 Basin Major Basin 10 01 ~[2J20 010105 Route NORMAL DEPTH Type Route [2]~
30 010110 Basin

J[2]40 010110 Combine 2 10 010110

I KO Output r o :U
Roule Type INORMAL DEPTH ][2]

Sort I 50 ¥~I

'II I
I

v
I

J
< ) ..-; I

IlEe!l_u.ml!~r.]I[ Cop~ II Print... II Qelete II 8dd II Major Basin II Qreats Dran II QK I

Click on 'Add'to add the first record. Enter the following data:

• Type
10

Basin
010105

(Click on adjacent icon to select)
(Click on adjacent icon to select)

•

Click 'Save' and the 'Add'to add another record and enter the following data:

Type Route (Click on adjacent icon to select)
10 010105 (Click on adjacent icon to select)
Route Type NORMAL DEPTH (Click on adjacent icon to select)

Click 'Save' and the 'Add'to add another record and enter the following data:

Type Basin (Click on adjacent icon to select)
10 010110 (Click on adjacent icon to select)

Click 'Save' and the 'Add'to add another record and enter the following data:

Type Combine (Click on adjacent icon to select)
10 010110
Combine No 2

Click 'Save' and the 'Add'to add another record and enter the following data:

Type Route (Click on adjacent icon to select)
10 010110 (Click on adjacent icon to select)
Route Type NORMAL DEPTH (Click on adjacent icon to select)

Click 'Save'

After all data has been entered click 'Create Draft' to establish a draft HEC-1 input file. A note pops up and
says that the procedure will override the existing model network. Select 'Yes'. Now, the following file will
come to the screen:

KVL Consultants, Inc.
Drainage Design Management System - kvlExample1
126-0040.doc

22



• ID KUL Consultants. Inc.
ID KULEXAMPLE1 - Example 1 tutorial project
ID 100 Year
ID 6 Hour Storm
ID Unit Hydrograph: Clark
ID 03/17/2005
IT 5 0 0 2000
IN 15
10 5
*DIAGRAM

*
*

97

0.074
0.950

94

0.066
0.931

90

0.058
0.911

84

0.050
0.834

77

0.041
0.377

BASIN

0.008 0.016 0.025 0.033
0.099 0.118 0.138 0.216
0.972 0.983 0.991 1.000

0.25 4.50 0.50 50
1.0

5 16 30 65

KK01 01 05
BA 1.0
PB 4.0
PC 0.000
PC 0.087
PC 0.962
LG 0.15
UC 1.0
UA 0
UA 100

*

•
KK01 01 05
RS 5
RC 0.016
RX 10
RY 15.0

*
KK010110
BA 1.0
LG 0.15
UC 1.0
UA 0
UA 100

ROUTE
FLOW

0.016
25

15.0

BASIN

0.25
1.0

5

-1
0.016

50
15.0

4.50

16

1000
52

0.0

0.50

30

0.015
82

0.0

50

65

84
15.0

77

100
15.0

84

110
15.0

90 94 97

*
KK010110 COMBINE
HC 2

*
KK010110
RS 5
RC 0.016
RX 10
RY 15.0
22

ROUTE
FLOW

0.016
25

15.0

-1
0.016

50
15.0

1000
52

0.0

0.015
82

0.0
84

15.0
100

15.0
110

15.0

Click back onto the DDMSW screen. A message pops up saying that the draft file was created with assumed
data. It also says to run the draft to make sure that the HEC-1 network is ok. If it is, then you can update it
with the real HEC-1 model data from the tables and run it again to obtain real model results. Press 'OK' to
close the note and press 'OK' again to close the HEC-1 Model Network form.

•
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•
16. Run Draft HEC-1 Model
Select Hydrology => HEC-1 => Model to access the HEC-1 model.

Check the '10 Year' Return Period and the 'Delete Prior Results' option. Uncheck all other return periods and
options.

t!Run H£C·1 Model· MB: 01 ~r9~

Return Period

02Year

OSYear

~10Year

02SYear

DSOYear

0100Year

Options

DAIlBasins

Major Basin l01 1[2]
DUpdale HEC-1
~ Delete Prior Results

I .Qchematic II Oytput " Results )[ Run Model Ilr·..·....QK-·..···_··~

•

•

Click 'Save'. Click 'Run Model' to run the Draft HEC-1 Model. If the model runs correctly, it means the HEC-1
Network is fine. Press 'OK' to close the Run HEC-1 Model form.
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•
17. Initialize Routing Step Values
Select Hydrology => HEC-1 => Routing to access the Routing data. Click on the 'Update from HEC-1' button
to update the Steps. A note will pop up saying that the HEC-1 model will run three times and the 'Steps' field
for all routing channels will be updated if the custom checkbox is not filled in. Select 'Yes'. The following will
be the results for Route ID 010105. Press 'OK' to close the HEC-1 Routing Data form.

~H[C 1 Routing Ddtd . MB: 01 Q@~

Look for

10 Type

I
010110 NORMAL DEPTH

I

v
>

Rotlte

Ma/or 8asin ID 01 [2]
Route ID 010t05

Type rNORMAL DEPTH 1[2]
Normal Depth

LOB N l oo~
StaUon Ele~ation

Chan N I 0038]
1.[ 5100] I 99.70]

~
2 L 1510.0 I [ 94.10l

R08N 0.035

Length I 4224.0
L: f

1585.0 I 93.60 I
Slope I 0.0012 J

1596.0 ] 92. 201
Max Ele~ [ 99.70 £.!illQ!!l.

1600.0 92.20J

Sleps 1
1 0

RB 1612.0 93.60 ]

1662.0 94.90
IlJpdale from HEC-1 I -

2262.0 99.70

•

•

Copy
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•
18. Run HEC-1 Model and Update Data
Select Hydrology => HEC-1 => Model to access the HEC-1 model.

Check the '10 Year' Return Period, the 'Update HEC-1' option and the 'Delete Prior Results' option. Uncheck
all other return periods and options.

tfR~~ HlC-1 M~del- MB: 01 . - ~[Q)r><1

Retllrn Period

D2Year

DSYear

~10Year

025 Year

050Year

0100 Year

Options

o All Basins

Major Basin [01 l[2)
o Update HEC-1
o Delete Prior Results

I g,chematic II Qylput II Results II Run Model IC···"Oi<········..·ij

•

•

Click 'Save'. Click 'Run Model' to run the Updated HEC-1 Model. If the model runs correctly, it means the
HEC-1 Network and data are fine. Press 'OK' to close the Run HEC-1 Model form.
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•
19. Compute the Routing Steps for the Final Model
Select Hydrology => HEC-1 => Routing to access the Routing data. Click on 'Update from HEC-1' to update
the Steps with the updated HEC-1 data and select ·Yes'. The following will be the results for Route 10 010105.

t1 H£C 1 Routing Data· MB: 01 GJ[Q]f8)
Look lor

I I
010110 NORMAl DEPTH I

~l
I

ID Type ROllte

Major Basin 10 01 [2]
Route 10 010105

Type NORMAL DEPTH (2)

y

Normal Depth

LOBN I 003~

Chan N [ OO~~

ROB N r 003"5]

Length I 4224.01

Slope [ 0.001i)

Max Elev r- 99.70].Q!!IDQm

Steps 6J 0

(Update from HEC-1!

ID2ll2!! f.!mllQ.n

1 L 510.0) [ 99.70]

2 [ 1510.0) [ 94:.2.~

LBr 1585.0 93:60]

4 ~960II 92.20J

5 1600.0 JI 92201

RB [ 161201[ 93.60J
7 1662.0 94~O]

8 2262.0 99JOl

•

•

Cop~ II Print..

Click the 'OK' button to close the Routing form.
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•
20. Verify the Final HEC-1 Model Data
Select Hydrology => HEC-1 => Data to access the HEC-1 Data form. You can use this form to review the
HEC-1 model data for different return periods. Currently, it should have data for the 10

KK 01 01 05 BASIN

SA 6.690

~INext )

FO F1 F2

Dejails

FB F9 FlO Sort [" ]
If I20

30

40

50

I60

70

I80

90

100
I

110
120

130

140 -
"n v

)
J

F5 F6 F7F4F3

hist

1JAN99 1200 2000

Unit Hyd rograph: Clark

6 HourS torm

03117120 05

100 YEAR

KVLEXAMP LE1 - Ex mple 1 tutorial project

IT 5

ID

ID

10

10

IN 15

10

10 5
*D IAGRAM

I i',lign Data II EJ:!lt II Import II E~port

I Renum!l.er II Copy II Print... II Qelete Md II Major Basin II Jlpdate " QK

•
To change the return period, press 'Update', highlight a desired return period and Select 'OK'. Press 'OK' to
close the HEC-1 Data form when finished.

Select Return Period

RP

5

10

R 50

I 100

.Q.ancel][ QK

•
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•
21. Run Final HEC-1 Model for All Return Periods
Select Hydrology => HEC-1 => Model to access the HEC-1 model.

Check All Return Periods, Update HEC-1 and Delete Prior Results.
Uncheck All Basins. Press 'Save'.

t.!Run HEC-1 Model - MB: 01 r;](QJ~

Retllrn Period

~2Year

~5Year

~10Year

~ 25 Year

~50Year

~100Year

Options

o All Basins

Major Basin l01 ][2]
~Update HEC-l
~ Delete Prior Results

I Qchematic j[ Oytput II Results ][ Run Model 1[:-QK....·..:..·~1

•

•

Click 'Run Model' to run the Updated HEC-1 Model for all return periods. If the model runs correctly, it means
the HEC-1 Network and data are fine. The results can be viewed by clicking 'Results'. A full output file can be
viewed with the 'Output' button, selecting the specific output file to view and pressing 'OK'. The 100-Year
Schematic can be viewed by pressing the 'Schematic' button.

t} Ii£e 1 flow Summary - MB: 01 grgf?<]
LoOk for

ID SOlt Type Area Q2 Q5 010 Q25 Q50 Ql00

II I
I010105 20 Routed 6.6900 1148 2802 3896 5365 6497 7626

1010110 30 Hydro9raph 5.7000 2271 3697 4662 5948 6924 7872

010110 40 Combined 12.3900 2362 4841 6710 9204 11182 13118

010110 50 Routed 12.3900 2173 4576 6306 8651 10489 12396

I

,

I

~

< )

View Flows I l;;xport II Print.. II Ellter II Major Basin II QK I
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•
21. Graph HEC-1 Results
Select Hydrology => HEC-1 => Graph to access the Graphing module. Enter the appropriate data for your
location and click the 'Graph' button as follows:

... life 1 Graph. !-l@1'Rl
I Graph I Graph Envelope Curves

~ Major Basin 01

Type 0Peak

OUni1

Envelope ~G~

Region 12 Central Arizona

100 Year Peak Discharge. Drainage Area
USGS Comparative Graphs - 12 Central Arizona Region

Basin: 01
1000000

------- ----------....---_...-----.,.------100 -_.--

1000

~ 100000

'"
;' 10000
.c
u..
Q

1
"-

10
010 1.00 10.00

Drainage Area (sq mil
100.00 1000.00

-Envelope -Region - -Low-Mid Elevation

•

•
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•
22. Backup Project
This final step is one of the two most critical steps. The other is the creation of unique folders for each
project (Step 1). Backup your projects on a regular basis. You will save yourself from wasted time and
unnecessary stress!

Select File => Project Management to access the Project Management module. Select 'Backup Project' as
the Action and KVLEXAMPLE1 as the project (use the adjacent icon to select). Click 'Backup'to backup the
project and select the directory where your backup file should go and finally click 'Select' when a directory is
chosen.

Project Mdndgement' fE)

•

•

Action

o Copy Project

o Backup Project

o Impo,l Project

o Clean Up Orphan Records

Project KVLEXAMPLEl

I aackup QK

1[2]

........
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