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WMS TRAINING SCHEDULE

DAY 0 (JUNE 9, 2000): BY FCDMC STAFF

Time Activity Topic

8:00 - 9:15 Lecture Introduction - Customization of WMS for FCDMC
9:15 - 9:30 Break
9:30 -10:15 Lecture Demos
10:15 -10:30 Break
10:30-12:00 Tutorial Session Hands-on
12:00-1 :00 Lunch on your own
1:00-1:45 Lecture Demos
1:45 - 2:00 Break
2:00-4:00 Tutorial Session Hands-on
4:00 - 5:00 Discussions Prepare a list of Questions, sUQQestions, and possible bUQS

DAY 1 (JUNE 12, 2000): BY WMS DEVELOPER

Time Activity Topic

8:00-9:15 Lecture Introduction - Overview of WMS
9:15 - 9:30 Break
9:30 -10:30 Lecture Feature Obiects and the Map Module
10:30-12:00 Tutorial Session Feature Objects
12:00-1 :00 Lunch on your own
1:00-1 :30 Lecture Basin Delineation with Feature Obiects
1:30-2:15 Tutorial Session Basin Delineation with Feature Obiects
2:15 - 2:30 Break
2:30 - 3:15 Lecture OEMs and Automated Basin Delineation with OEMs
3:15-4:00 Tutorial Session OEMs
4:00 - 5:00 Lecture Tins and Automated Basin Delineation with TINs

DAY 2 (JUNE 13, 2000): BY WMS DEVELOPER

Time Activity Topic

8:00 - 8:15 Lecture Review
8:15 - 9:15 Tutorial TINs
9:15 -10:15 Lecture Mapping Curve Numbers and Time of Travel with GIS Objects
10:15 -10:30 Break
10:30 -11 :30 Tutorial Session GIS Mappino
11 :30 - 12:00 Lecture Model Interfaces - National Flood Freauencv (NFF) Program
12:00-1 :00 Lunch on your own
1:00 -1 :30 Tutorial Session NFF Interface
1:30 - 2:30 Lecture HEC-1 and Special Features for Maricopa County
2:30 - 2:45 Break
2:45 - 3:45 Tutorial Session HEC-1
3:45-4:15 Lecture Rational Method
4:15 - 5:00 Tutorial Session Rational Method
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DAY 3 (JUNE 14, 2000): BY WMS DEVELOPER

Time Activity Topic

8:00-8:15 Lecture Review
8:15 - 9:00 Lecture Hydrologic and Hydraulic Calculators
9:00 - 9:45 Tutorial Session HydroloQic and Hydraulic Calculators
9:45 - 10:00 Break
10:00 - 10:30 Lecture Flood Plain Delineation
10:30-11:15 Tutorial Session Flood Plain Delineation
11 :15 - 12:00 Lecture ArcView, WMS-Hydro, Data Collection
12:00-1 :00 Lunch on your own
1:00 -1 :30 Lecture Questions and Answers
1:30 -2:00 Lecture Summary problems overview
2:00 - 2:15 Break
2:15 - 5:00 Tutorial Session Summary problem
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-----.--.-._ WMS Training-------..
.~

"~
"

An Introductory Course

-. -_.-------
-...........

...........
".

Who Ate".you?

• Where are you from?

• Do you have any previous experie
WMS?

• What do you expect to learn?
- Hydrologic models you want to use with



ou Know?

•
• Basic understanding of hydrolo

- The more modeling you have done
but not considered a prerequisite

• Basic computer operations
- Windows 95, or NT

• Course will focus on WMS as a tool for
hydrologic modeling

. ~--.~
.~._--.......

"'.......

Summ~rY'G(Course

• Learn how to process digital e ~. tion data in
support of hydrologic modeling
- Automatic watershed delineation and ge

parameter computations using WMS

- Use watershed data with NFF, HEC-l, TR
Rational Method

• Learn how to use GIS data layers to set up
compute CN's and time of concentration

• Create reports from WMS output

•

•



•

•

•

• Lectures will be mixed with Ii
demonstrations of WMS

• Workshops will reinforce lectures
- Don't be afraid to get of the beaten path

- Basic tutorial sessions (WMS tutorials)

- Advanced tutorial sessions

• ASK QUESTIONS PLEASE!

--.... ...........

HistorY··of.yvMS

• Large library of graphics softW .
developed at ECGL in 70'sand 8

• Development of application for Wate
Delineation in early 1990's.

• ECGL and COE partner to develop WM

.FHWA

• Under development for 6.0 years

• First version released in 1993 (GeoShed)



• As a result ofpartnerships, is distributed
- to Corps of Engineers through u.s.

WES

- to state and federal highway administrato
the Denver regional office.

• EMRL reserves rights to private distributl
- Approximately 600 private licenses

• EMS-I now handles all distribution

--'--

WMS""\iVep Site
-',

• http://www.ems-i.com/software~
• WMS mailing list

• General information on WMS

• News

• Demo versions of WMS

• Bug fixes posted periodically

•

•

•
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Mo'd'ul~s
"

..::t:J Map (GIS Layers)
jj Hydrologic Modeling

m20 Grids

a Scatter Point

f® ~m ~I WMS is organized into'si
.:fJm~

~ TINs
iiii OEMs

•



Macros are available for c
used menu commands

The tool set you see depends on

___ Graphics manipulation tools
are in every module

Tools with arrows are for selection

Tools without arrows are for creation

•

•

•
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• Edit coordinates of selected objects
vertices, etc.)
• Change the active coverage, TIN, data
• Track the coordinates of the cursor in t
graphics window

0,-:,:'. I ;ql( ••1 ~J I
v· _;"

•
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I;nages
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Watershed"'D,elineation..' ....

•

• Traditionally done from paper ' a; s

• WMS provides 3 different ways
- From Map/GIS-based data (semi-autom

- From DEMs (automated)

- From TINs (automated)
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The Basi~ Goal

• Create a digital representation
watershed
- automatically generate a topologic tree

• Compute geometric parameters

• Run Hydrologic model
- HEC-I, TR20, TR-55, Rational, NFF, others

--'-. - ..-._--
....-......

..............

•

Elevation grid

Flow direction

Flow
accumulation

Outlet location

Delineate
watershed



Elevation data
Bounding polygon
and streams
Generate TIN
Outlet location
Delineate
watershed

---~-

------"'-'
' ..... ........

• GIS Vector Data

Points

Lines

Polygons

•

•

•
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DEM delineation

TIN delineation

Alone

Land use

Soil

Others
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WMS Map ry10dule
"

• At the heart of most WMS operations
"- GIS data

-DEMs

-TINs

-.-..- _,

G

•

o

• •
o
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Watershed Feat~re Objects
""

, '
'.

Polygons - basini)k.
"~b!'f

r--l.-----~____ Arcs - streams .;;';,:1,

Feature Oi3}ect Attributes
''-,

• Attributes are associated with t
point/node, arc, polygon

•

•

•
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Purposes of F'e~~ure Objects
""~'~"

• To create watershed representations directly

• Store results of basin delineation WI
DEMs

• As a "conceptual model" for TIN creati ~

- In version 5.1 TIN results can also be
transferred back to feature objects (primarily
for export reasons)

• Provide a common gateway to GIS data

----- --._---
.......................

....•.

Cover.~ges
-"-"

• Feature Objects can be group
layers called "coverages".

• The attributes assigned to a feature
depend on the coverage type.
- drainage, land use, soil type, etc.

• One coverage is designated as the "active'
coverage. New objects are added to the
active coverage. Only objects in the active
coverage can be edited.



Coverage,.Jypes
"'-'-.

'¥

•
• Generic
• Drainage (default)

• Land Use

• Soil Type

• Runoff Coefficient

• Time Computation

• Others ...

•
.-.-..-.. ,

Drainage""GQverage
"

• Create watersheds and hydrolo .
from feature objects and DEMs

• Create TINs of an appropriate resolu
from another elevation source

• Primary coverage type for WMS
-llv1PORTANT: Only one drainage coverage

type per model can exist

•
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.Time ComputatiQ.~ Coverage

• Use arcs to specify runoff pathS\,

• Define equations for each arc seg ,
- TR55, FHWA, Maricopa County, Other

• Compute Time of Concentration or Lag
Time for a basin

• Compute travel time between outlet points

.._-----~_.---._-

------
LandUse,Qoverage

"'"
• Assign a land use id to each gon

- polygons can be imported from D
files

• Define a Land use table
ill, "Description ofland use type",SoilACN,SoilBCN,SoilCCN,Soi

\, 'FuIIy dcv<:Ioped arba _ .-ce. Pooo", 61, 79, 86, 19
2, "Fully dcv<:Ioped urb. _ Flit", 49, 69, 79,14
3, 'FoDy dcv<:Ioped arba _ Good", 39, 6\, 14, so
4, "PIveci PumllClll, rooD, drlvewoyo, de. (ad. AOW'f. 91, 91, 91, 91
~, "PIvecl_ widl =bt aad __ ........ (ad. ROW)', 91, 91, 91, 91
6, "PIvecl_widl ..... di1cll.. (iIlci. ROWr, 13,19, 92, 93
1, "Gnvd_, 16, 1', 19, 9\

• Use with soil type coverage to define eN's
Green-Ampt parameters



Soil TypeC.pverage

• Assign a soil type or an ID to each polygon
- hydrologic soil type A, B, C, D ~:.~}'~

- polygons and their ill's can be importe~

DXF or shape files

• Use with land use coverage to define C
or Green-Ampt parameters

• Use with soil type ID' s and a runoff
coefficient table to compute runoff
coefficients

•

•

•
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Runoff Coeffiti-eQt Coverage
"'-".....,,"..

• Used to compute composite basin J3..unoff
Coefficients .~ -

• A runoff coefficient is assigned to ea .
polygon in the coverage

• When a runoff coefficient is assigned to
polygon, the basin runoff coefficients are
automatically re-computed for the TIN

_._.._-----

----------~-Otfle(S

• Generic
- generally only an intennediate value

- editing perfonned so conversion to a eli
coverage would be possible

.CASC2D
- Used for defmition of2-D research models



Creating Feature Objects
"

• On-screen Digitizing (point and ~lick)

- images - scanned topo maps

- hill shaded DEMs - best if saved as an '1

first

- contours

• Import (DXF, shape files, DLG)
- shape files

-DXF

-DLG

.......

• TIFF Image
- desktop scanner

- DRG files developed by the USGS

- private companies

• Must register the image using three point

• Used as a background map to digitize
streams, land use polygons, etc.

•

•

•
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......
-'.

Image D'eft~ition

• Pixel coordinates

-------._-....

Regi'siert!1g Images
......, .....

Registration Tics

Pixel Coordinates ---

Real World Coordinates



Using Imag~s to Create
Feature Objects

- - ---
~ ~- '-- ._~. - ---

USingcOhtuws to Create
'--.

Feature 0 "ects

•

•

•
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Using a Shaded OEM to
Create Feature Objects

~. .~~11J
;i~'

-'- ._-----
Importinff"Exi,sting Data to

"Create Featur Objects
• ArcView Shape files

• DXF Files

• DLG Files



ArcView Shape Files

• Can be created from ArcView or ARC/INFO
".:z

• Attributes imported depend on cov~~? ' !ype

• The ARCSHAPE command can be us
convert and Arc/Info Coverage to a sha
file.

• Once a shape file has been imported you
want to convert to a WMS map file.

.----.
._--...._---..

.............. .....

DXF"'F-iles
"""

• Used as a background picture t
feature object on scr~en

• Converted directly to feature objects
- Points

-Lines

- Polylines

•

•

•
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C~P~R 2

Basic Feature Object Manipulation

The Map Module is at the heart of most operations in WMS, so it is important
to gain a good understanding of how to create, edit, and apply feature objects.
Within WMS, feature object data can be used for drainage characterization,
land use, soil types, time of travel calculations, and many other applications.
Often, the data you will want to use already exists in some other formats. This
tutorial session will focus on the basic concepts behind manipulating feature
objects and coverages. Also, this tutorial will discuss creating feature objects
from background images.

•

2.1 Feature Object Definitions

Feature objects in WMS have been patterned after Geographic Information
Systems (GIS) data objects and include points, nodes, arcs, and polygons
(Figure 2-1).
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Point

Io
Node

•

Arc Polygons

Figure 2-1 Feature Objects.

Feature objects can be grouped into coverages. Each coverage represents a
particular set or group of data. The following coverage types can be used in
WMS:

I. Drainage - defines basin boundaries and stream networks.

2. Land Use - defines land use type polygons

3. Soil - defines soil type polygons

4. Time Computation - used for determining lag times and times of
concentration.

5. Generic

6. Other model specific coverages

In this tutorial you will learn how to create points. arcs, and polygons to
develop these coverage types.

2.2 Display and Manipulation of Coverages

Because there are several different data layers represented by feature objects,
it is important to understand a few rules about how they are created and edited.
There is always one and only one active coverage at a time in WMS. Any
time you wish to edit points, arcs, or polygons in a coverage, that coverage
must be designated as the active coverage. Also, any new feature objects that
are created are added to the active coverage. The active coverage is the only

•

•
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Basic Feature Object Manipulation 2-3·

one displayed in full colors. All feature objects of the inactive coverages are
displayed in a single color (light gray by default).

In this section you will learn how to open a file and work with multiple
coverages.

I. Select the Map module icon:if3J.

2. Open asptutor.map.

3. Select the Coverages... command from the Feature Objects menu.

4. Notice that for each coverage, the name, attribute set, active status,
and visible status can be changed. To change the attributes for a
coverage, select the coverage name from the text window and set its
attributes.

Figure 2-2 The Coverages Dialog.

•

5. Select the Soil Type coverage from the text window and tum off the
Visible option. Then, select the lAnd Use coverage from the text
window and turn off the Visible option. Select the OK button to exit
the Coverages dialog. Notice that the only coverage displayed is the
drainage coverage.

6. Select the Coverages... command from the Feature Objects menu. Set
the Soil Type and lAnd Use coverages to visible. Select the lAnd Use
coverage and select the Active button. Select the OK button to exit the
Coverages dialog. Notice how the lAnd Use coverage is now drawn
in different colors, while the other coverages are drawn in the inactive
coverage color.
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7. Select the select polygon tool!· ,select one of the polygons in the
Land Use coverage, and select the Attributes... command from the
Feature Objects menu. Notice that the Land Use Mapping dialog
comes up. This dialog can be used to assign land use ID's to selected
land use polygons. The Land Use Mapping dialog can also be used to
change the attributes assigned to each land use ID and to create new
land use ID's. Select Close to exit the Land Use Mapping dialog.

8. Select the Display Options command from the Display menu.

9. Select the Map tab.

10. Turn on the Land use legend option and select the OK button. Notice
that a land use legend is displayed on the screen.

11. The upper left comer of the edit window displays the active coverage
and the drop-down combo box allows you to change the active
coverage without invoking the Coverages dialog as demonstrated
previously. Change the active coverage to the Drainage coverage by
choosing it from the active coverages drop-down combo box in the
Edit window.

12. Select the select polygon tool, select one of the polygons in the
Drainage coverage, and select the Attributes... command from the
Feature Objects menu. Notice that the Drainage Feature Polygon
Type dialog comes up.

13. The Drainage Feature Polygon Type dialog can be used to change the
type of a drainage polygon to a Generic, Drainage, or a
LakelReservoir polygon. The polygon (as well as the point and arc)
attribute dialog changes are based on the type of the active coverage
and the selected tool. For example, if the active coverage is a land use
coverage and the select polygon tool is selected, the Land Use
Mapping dialog will come up. However, if the active coverage is a
drainage coverage and the select polygon tool is selected, the
Drainage Feature Polygon Type dialog comes up. Select the Cancel
button to close the Drainage Feature Polygon Type dialog.

14. Select the Display Options command from the Display menu.

15. Select the Map tab.

16. Select the Land Use coverage from the drop-down list at the top of the
dialog.

17. Toggle the Land use legend option off and select OK.

18. Select the New command from the File menu to delete all your data.

•

•

•
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Basic Feature Object Manipulation 2-5

Using TIFF Images to Create Feature Objects

An image is an excellent way to provide a "background" picture from which
streams or other features may be digitized directly from the screen. However.
before an image can be used to define feature objects with accurate
coordinates, it must be properly registered. All of the tools necessary to
register and use images are available within the WMS interface.

There are three basic scenarios for registering images:

I. You must determine the correct coordinates and enter them manually
in the image registration dialog. This is what is demonstrated in this
tutorial and generally is applicable if you have scanned the image
yourself using a desktop scanner.

2. You image file (.tif) contains a corresponding tiff world file (.tfw).
The tiff world file will have the correct registration information for the
image and can be imported into WMS. The USGS digital raster
graphics files (DRGs) have the .tfw files and most organizations that
distribute them include the world files as well.

3. Many of the newer tiff files contain the registration information within
the image file (.tif) itself. This is referred to as a geotiff file. When
WMS reads a geotiff file it will bypass the registration window. The
image will be registered automatically.

You can obtain TIFF images using a standard desktop scanner, by purchasing
from a digital data provider, or from some locations on the internet (see
http://www.emrl.byu.edu/gishydrodata/images.htm for a list of some of these
sites). The image used for this tutorial was obtained from a USGS digital
raster graphics (DRG) ftle.

•

2.3.1 Importing and Registering a TIFF Image

To import and register the TIFF image being used ill this tutorial do the
following:

1. Select the Map module icon II.
2. Select the Import command from the Images menu.

3. Use the file browser to locate and open the file named ''jonescyn.tif''.
By default this file is found in the tutorial directory.

After a few seconds of reading the file an image of a portion of USGS quad
map will appear in the Register Image dialog as shown in Figure 2-3 .
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•

•
Figure 2-3 Image Registration Dialog.

Pixel coordinates of the image must be registered to proper ground locations
so that feature objects created by on-screen digitization will have the proper
coordinates.

• Set the values for the u,v and x,y pairs of each point according to the
table below and select the OK button:

Registration Points

•
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2.3.2

Basic Feature Object Manipulation 2-7

Point 1 Point 2 Point 3
U 0 0 715
V 756 0 0
X 422424 422424 426273
Y 4519461 4515391 4515391

The image will be resampled so that as much of the image as possible is fit
into the Graphics window (an image will often be of a higher resolution than
the screen). After a few seconds you should see the image in the Graphics
window.

Displaying and Manipulating Images

I. Select the zoom tool

2. Zoom in on any portion of the image.

The image will become blurry since there are now more screen pixels than
there are pixels in the portion of the image being displayed.

I. Select the pan tool

2. Pan to a different portion of the image by dragging the cursor in the
Graphics window.

3. Select the Resample command from the Image menu.

The image will become clearer after it is resampled.

1. Pan the image by dragging the cursor in the Graphics window.

The image will not cover the entire screen until another resample command is
given. To summarize how resampling works with the zoom and pan tool:

• If you zoom in on an image it will become more blurred (unless your
image has a lower resolution than the screen, or you have zoomed in
and resampled to the point that the region of the image you are looking
at has a lower resolution than the screen).

• You can pan an image if you zoom in without resampling.

• After resampling, the image will become as clear as possible, and fit
the Graphics window.

After any sequence of zooming, panning, and resampling you can restore the
original image by doing the following:

1. Select the Fit Entire Image command from the Image menu.



2-8 WMS Tutorials

2. Select the Resample command from the Image menu.

3. Select the frame macro .~. •
2.3.3 Using an Image to Define Feature Objects

As mentioned previously, the TIFF image you have imported is a scanned
image of a USGS quadrangle map. This particular map corresponds to the
northwest comer of Salt Lake City, Utah.

't~:-;'i

1. Select the Create Point tooI R.'¥ .

2. Click on the point labeled as the beginning boundary point in Figure
2-4.

3. Select the Create Arc tool'

4. Select the Attributes command from the Feature Objects menu.

5. Choose the Generic arc type and select the OK button.

6. Define a single arc, which will serve as the boundary, by clicking on
the feature point already created and then along several other points of
the polygon shown in Figure 2-4 until you close the arc on itself by •
clicking on the first point a second time.

7. Select the Attributes command from the Feature Objects menu.

8. Choose the stream arc type and select the OK button.

9. Using the streams/road from the image in Figure 2-4 as a guide enter
the two stream branches starting from the point marked "outlet" in
Figure 2-4. Be sure to double-click to end the entry of a stream
segment.

You may need to zoom and/or pan and resample the image in order to see
features more clearly.

•
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• Figure 2-4

Basic Feature Object Manipulation 2-g

Completed Feature Objects for Jones Canyon Watershed.

•

2.3.4

If you have troubles defining the feature objects you can read in the map file
named "jonescyn.map" to see what the final boundary and streams should look
like.

Saving a File and Deleting the Feature Objects

If you would like to save your feature objects for later use in creating a TIN:

1. Select Save As... from the File menu.

2. Click on the Maps toggle box.

3. Turn off any other toggle box that may be on, including the super file,
display options file, tree file, and image registration file. Since the
image file has already been saved, you only need to save the feature
object data at this time.

4. Click on the directory button and specify a directory where you want
to save your files.

5. Enter "jonesl.map" for the filename.
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6. Hit Save to exit the Save Files dialog and save the map file.

Now that you have saved this map file you may delete these feature objects by
doing the following commands:

I. Select New from the File menu.

2. Select OK to confirm that you want to delete all data.

2.4 Conclusion

This concludes the Basic Feature Object Manipulation tutorial. In this
tutorial, you have learned some of the basic concepts behind manipulating
feature objects and coverages. You have also learned how to digitize feature
objects from background images.

•

•

•
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Advanced Feature Object Manipulation

The previous tutorial focused on some basic concepts needed for creating and
editing feature objects. This tutorial will focus on more advanced topics.
First, you will learn about tools for cleaning and editing feature objects. Then,
you will learn how to import and use data in ArcView® Shapefile and DXF
format as feature objects in WMS.

3.1 Cleaning and Editing Feature Objects

Two scenarios can exist when using feature objects in WMS. The first is that
you have feature objects in another format that you have read into WMS. The
second is that you use WMS to develop your data. In this section, you will
first learn to import and clean existing data. Then, you will learn some
techniques for creating feature object data in WMS.

•

3.1.1 Importing and Cleaning Feature Object Data

This section will demonstrate various options for cleaning feature objects in
WMS. Options to intersect selected arcs, snap selected nodes, and remove
dangling arcs will be discussed. Then, the arcs will be converted to streams
for input into a watershed model.

Importing the Feature Object Data

1. Select the Open command from the File menu.
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2. Find and open "arco.sup ". It may take a few seconds for the superfile
to read in.

3. Switch to the Map module by clicking on the Map icon .~ at the top
of the Toolbox.

4. Select the Resample command from the Images menu to resample
your image to the size of the screen.

5. Select the Import command from the File menu.

6. Select the Shape file->Feature objects option and select the OK
button.

7. In the Import Shapefile Data window, select the arcs file browser
button.

8. Find and open "arco.shp ".

HINT: In the arc attribute text window, notice that the DRAINTYPE
database field is automatically mapped to the Drainage Arc type
attribute in WMS. This occurred only because the attribute name in
the stream file was DRAINTYPE. If the drainage type attribute name
is anything other than DRAINTYPE it can still be assigned to the WMS
Drainage Arc type variable manually using the Attribute
mapping... button.

9. Select OK and wait a few seconds while the stream shapefile for the
Area watershed is read in and displayed.

Intersecting Selected Arcs

There are two arcs that overlap each other in this model. Overlapping arcs are
not allowed in WMS, so you should intersect these arcs.

1. Select the zoom tool 131 and drag a box around the location of the
intersecting arcs. The intersecting arcs are marked with an arrow that
is labeled "Intersect", as in Figure 3-1.

2. Select the Resample command from the Images menu to resample
your image to the size of the screen.

•

•

3. Select the Select Arcs tool in the toolbox.

4. Find and use SHIFT-select to select the two intersecting arcs (See
Figure 3-1).

•
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•
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Figure 3-1
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5. Select the Clean... command from the Feature Objects menu.

6. Make sure the Intersect selected arcs option is selected and select the
OK button. The two selected arcs will be intersected and a node will
be created at their intersection point.

Removing Dangling Arcs

After intersecting the overlapping arcs, a small dangling arc was created.
Deleting a dangling arc is easy... simply select the arc and delete it.

1. Find and select the dangling arc (See Figure 3-1).

2. Select the Delete command from the Edit menu. If prompted, select
OK to delete the selected arc.

Snapping Selected Nodes

Occasionally, arcs or nodes on arcs that should be connected are not.
Sometimes, these problems can be fixed by intersecting all the overlapping
arcs and removing the dangling arcs using the automatic clean functions in
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WMS. Other times, you need to snap a node or vertex on one arc to a node or
vertex on another arc.

I. Select the Frame Image macro m.
2. Select the zoom tool .C\I and drag a box around the location of the

nodes that need to be snapped together. The nodes that need to be
snapped are marked with an arrow that is labeled '"Snap", as in Figure
3-2. You may have to zoom in very close to ee that the nodes are not
connected to each other.

3. Select the Resample command from the Images menu to resample
your image to the size of the screen.

4. Select the Select Point/Node tool '11.1.

5. Select the node at the end of the arc to snap (See Figure 3-2).

~

I

--

•

•

6, Select the Clean... command from the Feature Objects menu.

Figure 3-2 Snapping Selected Nodes

•
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7. Make sure the Snap selected nodes option is selected and select the
OK button. You will be prompted to select a snapping point. Select a
vertex on the arc adjacent to the selected node. The two points will be
snapped together and a node will be created at the intersection of the
arcs.

Creating Streams from Existing Feature Objects

Now that the arcs are cleaned, you are ready to convert your generic arcs to
stream arcs.

I. Select the Frame Image macro l~.

2. Select the Resample command from the Images menu to resample
your image to the size of the screen.

3. Select the zoom tool and drag a box around the location of the
downstream point. The downstream point is marked with an arrow
that is labeled "Downstream point", as in Figure 3-3.

4. Select the Resample command from the Images menu to resample
your image to the size of the screen.

•

•

/
/

Figure 3-3 Reordering Streams.
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S. Select the Select Point/Node tool.l!ll.

6. Select the downstream node (See Figure 3-3).

7. Select the Reorder Streams command from the Feature Objects menu.

8. Select the Frame Image macro 'lim.
9. Select the Resample command from the Images menu to resample

your image to the size of the screen.

10. Select the Select Stream Network tool 'mi.
11. Select any location on the arc network.

12. Select the Attributes... command from the Feature Objects menu.
Change the current feature arc type to Stream and select the OK
button. The stream network will be generated and linked to the
hydrologic modeling tree.

•

3.1.2 Creating Feature Objects from Images

Sometimes, you may have existing GIS data that you have been able to read
into WMS. But the data may not have all the attributes required for your
model. In addition, some data may not be in a format usable by WMS. Some
data, such as land use data or soil type data, must be digitized in WMS as
feature objects before it can be put to use.

Creating and Removing Attributes

In this section, you will learn how to convert a vertex to a node and how to
assign an attribute to that node. Recall that each arc consists of two nodes and
any number of vertices. The vertices define the shape of the arc and the nodes
define the arc's endpoints. Nodes can have attributes, but vertices cannot.

1. Select the Select Feature Vertex tool III.
2. Use SHIFf-select to select the two vertices labeled as outlet points.

•

•
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Figure 3-4 Creating Outlet Points.

•

•

3. Select the Vertex <-> Node command from the Feature Objects menu.

4. Select the Select PointlNode tool

5. Use SHIFf-select to select the two nodes labeled as outlet points.

6. Select the Attributes... command from the Feature Objects menu.

7. Change the attributes of the selected nodes to Drainage outlet and
select the OK button. The newly created outlets will be linked to the
hydrologic modeling tree.

Creating Soils Data from Image Data

To compute composite curve numbers or runoff coefficients, you need a soil
coverage defming the boundaries of each soil in your watershed. In the Arco
watershed model, the boundaries of each soil are defmed in the image, but not
as a coverage.

1. Select the Coverages... command from the Feature Objects menu.

2. Select the New button in the Coverages dialog.

3. Change the name of the new coverage to Soil Type and change the
coverage's Attribute set to Soil Type.

4. Select the OK button in the Coverages window.
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5. There are now two coverages: The drainage coverage and the soils
coverage. Your next task wiIl be to create arcs and polygons defining

the soils coverage. Select the Create Feature Arc tool iiJ:l.
6. Create a rectangular boundary around your entire model by selecting

one comer. Then select each of the remaining comers and create a
single closed arc around your entire model, as shown in Figure 3-5.

•

•
Figure 3-5 Step 1-Greate a Single Arc around the Entire Window.

7. The pink lines in the image represent soil type boundaries. Select a
point on the rectangular boundary that intersects with one of the pink
lines and create an arc along the pink line until another boundary line
is reached.

lllNT: If you click close to an existing arc when creating an arc, the
arc you are creating will automatically snap to that existing arc. All
the arcs you create in a soil type coverage must be connected to each
other and form closed polygons. If closed polygons are not created,
WMS will not be able to determine the type of soil for each point in
your watershed model.

•



•

•
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8. Create arcs from the other soil boundary lines, as shown in Figure 3-6.
Be sure all the soil arcs form closed polygons. You don't have to be
too accurate when creating the soil boundary arcs. If you are creating
a real model, of course, you should try to be more accurate.

Figure 3-6 Step 2-Greate Arcs Along the Soil Type Boundaries.

•

3.1.3 Building Polygons

ow that you have defined the boundaries for the soils in your coverage, you
are ready to build polygons and assign soil attributes to each polygon.
Polygons must be built to assign soil types to areas in the soil coverage.

1. Select the Build Polygon command from the Feature Objects menu.

2. When prompted if you want to use all arcs to build the polygons,
select OK to build the polygons. If you built the soil arcs correctly,
polygons will be generated from your soil arcs.

3. Select the Select Polygon tool !. . This tool must be selected to
access the polygon attributes for the land use coverage.
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4. Notice that the type of each soil is written on the background image.
Use SHIFf-select to select all the soil type A polygons and select the •
Attributes... command from the Feature Objects menu.

5. Note in the Soil type mapping dialog (Figure 3-7) that SCS soil type A
is the default soil type when a soil polygon is created. Select the
Apply button to assign this default value to all the selected polygons .

•
Figure 3-7 The Soil Type Mapping Dialog.

6. Perfonn steps 4 and 5 for soil types B, and C. For soil type B, you
will need to change the WMS soUID to SoUID 1. For soil type C, you
need to change the WMS soUID to SoUID 2.

7. Select the Display Options... command from the Display menu.

8. Toggle the Color fill polygons option on and select the OK button.

9. Select the New command from the FUe menu.

10. Select OK to confinn that you want to delete all data.

•
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Importing Feature Objects from Arc/Info (ArcView) Shape
Files

You have now learned how to create watershed boundaries and streams in the
map module from digital image data and digital elevation data. What if you
already have watershed boundaries, streams, or both in a Geographic
Information System (GIS) and you want to read this data into WMS? Or what
if you have soil type and land use information stored in a GIS?

WMS provides tools to import and export ArcView® GIS shapefiles. Some
basic functions of these tools will be discussed in this section. For more
information on where you can download these data see:
www.emrl.byu.edu/gishydrodata.

•

•

3.2.1

3.2.2

Reading a WMS Map Drainage File

First, you will read in a map file containing basins and streams in the Aspen
Grove, Utah watershed.

1. Select the Open... command from the File menu.

2. Find and open aspencn.map, a map drainage file of a watershed
containing streams, basin boundaries, and outlet points.

Importing a Soil Type Shape File

In this section, you will perform the next step in computing a composite curve
number-importing a soil type shapefile.

1. Select the Import... command from the File menu.

2. Select the Shape jile->Feature objects option and select the OK
button.

HINT: It is extremely important that you create a new soil type
coverage when importing a soil type shapefile or any other type of
attribute shapefile. After creating the new coverage, you must specify
the coverage attribute type as explained below.

3. Select the Coverage options... button in the Import Shapejile Data
dialog.

4. Select the New button in the Coverages window.

S. Change the name of the coverage to Soil Type and change the
coverage's Attribute set to Soil Type.
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6. Select the OK button in the Coverages window.

7. In the Import Shapefile Data window, select the polygons file browser
button (see Figure 3-8). •

•
Figure 3-8 The Import Shapefile Dialog.

3.2.3

8. Find and open "aspenso.shp".

9. In the polygon attribute text window (see Figure 3-8), notice that the
HYDGRP database field is automatically mapped to the SCS soil type
attribute in WMS. This occurred only because the attribute name in
the soil type file was HYDGRP. If the attribute name is anything other
than HYDGRP it can still be assigned to the WMS SCS soil type
variable manually using the Attribute mapping... button.

10. Select OK and wait a few seconds while the soil type shapefile for the
Aspen Grove watershed is read in and displayed.

Importing a Land Use Shape File

After importing or creating your watershed model, you can import other GIS
data to compute hydrologic parameters such as curve numbers or runoff

•



•

•

•

3.2.4

Advanced Feature Object Manipulation 3-13

coefficients. To compute a curve number, for example, you need land use and
soil type coverages. You will now import a land use shapefile.

1. Select the Import... command from the File menu.

2. Select the Shape file->Feature objects option and select the OK
button.

HINT: It is extremely important that you create a new land use
coverage when importing a land use shapefile or any other type of
attribute shapefile. After creating the new coverage, you must specify
the coverage attribute type as explained below.

3. Select the Coverage options... button in the Import Shapefile Data
dialog.

4. Select the New button in the Coverages window.

5. Change the name of the coverage to Land Use and change the
coverage's Attribute set to Land Use.

6. Select the OK button in the Coverages window.

7. In the Import Shapefile Data window, select the polygons file browser
button.

8. Find and open "aspenlu.shp".

9. In the polygon attribute text window, notice that the LU_CODE
database field is automatically mapped to the Land use attribute in
WMS. This occurred only because the attribute name in the land use
file was LU_CODE. If the attribute name is anything other than
LU_CODE it can still be assigned to the WMS Land Use variable
manually using the Attribute mapping... button.

10. Select OK and wait a few seconds while the land use shapefile for the
Aspen Grove watershed is read in and displayed.

Assigning Attributes to Feature Objects

When reading in your land use and soil type shapefiles, an ID is read in for
each land use and soil type polygon. However, you still need to be able to
compute a curve number for each basin in the Aspen Grove watershed. But
how do you relate the soil type ID and land use ID in each of these polygons to
a curve number?

WMS stores a separate table for each land use ID. This table relates each land
use ID to a land use name, a curve number for each SCS soil type CA, B, C,
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and D), and other land use properties. When WMS computes the curve number
for each basin, it determines the soil type and land use for several locations in
the sub-basin. WMS then determines the curve number for each of these
locations using the land use table. Fortunately, WMS provides an easy method
of setting up this land use table in the land use polygon attributes dialog.

In this section, you will learn how to set up a land use table using the land use
polygon attributes dialog.

\. Switch to the Map module by clicking on the Map icon ...d::J at the top
of the Toolbox.

2. In the Coverage box in the Edit Window, make sure the "Land Use"
coverage is the active coverage.

3. Select the Display Options... command from the Display menu.

4. Toggle the Land use legend option on and select the OK button to
close the Land Use Feature Object Display Options dialog. Notice
that a land use legend appears on your graphics window (see Figure
3-9). Three land use ID's are shown on the legend. You must assign
data to each of these land use ID's.

•

•

Figure 3-9 The Land Use Polygon Attributes (Land Use Mapping) Dialog.

•
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5. Select the Select Polygon tool '!.ill. This tool must be selected to
access the polygon attributes for the land use coverage.

6. Select the Attributes... command from the Feature Objects menu.

7. In the Land use mapping dialog window, select Land 10 32 from the
WMS landuse ID window. In the Selected land use properties
window, select the Land name row and change the name of the land
use to "Shrub and Brush Rangeland", as in Figure 3-9.

8. In the Selected land use properties window, select the SCS Soil type A
CN row and change the Type A CN Value to 49. Select the SCS Soil
type B CN row and change the Type B CN Value to 69. Select the SCS
Soil type C CN row and change the Type C CN Value to 79. Select the
SCS Soil type D CN row and change the Type 0 eN Value to 84.

9. Repeat steps 8 and 9 for soil types 41 and 42 with the following Curve
number and name values:

10. In the Export file type field, select the option to export an SCS Land
use file. Select the Export SCS file button, go to the directory where
you want to save the land use file, and call the SCS land use file
"aspencn.tbl". After exporting, this file can be used later without
having to set it up again.

11. Select the Close button to close the Land use mapping dialog.

12. In the Coverage box in the Edit Window, make sure the "Drainage"
coverage is the active coverage.

13. Switch to the Tree module by clicking on the Hydrologic Modeling

module icon III at the top of the Toolbox.

14. Select the Composite Runoff Coeff/CN... command from the
Calculators menu.

15. Select SCS Curve numbers for the Computation type and select the OK
button to compute the composite Curve numbers for each basin. WMS
will take a few seconds while the curve numbers for each basin are
computed. If you want to display the curve numbers for each sub-
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basin, you can tum them on from the Display Options dialog under the
Drainage tab.

16. Switch to the Map module by clicking on the Map icon '~I at the top
of the Toolbox.

17. In the Coverage box in the Edit Window, select the "Land Use"
coverage to make it active.

18. Select the Display Options... command from the Display menu.

19. Toggle the Display land use legend option off and select the OK
button to close the Land Use Feature Object Display Options dialog.

20. Delete all your data by selecting the New option from the File menu.
Select OK to delete all your data.

3.3 Creating Feature Objects from DXF Data

•

DXF data files can be imported and used in WMS for creating streams or other
feature object data in two different ways: 1) direct conversion, or 2) using
them as a background map. DXF files from any application can be used, but
must be in R-12 format. See the user manual for help in converting to R-12 •
format if you have problems reading a particular DXF file.

3.3.1 Creating a Boundary Polygon

Although the DXF file can contain data for the boundary of the watershed, the
file that you will import contains data for the stream. The boundary that will
be used in this portion of the tutorial will be read from an existing map file
(" .map"). To read the file:

1. Select Open from the File menu.

2. Using the file browser, find and open "aspenbnd.map."

3. Select YES if prompted to delete the current feature objects.

3.3.2 Importing a DXF File

To import the DXF file:

1. Select Import from the DXF menu.

2. Find and Open the file named "aspen.dxj."

•
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The file will be imported and then displayed in the main window. The next
two sections illustrate the two different ways DXF data can be used to create
feature objects.

Digitizing Feature Objects From DXF Data

The first way DXF data can be used to create feature objects is by simply
digitizing new arcs/polygons over the top of the existing data.

I. Select the Create Arc tool '~.

2. Select the Attributes... command from the Feature Objects menu.

3. Change the arc attribute type to Stream and select OK.

4. Create the arc along the main stream by clicking on the outlet point
(lower right) and then clicking on additional points along the DXF
stream data. Be sure to click (create a vertex) at locations along the
main stream at branching locations.

5. Finish the stream arc by double clicking on the last point.

Repeat steps 4 and 5 for each of the stream branches. If you missed placing a
vertex at one of the stream branches you can:

1. Select the Create Feature Vertex tool "III.
2. Click on any locations along the stream arc where the stream

branches.

3. Select the Create Feature Arc tool III.
If you wish to save the completed feature objects to a map file you may do so,
but you must delete the feature objects before proceeding to the next section.

1. Select the DeLete command from the Feature Objects menu.

2. Select OK to confirm that you want to delete the feature objects.

Converting DXF Data to Feature Objects

A more direct approach, especially for large data files, is to convert the DXF
data to Feature Objects. This is done using the following steps:

1. Select the DXF->Feature Objects command from the DXF menu.
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2. Tum on the toggle to convert arcs from dxf lines and tum off the
toggle to convert points from dxf points (nodes for arcs will •
automatically be placed at the beginning and ending locations of the
dxf lines).

3. Select the option to Add to currently active coverage.

4. Select OK.

Since the DXF line segments may not be ordered properly for stream arcs
(connected from downstream to upstream) they are defined as generic arcs.
You must now reorder the arcs for streams, and then convert them to stream
type.

I. Select the Select Points/Nodes tool 1"-'1.
2. Select the downstream most point in the lower right of the mam

window.

3. Select the Reorder Streams command from the Feature Objects menu.

3.3.5

4. Select the Select Network tool

5. Select anyone of the stream arcs.

6. Select the Attributes command from the Feature Objects menu.

7. Choose the stream type option and select OK.

Saving the Feature Objects to a Map File

Now that you have created feature objects you can save them to a map file if
you want to use them later.

1. Select Save As from the File menu.

2. Turn on the Map toggle box.

3. Turn off any other toggle box that may be on.

4. Specify the directory where you want to save your files.

5. Enter laspen3.map" for the filename.

6. Select Save to exit the Save Files dialog and save the map file.

7. Select the New command from the File menu.

•

•
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8. Select OK to confirm that you want all data deleted.

Conclusion

This concludes the Advanced Feature Object Manipulation tutorial. In this
tutorial, you have learned about some of the tools in WMS for cleaning and
editing feature objects. You have also learned how to assign some attributes to
feature objects. Finally you have learned how to import and use data in
ArcView® Shapefile and DXF format as feature objects in WMS.
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Supplementary Excerise for Map Module Basics-Session 2

For this exercise. a set of dems is provided. You will also need to use Paint Shop Pro.

All files for this exercise are located in the Supplimentary 2 directory.

I . Digitizing from Contours

Since the DEM is ultimately used to map elevations it is best to create the streams so that they cOITespond to
the DEM. One of the best ways to do this is by on-screen digitizing using the contours as a guide.

a) Import the following USGS DEM files:

wallsrdg.dem

bridal.dem

b) Tum on color-filled contouring.

c) Read in the following map file:

sfpoint.map

d) Create the major streams from this point up. Don't worry about a boundary polygon at this point, you
will do that in the next exercise.

e) Save your map as sf.map

2. Digitizing from a hillshade image

An appropriately shaded DEM (hillshade) can be useful in identifying key features, particularly the rough
boundary.

a) Import the following USGS DEM files:

wallsrdg.dem

bridal.dem

b) Set the display step to I and shade the DEM.

c) Move the cursor to the four corner points of the DEM and record their values.

d) Using Paint Shop Pro, capture the shaded DEM. Save the captured image as a TIFF file in the extra
directory.

e) Import and geo-reference the TIFF image you just created

t) Use the TIFF image to create a "rough" watershed boundary.

g) Save your map file as sf.map.

3. Digitizing from DLG data

An appropriately shaded DEM (hillshade) can be useful in identifying key features, particularly the rough
boundary.

a) Import the following USGS DEM files:

slc_e.dem



slc_w.dem

b) Tum on color-filled contouring.

c) Import the following DLG files:

slS.dlg

s17.dlg

s18.dlg

d) Use the DLG points to create a set of streams.

•

•

•
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Watershed··'D.~lineation
" .

• Traditionally done from pape~"'inaRs
~

• WMS provides 3 different ways ~:~

- From feature objects (semi-automated)

- From DEMs (automated)

- From TINs (automated)

.._._-----..._---
------....

---........,-..

Watershed"~elineation....,

• TIN-based model • DEM-based model

4 ~.
.,,

" .. ...

.' .
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• Create a digital representation o(~",

watershed '","

- automatically generate a topologic tree

• Compute geometric parameters

• Run Hydrologic model
- HEC-l, TR20, TR-55, Rational, NFF, others

•

•

•
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Watershed Dellneation - Maps
".

• Hydrologic models can be created from feature
object geometry and attributes ~

• Two basic methods are used in
- create from scratch

- import existing data from a GIS/DXF file

--------
------------~

Creating FrotlJ Scratch

• Use a scanned image

• Use contours

• Hill shaded image

• Or just a schematic "representation" wh
is not to scale
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Stream Direction Reminder!

• Arcs have direction

• WMS always assumes that a strea
defined from "downstream" to "upst

• Whenever creating stream arcs from sc
you should use this convention

..._...._-------_._------...
.......-.............

......
---'-

Importing
• Arc/Info

- through shape files

- special tools for version 1.1 ofArcVie
analyst

• Others
-DXF

-DLG

•

•

•
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-'" -".
'l-~.....

~

• Applies to all methods of impottip-g, but
WMS development has been pattem fier
the ARC/INFO model

• Three layers of interest
- Points - Outlets

- Arcs - Streams and basin boundaries

- Polygons - Basins

.._---._----.~-~--
-----~---.... ...----

Which D~Are Available?",

• Outlets, Streams, and Basins

• Streams and Basins

• Only Basins

• Only Streams



Outlets, Streams and Basins
".

• Preferred method
""

• WMS could possibly import direc':
without any further editing

• Problems which may occur?
- intersection of streams, basins, outlets may ,

coincide

- stream arc direction may be incorrect

- Vertices or nodes must be located at the
intersection of streams, basins, and outlets

.._-------
-.._--------....-.

...................
...........

Importing wttRQ~t Editing

• The following conditions mus
- stream arcs must have the proper d

- drainage type field in all three layers
• point draintype = 5 (outlet)

• arc draintype = 3 (stream)

• polygon draintype = 1 (drainage basin)

- The location of the outlet points, a vertex or
node on a stream arc, and a vertex or node on
the basin boundary must be within a tolerance
of 1.0 (feet or meters depending on base units).

•

•

•
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Streams···~lflq. Basins
""-..._",

• Some editing typically require
- Import into a general coverage (Befo

import, you must make sure the covera
general coverage)

- snap stream junctions to basin outlets

- reorder streams (to change direction of arcs)

- reconstruct polygon topology

nly

•

• Must add a stream from "scrat
- could be actual stream defmed from

contours, DLG file, etc.

- could be a ''ficticious'' stream that only d
the connectivity between basins



Streams.,Only

• Must build basins from scratch
- could be actual basins defined from 1

contours, etc.

- could be "ficticious" basins that only pro
representation

--~~d~~9ic-lv10del Definition
"','.........

• Topologic tree structure c" esponds to
outletlstreamlbasin feature obJ

• Use the "Update basin data" com
compute areas and other data from p

•

•

•
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.NFF

• HEC-l

• TR-20

• Rational Method

• Others...

--------------
Stren~~sing Feature

Objects for Bas~ elineation
• Hydrologic model can be cons

no elevation data are available
- nice graphical representation even if sc

correct

• Existing data
- you don't have to "re-invent the wheel"

• Overall interaction with GIS
- often this is where data is stored/viewed



Weaknesses- oJ Using Feature
Objects for Basln--Oelineation

• Cannot readily compute geom~,
parameters

• Reservoirs not yet included as part 0

•

•

•
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Hydrologic Models from Feature
Objects

4

•

•

4.1

This tutorial demonstrates how feature objects alone can be used to define
hydrologic models. Feature objects may be digitized on-screen using a
registered image, or imported as a shape file from an Arc/Info or ArcView
layer. Using the drainage coverage type, features can be converted to streams,
outlets, and basins to represent the watershed being modeled. If GIS layers are
imported as shape files, their corresponding attributes (i.e. area, curve number,
time of concentration, etc.) are also imported and assigned to the appropriate
basins.

Launching WMS

To launch the PC version of WMS:

Double click on the WMS icon ~.

To launch the Unix version of WMS:

1. Bring up an xterm window.

2. Change to the directory containing the WMS executable or make sure
the directory containing WMS is in your Unix path environment.

3. type wms at the command line.
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4.2 Creating a Watershed from Scratch with Feature Objects

By using a combination of stream arcs, outlet nodes, and basin polygons, you
can develop an entire watershed even without the use of a digital terrain
model. The watershed can be to scale or a schematic. Of course, if it were not
to scale, polygon areas and stream lengths would not be valid for your
hydrologic model.

In this section of the tutorial you will create the aspen grove watershed from
an image of a scanned paper map with clearly marked streams and basin
boundaries.

I. Select the Map module icon .~.

2. Select the Open command from the File menu.

3. Find and open the file named "aspentrc. img ".

You should see a portion of a USGS quad map with basin boundaries outlined
in red and the stream network in black.

•

4.2.1 Creating Basin Boundaries

We will begin by creating the basin boundaries, but it does not matter whether •
the basins or streams are created first.

1. Select the Create Arcs tool 1111.
2. Select the Attributes... command from the Feature Objects menu.

3. Make sure that the arc type is generic and select OK.

4. Beginning at the outlet point (lower right) trace out the entire
watershed boundary. You do not need to follow every detail, take as
much time as you want. End by double-clicking near the same point
where you began.

Note: Whenever you create feature arcs in WMS a snapping tolerance is used
to snap the new vertex to an existing node, vertex or arc. Therefore, you do
not have to click "exactly" on the same point when ending. For the most part
this is very useful because it avoids the necessity of creating vertices at ail arc
intersectionlbranching points the first time it is encountered (i.e. at a stream
branching point, or where sub-basin boundaries join).

1. Now create each of the other three sub-basin boundary arcs on the
interior of the watershed. Begin by clicking on a point near the
junction in the center of the watershed and ending by double-clicking •
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near the intersection of the arc previously created for the exterior
boundary.

Creating the Stream Network

The stream network is created in much the same way the basin boundaries
were. The only thing to note is that the upper basin the basin boundary comes
very close to the stream. You will need to zoom in on this region in order to
avoid conflicts with the snapping tolerance.

1. Select the Attributes... command from the Feature Objects menu.

2. Choose the stream feature arc type.

3. Select OK.

4. Create the main channel from the outlet of the watershed to the outlet
point for the two upper basins. Begin by clicking near enough to the
boundary arc at the outlet so that it snaps to it and end by double
clicking on the basin junction point.

5. Create the two branches of the lower basin by clicking on a point near
the stream arc just created and double-clicking at the most upstream
point of the branches in the image.

aTE: As you create new vertices on stream arcs you should always do so
from downstream to upstream.

1. Select the Zoom tool

2. Zoom in on the region shown in Figure 4-1.



Figure 4-1
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Junction of Main Channel in Aspen Grove Watershed.

1. Select the Resample command from the Images menu.

2. Select the Create Arcs tool

3. Create the initial portion of each portion of the stream by clicking on
the junction point (intersection of red boundary lines in the image) and
going as far upstream as is possible on the zoomed image. End by
double-clicking.

•

•

You needed to zoom in in order to avoid conflicts with the auto-snapping
feature. If you do click too close to an existing arc you will get a message that
the stream is illegal and you will need to try again.

You can end the stream at one location and then continue defining after
zooming out by beginning at the point where you left off.

1. Select the View Last command from the View menu.

2. Select the Resample command from the Images menu.

3. Finish defining each branch. Begin the branch by clicking near the
point you left off with and ending by double clicking at the terminal
point of the stream. •
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In order to define separate basins at the junction point you will need to convert
the node at the junction to an outlet node.

I. Select the Select Feature Point/Node tool &1.
2. Select the junction point in the center of the watershed corresponding

to the intersection of the streams and the sub-basin boundary arcs that
you just created.

3. Select the Attributes command from the Feature Objects menu.

4. Change the attribute to Drainage outlet.

5. Select OK.

Building Polygons

At this point the watershed boundaries are only arcs. In order for them to
become polygons you must create the polygon topology.

1. Select the Select Polygon tool ;11.
2. Select the Attributes... command from the Feature Objects menu.

3. Change the attribute to Drainage boundary. Select the OK button.

4. Select the Select Arcs tool

5. Select the Select All command from the Edit menu.

6. Select the Select Network tool II.
7. While holding down the SHIFrkey, select anyone of the stream arcs.

This should un-select the stream arcs and leave the remainder selected
for use in polygon generation.

8. Select the Build Polygon command from the Feature Objects menu.

Updating Geometric Parameters

1. Select Display Options... from the Display menu.

2. Tum on the Color fill polygons option.

3. Select OK.

In ord~r to transfer the basin area and stream lengths, and to compute them in
appropriate units for hydrologic modeling you need to compute the basin data.
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This will make it possible to use the polygon area in any of the hydrologic
modeling interfaces.

I. Select the Update Basin Data command from the Feature Objects
menu. This command computes areas, perimeters, and centroids for
each of the sub-basins and assigns these values to the hydrologic
modeling tree.

2. Set the model units to meters (the base units were UTM meters).

3. Set the area units to sq. miles.

4. Set the distance units to feet.

5. Select the OK button to compute the sub-basin data.

4.3 Importing GIS Data to Create a Watershed

Many times stream networks and/or basin boundaries already exist as layers in
a GIS. In such cases the data can be imported from a shape file (ArcView's
native file format), and all applicable attributes inherited by the WMS feature
objects for hydrologic modeling. If you have an ARC/INFO coverage you will
need to convert it to a shape file first using the ARCSHAPE command. You
will also want to pay attention to the keywords used for automatically mapping
attributes, and some of the issues associated with importing GIS data as
explained in Chapter 4 of the WMS Reference manual.

This part of the tutorial shows how GIS data developed with the end goal of
importing into WMS can be used, the next three sections in the tutorial discuss
how any watershed data layer(s) can be imported and then modified for use
within WMS.

In order for WMS to be able to import GIS layers and automatically create a
watershed for use in a hydrologic model, the following conditions must exist.

• You must have a polygon layer representing basin polygons with an
attribute item named draintype, and the draintype value for each basin
polygon needs to be 1.

• You must have an arc layer representing streams with an attribute item
named draintype, and for each stream arc the value of draintype
should be 3. Also the arcs must be ordered so that the from-node is
always downstream of the to-node (if this is not the case it may be
easier to follow the guidelines shown in the next section).

• You must have a point layer representing outlets with an attribute item
named draintype, and for each outlet point the draintype should be 5.

•

•

•
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A special extension in ArcView, called WMSHydro, has been developed which
automatically creates these three layers. If you are not using this extension it
may be more trouble to develop these three layers in the required format than
it is to import them in one of the ways described in sections 4.4-4.6.

In addition to the required attributes, the shape file may also contain other
hydrologic modeling parameters which can be mapped to corresponding
values in WMS. Table 2.1 in the reference manual lists the attributes that can
be mapped and the keywords used by WMS to automatically define the
mapping. If your shape file contains the correct parameter, but does not use
the specified keyword, you can still manually specify the mapping.

Importing Shape Files

I. Select the New command from the File menu to make sure that all
existing data is removed. Select OK to delete everything.

2. Select the Map module icon if it isn't active already.

•

•

3. Select the Import... command from the File menu.

4. Choose the Shape file to Feature objects option and select OK.

You should now see the Import Shapefile Data dialog. It allows you to define
the shape files and mappings for points, arcs, and polygons. You can also
access the coverage options dialog in case you need to change coverage types,
create a new coverage, etc.

1. Click on the open points shape file button.

2. Find and open the point shape file named "asppntsl.shp".

3. Click on the open arcs shape file button.

4. Find and open the arc shape file named "asparcsl.shp".

5. Click on the open polygons shape file button.

6. Find and open the polygon shape file named "asppolyl.shp".

Attribute items are automatically mapped to WMS parameters if they have the
appropriate keywords. Mappings are shown in the text window to the right of
the shape file name. If an attribute name doesn't match a keyword as listed in
Table 3.1 of the reference manual you can manually map it by doing the
following:

1. Select the Attribute Mapping... button below the polygon shape file.

2. Select AREA in the Database Fields window.
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3. Select Basin area in the Coverage Attributes window (you may have
to use the scroll bar to find Basin area).

4. Select the Map button. If you want, scroll the Mapped fields window
so that you can see that the area mapping has been added. An attribute
could be similarly unmapped by selecting it in the Mapped fields
window and selecting the Unmap button.

5. Select the Done button.

6. Select OK.

Your watershed data will be read in and all parameters that were mapped will
be set inside of WMS. If you are running a licensed version of WMS you could
very easily run an HEC-l model as outlined in the next section. If you are
running a demonstration version skip to section 4.4.

•

4.3.2 Running HEC-1 with Data Defined in a GIS

Since many of the required parameters to run the SCS options within HEC-I
were included in the shape files just imported, you can very quickly get to the
point where you can run HEC-l (this assumes of course that at some point
these parameters were correctly computed and stored in the GIS). In order to
complete the HEC-l model definition do the following.

1. Select the Hydrologic Modeling icon [II.
2. Select Job Control... from the HEC-l menu.

3. Change the Computational time interval to 5 (minutes).

4. Change the Number ofordinates to 50.

5. Select OK.

You have specified your simulation to last for 5 times 50 minutes or 4 hours
10 minutes.

1. Select the basin named 3B in the Graphics window.

2. Select Edit HEC-l Parameters... from the HEC-l menu.

•

3. Select the precipitation button.

4. Choose the Basin average option.

5. Select the Define Series button. •6. Select the Import button.
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7. Select and open the file "scstabls.ser".

8. Make sure that the SCS-StdEmergencySpillway is highlighted.

9. Select OK to the XY Series Editor and Precipitation dialogs.

10. Select basin 1B from the Hydrologic Modeling window.

II. Repeat steps 3-9 for basin 1B - be sure that you highlight the SCS
StdEmergencySpiliway option in the XY Series Editor as it will not be
the default.

12. Repeat for basin 2B.

13. After defining precipitation for all three basins select the Done button
on the Edit HEC-l Parameters dialog.

You are now ready to run HEC-I and review the results.

1. Select Run HEC-l from the HEC-l menu.

2. If you want to change the names of the files you can do so, but
keeping the files named untitled is okay.

3. Select a directory where you can save your HEC-I files using the
directory browser button.

4. Select OK.

5. After HEC-I completes the simulation close the window In which
HEC-I ran.

6. Select Open from the Hydrograph menu.

7. Find and open the .sol file created by HEC-I (untitled. sol unless you
changed the file names).

If you wish to examine the hydrographs in more detail:

1. Select Show Hydrograph Window from the Display menu.

2. Select any of the hydrograph icons in the Hydrologic Modeling
window.

This completes the tutorial on using "ideal" GIS data to defme hydrologic
models. More often than not you will have one or more of the three required
layers, and your data will need to be modified a bit after you read it in. The
next three sections demonstrate some of the kinds of problems you might run
into and what you can do about them.
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4.4 Creating a Watershed with a GIS Stream and Basin Layers

In this section you will learn how to create the same watershed model done in
the last two sections when you lack a point file defining outlets and/or the data
does not meet the requirements for automatic creation as outlined at the
beginning of section 4.3.

If you are continuing from the previous section you will want to delete your
data before going on.

I. Select the New command from the File menu. Select OK to confirm
that you want to delete everything.

2. Select the Map module icon ·at.

•

4.4.1

4.4.2

Importing the Basin and Stream Layer

1. Select the Import command from the File menu.

2. Choose the Shape file -> Feature objects option and select OK.

3. Click on the open arcs shape file button.

4. Find and open the arc shape file named "asparcs2.shp".

5. Click on the open polygons shape file button.

6. Find and open the polygon shape file named "asppoly2.shp".

7. Select OK.

The data looks almost exactly like the shape files of the previous section.
With a closer look though you will notice the following differences:

• The streams are not colored blue and the basin boundaries are not
colored brown because the "Draintype" field is not present for these
shape files. You may wish to tum off the color-filled option for
polygons using the Display Options command from the Display menu.

• The watershed outlet and stream branching points do not connect to
the basin boundaries.

Converting Generic Arcs to Stream Arcs

The first task will be to convert the existing set of "generic" streams to stream
arcs.

1. Select the Zoom tool

•

•
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2. Zoom in around the watershed outlet (lower right).

3. Select the Select Points/Nodes tool :.~.

4. Select the last node (the outlet point) on the stream network.

5. Select the Reorder Stream command from the Feature Objects menu.

This will insure that the arcs connected to the selected point will be ordered
from downstream to upstream (from-node at the downstream end and to-node
at the upstream end). This MUST be done before the stream arcs can be
assigned a stream attribute type.

1. Select the Stream Network tool illl.
2. Select an arc on the stream network (this will actually select all arcs

connected to this network).

3. Select the Attributes... command from the Feature Objects menu.

4. Choose the Stream attribute type.

5. Select OK.

ow you need to "snap" the stream outlet point to a point on the boundary of
the watershed polygon.

1. Select the Select PointslNodes tool

2. Select the downstream most point on the stream network.

3. Select the Clean... command from the Feature Objects menu.

4. Make sure only the Snap selected nodes option is on.

5. Select OK.

6. You will now be prompted to select a point to snap to (red text in the
help window). Click on a point on the polygon near the stream outlet
point.

7. Select the Frame Image macro!

: .
8. Select the Zoom tool!

9. Zoom in around the outlet point at the junction of the streams from the
two upper basins.
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If you have zoomed in around the right location your display should look
something like Figure 4-2. You will notice that the outlet point does not
coincide with the intersection of the three basins. You will now need to snap it
in the same way you did for the watershed outlet.

•

•
Figure 4-2 Snapping Nodes Together.

1. Select the Select PointslNodes tool [

2. Select the outlet junction point on the stream network.

3. Select the Clean... command from the Feature Objects menu.

4. Make sure only the Snap selected nodes option is on.

5. Select OK.

6. Click on a point on the basin intersection point.

7. Select the newly snapped node (the intersection of the basins and
stream network).

8. Select the Attributes... command from the Feature Objects menu.

9. Choose the Drainage outlet option. •
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10. Select OK.

II. Select the Frame Image macro~·~I.

Converting Generic Polygons to Basin Boundary Polygons

In order to "tie" the polygons to the topologic tree you must change them from
generic to Drainage boundary.

1. Select the Select Polygon tool "&fl.
2. While holding the left mouse button down, drag a box around all three

polygons (you could also multi-select the polygons by clicking insided
each while holding down the SHIFT key or by using the Select All
command fom the Edit menu).

3. Select the Attributes... command from the Feature Objects menu.

4. Choose the Drainage boundary option.

5. Select OK.

6. Select the Update Basin Data command from the Feature Objects
menu.

7. Choose Meters for Model Units and select OK.

This will insure that the units for polygon area and arc length are
converted/stored for hydrologic modeling.

You have now converted your stream and polygon shape file to a watershed
model that is ready for use with any of the hydrologic model interfaces.
Notice how if you select a single basin icon, the corresponding polygon is
highlighted in red.

•

4.5 Creating a Watershed with a GIS Basin Layer

In this section, using the same watershed boundary data as the previous
section, you will learn how to create a watershed model if you only have a GIS
layer for basin boundaries. In such cases you will need to create the stream
network within WMS. The stream network does not have to correspond to the
actual network, but is primarily used to determined how flow is combined and
routed from the different basins. If you have a scanned map, or other source
of stream data you can create the actual stream, but it is not required.
However, keep in mind that unless you create streams which represent the
actual channel, stream length information will be incorrect.
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If you are continuing from the previous section you will want to delete your •
data before going on.

I. Select the New command from the File menu.

2. Select the Map module iconntl.

4.5.1

4.5.2

Importing the Basin Layer

I. Select the Import command from the File menu.

2. Choose the Shape file -> Feature objects option and select OK.

3. Click on the open polygons shape file button.

4. Find and open the polygon shape file named "asppoly2.shp".

5. Select OK.

You should now have the basin file read in with three different sub-basins.
There is no stream network associated with these basins and so you must
define it.

Creating a Stream Network

I. Select the Zoom tool

2. Zoom in around the intersection of the three sub-basins near the center
of the watershed.

3. Select the Create Arcs tool

4. Select the Attributes... command from the Feature Objects menu.

5. Choose the Stream attribute type.

6. Select OK.

Use Figure 4-3 as a guide in the next few steps.

1. Click on the intersection point of the polygons to begin a new stream
segment.

2. Double-click on an interior point of the upper-left basin.

3. Repeat the last two steps for the upper-right basin.

•

•
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4. For the lower basin reverse the two steps by first clicking on an
interior point and then double-clicking on the intersection point.

I. Select the Frame Image macro 'III.•
Figure 4-3 Creating Streams for Basin Polygons.

•

2. Click on a location on the boundary of the basin polygons near the
watershed outlet (lower right portion of the screen), and then double
click on the stream point you just created in the middle of the lower
sub-basin. See Figure 4-4 as a guide.
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•

1. Select the Select PointlNode tool

Now you will want to eliminate the outlet point in the interior of the lower
basin polygon.

Figure 4-4 Finishing the Stream.

•
4.5.3

2. Select the node on the stream arc where you just double-clicked to join
the outlet to the stream network.

3. Select the Vertex<->Node command in the Feature Objects menu.

Converting Polygons to Basins

In order to "tie" the polygons to the topologic tree you must change them from
generic to Drainage boundary.

1. Select the Select Polygon tool

2. While holding the left mouse button down, drag a box around all three
polygons (you could also multi-select the polygons by clicking insided
each while holding down the SHIFT key or by using the Select All
command fom the Edit menu).

3. Select the Attributes... command from the Feature Objects menu.

4. Choose the Drainage boundary option.

5. Select OK. •
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6. Select the Update Basin Data command from the Feature Objects
menu.

7. Choose Meters for Model Units and select OK.

This will insure that the units for polygon area and arc length are
converted/stored for hydrologic modeling.

4.6 Creating a Watershed with a GIS Stream Layer

In this section, using the same stream data as section 4.4, you will learn how to
create a watershed model if you only have a GIS layer for streams. In such
cases you will need to create within WMS the basin boundaries. The
boundary polygons do not have to correspond to the actual watershed/sub
basin boundaries, but they are primarily used to identify the watershed and
sub-basins of a watershed model. If you have a scanned map, or other source
of drainage boundary data you can create the actual basin polygons, but it is
not required. However, keep in mind that unless you create polygons which
represent the actual basin boundaries, polygon (basin) areas will be incorrect.

If you are continuing from the previous section you will want to delete your
data before going on.

1. Select the New command from the File menu.

2. Select the Map module icon·

•

4.6.1

4.6.2

Importing the Stream Layer

1. Select the Import command from the File menu.

2. Choose the Shape file to Feature objects option and select OK.

3. Click on the open arcs shape file button.

4. Find and open the arc shape file named "asparcsl.shp".

5. Select OK.

You should now have the stream file. There are no basin polygons associated
with the stream this network and so you must defme them.

Creating Basin Polygons

Figure 4-5 is an example of basins created for the imported stream layer.
Refer to it as you create your own basin polygons. In particular you will want
to note the point on the stream where the three sub-basins intersect.
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•

Figure 4-5 Sub-basins of Stream Network.

1. Select the Select PointlNode tool :11I.
2. Double click on the node at the intersection point shown in Figure 4-5.

3. Set the attribute type to Drainage Outlet and select OK.

4. Select the Create Arcs tool III.
5. Select the Attributes... command from the Feature Objects menu.

6. Select the Generic option.

7. Select OK.

8. Create a bounding polygon for the watershed. Begin by clicking on
the outlet point, continue by creating additional points to define a
polygon around the entire stream network, and end by double-clicking
on the outlet point.

9. Select the Zoom tool II.
to. Zoom in around the point on the stream where you will create the

intersection of the three sub-basins (see Figure 4-5).

II. Select the Create Arcs tool

12. Create the three arcs shown in Figure 4-6 that will define the
boundaries of the three basins at the intersection point. For each arc

•

•
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begin by clicking on the intersection point in the stream and end by
double-clicking.

1. Select the Frame Image macro :111.•
Figure 4-6 Interior Boundary Arcs.

•

2. Finish defming each of the three boundary arcs started at the
intersection point by clicking on the end point of the arc to begin and
double-clicking on the watershed boundary arc to end.

At this point you have all the necessary arcs to defme the basin polygons, but
you need to convert them to polygons.

1. Select the Select Network tool III.
2. Select any of the arcs that will be used for the basin boundaries (this

should cause all of the basin boundary arcs to become selected).

3. Select the Build Polygons command from the Feature Objects menu.

4. Select the Select Polygons tool III.
5. Select all the polygons by dragging a box around them, or selecting

each while holding down the SHIFT key.

6. Select the Attributes... command from the Feature Objects menu.

7. Make sure that Drainage boundary is chosen as the polygon type (if
you are continuing from another part of the tutorial the polygons are
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likely already set to Drainage boundary, but in many cases they will
by default be Generic and you will need to change them).

8. Select OK.

You now have defined basins for each part of the watershed. The boundaries
are not actual boundaries, but rather an approximation. Still, the hydrologic
modeling tree can now be used to finish defining input for the watershed
model.

Practically speaking, the only time you will want to define a watershed model
in this fashion is if you already know areas for the sub-basin boundaries.

4.7 Conclusions

In this tutorial you have learned how to create watershed models using the
map module objects. In particular, you have learned how to import shape files
representing streams and boundaries and use them for setting up a watershed
model.

•

•

•
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Importing GIS Watershed Data

Supplementary Exercise for Basin Delineation using the Map Module
SessionS

In this exercise. you will import watershed boundary and stream data from a GIS and convert the data to a
format usable by the WMS drainage coverage.

You have watershed boundaries and streams defined in ArclInfo® and you want to import your streams and
boundaries into WMS to define your watershed model and generate a hydrograph. Your task in this exercise
is to import your watershed boundaries and streams into WMS and edit your data so a drainage coverage can
be generated.

For this exercise, you will need the following files in the supplementary 5 directory:

• streams.shp-An ArcView® shape file containing the streams in your watershed. This file was
generated in ArcView®. The appropriate database field was added to identify these arcs as stream arcs.

• boundaries.shp-An ArcView® shape file containing basin and sub-basin boundaries in your watershed.
This file was generated in ArcView®. The appropriate database field was added to identify these
polygons as boundary polygons.

Here's some helpful steps on how to convert your GIS shape file data to a WMS Drainage feature
coverage:
I. Import the stream and boundary shape files into a WMS General feature coverage. If the coverage type

is not general. you will have problems.
2. Clean your feature objects. For this model, you can select the Clean command from the Feature Objects

menu to accomplish this step. This step will join the streams with the basin boundaries at the outlet
points. Note that other tools are available for cleaning individual feature objects in WMS.

3. Re-build your polygons. The clean process made any existing polygons defunct.
4. Change your coverage type to a drainage coverage.
5. Select all the polygons and change their attributes to a drainage boundary attribute.
6. Convert the feature nodes at the sub-basin outlet points to outlet points.
7. Update the drainage data.
8. You are now done and ready to run your HEC-l model (After defining all hydrologic parameters).
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ARC/INFO OEM Format

• Used commonly by data publishers

• The GRIDASCII command can be used
from ARC to export a DEM in this form~'

...":'
ncols 128
IHOWS 136
xllcomer "22"15
yllcomer 4515405
cellsil.c 30
NODATA_value -9999
12871286128612881289129112911292 129212951300 1302 1304 1304 1304 1305 1309131~ 1323 1336 1
1375 13951411142614411~53146414721481149115011510 15141521153015361542 15H 155515601563
156515661569 1572 157~ 1575 1576 1576 15761577 15771578 1580 1581158315851586158815891590 159'f
1596160216091619162716331640164616481646164116361632 1632 1636 1641 16471655166516751684
1692 1701 1711 172617~~ 1750 1753175117461740 1735172917251720 17151709170~ 1700 1696169~ 1698
17011706170817091706170116941691168816811680 168316861691169917091719 1730 17~0 1750 1758
176~ -9999

•
", .. ~

""-, .....

•

the DOD

o
north: 2160
south: 0
east: 3060
west: 0
rows: 72
cols: 102
.00000 .00000 .00000 .00000 .00000 .00000 .00000 .00000 1.00000 1.00000 IH.5oooo 142.2
139.80000 136.30000 130.60000 132.40000 133.20000 136.20000 135.90000 131.60000 128.60000 135.70000
135.10000 135.10000 139.30000 135.10000 125.80000 117.60000 112.80000 116.40000 119.20000 119.80000
119.00000 112.80000 107.00000 105.30000 105.80000 102.20000 94.00000 95.70000 96.00000 89.20000
82.40000 77.80000 75.20000 74.80000 78.20000 84.60000 90.50000 95.10000 99.70000 107.40000 107.50
107.80000 111.50000 113.50000 105.60000 95.30000 88.20000 79.40000 73.20000 69.60000 73.00000
71.00000 60.60000 55.60000 57.00000 54.60000 60.20000 65.40000 68.00000 63.60000 67.90000 74.60000
72.20000 68.80000 76.20000 76.70000 78.60000 85.00000 87.00000 87.20000 85.80000 80.20000 80.80000
84.00000 79.80000 74.60000 74.20000 70.10000 61.90000 54.60000 49.00000 48.50000 54.30000 51.80000
44.30000 41.10000 43.00000 49.00000 57.00000 1.00000

GRASS [)E'M Format
",

"'-

• GRASS is a GIS used primaril

• Simple format, not as common as
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• Data from any source can be exported to the
WMS format
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Estimated Time: 15 minutes

A DEM is a file containing x, y, and elevation data (in UTM coordinates) for a
portion of the earth's surface. While DEM data can be obtained from the
USGS, it is often supplied by state, county or other local agencies involved in
GIS work. For a listing of web sites where DEMs can be obtained see
www.emrl.byu.edu/gishydrodata/dem.htm. WMS can use DEMs to directly
delineate watersheds, or as background elevation maps when constructing
TINs.

In this tutorial you will learn about WMS's DEM importing and visualization
tools. After you have completed this tutorial you should be able to:

• Import DEMs into WMS.

• Smooth elevations to eliminate roundoff error.

• Use WMSs three dimensional viewing tools to visualize DEMs.

• Use WMSs elevation contouring options.

• Display a hill shade of the DEM.

•
5.1 Importing a USGS OEM

The process of importing a USGS DEM can be subdivided into three steps.

• Opening the DEM file.
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• Selecting the portion of the OEM that you would like to import.

• Importing the desired portion of the OEM.

The DEM that you will be importing in this tutorial contains data for Aspen
. Grove, Utah. Aspen Grove is located about 50 miles south of Salt Lake City.

Utah. The Aspen Grove DEM was used in previous tutorial for creating
feature object data and will be used by later tutorials to construct a TIN
representing the watershed located near Aspen Grove.

•

5.1.1 Opening the File

I. Switch to the DEM moduLe by selecting the DEM module Icon lfuJ
from the top of the TooLbox.

2. Select the Import command from the File menu.

3. Choose the USGS DEM->DEM option.

4. Select OK.

The window at the top of the Import USGS DEMs dialog shows a list of the
. DEM files that will be imported. Since there are none in the list to begin with,

you will need to add some.

I. Click on the ADD button.

2. Use the file browser to find and open the file "aspen.dem". This file
should be found in the tutorial directory. This will add the DEM
contained in the file to the list.

3. Select the OK button to import the DEM into WMS.

•

5.2 Selecting an Active Area

Whether you are using a single DEM, or several tiled together, it is likely that
your watershed will not cover the entire area of the DEM. You can inactivate
the portions of the DEM that you know are outside of your watershed and then
delete them from memory in order to conserve RAM. There are actually
several ways to do this, but the easiest and most frequently used one is
demonstrated here.

I. Select the Open command from the File menu.

2. Use the file browser to find and open the file "aspenrgn.map." This
file should be found in the tutorial directory. •
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After reading this file you should see a bounding box around the portion of the
aspen grove DEM that contains the watershed we will be working with. You
now need to eliminate the DEM outside of this bounding box.

1. Select the select DEM points tool flil.

2. Drag a rectangle that encompasses the black box defined In
aspenrgn.map (see Figure 5-1).

3. Select the Set Active Region command from the DEMs menu.

.,',-
_ I',

I _. ~ .

Figure 5-1 DEM Region Selection Box.

•

It appears that portion of the DEM outside the box is gone, but actually these
elevations have just been toggled to inactive. You could bring them back by
selecting the Activate All command, but in this instance you won't be needing
these data so go ahead and delete them.

1. Select the Display Options... command from the Display menu.

2. Turn on the display of Inactive cells and select OK.

The inactive portion of the DEM will now be displayed in red. Since you
won't need this part of the DEM you can go ahead and remove it altogether.
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I. Select the Delete Inactive command from the DEMs menu.

5.3 Viewing the OEM

WMS features many options for viewing DEMs. These options include:

I. Elevation contours of the DEM.

2. Hill Shade display.

These tools will allow you to better visualize the topography of the region
represented by the DEM.

•

5.3.1

5.3.2

Displaying Contours

WMS has the capability of displaying elevation contours on DEMs. Elevation
contours are used to determine where the peaks, canyons, and valleys are in
the DEM. Contours are especially useful while digitizing feature lines from
the display window. WMS can display either normal linear contours or color
filled contours. By default linear contours are on and you have already seen
this options.

1. Select Contour Options in the Display menu.

2. To display color contours, select the Contours... button.

3. Turn on the Color fill between contours radio button.

4. Select OK.

Note: The escape key can be used to abort drawing at any time if it is taking
to long to refresh the display.

The color legend in the top left corner of the display indicates that the blue
regions are of high elevation while the red regions are of low elevation.

Display Speed

Depending upon the type of computer you are using, the display of the color
filled contours may have been slow. To speed up the display process you can
change the Point display step.

1. Select Display Options... from the Display menu.

2. Change the Point display step to 5.

3. Select OK.

•

•
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With a larger Point display step, the display is faster but the resulting contours
are not as smooth.

Displaying a Hill Shade View

By creating a hill shade view of the OEM you will get a nice image depicting
the overall topographic layout. A light source is used to determine the
direction of the sun. and therefore the "shadow" or shaded areas.

I. Select the Shade command from the Display menu.

With color filled contours on, the hill shade uses the contour values for
shading the OEM. You can also shade the OEM in a single color (the OEM
point display color) by turning off DEM contouring.

I. Select the Display Options... command from the Display menu.

2. Turn off contours.

3. Select OK.

4. Select the Shade command from the Display menu .

The lighting direction can be changed to highlight the OEM from a different
angle.

I. Select the Light Angle command from the Display menu.

2. Click on a location on the sphere to indicate a new direction for the
light source (the white regions on the sphere indicate the current light
source direction).

3. Select the Shade command again from the Display menu.

While a true hidden surface algorithm is not used to shade the OEM, an
oblique view can be used. Some angles will be more effecti ve/accurate than

others, so you may wish to experiment a little with the Rotate tool ~.

I. Select the ObLique View command from the View menu.

2. Select the Shade command from the Display menu.

3. Select Plan View from the View menu.

• 5.4 Importing ASCII Grid Files

Besides standard USGS OEMs, gridded elevation data from the ARCIINFO or
GRASS GIS files can be imported and used as a OEM. WMS also has it's
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own data file for gridded elevation, which can be used when trying to convert
a file from other non-supported formats. Refer to the reference manual for a
description of the OEM file format. •

5.4.1 Importing an ARC/INFO ASCII Grid

For ARCIINFO and GRASS formatted grid files the following sequence C,tll

be used to import an ASClI file.

I. Select the Map module icon 2:.1.

2. Select the Delete All command from the Edit menu.

3. Select the DEM module icon liliJ.

4. Select Contour Options... from the Display menu.

S. Tum on the Normal linear contours radio button 111 the upper right
portion of the dialog.

6. Select OK.

7. Select the Import command from the File menu.

8. Choose the Arc/Info grid -> DEM option.

9. Select OK.

10. Select OK to delete the existing DEM.

11. Select the Add button in the Import DEM dialog.

12. Find and Open the file named "jonescyn.grd".

13. Select OK.

This DEM represents a small hill with a couple of small canyons that empty
into a valley region. DEM elevations are typically rounded to the nearest
meter. For areas of high relief this rounding has little noticeable affect.
However, in valley areas it may cause artificial flat areas to appear. It is
important to remove these flat areas before creating a TIN for drainage basin
delineation. In order to see the flat areas:

1. Select the Display Options... command from the Display menu.

2. Tum everything off but contours and flat dem cells.

3. Change the Point display step to 1.

4. Select OK.

•

•
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The regions colored in red are locations in the DEM where four elevation
points, defining a square, all have the same elevation. While it would be rare
for this to occur naturally (except for where a lake exists). this often happens
with OEM data because of the roundoff errors. The natural smoothness can be
restored using the following commands.

I. Select the S/Iloothing Options command from the DEMs melll!.

These options determine how the DEM will be smoothed. By keeping the
maximum change in elevation to 0.5 we won't smooth the elevations beyond
what would be justified based on the original rounding to the nearest meter.
Sometimes several iterations of smoothing are required to propagate changes
over a large flat area. However, for this OEM you can use the default
smoothing values.

I. Select the Cancel button.

2. Select the Smooth DEM command from the DEMs menu.

Most of the red regions should be gone. If you decide you would like to
change the options for smoothing you can restore the original elevations by

selecting the Restore Elevations command from the DEMs menu .

Conclusion

This concludes the DEM Basics tutorial. In this tutorial you have learned how
to:

I. Import OEMs into WMS.

2. Use WMSs DEM visualization tools.

3. Smooth DEM data.

In subsequent tutorials you will use DEMs as background elevation data for
creating TINs.
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OEMs

Supplementary Excerise for OEM Basics-Session 3

For this cxcrci"c. t\\'O adjacent 7.5 minute DEMs are provided for you to experiment with.

All riles ror this exercise are located in the 5upplimentary 3 directory.

I. Import and Clip

You want to clip out only the I'ectangular portion of the DEM you will need. This is a very common
problem when working with USGS DEMs.

a) Import the following USGS DEM files:

wallsrdg.dem

bridal.dem

b) Use the following coordinates to clip out the rectangle you want:

North: 4468800

East: 464150

South: 4457300

West: 449000

•

2. Experiment

a) HillshadetheDEM, Can you identify the major features?

b) Are there any flat regions? Can you eliminate all of them?

c) View it in 3-D. What is the best setting for point display step.
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1. Smooth Elevations
2. Compute/Import flow directions
3. Compute/Import flow accumulation
4. Define watershed outlet
5. Convert DEM streams to Feature Objects
6. Add interior sub-basin outlets
7. Define basin(s)
8. Convert boundaries to polygons
9. Compute basin parameters
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Estimated Time: 25 minutes

In the last tutorials you were introduced to DEMs as a source of digital
elevation data. In WMS, DEMs can be used to develop watershed boundaries
and important geometric parameters, or as a background elevation source for
defining elevations at TIN vertices (see the tutorial in chapter 8).

In this tutorial you will learn how watersheds can be delineated from DEM
data and then converted to feature arcs and polygons for use in defining a
hydrologic model.

Specifically this tutorial covers the following topics:

• Importing aDEM.

• Computing flow directions with the TOPAZ program.

• Computing flow accumulations and conversion of DEM stream points
to a stream feature arc.

• Addition of outlet points at any location along the stream network.

• Basin delineation and computing basin geometric parameters.

• Conversion of DEM basins to feature polygons.
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6.1 Preparing the DEM

There are five OEM elevation files supported by WMS; USGS. USGS -SOTS,
OTEO, ARCIINFO ASCII grids, and GRASS ASCII grids. In this tutorial we
will import a USGS formatted OEM file, but recognize that the same
operations could be done using any of the supported formats.

6.1.1 Importing a USGS DEM
....

l. Switch to the DEM module by selecting the DEM module icon :=
from the top of the Toolbox.

2. Select Import command from the File menu.

3. Choose the USGS DEM->DEM options.

4. Select OK.

The window at the top of the Import USGS DEMs dialog shows a list of the
OEM files that will be imported. Since there are none in the list to begin with,
you will need to add some.

1. Click on the ADD button.

2. Use the file browser to find and open the file "aspen.dem". This file
should be found in the tutorial directory. This will add the OEM
contained in the file to the list.

3. Select the OK button in the Import USGS DEMs window.

•

•
6.1.2 Clipping a Region for Analysis

In the previous tutorial you learned how to specify a bounding box for
importing only a portion of a USGS OEM file. You can also limit the area of
analysis using the activate and inactivate OEM points commands.

1. Select the Open command from the File menu.

2. Find and open the file "aspenrgn.map". Since you are in the OEM
module you will not see *.map files by default. You can change the
filter or simply type in the file name.

This file contains a rectangle that illustrates the region you need active for
analysis. In order to inactivate the remaining regions do the following:

1. Select the Select DEM Point tool •
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2. While holding the left mouse button down drag a rectangle around the
rectangle you just read in.

3. Select the Set Active Region command from the DEMs menu.

4. Go ahead and delete the inactive OEM points using the Delete Inactive
command from the DEMs menu.

6.2 Delineating Stream Networks and Watershed Boundaries

•

•

6.2.1 Computing Flow Directions

Now that you have the region you want for analysis the next step is to compute
the flow directions for the OEM using the TOPAZ program. This is done in
two steps: 1) Computing the flow directions which requires launching the
TOPAZ program from within WMS, and 2) reading in the resulting flow
directions file.

1. Select the Compute TOPAZ FlowData ... command from the Drainage
menu.

2. Use the default options and select OK.

At this point WMS will write two files, OEONM.INP (input elevation data),
and ONMCNT.INP (a control file for executing the OEONM portion of
TOPAZ). You should see some status messages in the window that appears.

1. When TOPAZ finishes select OK to close the application window.

2. Select the Flow Directions... command from the Drainage menu.

3. Select the TOPAZ option.

4. Select OK.

5. Find and open the file ''j1ovec.dat''.

6. Select the Display Options... command from the Display menu.

7. Tum on the display of Flow directions and select OK.

A flow direction vector for each OEM point will be drawn. Because of the
resolution of OEM points it will be difficult to see the vectors so you will want
to do the following:

1. Select the Zoom tool
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2. Zoom in on a small portion of the DEM until the vectors become
visible. You should be able to get an idea of what TOPAZ has done in
creating flow directions from the elevations.

3. Select the Display Options ... command from the Display menu.

4. Restore the display settings by turning the flow directions option off.

5. Select OK.

6. Select the Frame Image macro~.

•

6.2.2

6.2.3

Drawing Flow Paths

Once a flow direction grid has been imported into WMS, flow paths for any
location may be drawn interactively.

1. Select the Flow Path tool illi.
2. Click on any location of the DEM.

A flow path will be traced across the DEM from point to point according to the
flow direction grid. You may wish to continue clicking on several locations of •
the DEM to examine the flow patterns. You can also draw all flow patterns at
once by:

1. Select the Draw Flow Patterns command from the Drainage menu.

This command draws a flow path from each DEM point. It is controlled by
the display step so if you wish to see a higher or lower density of flow paths
you need to adjust the display step in the DEM Display Options dialog.

Computing Flow Accumulations

In order to delineate a stream network a flow accumulation grid must be
computed. The Flow Accumulation command uses the flow directions to
determine how many DEM points "drain" to a given DEM point for every
DEM point in the analysis area.

1. Select the Flow Accumulations... command from the Drainage menu.

2. Choose the Readflow accumulation file option with TOPAZ being the
file type.

3. Select OK. Find and open the file named "uparea.dat."

The flow accumulations will be displayed when you have either read them in •
or computed them in WMS. The DEM points colored in blue represent
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locations likely to be in a natural channel because their accumulation is high.
The default threshold for display is typically 200, but you can change this.

1. Select the Display Options... command from the Display menu.

2. Set the Min accumulation for display value to be 1000.

3. Select OK.

Notice how the streams are smaller and have fewer branches. You can
continue to experiment with this display option if you wish. When finished
experimenting, set the threshold back to 200.

Converting Raster Streams to Stream Feature Arcs

Up until now the display of streams has been based solely on a threshold
value, and before basin delineation can take place you must identify where you
want watershed and sub-basin outlets to be along a stream vector.

1. Select the Zoom tool

2. Zoom in around the branch identified in Figure 6-1 .

•

•
Figure 6-1 Aspen Grove Stream Network Branching Point.
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~:~~:Wt

I. Select the Create Feature Point tool f
. iw'. (Note that the map module

tools are repeated in the DEM module because of the interaction with
feature objects when delineating basins with DEMs).

2. Create a new feature point just upstream from the branching location
in the stream you have just zoomed in on (see Figure 6-2).

•

•
Figure 6-2 Aspen Grove Watershed Outlet Location.

1. Select the Frame Image macro

2. Select the DEM->Streams Arcs... command from the Drainage menu.

3. Turn on the Display stream feature arc creation and Use feature
points to create stream options.

4. Set the Threshold value to 400.

5. Select OK.

Starting at the outlet point just created and working upstream, WMS converts
the OEM points with accumulation values greater than or equal to 400 into a
series of feature arcs. The feature arcs are assigned to be stream type.

•
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Delineating Watershed and Sub-basin Boundaries

With the stream network defined as an arc you are ready to define the
watershed boundaries.

1. Select the Define Basins command from the Drainage menu.

2. Select the Refresh macro r~1.

The OEM points which "drain" to the outlet of the stream network previously
defined are identified by using the flow direction information. You can now
inactivate and eliminate all OEM points outside of the watershed.

1. Select the Inactivate NULL Basin command from the Drainage menu.

2. Select the Delete Inactive from the DEMs menu.

You can further subdivide the watersbed into subbasins by converting some of
the feature points to outlets.

1. Select the Select Feature Point/Node tool

2. Select the two junction points identified in Figure 6-3. Remember you
can multi-select the two points by holding down the shift key.

3. Select the Node<->Outlet command from the OEM Drainage menu to
assign the nodes attribute type to be an outlet.

4. Redefine the basins with the new outlets by selecting the Define
Basins command from the OEM Drainage menu.
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•

6.2.6

6.2.7

Figure 6-3 Sub-basin Outlets of Aspen Grove Watershed.

Converting Raster Basin Boundaries to Feature Polygons

Now that the basins have been delineated you can convert the boundaries to
polygons.

1. Select the Basins->Polygons command in the Drainage menu.

Computing Basin Geometric Parameters

Finally you will want to compute the basin areas, slopes, runoff distances, etc.
and associate them with the polygons.

1. Select the Compute Basin Data command from the Drainage menu.

2. Set the Model Units to meters and leave the Parameter Units settings
at their default values.

3. Select OK.

4. Select the Display Options command from the Display menu.

5. Insure that the units, area, and slopes options are toggled on.

6. Select OK for both dialogs.

•

•
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Hill Shade With Stream and Watershed Boundaries

The hill shade command demonstrated in the previous tutorial functions
slightly differently once streams and watershed boundaries have been
delineated. Any DEM point that is part of the stream or a basin boundary is
colored accordingly when performing a hill shade.

I. Select the Shade command from the Display menu.

•

•

6.3 Conclusions

This concludes the tutorial on basin delineation from OEM data. You may
wish to continue experimenting with the different options.

In summary you have learned how to:

• Import a OEM and activate a region for analysis.

• Compute flow directions and flow accumulations for a OEM.

• Convert raster streams to vector streams (feature objects).

• Define watershed and sub-basin boundaries.

• Convert raster basin boundaries to polygons.

• Compute basin data.

With the watershed delineated and basin data computed you could now
continue to define a hydrologic model.
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DEM Basin Delineation

Supplementary Exercise for Basin Delineation using OEMs-Session 6

In this exercise, you will combine several of the concepts you have learned about DEM Basin delineation and
defining hydrologic models.

A residential development project is being planned west of Durango. Colorado. Your task is to compute the
flow for a hundred-year storm at three different points in your watershed and at the watershed outlet point.
The flow must be computed both before and after the residential development has taken place.

For this exercise, you will need the following files in the supplementary 6 directory:

• durango_west.dem-A USGS 7.5-minute DEM Quad of the area located west of Durango, Colorado.

• landnew.shp-An ArcYiew® shape file containing land use boundaries after the proposed development
takes place. A land use ID associated with each polygon is included in this file.

• landold.shp-An ArcYiew® shape file containing land use boundaries before the proposed development
takes place. A land use ID associated with each polygon is included in this file.

• soils.shp-An ArcYiew® shape file containing soil boundaries for the watershed.

• tr55I.dat, tr55IA.dat, tr55II.dat, and tr55III.dat-Tabular unit discharge data used for computing
hydrographs from TR-55 input parameters.

• scsland.tbl-A file that relates the soil type and land use ill's in the shape files to a curve number value.

If you are experienced in running TOPAZ, you will also want to use the following files:

• flovec.dat-A TOPAZ-computed flow direction file that can be read into WMS.

• uparea.dat-A TOPAZ-computed flow accumulation file that can be read into WMS.

The following data values will be helpful for this project:

Watershed outlet point coordinates: X=239424.00, Y=4131270.75

Sub-basin outlet point coordinates:

• Upper 2 sub-basins: X=23931 0.00, Y=4134630.00
• Upper middle 2 sub-basins: X=240120.00, Y=4135980.00
• Lower middle 2 sub-basins: X=239250.00, Y=4137000.00
• Lower sub-basin: Same as the watershed outlet point coordinates (just use the same outlet point).

• lOO-year 24-hour precipitation: 5.0 inches

• Rainfall distribution: SCS Type IT
• Pond and swamp area in each basin: 0.0% in upper 4 basins, 1.0% in lower 3 basins.

• If the drainage area is below 2.0 miz, assume a time of concentration (Tc) of 0.7 hours.
• If the drainage area is above 2.0 miz, assume a time of concentration (Tc) of 1.0 hours.
• Travel time from upper 2 sub-basins: 2.2 hours
• Xravel time from upper middle 2 sub-basins: 1.5 hours

• Travel time from lower middle 2 sub-basins: 1.0 hours

Here's some helpful steps on how to compute the hydrographsfor the desired points on the watershed:
1. Import the USGS DEM "durango_west.dem".
2. Compute and import the flow direction grid and flow accumulation grid.
3. Add an outlet point at the following coordinates: X=239424.00, Y=4131270.75



4. Create stream arcs from the outlet point just created.
5. Convert the nodes at the following locations to outlet points:

6. X=239310.00. Y=4134630.00
7. X=240120.00. Y=4135980.00
8. X=239250.00. Y=4137000.00
9. Define the drainage basins.
10. Convel1the basin boundaries to boundary arcs.
II. Compute the basin data. Remember that your model units are in meters since your OEM was in UTM

coordinates.
12. Go to the Tree module and select the Run Simulation command from the TR-55 menu. Initialize the TR-

55 data and enter the appropriate values to each basin--
13. Basin Precipitation: 5.0 inches
14. Pond and swamp area in each basin: 0.0% in upper 4 basins, 1.0% in lower 3 basins.
15. Drainage area below 2.0 square miles use a Tc of 0.7 hours.
16. Drainage area above 2.0 square miles use a Tc of 1.0 hours.
17. Select the outlets and enter a travel time of2.2 hours in the uppermost outlet, 1.5 hours in the next

downstream outlet, and 1.0 hours in the next downstream outlet. The most downstream outlet has a

travel time of 0.0 hours.
18. Close the TR-55 editor and do the following:
19. Import soils.shp
20. Import landold.shp
21. Compute the composite Curve Number for each basin. Before computing, you will need to import

"scsland.tbl" from the Compu!e Composite Runoff Coeff/CN's window. Vou will also need to enter a
computation step. I recommend using 100 Meters for the computation step.

22. After the curve numbers are computed, open the TR-55 window and compute the hyclrographs. Follow
the instructions after selecting the Compute hyclrographs button in the TR-55 editor.

23. Repeat the last 4 steps after deleting the old land use coverage and importing the new land use coverage

(landnew .shp).
24. After re-computing your hyclrographs using the new curve numbers, observe the outflow before and after

development. Record any observations.

•

•

•
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Triangulat~d Irregular
Networks'(T,JNs)

' ..'\

• A TIN is a triangulated set of scatt.~redxyz
data points

• Each triangle represents a planar sur

• Together the triangles of a TIN form a
piece-wise planar surface which honors t

original data points



• More accurate representation
features
- Points are not restricted to lie on a grid

- High density of points where there are lar
variations in surface features

• Less redundant
- Sparse data in flat regions, dense data in

regions of high relief

How areTINs Created?
..... ,,'\;

• Manual triangulation
- Tedious, if not impossible for large

• Automatic triangulation
- Delauney, others...

• TIN Editing
- AddinglDeleting Vertices }
- Breaklines Conditioning

- Edge swapping

•

•

•



•
Limitation"to Automated
Triangulati~'ri"Methods

'~\

•

• Triangle edges do not conform wi
breaks in terrain
- streams, ridges, local min and max

•

Conditio'n'ing,,~he TIN
"

• Manual
- Edge Swapping

- Breaklines

- Adding/Deleting points and triangles

• Automatic
- Elevation smoothing

- Pit/Flat Triangle/Flat Edge removal

- automatic edge swapping



- ---~ ..
. _--...,- .

.............
.........

Brea'k~,ines
'"

Breakline

•

•

•



•
Smoothing Elevations

•

• Similar to DEM smoothing
- iteration control

- maximum adjustment control

• Onl adjusts unlocked vertices

...,',.........

•

Eliminati~g'TIN"Anomalies

• Pits
- Usually occur because a lack of reso

- Swap an edge or adjust an elevation sli

• Flat Triangles
- Insert a new vertex in the interior of the tri

and interpolate the elevation

• Flat Edges
- same as TINs only along the flat edge



Display

• Contours

• Shaded
• Mapped images

• The z value could be another function v
such as rainfall

•

•

•
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7.1

WMS allows you to quickly and easily import and manipulate terrain data.
Besides DEM data, WMS can also use TINs (Triangulated Irregular Networks)
for surface representation. Each TIN is constructed from a scattered set of x y
z vertices. From the TINs generated by WMS, drainage basins can be
delineated.

The vertices used to create a TIN can be imported from an ASCII file, from
another TIN file (such as InRoads), or by interpolation from aDEM.

To use TINs in WMS effectively you will want to learn about the following:

• Importing data files.

• Using WMSs viewing tools to change perspectives, allowing you to
visualize a TIN in 3-D.

• Contouring the TIN.

• Using TIN display options to identify important features of the terrain
model.

• Editing the TIN.

Reading Vertex Data Files Into WMS

After familiarizing yourself with the WMS window, you will be ready to load
the sample vertex file that you will be using for the rest of this tutorial. This
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ASCII text file is simply a list of XYZ coordinates. To load the sample vertex
file, do the following:

~j
1. Select the TINs module icon ~.

2. Under the File menu select Open.

3. Find and Open the file named "jonescyn.tin". By default this file is
found in the tutorial directory.

A group of vertices will appear in the graphics window. If you can't
see the vertices try selecting Display Options from the Display menu
and turn vertices on.

7.2 Triangulating Vertices To Make a TIN

After the vertices have been read into WMS, they must be triangulated into a
TIN.

1. Select Triangulate from the TINs menu.

During the triangulation process several long, thin triangles may be created
around the perimeter of the TIN. Often these triangles are not wanted and so
WMS provides a way of automatically selecting thin boundary triangles, so
that you may delete them. To delete the triangles, do the following:

1. Select the Select Boundary Triangles from the TINs menu.

2. Choose the Select thin boundary triangles only option and select OK.

All thin boundary triangles will be shaded, indicating they are
selected.

3. Select the Delete command from the Edit menu (You can also do this
by selecting the DELETE or BACKSPACE key).

4. Select OK when the confirmation dialog box appears.

7.3 Changing the Viewing Parameters

To help you better visualize a three-dimensional terrain model, WMS provides
multiple viewing perspectives of your TIN. The default view is plan view,
where you are looking at your TIN from directly overhead. This is the easiest
view in which to edit and do most of the drainage analysis with your TIN.

The Oblique View option in the View menu allows you to display the TIN in a
perspective view.

•

•

•
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2. Hold down the CONTROL key on your keyboard, move your cursor to
the middle of the graphics window, and click and hold down the
mouse button while you drag the cursor in different directions. As you
move the mouse, the TIN is constantly redrawn to reflect your
changes. The bearing is changed by dragging the mouse horizontally,
and the dip is changed by moving the mouse vertically. Any
combination of the two directions can be used. The amount an object
is rotated depends on how far the mouse is dragged. Dragging from
the left edge of the edit window to the right edge rotates the object 180
degrees.

1. Select Oblique view from the View menu. (You could also use the

macro !£h

1. Select the Rotate Image tool .~.

You can use the Rotate Image tool ~ to quickly change viewing angles
without having to use the View Angle dialog box. Use the View Angle dialog
box when you warrt to set the view angle to an exact value or to check what the
current viewing angle is.

Oblique view shifts you from plan view to a viewing angle determined by the
bearing and dip angles entered in the View Angle dialog box under the View
menu. The default or plan view corresponds to a bearing of 0 degrees and a dip
of 90 degrees.

The display will be updated, and you will be viewing your TIN from a
perspective view. This view emphasizes the peaks and valleys on your terrain
model.

\VI
'\ \ / /

_--1\-:--.,...--._-!.I_/ To use the Rotate Image tool to change viewing perspectives, do the following
------ I'i steps:

I

•

•
When working with complex TINs, your computer may not update the
screen quickly enough. To change the viewing perspective in one step
without any intermediate screen updates, do the same steps outlined
above without holding down the CONTROL key.

3. When you are finished, select Plan view macro 111.

7.4 Displaying Contours on a TIN

•
WMS has several options for displaying contours on a TIN. WMS can display
lined contours, color-filled contours, and contour elevation labels.

To display contour lines, do the following steps:

I. Select Display Options from the Display menu.
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2. Click on the Contours option so that it is enabled.

3. Click on the OK button.

The screen will redraw, and the TIN will be overlaid with contour
lines.

As you can see, vertices and triangles were also displayed along with the
contour lines. Often when displaying contours you want to disable vertex and
triangle display. To disable vertex and triangle display, do the following:

1. Select the Display Options command from the Display menu.

2. Click on both the Vertices and Triangles options so they are disabled.

3. Click on the OK button.

The screen will now redraw with only the contour lines and the outer
boundary of the TIN.

In addition to displaying lined contours, WMS can display color filled
contours. When active, this option fills the area between two adjacent contour
lines with a color corresponding to the upper contour value. Two types of
shading are available: hues of varying colors and multiple shades of a single
color.

•

To display color filled contours shaded with hues of varying colors, do the •
following steps:

1. Select Contour Options from the Display menu.

2. Select the Color fill between contours option.

3. Click on the OK button.

The screen will redraw, and the TIN is displayed with hues
corresponding to elevations indicated by the color legend displayed in
the upper left-hand comer of the graphics window.

To display contours shaded with multiple shades of a single color, do the
following:

1. Select Contour Options from the Display menu.

2. Select the Color Ramp tab.

3. Select the Ramp ofintensity option.

4. Click on the OK button.

•



•

•

•
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After the screen redraws, your TIN will be shaded with multiple
shades of a single color indicating various elevations.

WMS allows Contour labels to be created and placed manually on a TIN. To
display contour labels, do the following:

1. Select Plan View from the View menu.

Contour labels can be displayed only in Plan view.

2. Select the Create Contour Label tool ~.

3. Click on a point interior to your TIN.

A value indicating the elevation of the nearest contour to the point
clicked will appear. Multiple labels can be displayed on a TIN. A
label can be removed by holding down the SHIff key while clicking
on the label. Labels remain and are displayed each time the model is
redrawn until the TIN is edited in any way at which time they are
deleted.

For the next section of this tutorial you will want contours turned off. To turn
off the contours and restore vertex and triangle display, do the following:

1. Select Display Options from the Display menu.

2. Turn Contours off.

3. Turn Triangles back on.

4. Change the color of triangles to a color of your choice by clicking on
the color-filled box adjacent to the toggle. Click on the color box in
the attributes dialog. In the color chooser select any color you want,
except black. If triangles are black no shading will occur.

5. Click on the OK button.

7.5 Creating a Shaded Image of Your TIN

WMS provides several options for generating shaded images of TINs. TIN
shading converts the wire frame TIN that you normally see into a shaded
image. To shade a TIN, do the following:

1. Select Oblique View from the View menu.

2. Select Shade from the Display menu.

The screen will redraw and your TIN will appear as a solid shaded
object rather than as a wire-frame image.
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WMS also allows you fo vary the simulated light source's position. This is
useful when the default setting does not provide enough contrast in the shaded •
image. To vary the light source position, do the following:

1. Select Light Angle from the Display menu.

A dialog containing a shaded sphere will appear. The way the sphere
is shaded indicates how the light source is directed at the TIN when
shading.

2. Click on the sphere at a new location to change the light source
direction.

3. Click on the OK button.

4. Select Shade from the Display menu.

5. If the shaded image is too dark or too light, change the light angle
again.

7.6

6. When you are finished shading, select Plan View from the View menu
to restore the default view.

Mapping an Image to a TIN

You can map an image to your TIN so that you can see the effects of shading
with an image "draped" over the TIN. This operation is relatively simple and
can be a highly effective way to show-off your data.

You will need to be sure that the image is appropriately registered. In this
example you will read in an already registered image, but if you need to
review this see section 2.3 of this tutorial manual.

1. Select the Map module II.
2. Select the Open command from the File menu.

3. Find and open the file named ''jonescyn.img.''

4. Select the Display Options... command from the Display menu.

5. Select the Image Display Options button.

6. Tum on the Texture map to surface when shaded option.

7. Set the option to Map to active TIN.

8. Select the TINs module 19.

•

•
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9. Selectth6 Shade command from the Display menu. This may take 30
60 seconds depending on the speed of your computer processor.

You may want to experiment with the following adjustments to get the best
view of a mapped image:

• Change the view angle using the Rotate tool ~.

• Change the Z-magnification by selecting Z Magnification ... command
from the View menu. This will exaggerate the 3-D effect so that terrain
features appear more prominently. A value of 1-3 is generally
appropriate, if the value is too large the TIN will become overly
distorted.

• Change the lighting angle by selecting the Light Angle... command from
the Display menu and then choose the Shade command from the Display
menu.

When you are finished reset the display options.

1. Select Display Options... command from the Display menu.

2. Select the Map tab.

3. Select the Image Display Options button.

4. Turn off the Texture map to surface when shaded option.

5. Select the TIN tab.

6. Turn on Contours.

7. Select OK.

8. Select the Plan View macro ..

7.7 Adding Breaklines to Preserve Geometric Features

Because of the way WMS triangulates vertices, geometric features such as
ridges or valleys may not appear on your TIN as they do in the original terrain.
You can use the Add Breakline(s) option to enter these features manually.

To add a breakline, do the following:

1. Select the Select Vertex Strings tool II
2. Click on any vertex in your TIN.
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The vertex you clicked on will now be highlighted in red.

3. Click on another vertex that is not attached to your original vertex (i.e.
connected by a triangle edge).

The two vertices you selected are now connected by a solid red line.
This red line, when processed, will force triangle edges to be honored
along it.

4. Select Add Breakline(s) from the TINs menu.

WMS adds vertices and retriangulates your TIN so that triangle edges are
honored along the line you entered with the Select Vertex String tool.

Several vertices can be added to a string before selecting the Add Breaklines
command. If a mistake is made entering a vertex string single vertices can be
removed by pressing the DELETEIBACKSPACE key. To abort entering a
vertex string using the ESCAPE key.

7.8 Swapping Triangle Edges

Local changes in the TIN topology can be made by swapping the edges of two
adjacent triangles. This process is similar to the breakline method described
above since it allows you to force triangle edges to coincide with important
TIN features.

To swap triangle edges, do the following:

1. Click on the Swap Edges toolllJ.

2. Click on the edges of several triangles and notice how the edge
configuration is swapped.

Some triangle edges can not be swapped, since by so doing overlapping
triangles would be formed. If you try to swap one of these edges, you will
hear a beep and the edge will not be swapped.

7.9 Selecting and Deleting Vertices on a TIN

Some functions require one or more vertices to be selected before you perform
the function. This portion of the tutorial familiarizes you with the different
options for selecting vertices and how they are used in conjunction with
deleting and dragging.

When selecting vertices, WMS allows you to work with either single or
multiple vertices simultaneously.

•

•

•
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To select a single vertex:

I. Click on the Select Vertices tool ~.

2. Move the mouse pointer over a vertex on your TIN and click on that
vertex. The vertex will now be highlighted, indicating it is selected.

3. Click on another vertex. The vertex you selected originally is now
unselected, and the new vertex is now the selected one. Notice that
the xyz values of the vertex are placed in the vertex edit box.

Often you will want to manipulate multiple vertices, as when you are deleting
a section of a TIN. WMS provides three methods for selecting multiple
vertices:

• Select multiple vertices individually by holding down the SHIFf key
and selecting several points.

If the SHIFf key is depressed while selecting allows you to select
multiple points. If the SHIFf key is not depressed, only one point can
be selected at a time.

• Select multiple vertices by holding down the mouse button and
dragging a box enclosing the portion of the TIN you want selected.
When the mouse button is released, all vertices lying within the box
are selected.

• Select multiple vertices by using a selection polygon. Under the Edit
menu, select Select With Polygon.

Before a vertex can be deleted it must be selected. To delete a vertex, do the
following:

1. Select a single vertex on your TIN.

2. Press the DELETFJBACKSPACE key, and when a dialog box appears
confmning your deletion, click on the OK button.

Remember that by selecting multiple vertices before pressing the
DELETE key, you can delete multiple vertices in one step.

Dragging Vertices on a TIN

WMS allows you to easily move a vertex with the select vertices tool. The
dimensions on which a vertex is dragged depends upon the editing view. In
Plan view, only the x and y values are changed. In any view other than plan,
the z value is the only value affected.



7-10 WMS Tutorials

First, turn on several display options so you can see the effects of vertex
modifications more easily: •

I. Select Display Options from the Display menu.

2. Enable the Contours, Channel edges, Pits, and Ridge edges options,
and leave the triangle and vertex display enabled so you will be able to
see the points you are editing.

3. From within the Display Options dialog click on the Contours...
button. Select the Normal linear contours option.

4. Click on the OK buttons of each dialog.

To drag a vertex, do the following:

1. Make sure you are in Plan view, and with the Select Vertices tool ~
active, click on a vertex near the center of your TIN. While holding
down the mouse button, drag the point to a new location. Notice how
the TIN stretches to follow your changes and how only the x and y
values of that point are changed in the vertex edit dialog in the upper
left side of your screen. Notice also how there are limits to the amount
a vertex may be dragged so that the triangulation will remain valid.

2. With the vertex still selected (four squares are drawn around the vertex
to indicate that it is selected), click in the x, y, or z vertex edit box in •
the upper left of the screen and change the value. Notice that you can
not change the x or y value in such a way that the triangulation will
become invalid in the same way that there was a limit to the distance a
node could be dragged above.

3. Enter a new value into the z edit box in the edit window adjust the
elevation of the selected vertex. Notice how the contours, channel
edges, pits, etc. display, are all updated instantaneously as the values
are modified.

4. Continue moving/editing the vertices until you are comfortable with
how these options work.

7.11 Inserting Vertices on a TIN

Mter you have triangulated your initial set of vertices, it might be necessary to
manually add vertices in certain locations to help improve the definition of the
TIN.

Before adding vertices, it is wise to lock the existing vertices. Locking
vertices serves two purposes. First, it prevents them from being moved •
(intentionally or accidentally) as described above. It also distinguishes them
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from points which are subsequently added. This distinction is often important
since the original vertices represent data with a greater amount of certainty
(and which you are less likely to want to change).

To lock the vertices, do the following:

I. Select Lock/Unlock Vertices from the TIN menu. The color of the
vertices will change from the unlocked color (black by default) to the
locked color (red by default).

To add vertices, do the following:

1. Select Plan view from the View menu.

Plan view is the only view that you can use to enter new vertices.

2. Select the Create Vertices tool.~ from the tool palette.

3. Click anywhere within the TIN.

4. Accept the default z-value by selecting the OK button.

WMS will retriangulate the affected portion of the TIN, incorporating
the new vertex. Notice that the new vertex is black indicating that is
unlocked and can be adjusted. A default z value for the new vertex
will be determined from the surrounding triangles.

5. Add a few more vertices, this time experimenting with different Z
values. Watch how the TIN changes as the new vertices are inserted
into the triangulation.

6. Select Refresh from the Display menu.

Changing Display Attributes

Throughout this tutorial you have turned various display attributes (contours,
vertices, triangles, etc.) off and on using the TIN display options. Besides
toggling the display, colors, line widths, and line styles may be changed for
contours, triangles, or any of the different objects which can be displayed.

To change display attributes, do the following:

1. Select the Display Options command from the Display menu.

2. Click on the Contours... button next to the contours display toggle
box.

3. Click on the Color Ramp tab.
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4. In the Color Options tab click on the default contour color box.

S. A color palette appears from which you may assign a new contour
color.

6. Change the width style to 2.

7. Click on the OK button for the Attributes dialog.

8. Click on the OK buttons for the Contour Options and Display options
dialogs.

Continue experimenting with turning off and on display options and changing
any of their attributes. PC NOTE: MS Windows only allows dashed lines
when the thickness is 1.

The ability to change line thicknesses and styles comes in particularly handy
when creating hard copies where all lines are typically drawn in black.

•

7.13 Conclusion

TINs are one of the different types of terrain models that can be used for
performing drainage analysis in WMS. The next tutorial illustrates how TINs
can be created from feature object data. This is important since an arbitrary
triangulation of scattered data points may not produce a TIN which is suitable
for drainage analysis (Le. triangle edges enforced along streams and ridges). If
you have a set of scattered data points initially it may be a good idea to
triangulate them and then treat them as a background elevation map (similar to
the DEMs of the previous tutorial) for creating a new TIN from feature object
data.

In this tutorial you have learned the basics of viewing and manipulating TINs.
These concepts apply whether you are using the TIN for visualization only, as
a background· elevation map for creating a more suitable TIN for drainage
analysis, or as a TIN from which a watershed will be characterized.

•

•
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Estimated Time: 25 minutes.

In order to define a stream network and delineate basins, you must first have
flow defined everywhere on the TIN. Triangulating a set of raw data points
rarely produces such a TIN. Often, flat triangles and edges, artificial pits, and
discontinuities in channel segments exist. For this reason, a set of tools is
provided in WMS which allows you to alter the initial triangulation, using your
own knowledge about the site being modeled, so that drainage is properly
defined and channel edges accurately represented. A certain amount of TIN
editing was required for all of the TINs used in the previous tutorial. In this
and the next tutorial, you will learn the different methods available for pre
processing TINs before using them for drainage analysis.

Data points used for the initial triangulation generally come from one of two
different sources: digitized data from an existing contour map or gridded data
such as is provided by the USGS. Different types of problems arise with each
of these types of data, and therefore the editing approach is generally different.
This tutorial covers editing techniques appropriate for digitized data, while
techniques for gridded data is the topic of the next tutorial.

Stream network creation in the previous tutorials was done automatically.
However, having a continuous set of well defined channel segments is a
prerequisite to creating streams in this fashion. While having a continuous set
of channel segments is ideal, it is not always practical, and therefore an
alternate method of stream network creation is presented in this tutorial. This
method allows you to interactively select points which make up a stream or
input a digitized set of stream points from a file.



17-2 WMS Tutorials

17.1

17.2

Objectives

In this tutorial you will learn basic editing techniques and automated
techniques which apply specifically to data which has been generated by
digitizing a contour map. The steps covered include the following:

• Reading the TIN data file.

• Triangulating the data points.

• Removing boundary triangles.

• Swapping edges to remove flat triangles and define channel segments.

• Adding breaklines so that triangle edges honor important features.

• Inserting additional points.

• Interactively moving points.

• Automatically removing flat triangles.

• Creating streams by interactively selecting a network of vertices.

• Using the display options to guide the editing process.

Reading the Data File

The TIN you will be reading for this tutorial only contains the vertices, as
triangles have not yet been created (you can use this file as an example format
for data you may already have and wish to read into WMS). To read the file,
do the following:

1. If you are continuing from a previous WMS session, select New from
the File menu.

2. Select the TINs module icon '9.
3. Select Open from the File menu.

4. Use the file browser to find and open the file "digitize.tin". This file
should be found in the tutorial directory.

5. Select the Display Options command from the Display menu.

6. Make sure that triangles and vertices are turned on.

•

•

•
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7. Select OK.

After opening the file, you should see several data points drawn in the
main graphics window.

Triangulating the Data Points

Triangulation is the first process that must be done any time a new set of datu
points is read into WMS. You can watch the triangulation process proceed as
will be shown, however displaying the triangulation process is more time
consuming, and therefore you typically won't want to do this. To triangulate
the points, do the following:

1. Select Triangulation Options from the TINs menu.

2. Tum on the Display triangulation process option.

3. Click on the OK button.

4. Select Triangulate from the TINs menu.

5. Select the LockJUnlock Vertices command from the TINs menu.

Locking the original set of data points is a good idea since location
and elevation of these points are more certain, and you do not want to
move them accidentally. Any additional points created will by default
be unlocked.

6. Select Display Options from the Display menu.

7. Turn on Contours, Channel edges, and Flat triangles.

8. Tum off Boundaries.

9. Click on the OK button.

The display should show the triangulated TIN. Notice the flat
triangles displayed in red, and channel edges in yellow.

Removing Thin Triangles on the Boundary

Several long thin triangles around the perimeter of the TIN exist. Often these
triangles are outside of the area of interest and, as seen along the bottom, can
create several flat triangles, since all perimeter points were digitized from the
same contour. These triangles can be selected for deletion in the following
manner:
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1. Select the Select Boundary Triangles command from the TINs menu.
Several of the thin boundary triangles will automatically be selected.

2. Make sure the the Select thin boundary triangles only option is chosen
and select OK.

3. Select the Delete command from the Edit menu.

4. Confirm that you wantthe triangles deleted by selecting OK.

The boundary triangles selected will be deleted and the display
updated appropriately. This process could have been done manually

by using the select triangles tool ~ and the techniques for selection
described in the reference manual.

•

17.5 Swapping Edges

It appears as if there is some type of channel on the right side of the TIN.
However, because of the flat triangles and the current TIN topology, the
channels are not all present nor continuous. Edge swapping can often be used
to remove flat triangles and force triangle edges where channel segments
should be. The figure below shows four edges which need to be swapped in
the following manner. To swap edges, do the following:

1. Select the Swap Edge tool~.

2. Click on the edges labeled 1-4 (in that order). Notice how the contour,
flat triangle, and channel edge display is immediately updated.

Figure 17-1 Before Swapping

•

•
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Figure 17-2 After Swapping

Adding Breaklines

Another method which can be used to force triangle edges along important
terrain features such as ridges and streams is breaklines. The remaining flat
triangles will be removed using a breakline. The figure above acts as a guide
for placing the breakline. To add a breakline, do the following:

1. Click on the Select Vertex String tool.ln.

2. Click on the vertices marked 1-4 (in that order) in Figure 17-3.

3. Select the Add Breaklines command from the TINs menu.
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Figure 17-3. Before Adding Breakline

Figure 17-4 AfterAdding Breakline

•

•

17.7 Removing False Dams
False dams occur when a triangle edge is created perpendicular to a stream
channel (from one bank to the other), as opposed to along the channel. The
figure shown below shows two different cases where false dams are present.

•



•
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I
i
I

I
~

Figure 17-5 Before Removing False Dams.

It may not be obvious from the contours that a channel edge should exist at 1;
however, the discontinuity in the channel segment provides a clue that the
edge should be swapped. It should be more obvious that edge 2 forms a false
dam. False dams can always be removed by swapping edges. To remove false
dams, do the following:

1. Select the Swap Edge tool •.

2. Click on edges 1 and 2 as shown in Figure 17-5.

Figure 17-6 After Removing False Dams.
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17.8 Inserting Additional Points

You may have noticed that there are several small channel edges connected to
the main stream network. Often, no such channels exist and for clarity you
wish to remove them. Typically these types of problems can be corrected by
inserting additional points into the triangulation. Figure 17-7 shows how the
two small channels segments near the upper middle portion of the TIN can be
removed by placing a new point at A in the following manner:

1. Select the Create Vertex tool .2.1.
2. Click on the TIN at or about point A.

3. Accept the default z value by selecting OK.

4. A new point will be inserted into the triangulation, and both adjacent
stream edges should disappear.

---.,
"I
\
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Figure 17-7 Before Adding the Point

•

•

•



•
TIN Editing 174

.~-~---

-- .~---j
.. I
I

i
L/"

~, .. -....

•

•

17.9

Agure 17·8 AfterAdding the Point

1. Click on the Select Vertices tool~.

2. Click on the new vertex and, while holding the mouse button down,
drag it around. You should see the contours, stream edges and any
other TIN display option which is turned on update immediately. This
function of WMS is particularly useful when editing.

3. With the vertex selected, the z value is displayed in the text edit box in
the Edit Window. You can edit the z value by changing it in this edit
field.

4. Restore the z value of the new vertex to a logical position (make the
contours look similar to the contours shown in Figure 17-8).

Automated Editing Techniques

The TIN you have been working with so far in this tutorial is only a small part
of a much larger TIN created using a digitizer. The editing techniques you
have learned thus far could be used repeatedly to correct flat triangles, flat
edges, false dams, etc., for the entire TIN. However, removal of flat objects
can often be done automatically, greatly increasing the speed and efficiency at
which TINs can be prepared for doing drainage analysis. To perform these
editing techniques, do the following:

1. Select the New command from the File menu.

2. Select the Open command from the File menu.
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3. Find and open the file "auto.tin".

4. Select the Triangulate Options command from the TINs menu.

5. Turn off the Display triangulation process command.

6. Click on the OK button.

Displaying the triangulation for larger data sets can take significantly
more time.

7. Select the Triangulate command from the TINs menu.

8. Select the Select Boundary Triangles command from the TINs menu.

9. Select the Select thin boundary triangles only option.

10. Select OK.

11. Select the Delete command from the Edit menu.

12. Click on the OK button to confirm the deletion of the selected
triangles.

13. Select the LocklUnlock Vertices command from the TINs menu.

In order to automatically remove flat objects, the vertices should be

locked.

14. Select the Interpolate Flat Triangles command from the TINs menu.

This operation could take several seconds to a few minutes depending
on your hardware. After a few seconds you should start to see the flat
triangles and edges being modified. When complete you should see
that channel edges run through the entire region of flat triangles.

15. Select the Display Options command from the Display menu.

16. Tum on Pits.

17. Click on the OK button.

As the display is updated. notice that there are several pits in the
stream. These pits occur as a result of removing flat triangles and
edges. and not necessarily because of actual pits in the stream.

•

•

•
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17.10 Creating Streams Manually

Recall from earlier tutorials that streams could be automatically delineated
from outlet points if a continuous set of channel edges existed. Even though a
continuous set of channel edges exists in the current TIN, it is still interrupted
by several pits. In order to automatically delineate the streams, TIN editing
would have to be done to remove the pits and ensure that each successive
stream vertex from upstream to downstream had a lower elevation. This
process often takes a considerable amount of time, and therefore an alternati ve
to automatically delineating stream networks is provided in WMS.

Stream networks can be created by manually selecting a set of vertices, from
downstream to upstream, regardless of whether the next upstream vertex is
higher or lower in elevation. This allows you to run a stream right through the
set of pits in the channel above without having to do any additional editing.
This type of stream creation is possible because once flow reaches a stream, it
is routed downstream strictly by the connectivity of the stream. This type of
stream creation has several important uses:

1. Pits in natural streams don't have to be removed using TIN editing
techniques. '

2. Streets, canals, storm drains, etc., which are not necessarily
represented as stream edges in a TIN can be modeled.

3. A set of stream vertices can be imported and stamped into the TIN.

Along with the advantages there are a couple of pitfalls which you must be
aware of:

1. Calculated stream slopes may not be accurate. However, overall
averages still give reasonable results.

2. Improper placement of a stream, street, storm drain, etc., can cause
significant error in computed basin areas and drainage characteristics.

In general, creating streams in this fashion is a powerful tool, but it must be
used with common sense and a good understanding of the terrain being
modeled. Streams can be manually entered by following the steps outlined
below:

1. Click on the Select Vertex String tool II.
2. Starting at the outlet point, select the vertices corresponding to the

stream (the lower right corner of the TIN). Figure 17-9 can be used as
a guide to start entering the stream. You don't have to select vertices
along triangle edges since a breakline will be inserted where
necessary, but be sure to pass through the pits.
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3. After selecting several vertices, select the Create Streams command
from the Streams menu.

4. Click on the OK button if asked if you would like to process a
breakline before the stream is created.

You can stop entering points with the Select Vertex String tool ~ at any time
and use the Create Streams command. Begin the next segment from where
you left off, or come back to a branching point and begin entering that branch.
A couple of important rules should be remembered when entering manually
created streams.

1. Streams should always be entered from downstream to upstream.

2. Streams can not cross existing streams.

3. The first vertex entered for a new stream becomes an outlet, unless
you are branching off from an already existing stream.

4. If stream edges created manually are swapped, or the triangulation of
any of these edges are changed, the streams will no longer be valid.

5. The Pan~ and Zoom .@J tools can be very useful when entering
streams.

Figure 17-9 Stream Creation

•

•

•
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17.11 Conclusions

In this tutorial you have learned many important TIN editing techniques, as
well as an alternate method of creating stream networks. The important topics
covered include the following:

• Triangulating a raw set of data points.

• Removing flat triangles and edges by swapping edges, inserting
breaklines, and adding additional points.

• Recognizing the power of the instantaneous feedback of the display of
flat triangles, channel edges, contours, etc., when editing a TIN.

• Automatically removing flat triangles and edges.

• Creating streams by manually selecting the network of vertices.
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TINs

Supplementary Excerise for TIN Basics-Session 4

For the supplementary exercise with TINs do the second tutorial on TIN editing.

All files for this exercise are located in the Supplimentary 4 directory.
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• The piece-wise linear nature or£F~s make
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common point
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Stream Network
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Watershed Delineation from TINs

8

•
Estimated Time: 20 minutes

The last three tutorials have introduced you to using Feature Objects and
OEMs and TINs for background elevation maps. In this tutorial you will
combine these tools together to create a TIN which can be used for watershed
delineation parameter computation.

Specifically this tutorial covers the following topics:

• Reading in a registered TIFF image.

• Reading in a map me for use in defining key watershed features.

• Importing a DEM and using the feature objects to create a TIN.

• Delineating a watershed and sub basin boundaries from the TIN.

• Computing basin geometric parameters.

• Using drawing objects for annotations.

•
8.1 Reading a Registered TIFF Image

The feature object data you will be using in this tutorial was created from a
TIFF map in the same way shown in section 2.2 of these tutorials. This same
TIFF image, which was previously registered can be read into WMS by:
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I. If you are continuing from another tutorial select the New command
form the File menu.

2. Select the Map module icon 1ml
3. Select Open from the File menu.

4. Type *.img in the file name edit field (this will cause the file browser
to only list file names ending with img).

5. Find and Open the file named "jonescyn.img".

After a few seconds of reading the file and registering the image, the TIFF
image of a portion of USGS quad map will appear in the Graphics window.

8.2 Reading in a Map File

•

As stated in the previous section, the registered image can be used as a
backdrop for on-screen digitization of streams and a rough boundary. These
feature objects will be used to create a TIN that will conform to the boundary
polygon and maintain triangle edges along all streams or other interior feature
arcs.

If you haven't done the tutorial on creating feature objects from image, or if •
you need a refresher, refer to section 2.3.3 in this tutorial manual before
proceeding to the next section. If you have completed the Feature Objects
tutorial and already feel comfortable with how feature objects·are created, then
do the following:

1. Select Open from the File menu.

2. Find and Open the file named "jonescyn.map".

This map files contains a bounding polygon and two stream branches' '.

8.3 Importing a Background. Elevation Map

Elevations for vertices created inside the boundary polygon can be interpolated
from a background elevation source such as a DEM or another TIN. Without a
background elevation map the TIN will not have z values and therefore will be
unusable for watershed delineation. The tutorial in Chapter 5 teaches you how
to work with DEMs as background elevation maps. If you have not yet done
this tutorial or need a refresher you may wish to do it now. To import a
background elevation map.

1. Select Import from the File menu. •
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2. Choose the Arc/Info grid->DEM option.

3. Select OK.

4. Select the Add button in the Import OEM dialog.

5. Find and Open the file named "jonescyn.grd".

6. Select OK.

....
7. Select the DEM module iiI:

8. Select the Smoothing Options command from the DEMs menu.

9. Set the number of iterations to 3.

10. Select OK.

11. Select the Smooth DEM command from the DEMs menu.

Smoothing the DEM will help to eliminate the affects of rounding to the
nearest meter.

Contours of the DEM will be overlaid on the image. If the color filled contour
options is active you may wish to change to linear contours by:

1. Select the Contour Options command from the Display menu.

2. Choose the Normal linear contours option.

3. Select OK.

8.4 Creating a·TIN and Defining a Watershed

With the feature objects defmed, and a background elevation map you are
ready to create the TIN.

•

8.4.1 Redistributing Vertices

The density of vertices that are created inside the boundary polygon will be
proportional to the density of vertices along the feature arcs." In order to have .
control over the TIN vertex density, WMS allows you to automatically
redistribute vertices along arcs to a higher or lower density (decrease or
increase spacing between arc vertices). To redistribute the vertices:

1. Select the Map module
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2. Select the Select Arc tool i~.

3. Choose the Select All command from the Edit menu.

4. Choose the Redistribute command from the Feature Objects menu.

5. Specify the Subdivide each end uniformly with a Specified spacing of
100 (meters).

6. Select the OK button.

•

8.4.2 Creating a TIN

To create a TIN from the defined feature objects.

I. Select the Select Polygon tooll~.

2. Click anywhere inside the boundary polygon.

3. Select the Create TIN command from the Feature Objects menu.

4. Select No when prompted if you would like to save your data before
proceeding. The drainage coverage and TIN cannot coexist in WMS
so the drainage coverage is deleted as a result creating the TIN. This •
prompt allows you to save the drainage coverage prior to having it
deleted from WMS so that you can come back and use it later should
you need to.

5. Turn on the Display triangulation process option (this will allow you
to see, and better understand, how the TIN creation process works).

6. Select OK in the Create TIN Options dialog.

7. When prompted to delete the DEM select YES.

8. Select the Display Options command from the Display menu.

9. Select the Image Display Options button.

10. Turn off the Draw on xy plane behind all objects option.

11. Select OK to the Image Display Options and DispLay Options dialogs.

12. Select the DeLete command from the Drawing Objects menu.

13. Confirm that you want to delete all drawing objects.

A TIN should be genearted inside the bounding polygon and a stream enforced •
along the stream arcs. The TIN does not represent the actual watershed
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boundary, but can now be used to delineate the watershed and define sub
basins.

Watershed Delineation

The feature object boundary used to create the TIN was not the watershed
boundary. In fact it was created to be larger than the watershed boundary so
that a more precise watershed boundary can be delineated from the TIN.

I. Switch to the TINs module i:~.

2. Select the Display Options from the Display menu.

3. Turn off Vertices and turn on Pits and Flat triangles.

4. Select the OK button.

•

•

8.5.1

8.5.2

Eliminating Pits and Defining Boundaries

You should not have any flat triangles, but there may be a few pits which must
be removed before defining watershed and sub basin boundaries.

1. Select the Smooth Pits command from the TINs menu.

A single pit will likely remain along the stream, but since it is part of the
stream it will not affect basin delineation.

1. Choose the Define Basins command from the Drainage menu.

Correcting Split Flow Problems

For some models locations of split flow occur, causing an ambiguity in sub
basin defInition. If this occurs for your model you will get an error message
stating that "triangles drawn in red belong in two drainage basins." If this
happens you can correct the problem by:

1. Select the Correct Split Flow command from the Drainage menu.

You no longer need the display of pits, flat triangles and split flow vertices.

1. Select the Define Basins command from the Drainage menu.

2. Select the Display Options from the Display menu.

3. Turn off all of the display options.

4. Select the Drainage tab.
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5. Tum on Fill drainage basins.

6. Select OK. •
8.5.3

8.5.4

8.5.5

Refining Boundaries and Eliminating Exterior Triangles

Triangles are assigned to drainage basins based on following a flow path from
the centroid of the triangle to the stream/outlet encountered first. Since some
triangles will straddle the basin boundaries there is a small amount of error in
the current basin definition. You can correct this by refining the boundaries.

I. Choose the Refine Boundaries command from the Drainage menu.

2. Remove the exterior triangles by choosing the Delete Null Basin
Triangles command from the Drainage menu.

Computing Basin Geometric Parameters

The brown and orange areas represent the sub basins of the two stream
branches. By default WMS created an outlet point at the downstream-most
part of the feature arcs. Basins were created for each upstream branch of the
outlet. You can now compute the basin geometric parameters for the
watershed, and alter the delineation by eliminating exterior triangles, merging •
basins, adding additional outlets, etc.

1. Choose the Compute Basin Data command from the Drainage menu.
Be sure the model units are set to meters and specify the parameter
units to be whatever you wish.

2. Select OK to compute the basin data.

Adding a New Stream

Additional streams and outlets can be created for the TIN, even after disposing
of the feature. objects and establishing an initial delineation.

1. Select Display Options from the Display menu.

2. Turn on triangles and contours.

3. Select the Drainage tab.

4. Turn off Fill drainage basins.

5. Select OK.

6. Select the Zoom tool I'll. •
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7. Drag a rectangle around the region identified in Figure 8-1.

You will now add a new stream that was not present In the initial feature
object definition.•
Figure 8-1 Zoom Window.

•

1. Select the Select Vertex String tool

2. Starting with the vertex already in the stream click one by one on the
vertices identified in Figure 8-2. A red line will indicate the string of
vertices selected.
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•

Figure 8-2 Entering a Vertex String to Create a New Stream.

8.5.6

1. After selecting the last vertex, select the Create Stream command in
the Streams menu.

2. Select Yes to process the breakline before entering the stream.

Creating Additional Outlets

1. Select the Select Vertex tool·

2. Select the vertex where the newly created stream meets the existing
stream.

3. Select the Add Outlets command in the Streams menu.

4. Select the Frame Image command from the View menu.

5. Select the vertex midway up the upper branch as indicated in Figure
8-3.

6. Select the Add Outlets command in the Streams menu.

•

•
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Figure 8-3 Vertex for New Stream

•

•

8.5.7

You must now redefine the boundaries so that the new outlet is recognized.

1. Select the Display Options command in the Display menu.

2. Turn off triangles and contours.

3. Select the Drainage tab.

4. Turn on Fill drainage basins.

5. Select OK for both dialogs.

6. Select the Define Basins command from the Drainage menu.

7. Select Refine Boundaries from the Drainage menu.

8. Select the Compute Basin Data command from the Drainage menu.

9. Select OK on the Units dialog.

Merging and Splitting Basins

WMS always creates a basin for each upstream branch from an outlet point.
However, it is sometimes preferable to merge these two basins together.

1. Select the Select Basins tool II.
2. Click inside the yellow basin.
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3. Hold the SHIff key down and click inside the green basin.

4. Select the Merge Basins command from the Drainage menu.

The text displaying the area of the basins disappears. This means that the
basin geometry has changed, and the basin data must be recomputed.

1. Select the Compute Basin Data command from the Drainage menu.

2. Select OK on the Units dialog.

3. Select the yellow basin again.

4. Select the Split Basins command from the Drainage menu to again
split the watershed into separate basins for each branch.

5. Select the Compute Basin Data command from the Drainage menu.

6. Select OK on the Units dialog.

•

8.5.8

8.5.9

Deleting and Existing Outlet

You can eliminate outlets once they have been created by doing the following.

l. Select the Select Vertex tool·

2. Select the outlet of the stream branch of the basin you just split.

3. Select the Delete Outlets command from the Streams menu.

4. Select the Compute Basin Data command from the Drainage menu.

5. Select OK on the Units dialog.

Basin Label Text.

By default some text annotations for the basin geometric parameters are placed
at the centroid of the basin. You can view any of the computed parameters by:

1. Select the Display Options from the Display menu.

2. Select the Drainage tab.

3. Examine all of the different parameters. Tum on Basin slope and
Average overlandflow.

4. Select the OK button.

•

•
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Text showing these values, in addition to the area and id, now appears at the
basin centroid. When many attributes are displayed, or for larger models, it is
sometimes convenient to relocate the display of text attributes.

I. Select the Place Basin Labels tooltiU

2. Click inside of one of the basins and while holding the mouse button
down, drag the cursor to a region outside of the TIN but relatively
close to the selected basin and release the mouse button.

3. Select the Refresh command from the Display menu.

The label moves to the location where you let up on the mouse button and an
arrow from this point to the location where you first clicked inside the basin is
drawn. If you want to place the label in a different position (or have the arrow
point to a different location inside the basin) repeat the process.

Adding Annotations to a Project

Annotations, including text, lines (with or without arrows) and rectangles and
ellipses (filled or outlined). This section of the tutorial could be part of any or
all of the tutorials but is included here to highlight the use of the annotation
tools.

1. Switch to the Map module

r'-'
2. Select the create text tool i.

3. Click on any point near the boundary of the defined watershed. A
dialog will appear which allows you to specify the text string, the
color and the font. Type "Jones Canyon Basin" in the text edit field
and change the color to blue.

4. Select the OK button.

If the text did not appear where you want, or if you would like to move it after
it has been created you can do the following:

1. Select the select drawing object tool II.
2. Click on the text. It will be outlined with a box.

3. Click anywhere in the box and while holding down the cursor drag the
text to a new location.

I

4. Select the create line tool I
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s. Click on a point that is near the text and then double-click on a point
in the center of the brown (upper) basin.

6. Select the select drawing object tool ~.

7. Double-click somewhere along the newly created line. This is
equivalent to clicking once on the line and then choosing the attributes
command as was done with the rectangle. Double-clicking to change
attributes can be done with any of the drawing object .

8. Change the line arrowhead attributes so that an arrow is placed at the
end.

9. Change any other attributes you wish and select the OK button.

Your dispiay should look similar to Figure 8-4. Try adding other annotations
and experiment with the different options available to each drawing object.

•

Figure 8-4 Annotations for Jones Canyon Watershed.

•

•
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Conclusions

In this tutorial you have learned how to use images in conjunction with OEM
and feature object data to define a TIN that can be used for basin delineation.
You have also learned how to use annotations to "dress" up the final display of
any project.
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Supplementary Excerise for Basin Delineation using TINs-Session 7

This exercise will give you additional practice at creating a watershed frolll background elevation c1ata and a Illap
Ii Ie.

All files lor this exercise are located in the Supplilllentary 7 directory.

•

I. Spanish Fork Canyon

a) Import the following USGS OEM files:

wallsrdg.dem

bridal.dem

b) Read in the following map file:

sforig.map (if you created this In the Map supplementary exercise
then you may wish to use your own map file) .

c) Create a TIN from the map and OEM file. you may wish to redistribute the vertices first.

d) Eliminate pits or any other TIN anomaly.

e) Add at least two additional outlets to the stream.

f) Delineate the watershed.

g) Correct any split flow problems.

h) Refine Boundaries

i) Compute basin data.

j) Save the tin as mysf.tin

Delineate the watershed.

Correct any split flow problems.

Refine Boundaries

Compute basin data.

Save the TIN as myjord.tin

2. Jordanelle

a) Import the foIIowing USGS OEM files:

slc_e.dem

slc_w.dem

Read in the foIIowing map file:

jordanel.map

Create a TIN from the map and OEM file, you may wish to redistribute the vertices first.

Eliminate pits or any other TIN anomalies.

Add additional outlets to the stream.

b)

c)

d)

e)

f)

g)

• h)

i)

j)
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Mapping G'~S Layers

• Drainage Coverage is primary'la)J. r in WMS

• Additional Coverages used to map " utes
- Land Use

- Soil

- Rainfall

- Time of Travel (lines rather than polygons)

• Some coverages allow use of either vector
raster data

-...._-...- -..---...--
MapOv~lay

•
Weighted Average Predominant



Computati-on Step

• If gridded data are used the grit!
determines the computation step

• If vector (coverage) data are used yo
specify the computation time step
- Polygons of soil, land used, etc. are rasterize

(gridded) into grid cells of the specified step

,._-_._.__._----------------,._----
---.,

Rasteri~~olygons

•

•

• Small Cell Size
- More accurate

- Longer to compute

• Large Cell Size
- Less accurate

- Faster to compute

• Find right balance

•



•

•

•

<..~

• Composite Curve Numbers

• Runoff coefficients

• Time of Travel for computing tc and

-----.-._-
"'-

The NRDS.,~CS) Curve
Number'( N)

• Much has been written
- many supporters

- just as many opponents

• The fact is, it is commonly used and co
up time and time again with different
models
- HEC-l TR-20 TR-55, ,



...........

How are C·N·~s Derived
"

• Based on two physical chara~ll'.
- hydrologic soil type

-land use

• A matrix of CN numbers based on thes
two factors is used to determine the most
appropriate value for a basin

• Large CN values correspond to high runoff

Hydrologic S'OIt{~l?SSificationS

• A - high infiltration rates
• .30 - .45 in/hr (sands, deep loess, aggre

• B - moderate infiltration rates
•.15 - .30 in/hr (shallow loess and sandy loams

• C - slow infiltration rates
•.05 - .15 in/hr (clay loams, low organics, high cla

• D - very slow infiltration rates
.0.0 - .05 in/hr (high water table, clay layer near surf

•

•

•



•

•

•

......

• The type of land use affects ho",,
"held" on the land surface until it
transpire, evaporate, or infiltrate

• Impervious areas are often treated
separately

Fully devcloped urban - POOl" 68 79

Fully devcloped urban - Good 39 6I
Pasture, grassland, or range - Poor 68 79

Pasturc, grassland, or range - Fair 49 69
Pasture, grassland, or range - Good 39 6I

Meadow 30 58

Wood-grass combination - orchard - POOl" 57 73
Wood-grass combination· orchard· Fair 43 65

Wood-grass combination· orchard - Good 32 58



Composite'C"un(e Numbers
""" "t

• Watersheds can never be char~t ized by a
single value for CN
- you should try to subdivide the watersh

boundaries that are hydrologically similar

• Area weighted averaging techniques can
used to develop a composite curve numben

Aut~~Gomposite eN
Calculations"i WMS

• Data defined through coverage
- hydrologic soil type

-land use

- table relating the two

• Computations slightly different for TIN,
DEM, or Feature Object based watersheds

•

•

•
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•
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Computatj-on.~ for Feature
Object Based Watersheds

• Finds the land use coverage or . - .

• Finds the soil type coverage or gri

• Computing the Composite CN-
- For each basin polygon, a temporary grid i

created.

- For each point in this grid, WMS computes th
CN based on the soil type ill (0 = A, 1 = B, 2
C, 3 = D) and land use ill at this point.

.. _.._._-----

Computations for Feature
....."

Object Based-"'Vatersheds
(Continue

• Composite CN Equation
n

LCNixA,
CN =~is:-l__

A

- n = The number of grid cells inside the basin.

- CNi =CN for a grid cell inside the basin.

- Ai = The area of the ith grid cell inside the basin.

- A = The area of the basin.



Computations..Jor OEM Based
Watersheds

'.

• DEM-based watersheds use th'~
method as feature object-based wa

• A soil type coverage or grid is requir

• A land use coverage or grid is required.

----._-- ._-----.-.--.'...............

ComputatTo~naJor TIN Based
Watersl1 s

• Finds the land use coverage or .

• Finds the soil type coverage or gri

• Land use and soil type values are aSSl
to each triangle based on land use
grid/coverage and soil type grid/coverag
data

• The Composite CN is computed for each
basin

•

•

•



•

•

•

·ComputaTions,.for TIN Based
Watersheds (CQJ)tinued)

• Composite CN Equation

n

ICNixAi
CN = -,-i=-=--I__

A

- n = The number of triangles inside the basin.

- CN j = CN for a triangle inside the basin.

- Ai = Area of the ith triangle inside the basin.

- A = The area of the basin.

---- --.-.-.... ---......,.
~-

Hydrologi~~'Soit Coverage



IX''' .
l'''~ ....f\vrr-;--,:..~

"--- -....-........
........

......"
Composite"GN Values

•

•

•
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•

. .

Steps for C.Q.,mputing the
Composite C'N' i.[l WMS

' ...~
• Delineate a watershed model "'~,,,,

- Feature Objects, DEMs, or TINs

• Read in a soil type coverage or grid

• Read in a land use coverage or grid

• Read in a table relating land use and soil
type to curve number

• Compute the composite curve number

-_._.~---._- -.~---~

....-
Consideralfc)A$" for Computing

the Composite'" in WMS
• The land use and soil type data sho cover the

entire watershed model. If it does not,
CN's may be computed for some basins.

• When computing CN's, WMS uses data fro
land use coverage/grid as an ill. The data fro
soil type coverage/grid are used directly to
determine the soil type (O=type A, 1=type B, 2=
type C, and 3= type D)



•
Auto'mating Green-Ampt

Calculatio·ns·.jn WMS
...

• Data defined through coverag~

- Soil type ID's

- Land use ID's

- Table requirements:
• Table relating soil type lD to XKSAT, RTlMP,

% Effective values.

• Table relating land use to la' RTlMP, and Percent
Vegetation values.

• Computations slightly different for TIN,
DEM, or Feature Object based watersheds

•

•

ID 1 lO<SAT I lUIif' I!'ct'. EffeetlvelSoIl Description·
-1--1-.-1 1----
3; 10.58., I~;oo· 10.00. l~tho-Carrlzo-llot>lpo CClOOPlex
S 10.$2 150.00. 10.00' I~IZO CClOOPlex
8 10.9S~ 150.00 10.00 .. 1~lzo. cobbIy~ 10lII0 .
10 10.94 . 150.00 10.00· . IIlrloa-C.vT1zo CClOOPlex. 1-5% SloPes
13. 10.01 150.00 10.00 ICaref......Beardsley CClOOPlex
22 10.~ . 150.00 10.00. . IContIIlll clay 10-
24 10.02 . 150.00 10.00 lcontlnental clay 10lll0. 0-3% Slopes

----..

A~~~~ali~Green-AmPt
calCulationSl~S

ID I III I RTIIf' IPercent Yog.ILand Use Description
-1-1--1 1-----
76 10.300 115.00 150.00 11.011 Ilonlty Residential
77 10.250- 130.00 150.00 IHed1.. Density Residential
80 10.300.115.00 150.00' .' IPlbllc and ll>as1-f'lbllc
82 10.150 155.00. 1$0.00 . IRatalve--clal
as 10.250 145.00 150.00 - .. IYacant

• Land use/Soil
Type table ID's
and land use
coverage/grid
ID's should
match.
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•

•

"-".

Steps for-Computing Green-
.....

Ampt pararrl"ete.rs in WMS
• Delineate a watershed mode

• Read in a soil type coverage or

• Read in a land use coverage or grid

• Read in two tables:
• Table relating soil type ill to XKSAT, RTIMP,

% Effective values.

• Table relating land use to la' RTIMP, and Percent
Vegetation values.

• Compute the Green-Ampt parameters

----- ---------------._----
~

Lag Time and"Tc Calculations



-'--.

Lag Time and"'Tc"Calculations
"'"

-~---._--..~-- .-...............

Steps for'1)0tlJPuting Travel
'"Time

• Delineate a watershed

• Create a Time Computation Cover

• Defme separate arcs within a basin
representing different flow segment typ

• Assign an equation to each arc

• Define required parameters and compute
travel time

• Sum arc travel times within a basin

•

•

•
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CHAPTER

Computing Curve Numbers

15

•
Estimated Time: 45 minutes.

One of the most important parameters to compute when running a hydrologic
simulation is the curve number or runoff coefficient for a basin. Besides being
one of the most sensitive parameters, the curve number is also one of the most
difficult parameters to compute. Fortunately, WMS has tools that make
computing curve numbers for a basin a simple task.

This tutorial will outline the different methods that can be used to compute
composite curve numbers for delineated drainage basins and sub-basins. First,
curve numbers will be computed for a drainage coverage using a land use grid
and a soil type grid. Next, curve numbers will be computed for a drainage
coverage using a land use polygon coverage and a soil type grid. Finally,
curve numbers will be generated for a TIN using a land use polygon coverage
and a soil type polygon coverage.

In addition to computing composite curve numbers, WMS also computes
composite runoff coefficients for delineated basins and sub-basins. The final
section of this tutorial will show how composite runoff coefficients can be
computed for a drainage coverage using gridded soil data.

•
15.1 Computing Composite Curve Numbers

In this tutorial, you will learn how to compute composite curve numbers using
several different methods. The topics covered include the following:

• Reading in a land use grid.
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• Reading in a soil type grid.

• Reading in and defining sub-basins in a drainage coverage.

• Importing a land use table.

• Computing curve numbers for a drainage coverage.

• Reading in a land use polygon shapefile.

• Computing curve numbers for a drainage coverage using a land use
polygon coverage and a soil type grid.

• Reading in a soil type polygon shapefile.

• Reading in a TIN with defined sub-basins.

• Computing curve numbers for a TIN using a land use polygon
coverage and a soil type polygon coverage.

•

15.2

15.3

Reading a Land Use Grid

ArclInfo and GRASS ASCII grids can be read into WMS. These grids can
either represent land use or soil type. The first step in computing composite
curve numbers for a drainage coverage is to read in a land use grid:

1. Select New from the File menu.

2. Confirm that you want to delete everything.

3. Select the Import command from the File menu.

4. Select the Gridded Attributes->WMS Attributes option and select the
OK button.

5. Select the Land use option for the Mask.

6. Select Arc/Info for the file type, and select the OK button.

7. Select and open "asplugrd.asc". Wait a few seconds while the land
use grid is being displayed on your screen.

Reading in a Soil Type Grid

The next step is to read in a soil type grid. Soil type grids in ArclInfo or
GRASS ASCII format can be read into WMS. In this section, you will read in

•

•
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•

•

15.4

15.5
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an ArclInfo ASCII soil type grid prepared from polygon data for the Aspen
Grove watershed.

I. Select the Import command from the File menu.

2. Select the Gridded Attributes-> WMS Attributes option and select the
OK button.

3. Select the Soil type option.

4. Select Arc/Info for the file type, and select the OK button.

5. Find and open "aspsogrd.asc". Wait a few seconds while the soil type
grid is being displayed on your screen.

Reading in and Defining Sub-basins in a Drainage Coverage

The next step is to define your model or read in an existing model.

1. Select the Open command from the File menu.

2. Type "*.sup" in the file name window so only WMS super files are
shown. Select and open "aspencn.sup".

Importing a Land Use Table

Next, you will import a land use table. This land use table relates land use and
soil type to curve number values. You have already read in a land use grid, a
soil type grid, and a drainage basin model. This table, relating land use and
soil type to actual curve number values, is the final piece of the puzzle to
compute curve numbers for each basin.

1. Select the Hydrologic Modeling module icon j'

2. Select the Compute RunoffCoeff/CN... command from the Calculators
menu.

3. Select the Import button.

4. Find and open "scstut.tbl". Notice that the table appears in the
Mapping text window after it is imported.



15-4 WMS Tutorials

15.6

15.7

Computing Curve Numbers for a Drainage Coverage

The final step is to compute the curve numbers for the drainage coverage.
This step is simple since WMS does this automatically. As an overview, the
following data are required to compute composite curve numbers for a
drainage coverage:

• A drainage coverage with outlet points and sub-basins defined.

• A land use grid or a land use polygon coverage.

• A soil type grid or a soil type polygon coverage.

• A land use table relating land use and soil type to curve number.

Now do the following:

I. Insure that SCS Curve numbers is selected for the computation type.
For both soil type and land use the default option of using a grid for
computation should be selected.

2. Select the OK button.

Curve numbers will be computed and displayed for each of the basins.

Reading in a Land Use Polygon Shapefile

Now that you have computed curve numbers for the Aspen Grove sub-basins
using a land use and soil type grid, you will compute curve numbers using a
land use coverage and a soil type grid. To do this, you must first create a new
land use coverage and read in a land use shapefile:

11. Select the Map module icon ~BI.

12. Select the Coverages... command from the Feature Objects menu.

13. Select the New button in the Coverages window.

14. Change the name of the coverage to Land Use and change the
coverage's Attribute set to Land Use.

15. Select the OK button in the Coverages window.

16. Select the Import... command from the File menu.

•

•

17. Select the Shape file->Feature objects option and select the OK •
button.
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18. In the Import Shapejile Data window, select the polygons file browser
button.

19. Find and open "aspenlu.shp ".

20. In the polygon attribute text window, notice that the LV_CODE
database field is automatically mapped to the Land use attribute in
WMS. This occurred only because the attribute name in the land use
file was LU_CODE. If the attribute name is anything other than
LU_CODE it can still be assigned to the WMS Land Use variable
manually using the Attribute mapping... dialog.

2J. Select OK and wait a few seconds while the land use shapefile for the
Aspen Grove watershed is read in and displayed.

Computing Curve Numbers for a Drainage Coverage Using
a Land Use Polygon Coverage and a Soil Type Grid

Now that you have imported a land use polygon coverage, you are ready to
compute composite curve numbers for your drainage coverage using the land
use polygon coverage you just imported and the soil type grid.

1. Again select the Coverages... command from the Feature Objects
menu.

2. Select the Drainage coverage in the window displaying all the
coverages and make it the active coverage by selecting the Active
button. Select OK in the coverages window.

3. Select the Hydrologic Modeling module iconli1l.

4. Select the Compute RunoffCoeff/CN... command from the Calculators
menu.

5. Select the option to compute SCS Curve numbers using a soil type
grid and a land use coverage (You will have to select the Use a land
use coverage for determining land use option).

6. Enter a Drainage Coverage Computation step of 50.0 (Meters in this
case).

7. Select the OK button in the Compute Composite Runoff
CoefficientS/CN's window. The computation may take anywhere from
a minute to several minutes, depending on the speed of your computer.
The computed curve numbers using this method should match the
previously computed curve numbers.
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When the curve number is computed for the drainage coverage, each polygon •
in the drainage coverage is visited. For each polygon, a temporary grid is
created around the polygon with a cell width equal to the user-specified
computation step. Each cell in this temporary grid is visited. For each
temporary grid cell that is inside a basin, the curve number is computed (if it
can be). Thus, the smaller the computation step, the longer WMS will take to
compute the curve numbers for the basins. This computation step should be
about equal to the smallest soil type or land use grid cell size (depending on
whether you are using a soil type or land use grid to compute the composite
curve number).

15.9 Reading in a Soil Type Polygon Shapefile

Besides being able to compute curve numbers for drainage coverages, WMS
also computes curve numbers for TINs in much the same way. In this section,
you will compute curve numbers for the same basins in a TIN-based model of
the Aspen Grove watershed. Also, instead of using grids to compute the
composite curve numbers for this model, you will import a soil type polygon
shapefile and use a soil type polygon coverage and a land use polygon
coverage.

1. Select the Map module icon j:J.

2. Select the Coverages... command from the Feature Objects menu.

3. Select the New button in the Coverages window.

4. Change the name of the coverage to Soil Type and change the
coverage's Attribute set to Soil Type.

5. Select the "Drainage coverage" and select the Delete button. Select
OK when prompted for confirmation.

6. Select the OK button in the Coverages window.

7. Select the Import... command from the File menu.

8. Select the Shape jile->Feature objects option and select the OK
button.

9. In the Import Shapejile Data window, select the polygon file browser
button.

10. Select and open "aspenso.shp".

•

11. In the polygon attribute text window, notice that the HYDGRP •
database field is automatically mapped to the SCS soil type attribute in
WMS. Since we want to map HYDGRP to WMS SCS soil type and
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there is nothing else to map, select the OK button. If your database
field for hydrologic soil group is named something other than
HYDGR? then you can manually map it to the WMS parameter by
selecting the Attribute mapping button and defini ng which database
field represents hydrologic soil group.

12. Select OK and wait a few seconds while the soil type shapefile for the
Aspen Grove watershed is read in and displayed.

15.10 Reading in a TIN with Defined Sub-basins

Now that you have a land use polygon coverage defined and a soil type
polygon coverage defined, you can import a TIN containing defined sub
basins. Then, you can compute the composite curve numbers for your TIN
using the land use and soil type polygon coverages.

1. Select the TIN module icon ~.

2. Select the Open... command from the File menu.

3. Select and open "aspentin.sup" .

15.11 Computing Curve Numbers for a TIN Using a Land Use
Polygon Coverage and a Soil Type Polygon Coverage

In this section, you will compute composite curve numbers for your TIN file
using a land use polygon coverage and a soil type polygon coverage.

1. Select the Display Options command from the Display menu.

2. Select the Drainage tab.

3. Tum on the display of Basin CN's.

4. Select OK.

5. Select the Tree module icon'

6. Select the Compute Runofj Coefj/CN. .. command from the Calculators
menu.

7. Select the option to compute SCS Curve numbers using a soil type
coverage and a land use coverage (You will have to select the Use a
soil type coverage for determining soil type and the Use a land use
coverage for determining land use options).
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8. You do not need to enter a computation step when computing the
curve number for a TIN. Just leave this value alone.

9. Select the Import button.

10. Find and open "scstut.tbl".

II. Select the OK button in the Compute Composite Runoff
Coefficients/CN's window. The computation may take anywhere from
a few seconds to several minutes, depending on the speed of your
computer. The computed curve numbers using this method are slightly
different than the curve numbers computed for the drainage coverage.
This is because the shape of the basins are also slightly different.

15.12 Computing Composite Runoff Coefficients for a Drainage
Coverage Using a Soil Type Grid

Besides being able to compute composite curve numbers, you can also
compute composite runoff coefficients in WMS. These runoff coefficients can
be computed from a soil type grid and can be used in a Rational method
simulation.

I. Select the New command from the File menu. Select OK when
prompted if you want to delete everything.

2. Select the Map module icon ;~.

3. Select the Open... command from the File menu.

4. Find and open "aspencn.sup".

5. Select the Import... command from the File menu.

6. Select the Gridded Attributes->WMS Attributes option and select the
OK button.

7. Select the Soil type option for the mask.

8. Select Arc/Info for the file type, and select the OK button.

9. Select and open "aspsogrd.asc".

1O. Select the Tree module icon .IIf.
11. Select the Compute Runoff Coeff/CN. .. command from the Calculators

menu.

12. Select the Rational method runoff coefficients computation option.

•

•

•



•

•

•

15.13

Computing Curve Numbers 15-9

13. Select the Import button in the Compute Composite Runoff
Coefficients/CN's window.

14. Find and open "soilrype.tbl". Notice that the table appears in the
Compute Composite Runoff Coefficients/CN's window after it is
imported.

15. For soil type, select the option to Use a soil type grid for determining
soil type.

16. Select the OK button.

You have now computed the runoff coefficients for your watershed. The
computed runoff coefficient values can be used in the Rational Method to
determine watershed runoff. You can view these values by doing the
following:

I. Select any of the square basin icons in the Hydrologic Modeling Tree
Window.

2. Select the Run Simulation command from the Rational menu.

You should see the composite runoff coefficient for this basin. You can view
the values of the other basins by selecting their respective basin icons.

Conclusions

This concludes the Curve number computation tutorial. You are encouraged
to experiment with all of the commands explained in this section until you feel
comfortable with the tools available to you for computing curve numbers.

In this section, you have learned how to:

• Compute curve numbers (or runoff coefficients) for drainage
coverages and TINs using:

• soil coverages or soil grids

• land use coverages or land use grids

• tables relating land use to CN or soil type to runoff coefficient.
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CHAPTER 10

Time of Concentration Calculations

Estimated Time: 30 minutes.

Travel times (time of concentration, lag time, and travel time along a routing
reach) are critical to performing analysis with any of the hydrologic models.
In this tutorial you will learn about the two different ways WMS can be used
to compute time of concentration for a TR-55 simulation (lag times are
computed in the same way):

• Runoff distances and slopes for each basin are automatically computed
whenever you create watershed models from TINs or DEMS and compute
basin data. These values can then be used in one of several available
equations in WMS to compute lag time or time of concentration.

• If you want to have a little more control (and documentation) over the lag
time or time of concentration, you will use a time computation coverage to
define critical flow paths. Time computation coverages contain flow path
arc(s) for each sub-basin. An equation to estimate travel time is assigned
to each arc and the time of concentration (or lag time) is the sum of the
travel times of all arcs within a basin. Lengths are taken from the length
of the arc and slopes derived if a TIN or DEM are present.

In this tutorial you will compute the time of concentration for the two sub
basins and the travel time between outlet points in the watershed shown below.
You will use the TR-55 library of equations, but you could just as easily use
one of the other pre-defined equations, or enter your own equation.
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A=O.10miI\2

•

Figure 10-1 American Fork Watershed

10.1 Launching WMS

If you haven't already, start WMS by double-clicking on the WMS icon on the
desktop or choosing WMS 6.0 from the Start menu.

10.2 Reading a TIN File

You will first read in a TIN that has already been processed and used to
delineate two sub-basins.

I. Select the TINs module.iJ.

2. Select the Open command from the File menu.

3. Find and Open the file named aftr55.tin. By default it should be in the
tutorial directory.

4. Select the Compute Basin Data command from the Drainage menu.

5. Select Feet for model units, square miles for Basin Areas, and Feet for
Distances.

6. If the display options for triangles and vertices are on tum them off by
selecting the Display Options from the Display menu and toggling off
the check box in front of the vertices and triangles display options.

7. Select OK.

Your display should now show the basin boundaries and stream network.

•

•
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Defining Flow Path Arcs

Flow paths can automatically be traced across a TIN (or OEM with flow
directions computed) using the flowpath tool. You can take advantage of this
functionality in WMS to set up your flow path segments.

I. Select the Map module ..1:1.

2. Select the Coverages command from the Feature Objects menu.

3. Set the default coverage type to Time Computation in the Attribute Set
drop down combo box.

4. Confirm that you want to change coverage types by selecting OK.

5. Select the Create Feature Points tool 21.
6. Create feature points at the two locations marked by an X in the figure

below. Be sure that there is one point inside of each basin boundary.

r x

_--"'T"""--:----:-" x

I
A=O. 12 mi"2

Figure 10-2 Starting Locations for Time of Concentration Arcs.

These points represent the furthest point from the outlet for their respective
basins. Now feature arcs will be created from these points to the outlet by
following the flow path.

1. Select the Select Feature Point/Node tool II.
2. Select both feature points just created. Use the shift key to multi

select (the last point you just created will likely already be selected).

3. Select the Node->Flow Arc command from the Feature Objects menu.

4. Choose the Create multiple arcs command.

5. Select OK.
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The Create multiple arcs option will cause WMS to break the flow path arcs
once they enter the stream defined on the TIN. The TR-55 method (others are
similar as well) use three different flow segments to compute time of
concentration: sheet flow (up to 300 feet), shallow concentrated flow, and
open channel flow. Since WMS will automatically break the arcs between
overland and channel flow two of three segments will already be defined. You
will need to separate the sheet flow from the shallow concentrated flow before
setting up the equations.

I. Select the Select Feature Vertex tool AJ.

2. The figure below identifies locations approximately 200-300 feet
downstream from the beginning of the flow path arc. Select one of
these vertices.

3. Select the Vertex<->Node command in the Feature Objects menu.

4. Repeat for the other flow arc (alternatively you could multi-select the
two vertices and convert them to nodes at the same time).

Select Here _-----:::.,,-~'7'

A=O.12 miA2
A=O.10 mjA2

Figure 10-3 Locations to Break Sheet Flow Segments.

You should now have three arc segments for each basin. These arcs will be
used to compute a time of concentration for the TR-55 analysis. However we
will also want to compute a travel time for the flow from the upper basin to the
lower basin. This will require a flow path segment between the upstream
outlet and the lower outlet. The flow path arcs from the lower basin already
include flow for part of this distance, but there remains a segment for which no
flow path arc exists.

1. Select the Streams->Flow Arcs command from the Feature Objects
menu.

•

•

This will create an arc that joins the outlet of the upper basin with the flow
path segment already created for the lower basin. Where the flow path •
segments meet the arc from the lower basin is split into two. This will leave
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four arcs to define time of concentration for the lower basin (two will actually
be in the stream). The arc just created, while in the lower basin, will not be
used when computing time of concentration.

You have used the Node->Flow Arcs and Streams->Flow Arcs commands to
automatically generate the flow path segments from flow on a TIN. Similarly
arcs could have been created from flow on a OEM with flow directions, or

they could be created manually using the create arc tool D. When defining
arcs manually you must keep in mind that, just like stream arcs in the drainage
coverage, direction is important. Time computation arcs should be defined
from downstream to upstream.

Assigning Equations to Time Computation Arcs

With the flow path segments defined you are now ready to assign equations
that will be used to determine a travel time for the arc. Use the following
figure as a guide while defining the equations.

•
7

r
8

4

3

2

•

Figure 10-4 Time Computation Arcs.

1. Select the Select Arc tool g.

2. Select the arc labeled 1.

3. Select the Attributes command from the Feature Objects menu.

By default the arc will be a TR-55 sheet flow equation arc, so all you need to
do is define the overland manning's roughness coefficient and the 2yr-24hr
rainfall. Length and slope will already be defaulted from the selected arc.

1. Click on the "n Mannings" line in the Variables text window.

2. Enter a value of 0.24 in the Variable Value edit window.
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3. Click on the rainfall line in the Variables text window.

4. Enter a value of 1.1.

You should notice in the Instructions/Results window that you are told what
variables need to be defined before a travel time can be computed. Once you
have entered all the necessary values, this same window reports the travel time
for this arc. In this way, you can compute travel time for any arc segment no
matter what the application is.

I. Select OK.

2. Repeat the previous steps for the arc labeled 4. Use a Manning's
roughness of 0.15 and a rainfall value of 1.1.

You have now defined equations for the overland sheet flow segments in each
basin and are ready to define the next two arc segments as shallow
concentrated flow.

I. Select the arc labeled 2.

2. Select the Attributes command in the Feature Objects menu (note you
could have double-clicked on the arc labeled 2 to bring up this same
dialog).

3. Change the arc type to TR-55 shallow conc eqn.

4. Click on the paved line in the Variables text window.

5. Enter "no" in the Variable Value edit window.

6. Select OK.

7. Repeat for the arc labeled 5, using the same arc type. In this case set
the paved value to yes.

The remaining arcs will be defined as open channel flow arcs.

1. Select the arc labeled 3.

2. Select the Attributes command in the Feature Objects menu.

3. Change the arc type to TR-55 Open channel eqn.

4. Click on the Manning's n line.

5. Enter a value 0.016 in the Variable Value edit window.

6. Select the hydraulic radius line in the Variables window.

•

•

•
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7. Select the Hydraulic Radius button to open up the channel calculator
so that the hydraulic radius can be computed from rough estimates.

8. Change the Channel type to Rectangular.

9. Enter a longitudinal slope of 0.015.

10. Enter a width of 3.0.

II. Make sure the Enter depth option is chosen and enter a depth of 0.33
(an approximated depth since we do not know what the flow is at this
point).

12. Select the Calculate button.

13. Select OK.

You have now defined the necessary parameters for computing travel time
using the TR-55 open channel flow (Manning's) equation. Repeat for the arcs
labeled 6, 7, and 8 using the following values:

1. For arc 6 use a Manning's n of 0.016, and a hydraulic radius of 0.35.

2. For arc 7 use a Manning's n of 0.016, and a hydraulic radius of OAI .

3. For arc 8 use a Manning's n of 0.016, and a hydraulic radius of 0.38.

If you wish you can continue to experiment with the channel calculator to
compute the hydraulic radius rather than entering the given values.

You now have defined equations and variable values for each flow path
segment. You can change these equations, variables, add new flow path
segments, etc. in order to determine the best flow paths and most appropriate
equations for each basin. In other words, this process is subjective and it may
take a few iterations to get the best value.

Using the Time Computation Arcs to Compute Time of
Concentration for a TR-55 Simulation

Before assigning time of concentrations to each basin you need to decide
which model you want to use. In this tutorial you will be running TR-55, but
WMS includes similar links to use of the time computation arcs in the TR-20
basin data dialog, the HEC-I Unit Hydrograph method dialog, and the
Rational Method dialog. In addition, you can view the travel time for any arc
as demonstrated in the previous section and then use/enter the value for a hand
calculation or some other model.

1. Select the Hydrologic Modeling module :ill.
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2. Select the Run Simulation command from the TR-55 menu.

3. Select the Initialize TR-55 data button (memory to store
variables is not allocated in WMS until you initialize a
simulation).

4. Select the Select Basin tool ~.

S. Select the upper basin.

6. Change the Curve Number to 70.

7. Enter a Rainfall value of l.S.

8. Change the Rainfall distribution to Type II.

TR-55
TR-SS

•

9. Select the Compute Tc - Map Data button. You will see the three arcs
that time computation arcs that are in the basin.

10. You can create a detailed report as a text file if you want by selecting
the Export Data or Copy to Clipboard buttons.

11. Select Done and the sum of the travel times for these arcs will be used
as the time of concentration for this basin.

Note that you could bring up the time computation attributes dialog and
change the equation or any of the equation variables by selecting theEdit Arcs
button. Now you will set up the TR-55 basin data for the lower basin.

As a comparison you will now compute the time of concentration using the
pre-computed runoff distance and slope parameters and one of the equations
defined in WMS. To see the values that WMS has computed you will need to
modify the display options.

1. Select the Done button.

2. Select the Display Options... command from the Display menu.

3. Select the Drainage tab.

4. Toggle on Maxflow distance and Maxflow slope.

5. Select OK.

Notice that the longest flow path distance within a basin is displayed for each
basin as well as the slope along that flow path. These are the variables that
will be used in a separate equation to determine the time of concentration.

I. Once again select the upper basin.

•

•
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2. Select the Run Simulation command from the TR-55 menu.

3. Note that the time of concentration is currently about .57 hours and
then select the Compute TC - Basin Data button.

In the Basin Time Computation dialog you can pick from one of several lag
time or time of concentration equations that are pre-programmed in WMS (see
the reference manual for a complete description of these equations). You can
also create your own equation from the computed variables, or parameters that
you define yourself. In this tutorial we will use the Kerby equation for time of
concentration, but you may wish to experiment on your own with some of the
other equations or by making your own.

I. Select the Time of Concentration option from the Computation type
drop-down box.

2. Choose the Kerby method for overland flow equation in the drop-down
list of equations. Notice that all variables needed for this equation are
defined and so the time of concentration is reported in the text window
at the top of the dialog.

3. Select OK.

You should notice that the time of concentration is very nearly the same as
before (.57 hours).

At this point you might be wondering why you would ever want to create a
time computation coverage and go through the effort of defining travel time
arcs and assign equations to each if the same value can be determined using
the parameters already computed from a TIN or DEM?

1. Select the Compute TC - Basin Data button again.

2. Select the Kirpich method for overLand flow on bare earth equation.

3. Select OK.

You should now see that the computed time of concentration is less than half
of what it was previously. You should now set the time of concentration back
to the one originally computed by the flow arc method. To do this:

1. Select the Compute Tc - Map Data button.

2. Select Done.

The lesson here is the equations using Basin Data work great if you are
confident the equation represents the same kind of land surface you are dealing
with. If not, you are likely better off to define equations along separate flow
path segments using the Map Data. Of course, in either case you can
customize the equations to suit your own needs.



10-10 WMS Tutorials

I. Select the lower basin from the graphics window.

2. Change the Curve Number to 80.

3. Enter a Rainfall value of 1.5.

4. Change the Rainfall distribution to Type II.

5. Select the Compute Tc - Map button.

This time you will notice that there are more than three arcs. This is because
one of the flow path arcs (the one labeled 8 above) will be used to compute
travel time between outlets but still is within the lower basin. Notice that
WMS defaults it's status to inactive. WMS will try to make the best choice of
arcs that are used for time of concentration for a basin, but at times you may
need to set the active/inactive status on your own.

6. Select Done.

•

10.6

10.7

Using the Time Computation Arcs to Compute the Travel
Time Between Outlet Points

Besides using time computation arcs for computing time of concentration or •
lag time for a basin, you can also use them to compute the routing travel time
of a channel.

1. Select the Select Outlet tool ~.

2. Select the upstream outlet (the outlet to the upper basin).

3. Select the Compute travel time... button.

4. Make sure that both of the downstream arcs are active.

5. Note the time of concentration for these arcs.

6. Select Done; the time of concentration from the arcs should now
appear in the Travel time box.

More TR-55

While you were entering the data for each of the two basins you should have
noticed that instructions are given in the TR-55 data window to let you know
what must be entered before a peak Q can be determined. Once you did enter
all of the data the peak Q was computed and displayed in this same window. •
You can also get help for anything listed in this window.



•

•

•

10.8

Time of Concentration Calculations 10-11

I. Select the Select Basin tool .BJ.

2. Select the upper basin.

3. Select the line in the TR-55 data window where the peak Q is
displayed.

Notice that the TR-S5 equation for computing peak flow is displayed in the
help window. You can get help for missing data as well.

I. Change the Time of concentration to 0.0.

2. Select the line in the TR-55 data window that instructs you to define a
time of concentration.

ow you are told the units for time of concentration as well as the available
options for determining it.

I. Reenter the time of concentration by typing in the appropriate value,
or if you can't remember use the Compute Tc - Map Data button
again.

2. Select the Compute Hydrograph button.

3. Select the Show Hydrograph Window command from the Display
menu.

4. Click on the hydrograph icon that is displayed by the upper basin.

Conclusions

This completes the tutorial on using the time computation coverage to
compute time of concentration and travel times. In the process you have also
learned about the TR-55 interface. You are encouraged to continue
experimenting with the time computation arcs and the TR-55 options.
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Computing Green-Ampt Parameters

Supplementary Exercise for Computing Curve Numbers-Session 8

In the Curve number tutorial, you learned how to compute curve numbers and runoff coefficients using WMS.
In this supplementary exercise. you will learn how to compute composite Green-ampt parameters for sub
basins using WMS.

Your county is considering switching to the Green-Ampt method for computing watershed losses. This
method is more scientific than the SCS Curve Number method and should provide more accurate results. The
problem with the Green-Ampt method is there's lots of data involved. Fortunately, you have WMS. Your
county has assigned you, the county hydrologist, to write a new county hydrology manual in which the Green
Ampt method is used to compute runoff. Your task is to figure out how to compute Green-Ampt parameters in
WMS and view these parameters.

Once you have computed the Green-Ampt parameters, you can define a HEC-l model and compute a
hydrograph using these Green-Ampt parameters. This hydrograph can than be compared with the real
hydrograph at a gage station in your experimental watershed. After tailoring Green-Ampt parameters to your
county's soil types and land use types, you can gather your data and write your new county hydrology manual.
Your experimental watershed is the Aspen Grove watershed, located near Provo, Utah.

For this exercise, you will need the following files in the supplementary 8 directory:

• aspenlu.shp-An ArcView® shape file containing land use boundaries in your experimental watershed.
A land use ID associated with each polygon is included in this file.

• aspenso.shp-An ArcView® shape file containing soil boundaries for your experimental watershed. A
soil type ID associated with each polygon is included in this file.

• asplugrd.asc-An ArclInfo® ASCII grid file containing land use ID's for your experimental watershed.

• aspsogrd.asc-An ArclInfo® ASCII grid file containing soil type ID's for your experimental watershed.
• greenlu.tbl-A file that relates the land use ID's in the shape files or grid files to the initial loss (IA), the

percent of the basin that is impervious (RTIMP), and the Percent vegetation.
• greenso.tbl-A file that relates the soil type ill's in the shape files or grid files to the Hydraulic

conductivity (XKSAT), the RTIMP value for the soil, and the percent of the basin where the RTIMP
value is effective.

• aspentin.tin-A WMS TIN file containing a model of your experimental watershed.

Here's some helpful steps on how to compute the Green-Ampt parameters for the watershed sub
basins:
1. Read the file aspentin.tin and compute the basin data (the model units are in meters).
2. Import the files aspenlu.shp and aspenso.shp into separate land use and soil type coverages.
3. Import the files aspsogrd.asc and asplugrd.asc. These ArclInfo® ASCII grid files can be read in by

selecting the DEM Mask->DEM Attributes option from the Import conunand in the File menu. Select a
land use mask when importing asplugrd.asc and a soil type mask when importing aspsogrd.asc.

4. After you're done reading in the land use and soil type grids, you may want to turn them off so they are
not displayed (displaying takes a long time). To this, go to the DEMs module and select the Display
Options conunand. Tum off the options to display land use and soil type grids.

5. Go to the Tree module and select the Composite Runoff Coeff/CN conunand from the Calculators menu.
6. Select the option to Compute Green-Ampt parameters.
7. For Land use mapping, import greenlu.tbl. For Soil type mapping, import greenso.tbl.



• First. compute the Green-Ampt parameters using the land use and soil type grids. Enter the Green-Ampt
parameters in the table below (Go to the HEC-I Loss method window to detennine the Green-Ampt for
basins lB, 3B. and4B): •Basin Name IA DTHETA PSIF XKSAT RTIMP

~- -_..._-_....._-------------------- -_.__.__._--_._--_._._-
1B
3B
4B (0.2731) (0.3500) (3.2757) (0.9203) (26.7289)

• Next. compute the Green-Ampt parameters using the land use and soil type coverages. Enter the Green
Ampt parameters in the table below:

Basin Name IA DTHETA PSIF XKSAT RTIMP
.H_•••••• • • __ ••••_·_· ·_. ._. • __•• ••__ • ••__•• ••_ ••__._.__._. ••__._._._ H ••• H···.H. .,_ H ••H •••_. _

lB
3B
4B (0.273 I) (0.3500) (3.2741) (0.9215) (26.7289)

Finally, compute the Green-Ampt parameters using the land use grid and soil type coverage.
Green-Ampt parameters in the table below:

RTIMP

(26.7289)

Enter the

(0.9215)

XKSAT

(3,2741)

PSIF

(0.3500)(0.2731)

Basin Name IA DTHETA
IB
3B
4B

•

Notice that computing Green-Ampt parameters using grids is much faster and yields similar values. The
disadvantage of the grid method is that it uses more of the computer's memory.

•

•
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So What Abo"lJl"a.,.Hydrograph?
",

• Statistical Methods
- regression analysis

• Deterministic
- rainfall characteristics required

- algorithms for determining
losses (excess)

conversion of excess to flood runoff

Interfac'eS'"in WMS
"

•

• Regression
-NFF

• Deterministic
-HEC-l

- TR-20

- TR-55

- Rational



What is a Topq,logic Tree?

• Topologic representation ~fth,~""watershed
- All models in WMS use the Tree"~ oped

from geographic data to access the s
interface

.__._._-------_.._-_._.-.....

...-._- .......
"-'"

• Basins and outlets can be selec
geographic data or the tree

• Trees can be created without geograp
data
- more detail in a later lesson

- additions to trees must be made in the Terrain
Window when a geographic data is present

•

•

•
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NFF

• NFF - National Flood Frequency.Program

• Regional regression equations
- equations created on a state-by-state b

• Compiled into the NFF program
-USGS

-FHWA

-FEMA

.._-------._---

What~~ Regression
EquatiOn?

• Transfers flood characteristics
to ungaged watersheds

• Through a set of characteristic variao
- watershed

- climatic

• Estimates of flood-peak discharges and
estimates of typical flood hydrograph for
specified recurrence intervals



•
How are Equatio,Qs Created?

• State subdivided into "homogel1~pus"

hydrologic regions

• T-year flood-peaks for gaged location
determined using a Pearson Type III
distribution

• Least squares regression analysis used to
relate peak floods to watershed and climati
characteristics

•
----~. -..........._-

-"- ........

Regre~;io~quations
"

•

RQT - T-year rural flood-peak discharge
A - drainage area
S - channel slope
P - mean annual precipitation
a,b,c,d - regression coefficients

• Equations are generally reporte
following form:
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., .

Adding Your:---·Ow.n Equation
,~ .

• Equations only update every 3~'4?,.y" ars

• Your state/area may have a differe
updated equation

• You can place a file named "custnff.eq
WMS directory
- See 14.2.6 and 20.23 of WMS reference for

more information

-----~-.

~_.---.._-.....

. ~"

Basin Characteristics
",



Hydrograph's,·from NFF
"

".
"~

• Typical hydrograph can be c~rilp¥ ed from Q
- An average, not representative of an .cular

rainfall

• Composed of three essential parts:
- Peak discharge

- Basin lag time

- Dimensionless hydrograph ordinates

The NFF Dimensionless
Hydrogr

1.2

0.8

~ 0.8

0.4

0.2

o
8 ~ ~ 2 i 8 ~ ~ 2 i
000 d d ~ ~ ~ ~ ~

lito

•

•

•
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-'"

Applicability---&,,-_~imitations
-"--

~.
• Rural equations should only be used for rural watershedt•.,

• Should not be used in conjunctions with dams/detention pdn:-
• Should use parameter values within the ranges identified by

• Drainage area must always be computed

• Curves for watersheds in two different regions can only be comput
equations for the desired T-year interval. No provision for watershe

• To insure peak discharges do not exceed the max envelope, care must b
choose the maximum flood-region

• No estimates are allowed for the SOO-year peak discharge - it may be less

• Some regions do not hav~ a IOO-year equation - examine frequency plots if
form of extrapolation will be used

• Hydrographs do not accurately account for snowmelt runoff, or watersheds w
typically have a double peak

------ _._-.-._-.-... .

----------.."

How Does NFF-,-Work in WMS?
-',

1 Delineate a watershed
2 Initialize an NFF analysis

3 Define maximum flood-region

4 Select the state and hydrologic region
5 Define any climatic variables

6 Compute peak discharges
7 Generate a hydrograph

- Must defme a basin lag time
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CHAPTER 11

National Flood Frequency Program
(NFF) Interface

Estimated Time: 20 minutes.

The National Flood Frequency program developed by the USGS provides a
quick and easy way of estimating peak flow values and hydrographs at
ungaged sites. This data can be used in the design of bridges and culverts,
flood-control structures, and flood-plain management. It utilizes regression
equations which have been developed for each state. Besides an interface to
the NFF program, WMS can be used to calculate many of the variables used
by the regression equations.

In this tutorial you will use an existing TIN, "rockynff.tin", and the regression
equations for Texas. The TIN allows you to compute basin area and slope,
each used in the Texas regression equations. A TIN is not necessary to use
NFF and you may wish to construct only a tree if you already have values for
your state's equation variables.

11.1 Launching WMS

Before launching WMS, you should have installed WMS on your computer
according to the directions in the WMS Installation Guide. If you have not yet
installed WMS, please do so before continuing.

To launch the PC version of WMS:

Double click on the WMS icon ltMii.
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To launch the Unix version of WMS:

I. Bring up an xterm window.

2. Change to the directory containing the WMS executable.

3. type wms at the command line.

•
11.1.1 Normal Mode Operation

If you have not licensed the digital terrain and map modules you will need to

switch to Demo mode by selecting the Demo Version On command in order to
complete this tutorial.

If you are not licensed to run NFF, you can still run this tutorial to evaluate the
interface, and determine of what value it can be for your work. The demo
tutorial is subject to the following restrictions:

1. Texas is the only state available to test.

11.2

11.3

2. Only the values specified in the tutorial may be used to do actual
computations.

Reading a TIN File

You will first read in a TIN which has already been processed and used to
delineate a single basin.

8. Select the TINs module~

9. Select the Open command from the File menu.

10. Find and Open the ftle named rockynfftin. By default it should be in
the tutorial directory.

Prepare the TIN to Use With NFF

The watershed in rockynfftin has previously been prepared for basin
delineation. However, you must compute basin data in order to use the
geometric parameters in conjunction with NFF.

1. Select Compute Basin Data from the Drainage menu.

2. Set model units to/eet (since the original TIN data is in feet).

3. Set basin areas to square miles.

•

•
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4. Set distances to feet.

5. Select OK.

In order to see the parameters which will be used with the NFF program you
can turn them on for display.

I. Select the Display Options from the Display menu.

2. Select the Drainage tab.

3. Turn on the following toggles: Show units, Basin areas, Basin slopes.

4. Select OK.

Basin attributes are displayed at the centroid of the basin.

Running an NFF Simulation

The geometric data computed from the TIN has automatically been stored with
the NFF data. You can now run a simulation, using the data derived from the
TIN.

1. Select the Hydrologic ModeLing module~

2. Select the SeLect Basin tool .JII.
3. Select the basin icon or anywhere within the basin boundary.

4. Select the Run SimuLation command from the NFF menu.

Demo users will need to select NFF - Read Simulation, and choose
"rockynff.nff', then select NFF - Run Simulation, and Texas will be
automatically loaded.

The NFF dialog appears. The instruction window at the bottom of the dialog
indicates the steps that remain to complete the set up of an NFF simulation.

•

11.4.1 Choosing a State

WMS is linked to a database of state-by-state regression variables which are
used in the NFF program to compute peak flows. This tutorial will focus on
Texas, but if you are not running in demo mode you may wish to return at the
end and test another state.

1. Select the State button.
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2. Scroll through the states until you see Texas and then select it by •

clicking on it.

3. Select OK.

11.4.2 Defining Regions

The regions with defined regression equations are shown. Scroll through them,
and notice the available urban equations. For this tutorial, we will assume that
70% of the study basin is located in Region 5 and 30% in Region 6. (Refer to
region maps for your state in the NFF manual to determine if your basin
overlaps more than one hydrologic region).

I. Select region 5 by clicking on it in the regions list window.

2. Select the button with a right arrow.

3. Now repeat the last two steps for region 6.

The variables required by each region's equations are displayed along with a
defaulted U.S. Maximum Flood Region (the edit field in the upper right
portion of the dialog), as shown on page 16 of the NFF manual.

11.4.3 Assigning Areas to Selected Regions

The total basin area is supplied by the TIN, but you must assign the amount
overlapping each hydrologic region.

1. Select the Assign % Watershed Which Overlaps Regions button.

2. Enter 70 for the percent area for region 5.

3. Enter 30 for the percent area for region 6.

4. Select the Compute Areas From Percents button.

5. Select the OK button.

The area variables are updated with the computed values.

Highlight each of the selected regions and move the mouse over each
variable's edit field. Examine the help window (you may need to relocate the
National Flood Frequency Regression Equations for Texas dialog) to see the
range of values used for each variable in defining the regression equations.

•

•
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11.4.4 Defining Regression Variables

The slope shown on the TIN differs from that defaulted for region 5 because
slopes computed for the TIN are in ftlft, and slope data for the Texas equations
is in ftlmile and has been converted by NFF.

Three of the four required variables are now determined. You may overwrite
any variable values supplied by a TIN if you would like to test your own
values. Original TIN values may be restored using the Restore Values From
TIN button.

I. Select region 6 by clicking on it 1D the Regions overlapped by
watershed text window.

2. Set the Precipitation (labeled with a P) variable for region 6 to be 15.

11.4.5 Computing Peak Discharges

You are now ready to compute flow data. Check the instructions window for
any items overlooked.

1. Select the Compute Peak Discharges button.

Rural peak flows are displayed for the 2 yr - 500 yr storms, along with a
maximum flood envelope computed using the maximum flood region, as
defined in the edit field in the upper right. Predefined standard error is also
shown, and is considered valid provided that variables were within specified
range. If the regions have any equivalent years of data known for the site,
computed peaks can be weighted with the known values. You will be
prompted for weighting if this is possible.

•

11.4.6 Exporting Flow Data

Once flow data is computed it may be exported to a text file in the format
shown in the window, along with pertinent infonnation used in computing the
peak flow values.

1. Select the Export Flow Data button.

2. Locate the directory, and define a name for the file.

3. Select the Save button.

The exported file can be viewed using any word processor.
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11.4.7 Computing a Hydrograph

A dimensionless unit hydrograph can be used to define a hydrograph for any
interval, based on the peak flow. This hydrograph will be based on the peak
discharge and basin lag time.

I. Select the Compute Peak Discharges button.

2. Select a recurrence interval from the window where computed peak
flows are reported (select the line of text containing the recurrence
interval).

3. With the recurrence interval highlighted, select the Compute
Hydrograph button.

4. Select the Auto Lag Time button.

5. Select the Espey Rural Method option from the drop down list for
computing lag time.

6. Select OK.

The computed lag time is shown in the lag time edit field.

1. Select OK.

2. Select the Done button.

A hydrograph icon will appear in the Graphics Window. You can examine the
hydrograph in more detail by:

1. Select the Show Hydrograph Window from the Display menu.

2. Select thehydrograph icon in the Hydrologic Modeling Window.

The hydrograph is displayed and may be manipulated using commands the
Hydrograph menu.

When the hydrograph became selected the basin became unselected. Re-select

the basin by clicking inside the basin using the Select Basin tool ;;11. If you
want to see the computed peak flows again you must select the Compute Peak
Discharges button.

11.4.8 Saving and Reading Simulations

•

•

You may wish to save this NFF simulation containing a state, selected regions,
and defined variables. If you are running a demo version of WMS you should
skip this step. •

1. Select the Save Simulation command from the NFF menu.
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The simulation may then be restored at a later date using the Read Simulation
command in the NFF menu.

Using the National Urban Equations Defined in NFF

A national urban regression equation has been defined for use by any state, in
addition to several equations particular to specific urban areas. Urban
equations available for use are identified in the available equations window by
the "$" symbol for local, and "#" symbol for national. Local urban equations
may not be used in conjunction with rural equations, consequentially rural
equations disappear when a state urban region has been selected. However,
the national equation is dependent on computed flows from the corresponding
rural region, and therefore must be used in conjunction with the appropriate
rural region.

To use the National Urban Equation based on the flows you have just
computed:

I. If the basin is not selected and the National Flood Frequency
Regression Equations is not up the select the basin using the Select

Basin tool .it and choose the Run Simulation command from the
NFFmenu.

2. Select the #National Urban Equation from the regional regression
equations text window.

3. Click on the right arrow to move it to the regions overlapped by
watershed window.

4. Enter the following values:

• BDF=8

• IA=45

• SL= 42.03

• RI2 = 1.8

• ST=7

5. Select the Compute Peak Discharges button.

Computed urban peak flows are shown along with previously computed rural
peak flows. You may wish to read pages 8-9 in the NFF manual for further
information regarding the National Urban Equation.
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11.4.10 Using Individual State Urban Equations Defined in NFF

The National Urban Equation is common to all states, but some states have
local urban equations as well (Texas is one of those states). To use urban
equations defined for Texas you must unselect all of the regions defined in the
regions overlapped by watershed text window. Available state urban
equations will reappear, and you can select one for analysis. OTE: The
watershed defined by the TIN is not an urban watershed, but we will
demonstrate how state-wide urban equations are used with this same data.

1. Highlight Region 5 in the regions overlapped by watershed window.

2. Unselect it by pressing the button with the left arrow.

3. Repeat the last two steps for Region 6 and #National Urban Equation.

Scroll down the regional regression equations text window and notice that
urban equations have been defined for Houston, Austin, and Dallas.

I. Select $Dallas as the urban region for analysis by selecting it in the
regional regression equations text window and then selecting the right
arrow. (Notice that all other regions disappear, since they cannot be
used in conjunction with a statewide urban equation).

2. Enter 24.60 for A.

3. Enter 30.0 for VI.

4. Select the Compute Peak Discharges button.

Projected peak flows for the Dallas urban basin are shown.

•

•
11.5 Conclusions

This completes the NFF tutorial for computing rural discharges at ungaged
sites. You may select "Done", or if you are not in demo mode you may choose
another state for analysis.

•
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NFF

Supplementary Excerise for the NFF Interface-Session 9

There are numerous different ways to continue experimenting with the NFF interface. Try using the following tins
as if they are part of your state. You can also try using them in other states. Be sure to eliminate interior outlet
points so that you only have a single watershed.

All files for this exercise are located in the Supplimentary 9 directory (Except for files created by you).

I. Spanish Fork Canyon

a) You can use the sf.tin file or if you delineated it on your own you will have a mysf. tin file.

b) Define an NFF model and compute the hydrographs for the sub-basins using your own state's data.

2. Jordanelle

a) You can use the jordanel.tin file or if you delineated it on your own you will have a myjord.tin file.

b) Define an NFF model and compute the hydrographs for the sub-basins using your own state's data.
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• Lumped parameter

• One of the most commonly used
rainfall/runoff programs

• Options to use several different metho

-~.. _....

• Rainfall/runoff for "single" eve ;

• Infiltration losses

• Creating unit hydrographs for a water'

• Complete runoff hydrograph for a
watershed

• Routing hydrographs downstream

• Combining hydrographs of different sub
basins
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"-----Limitations'O! HEC-1

• Lumped parameter model

• Single event

• No stage computations

• Hydrologic NOT Hydraulic stream flo
routing

• Level pool reservoir routing

-._----- ......-..

......

•

•
• Basins

• Outlets

• Reservoirs

• Diversions

•
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Topol'ow~ Model
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HEC-1·-"·Mbd.~.~Created by
Wf\AS·,
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Preclpit?tion
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•

•
• Hyetograph

- Total rainfall

- Time distribution of rainfall

• Spatial distribution

• Temporal distribution

•
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• Precipitation (could apply to a

• Base flow

• Losses
• Unit hydrograph method

• Snowmelt data

~-----

-~.__._~----- .

..................

Available"'LbsS Methods
",

'''"-

• Initial-Uniform (LU)

• Exponential (LE)

• Green-Ampt (LG)

• Holtan (LH)

• SCS (LS)

•

•

•
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--~~-MethQ9 (eN)

• Initial abstractions
- Soil moisture capacity in inches

- .2S where S=1000-1OCN/CN by defaul

• Curve Number (CN)
- Soil group

- Land use

- Never account for development

....~.......,.

Initial and LJnifqr~ Method

• Initial amount satisfied
- .8-1.2 inches for sandy soils

- 04-1.0 inches for clay soils

• Thereafter the uniform rate is used.
- .1-.3 in./hr for sandy soils

- .05-.15 for clay soils

• should be developed for your specific basin
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ExponenttalJv1ethod

• Must be determined using opti
routines

• Therefore, used infrequently

--- '- .....

Holt~'n""'M,ethod
"'","

• Accounts for plant cover

• Accounts for some moisture capac ,
recharge

•

•

•
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• Actual physics of soil percolatl

• More sophisticated

----------
----.-......

...... .....-

• SCS, Initial-Uniform, Green-AntE!
preferred
- Data availability

• Use Exponential only with calibrated d

• Use Holtan if plant growth is significant

• All methods work if given good data
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• Unit Hydrograph Methods

• Distributed Methods

....... ......

•
Unit Hydro~i·rElp·h,s of HEC-1

"""-

• Derived

• Synthetic
- SCS

- Clark

- Snyder

•
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• Lag time is the only required p

• Applicable only to moderately slo
watersheds
- Should not use for flat or steep watersheds

--------------_._.--._......~....

• Time of concentration
- Many different ways to detennine

• Storage coefficient

• A user supplied or default time area cur,
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• Time of concentration

• Peaking coefficient

•

•

•
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Routing'S~m Flow

•

• Travel time

• Attenuation

• Volume changes - channel losses

----. ~
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HEC-1 R~'Uting, Methods

• Kinematic Wave

• Muskingum-Cunge

• Muskingum

• Straddler-Stagger and Tatum (Averagin

• Modified PuIs Storage Method

• Normal Depth Storage Method

.-....

Segme··nllng.,Jhe Channel
Reach,"'.

• Segment Length = Distance Flo't>.
travels in one time step

• Subdivide the channel reach

• NSTPS = Travel time/Computational T
interval

• Travel time = Length of reach/Velocity of
flood wave

• Velocity of flood wave = Channel velocity
* ~1.5

•

•

•
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• May occur at any point in the

• Must define relationship between
the channel and diverted flow.

• Diverted flow can be returned at any po
downstream

• Diverted flow may also be routed to accou
for lag and attenuation

--~--.~.~-_...._.-...-.....

ReserVoTrs····and Detention
Po~'dS,

• Effect on runoff hydrograph
- attenuation

-lag time

• Design of reservoirs and reservoir struc

• Safety
- Dam breaching and breaking
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• Storage

• Discharge

•
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Reservo;'st<:mt e Options

•

• Table of Volumes

• Volumes and elevations

• Areas and elevations
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Reservoir DiScnqEge Options

••

• Discharge

• Discharge and elevations

• Spillways

• Low level outlets

• Pumps
• Overtopping (Dam Safety)
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• Reservoir creation
- storage capacity curves (only with a TIN)

• Time area curve generation
- approximates travel time with flow distance

• Thiessen polygons for gauges

• Lag time and time of concentration equations

• Curve Number computations

• Snow melt zone calculations

• NEXRAD (rain gauge) rainfall interpolation

• Phoenix Valley S-Graphs

------
..... -.-.

How Do·es···HEC-1 Work in
WM'S',o

Delineate a watershed

2 Initialize an HEC-l analysis

3 Define precipitation

4 Define basin parameters

5 Define routing parameters

6 Add reservoirs/diversions

7 Generate a hydrograph

•

•

••
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CHAPTER

HEC-1 Interface
9

•

•

Estimated Time: 30 minutes.

Once a watershed has been appropriately subdivided into smaller basins, you
can use WMS to enter parameters for defining a complete HEC-l input file .
Geometric attributes such as areas, lengths, and slopes are computed
automatically from the TIN geometry. Parameters such as loss rates, base
flow, unit hydrograph method, and routing data are entered through a series of
interactive dialog boxes. Once the parameters needed to define an HEC-I
model have been entered, an input file with the proper format for HEC-l can
be written automatically. There is no need to use an editor or even look at the
file.

Since only parts of the HEC-l input file are defined in this tutorial, you are
encouraged to explore the different available options of each dialog, being sure
to select the given method and values before exiting the dialog.

9.1 Objectives

In this tutorial you will load a TIN which has already been delineated into
several different sub basins. You will read in a partially defined HEC-I input
file and finish defining all necessary parameters. Finally you will run HEC-I
and view the resulting hydrographs from within WMS. The steps covered
include the following:

• Reading TIN, Map and HEC-l data files .

• Defining gages, and precipitation for the watershed.
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• Defining the SCS loss rate for all basins.

• Defining a hydrograph method and an equation to compute lag time
for the basins.

• Defining the routing parameters from one outlet to the next.

• Computing geometric attributes.

• Computing curve numbers (CN) from land use and soil type
coverages.

• Creating an HEC-I input file.

• Running HEC-I.

• Reading the TAPE22 hydrograph results file and displaying the
results.

• Computing time area curves.

•

9.2

• Defining elevation zone areas for a snow melt analysis.

Reading the Data Files

A super file will be used to read in the necessary data files. A super file simply
contains the names of other files that may be components of your project, and
works best if each component is in the same directory as the super file. You
may edit the super file with any standard editor such as Notepad or DOS Edit
if you find it necessary. On UNIX operating systems you will undoubtedly
need to change the directories to match where WMS has been installed.

The TIN you will be reading is the same one used in the last tutorial, except
that a stream network and five drainage basins have already been defined.
Land use and soil type coverages have been defined and saved in a map a file.
An HEC-I input file will also be read as part of the input so that some of the
basic input can be predefined. To read in the file, do the following:

I. If you are continuing from a previous tutorial select New from the File
menu and confirm that all data should be deleted.

2. Select Open command from the File menu.

3. Find and Open the file named rockyhec.sup. By default it should be in
the tutorial directory.

Once the files are read In you should see the Rocky TIN and two
polygon coverages.

•

•



•

•

•

HEC-1/nterface 9-3

4. Select Display Options from the Display menu.

5. Turn the display of all entities off.

6. Select the Drainage tab.

7. Be sure the display of Outlets, Outlet names, Stream networks,
Drainage basin boundaries and both gage types are all turned on.

8. Select the OK button. The display is updated and you should see the
watershed divided into five sub basins.

You may want to move or turn off basin labels as described In

previous tutorials.

9.3 Computing Geometric Attributes

Some of the geometric attributes are not saved as part of the TIN file, therefore
be sure to compute them each time you wish to define an HEC-l input file.

1. Select the Compute Basin Data command from the Drainage menu..

2. Specify feet for the model units, sq. miles for area, and feet for length
and then select the OK button.

After the computation, the basin areas will be displayed at the centroid of the
drainage basin. If you wish, you can turn these labels off from the drainage
display options dialog.

Once computed, basin areas, stream lengths and stream slopes are
automatically stored for use in defining the HEC-I input file. The flow
distances and basin slopes computed are used to compute lag times with the
Tulsa equation.

9.4 Entering Gages

The gage method for rainfall will be used in each basin. To do this you must
define the gages with their associated precipitation accumulation and
distribution values. The table below will aid you in creating the rain gage
network.

Table 7.1. Gage Information.

NAME X-Coordinate V-Coordinate Precipitation

qaqel 10500 25000 1.38
qaqe2 18000 12000 1.41
qaqe3 35670 7530 1.36
QaQe4 35900 23320 1.32
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These gages represent total storm stations, and therefore no temporal
distributions are associated with them. After entering these four gages, you
will be instructed to enter one gage that defines the temporal distribution for
all four gages. All of the gages can be entered from within the Gages dialog as
explained below:

1. Change to the Hydrologic Modeling module ill.
2. Select the Gages command from the HEC-I menu.

3. Select the New button.

4. Enter the name for the first gage in the name box.

5. Enter the values of the first gage from the above table.

6. Select the New button again and define the values for the second gage.

Continue this process until all four gages have been entered.

You must now enter one gage which defines the temporal distribution for all
of the gages:

1. Select the New button.

2. Enter the name "gage5" in the name edit box.

3. Enter the x-y coordinates x=29,OOO.0 and y=15,400.0.

4. Click the Stonn Total Station check box off.

5. Click the Temporal Distribution Station check box on.

6. Enter today's date in the appropriate edit boxes.

7. Select the Define Series button.

8. Click on the Import button found in the lower right-hand corner of the
dialog box.

9. Locate and select the file called scstabls.ser. By default it is located in
the tutorials directory. A list of six defined rainfall distributions will
appear in the xy series window.

10. Click on the SCS-StandardEmergencySpiliway series to make it the
active xy series. The plot window will show the distribution for this
senes.

The values corresponding to this standard distribution are
automatically inserted into the text edit fields. You are free to scroll

•

•

•
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through and examine the values. You are also free to change the
distribution according to a pattern of interest to you.

11. Click on the OK button of both dialogs.

The storm total stations will be displayed along with the Thiessen network
made up of the four storm total stations. The temporal distribution gage is
displayed in a different color than the other gages, and is not included in the
Thiessen network since it defines only a distribution and not a storm total.
Later, as basin data are computed, weights corresponding to the Thiessen
network will be assigned to each basin.

9.5 Defining Job Control Parameters

Each HEC-l input file must have certain basic parameters defined. Job
control data is entered in the following manner:

1. Select the Job Control command from the HEC-l menu. A dialog will
appear with several different job control options.

2. Enter three text strings of your choice in the ill text edit fields. These
text fields correspond to the identification cards at the top of the HEC
1 input file .

3. Set the computational time interval to 10.

4. Set the date fields to today's date.

5. Set the number of hydrograph ordinates to 75.

6. Click on the OK button to close the dialog.

9.6 Defining Basin Parameters

HEC-l basin parameters that can be defined using WMS include precipitation,
loss rates, unit hydrograph method, and base flow. The first set of parameters
to enter are the loss rates:

1. Click on the Select Drainage Basin tool jIJ.

2. Choose the Select All command from the Edit menu.

3. Select the Edit HEC-l Parameters command from the HEC-l menu.
You may wish to reposition your windows so that the HEC tree and
the Edit HEC-l Parameters can be seen.
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9.6.1

9.6.2

Loss Method

HEC-I provides several different methods for performing rainfall loss
computations. For this tutorial we will be using the SCS curve number
method. The actual curve numbers will not be entered at this time, but will be
computed from land use and soil type coverages later. However you must be
sure to specify that you want to use the SCS method.

1. Select the Loss Method button.

2. Select the SCS curve number (LS) method.

3. Select OK.

Unit Hydrograph Method

Once the loss rate method has been set, you are ready to define the unit
hydrograph method which will be used for computing the basin hydrographs.
To define the unit hydrograph parameters, do the following:

1. Select the Unit Hydrograph Method button.

•

9.6.3

The dialog you will see provides you with the ability to choose from
the different unit hydrograph methods available in HEC-l, and then •
define the appropriate value. The method you will be defining is the
SCS dimensionless unit hydrograph method.

2. Click on the SCS dimensionless method option.

3. Click on the Compute Parameters - Basin Data button.

4. Set the computation method to the Tulsa (rural) method.

The lag time used in the SCS dimensionless method is a function of
basin slope, and lengths of flow within the watershed. Since these
parameters are computed by WMS when computing basin data, the lag
times can also be computed. Refer to the users manual to see a full
description of the Tulsa district equation.

5. Repeat step 4 by selecting each basin listed in the Basin text window
and assigning the Tulsa (rural) method to it.

6. Click on the OK button of both dialogs.

Precipitation

The last basin parameter you will enter here is the precipitation. To enter the •
precipitation parameters, do the following:
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1. Select the Precipitation button.

2. Choose the gage option.

3. Select the OK button.

4. Select Done in the Edit HEC-I Parameters dialog.

Weights are assigned automatically using the Thiessen method when
computing basin data. In order to make this happen you must compute
the basin data once again.

5.. Select the TINs module icon m
6. Select the Compute Basin Data command from the Drainage menu.

7. Specify feet for the model units, sq. miles for area, and feet for length
and then select the OK button.

Defining Routing Data

Routing parameters are defined at outlet points, and they define the reach from
a given outlet to the next downstream outlet. Stream lengths and slopes are
automatically computed and associated with the appropriate outlet when
computing drainage data from the Drainage menu. For the example model you
are working with, you will be defining Muskingum routing for the three outlet
points in the stream (no routing needs to be defined at the outlet representing
the watershed outlet). To define this routing method, do the following:

1. Change back to the Hydrologic Modeling module .:rJ.

2. Select the Select Outlets tool .1l.
3. Click one of the three "upstream" outlet points (not the bottom most

outlet). The three "upstream" outlets should have routing data
defined.

4. Select the Edit HEC-I Parameters command in the HEC-I menu.

S. Choose the Routing Data button.

6. Select the Muskingum routing option (be sure it is the Muskingum 
RM option and not the Muskingum Cunge - RD option).

7. Enter a value of.2 for X.

8. Determine the routing time for this reach by doing the following:
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9. Find the length of the channel (you should be able to see a value for L
such as 16992.7 in the Muskingum-Cunge edit field - it will be
dimmed but you should be able to read it).

10. Estimate the channel velocity (use 3.0 ftlsec).

II. Divide the length by the estimated velocity (16992.7/3 =5664.2 sec.)

12. Divide by 3600 seclhr to get travel time in hours. Enter this value for
AMSKK.

13. Finally determine how many time steps it will take to route the flow
through this channel segment and enter the value in the NSTPS field.
This can be determined by dividing the travel time (in minutes) by the
computational time step entered in the Job Control dialog (10
minutes).

14. Select the OK button.

•

9.8

15. Repeat steps 2-8 for the other two outlets where routing is to be
defined.

16. Select the Done button in the Edit HEC-I Parameters dialog.

Computing Composite Curve Numbers

Besides computing geometric data, composite curve numbers can be
determined using the land use and soil coverages read in with the model.

I. Select the Composite Runoff CoeffICN... command from the
Calculators menu.

2. Select Compute Using Coverage for Soil Type.

3. Select Compute Using Coverage for Land Use.

4. Select OK to comput composite CN's.

So that you can be satisfied that lag times and CN numbers have been
computed, double click on anyone of the basin icons in the Tree window.
This brings up the Edit HEC-l Parameters dialog. You will see the composite
curve number of the selected basin following the LS record (it is the second
number) shown in the HEC-I cards window. The lag time computed can be
seen following the UD card. Select the other basins and note the differences in
these two parameters.

I. Select the TINs module icon ~.

2. Select the Display Options option from the TINs menu.

•

•
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3. Tum on the soil group, land use, soil group legend, and land use
legend options.

4. Select OK.

You should see the different combinations of land use/soil group combinations
that have been assigned to the TIN.

9.9 Running and Saving HEC-1 Files

You have now completed the definition of the HEC-l model and are ready to
run the analysis. HEC-I is a stand-alone program, but can be launched from
within WMS using the following steps:

I. Change to the Hydrologic Modeling module~.

2. Select the Check Model option from the HEC-I menu.

This will perform a check on the data and try to determine problems
that should be addressed before HEC-I can be successfully run. Just
because the model checker does not find any errors, does not insure
that HEC-I will compute the correct result, but it should help.

3. Select DONE.

4. Select the Run HEC-I option from the HEC-I menu.

HEC-I needs the names of three files: I) the input file (which will be
saved when running HEC-I). 2) an ASCII output file outlining the
processes used and the final results. 3) a TAPE22 solution file
containing hydrograph information which can be read back into WMS
for display.

5. Enter rocky in the prefix for all files edit field and click on the Update
All Prefixes button.

6. Click OK to start HEC-I.

The View File command in the File menu can be used to examine the ASCII
output file should problems occur. On PC's the view file command brings the
file up within the Windows Notepad program, whereas on UNIX operating
systems you can specify an editor (vi by default) to bring the file up in.

•
9.10 Displaying Hydrograph Results

The TAPE22 file generated by HEC-I, and stored in the third file specified
when running HEC-I from within WMS contains hydrographs for each basin
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of the watershed, for the routed hydrographs from outlet points, and for the •
combination of basin and routed hydrographs at each outlet. You can read this
file and display the hydrographs in the hydrograph window. To read the
hydrograph file, do the following:

1. Select the Show Hydrograph Window from the Display menu.

If you are running on a UNIX operating system your hydrographs have already
been read in and you can skip the next two steps. If you are running Microsoft
Windows you will need to follow the next two steps to read in the
hydrographs.

1. Select the Open command from the Hydrographs menu.

2. Find and Open the solution file used to store the resulting
hydrographs. If you did not actually run HEC-1, or are having
difficulties you can read in tape22.bak.

After you have successfully read the hydrograph file, you should see several
small hydrographs displayed in the upper right comer of each outlet and basin
in the Hydrologic Modeling window. You can examine the hydrographs in
greater detail by selecting them for display in the hydrograph window. Two
hydrographs for some of the outlets will be displayed representing the
hydrograph before and after channel routing. To view the hydrographs in the •
hydrograph window, do the following:

1. Select one of the hydrographs by clicking on the miniature.

2. Hold the SHIFT key down while selecting more hydrographs. All
currently selected hydrographs should be displayed in the hydrograph
window.

3. Select the Display Options command from the Display menu.

4. Select the Plot Options button.

5. Tum on the Display X grid toggle.

6. Tum on the Display Y grid toggle.

7. Set any other parameters you wish to experiment with.

8. Click on the OK button of both dialogs.

9.11 Conclusion

This concludes the tutorial on defining HEC-l files and displaying •
hydrographs. The concepts learned include the following:
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• Entering job control parameters.

• Defining basin parameters such as loss rates, precipitation, and
hydrograph methodology.

• Defining routing parameters.

• Creating gages, and their associated Thiessen networks.

• Writing HEC-l input files.

• Reading hydrograph results and manipulating their display.
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CHAPTER 18

Creating Topologic Models For HEC-1

Estimated Time: 40 minutes.

This chapter, if you are familiar with HEC-I, will help you understand how
WMS compares to and how it differs from traditional HEC-I modeling. It is
useful for new users of HEC-I as well, since it will help you become familiar
with what types of structures can be modeled with HEC-I, and how they are
set up in WMS.

The example problem illustrated here is the Red River watershed. It is chosen
since it illustrates many of the basic capabilities available in HEC-I.
Furthermore, since it is the first example given in the HEC-I User's Manual, it
is a good source for illustrating how traditional HEC-I models are created in
WMS. This tutorial will not lead you through every step to completely set up
the model. Instead you will be shown how to create and enter data for each
type of object (i.e. basins, outlets, reservoirs, diversions) and then data for
other similar objects will be provided so that you can repeat the steps. A
completed model of the Red River watershed is provided in the tutorial
directory. If you don't wish to enter all of the necessary data, or if you want to
skim through this section and look at the results, you can read this file in using
the Open HEC-l File command in the HEC-l menu.

The Red River watershed demonstrates the following capabilities available in
HEC-I:

• Rainfall data using gages.

• Calculating hydrographs using base flow, losses, and unit hydrograph
methods.
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• Rood hydrograph routing by the channel storage method.

• Reservoir routing using both spillway and low-level outlet options.

• Diversions.

• Input of time series data using time increments different than the
computational time step.

18.1 The Topologic Tree Representation

The schematic shown in Figure 18-1 illustrates how different components in
the Red River watershed are modeled using HEC-l. Figure 18-2 shows a
completed tree diagram for the same watershed created using WMS. A few
important differences need to be noted.

• Names for all hydrograph computation units (outlets, basins, etc.)
must be unique. In the traditional HEC-1 diagram the name LOSTBR,
EASTlO, and RED30 are all used twice. In WMS the names must be
unique so that resulting hydrographs read from a TAPE22 file can be .
associated with the proper hydrograph station. For this reason the
basins LOSTBR and RED30 were changed to LOSTBS and RED30B .

• Diversions may exist from basins to outlets or from outlets to outlets.
In the traditional HEC-l schematic the EASTI 0 outlet point exists
solely to provide a point from which a diversion can be defined. In
WMS the diversion is defined directly from the EAST1 0 basin so there
is no need to have the extra EASTlO outlet point. Diverted flow will
be taken from the EASTIO basin before being combined with the
REDRI basin at the RED 10 outlet point.

• Reservoirs are defined with separate icons (triangles) in the
traditional HEC-I schematic, whereas in WMS they are defined at
outlet points. There are actually a couple different ways the same
problem can be set up using reservoirs in WMS. Figure 18-3 and
Figure 18-4 illustrate these alternatives.

•

•

•
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Figure 18-2 HEC-1 Tree Diagram of Red River Watershed Created by WMS.

Figure 18-3 shows an alternate tree created using WMS. The difference
between this diagram and the one in Figure 18-2 is that E.DAM has been
created as a reservoir rather than routing from LOSTBR to RED20 using the
reservoir storage routing option.
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Figure 18-4 puts the E.DAM reservoir at RED20, since there is no need to
have the outlet at LOSTBR. The reservoir can be placed at the RED20 outlet.
The diversion is routed from EASTlO to RED20, and the basin LOSTBS is
connected directly to RED20.

•
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Figure 18-4 LOSTBR Outlet Eliminated with EDAM Reservoir at RED20.

The HEC-l input file generated from all three trees will be identical. They
simply illustrate different ways in which reservoirs, and reservoir routing from
outlets can be done. The tree defined in the remaining sections of this tutorial
will correspond to the one in Figure 18-2. •
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Creating the Tree

If you are running the professional version switch to the Tree Module [iii. If
you are running the basic version you will be in the Tree Module already,
unless you have turned the Demo on. If you are running the Demo tum it off
now. The following commands can be used to create the topological tree for
the Red River watershed as shown in Figure 18-2. All commands are in the
Tree menu.

1. Select the Add Outlet command. The bottom outlet will be created
and then selected. Each time you create a new outlet it becomes the
selected outlet.

2. Select the Add Basin command. Don't worry that the names don't
match those in Figure 18-2, you can change them later.

3. Select the Add Outlet command.

4. Select the Add Basin command.

5. Select the Add Outlet command.

6. Select the Add Basin command.

7. Click on the Outlet point named 2C to select it.

8. Select the Add Outlet command.

9. Select the Add Basin command.

10. Select the Add Basin command.

Except for the names, your tree should now look like the one in Figure 18-2.
If it does not you can start over by selecting the New command in the File
menu, or you can use a combination of the Delete and Add commands in the
Tree menu to correct your tree.

Changing Hydrograph Station Names

WMS requires that all hydrograph stations have a unique six character
identification name. In order to help avoid this problem default names are
provided whenever an outlet, basin, diversion, or reservoir is created (i.e. I C,
2C, 1B, 2B, etc.). You can change the name of these stations to make them
more identifiable, however you must remember these two limitations:

• Names can not be longer than 6 characters.

• Names must be unique.
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To change the outlet names do the following:

1. Click on the outlet point IC and select the Edit HEC-J Parameters
command from the HEC-J menu, or double-click on the outlet point
(this automatically brings up the Edit HEC-J Parameters dialog).

The Edit HEC-I Parameters dialog contains several buttons which can be used
to define/edit data for hydrograph stations. Only the buttons which pertain to
the selected hydrograph station are active, all others are dimmed. The text
window below the group of buttons shows the actual HEC-I cards as they are
currently defined for the selected object(s). You can define/edit data by either:
1) Clicking on the appropriate button, or 2) Clicking on the appropriate HEC-I
card in the text-window.

1. Select the Routing Data button, or click on the KK card in the text
window.

2. Change the combining name from IC to RED30 and click on the OK
button. There is no routing from this outlet so you don't need to worry
about changing the routing name.

•

3. Select the next upstream outlet 2C. You may wish to reposition your
Hydrologic Modeling Window and/or the Edit HEC-J Parameters
dialog so that you can see both the tree and the dialog. You don't need •
to quit the Edit HEC-J Parameters dialog, data for the next selected
outlet point will now be displayed.

4. Select the Routing Data button, or click on the KK card in the text
window.

5. Change the combining name from 2C to RED20. There is routing
from this outlet so change the routing name from 2R to 20T030.

6. Repeat the last three steps changing 3C to LOSTBR, 3R to E.DAM,
and 4C to RED 10, 4R to lOT020.

To change Basin names do the following:

1. Click on the basin IB. If you accidentally closed the Edit HEC-l
Parameters dialog then double-click on IB to bring it back up.

2. Select the Basin Data button, or click on the KK card in the text
window.

3. Change the basin name from IB to RED30B and click on the OK
button.

4. Click on basin 2B. •
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5. Select the Basin Data button, or click on the KK card in the text
window.

6. Change the basin name from 2B to WESTIO and click on the OK
button.

7. Repeat the last three steps changing 3B to LOSTBS, 4B to EASTIO,
and 5B to REDRI.

1. Select the Done button.

Creating the Tree with Feature Objects

In more recent versions of WMS, the hydrologic modeling tree can be created
directly from feature arcs (streams), and polygons (basins) (see chapter 4).
This means that a tree can be created even without a map from which actual
stream networks and watershed boundaries are digitized. In such cases the
feature objects represent a "picture" or "drawing" of the watershed and are not
used to calculate areas and lengths. However, the drawing itself may be much
more instructive to clients and reviewers than just the modeling tree. If you
want you can read in a map file that contains the same watershed definition
you have just created by following these three steps:

1. Select the New command from the File menu and confirm that you
want delete all data.

2. Select the Open command from the File menu.

3. Find and open the file named redri.map.

If you choose to do this your model will replace (but be equivalent to) the one
you have just defined and should look like Figure 18-5.
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Figure 18-1 Red River Watershed Tree Defined from Feature Objects..

Diversions cannot be saved with feature objects (TINs, or OEMs either) so
after creating a watershed using feature objects diversions still need to be
entered using the commands in the Tree menu of the Hydrologrc Modeling
Module.

1. Select the Hydrologic Modeling module icon~~1.

2. Select the Select Basin icon tool .n I.

3. Click on the basin named EAST 10 to select it.

4. Select the Add Diversion command from the Tree menu.

5. Click on the Outlet point named E.DAM to select it.

6. Select the Retrieve Diversion command from the Tree menu.

To change the diversion name do the following:

I. Click on the diversion 01.

2. Select the Edit HEC-I Parameters command from the HEC-I menu.

3. Select the Diversion Data button.

•

•

•
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4. Change the name from D1 to DIVERT.

5. While in this dialog change the outflow hydrograph name to EASTDV
and the inflow hydrograph name to LOSTDV. These are the names
used on the KK records where the diversion is created (DT record) and
retrieved (DR record). Click on the OK button.

Job Control Data

Job control data includes computational starting time and data, interval, and
length, general output specification and other custom features of HEC-1. To
modify this data do the following:

1. Select the Job Control command from the HEC-I menu.

2. Change the day to 12.

3. Change the month to 6.

4. Change the year to 68.

5. Change the computational time interval to 15.

6. Change the beginning time to 715.

7. Change the number of hydrograph ordinates to 58. The total length of
the simulation will be 58*15min or 14 hours and 30 minutes.

8. If you wish. you can change the ID cards.

9. Select the OK button.

Defining Gages

The Red River watershed model uses 5 total storm stations and one recording
station to define the precipitation for the simulation. This is done in WMS
with the following steps:

l. Select the Gages command from the HEC-I menu.

2. Select the New button.

3. Turn the Define rain gage location toggle off.

4. Change the Name to 60.

5. Define the precipitation to be 4.68 (inches).
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6. Repeat the last three steps defining gages 61,62,63, and 64 using the
data in Table 2.1 to define the precipitation.

Table 2.1. Total Storm Gaging Stations.

Name Precipitation

60 4.68
61 4.65
62 4.85
63 4.90
64 5.10

At least one recording station must be defined to set up the temporal
distribution data for the gages. For the Red River watershed a single recording
station is defined and then used for all storm total stations. Set this gage up
with the following steps:

1. Select the New button.

•

2. Change the Name to 400.

3. Toggle off the Storm Total Station button, and toggle on the Temporal •
distribution station button.

4. Click on the Define Series button.

This will bring up the XY Series editor dialog. WMS uses this dialog to define
several different series of data. Rainfall distributions are one type of series
data. For additional information see the chapter in the reference manual on
using the XY series editor.

By default the rainfall distribution values are considered to be cumulative.
The Red River model however uses incremental. This model also uses a time
step of 60 minutes rather than the default of IS. To change these two defaults
to match the Red River model use the following steps.

I. Select the XY Opts button.

2. Toggle on the Unit Time box.

3. Change the beginning time to 435 minutes (This corresponds to 7
hours and IS minutes and will be converted appropriately when
exiting the dialog).

4. Change the increment to 60.

5. Select the Delta button in the Distribution box.

6. Select the OK button.
•
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7. Starting with time 7: 15 in edit field I enter the following ten
incremental values: .04, .35, .01, .03, .73, .21, .02, .01, .03, .01.

8. Change the name of the Current XY Series to "Rainfall Distribution".

9. Select the OK button of both dialogs.

Defining Basin Parameters

HEC-1 requires that all basins have an appropriate area, precipitation, loss
method, and unit hydrograph method defined. Just about any combination of
these methods will work. This tutorial will describe how these parameters can
be defined for one basin and then a table of values will be provided so that the
parameters can be defined for the remaining basins.

Since the base flow parameters are identical for all basins this will be defined
first.

I. Click on the basin named RED30B.

2. Select the Edit HEC-l Parameters command from the HEC-l menu.
Once again you may wish to reposition windows.

3. Select the Select All command from the Edit menu. All basins will be
selected and their data displayed in the text window.

4. Select the Basin Data button. Notice that the name and area fields are
dimmed since you wouldn't want to change these values with all
basins selected.

5. Change the STRTQ value to be 10.

6. Change the QRCSN value to be -.25.

7. Change the RTIOR value to be 1.2.

8. Select the OK button.

9. Click on the RED30B basin once again so that it IS the only one
selected.

10. Select the Basin Data button or click on the BA card In the text
window.

II. Change the Area to .19 and select the OK button .

12. Select the Precipitation button.

13. Select the Gage button.



18-12 WMS Tutorials

14. Select the PT Gage Weights (These are weights for total storm
stations).

15. In the first two Gage Name fields enter 64 and 63, and in the first two
Weight fields enter .65 and .35.

16. Select the OK button.

17. Select the PR Gage Weights (These are weights for distribution
station).

18. In the first Gage Name field enter 400, and in the first Weight field
enter 1.0.

19. Select the OK buttons for both the Weight and Precipitation dialogs.

20. Select the Loss Method button or click on the LS card in the text
window.

21. The SCS method is on by default (for some of the other basins you
may need to change the method), but change the curve number
(CRVNBR) field to 79.

22. Select the OK button.

23. Select the Unit Hydrograph Method button or click on the UD card.

24. Once again the SCS method is on by default, but you need to change
the lag time (TLAG) to 1.04.

25. Select the OK button.

Basin parameters for RED30B should now be defined. You can now select the
other basins one at a time and repeat the above steps for defining area,
precipitation and weights, loss method, and unit hydrograph method using the
data given in Table 2.2. For some basins you will need to change the Loss and
Unit Hydrograph Methods before the appropriate parameters can be defined.
The HEC-l card identification (LS, LE, etc. is always part of the method
button so you can identify which method to choose from the HEC-l cards in
Table 2.2. Where there may be some confusion parameter names are given in
the table. If only one parameter exists, no name is given and if a parameter is
left out of the table just leave its value at zero.

•

•

•
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Table 2.2. Basin Parameters for the Red River Watershed.

Name Area Gaae Welahts Loss Parameters Unit Params

RED30B .19 63 .35 LS CRVNBR=79 UD 1.04
64 .65
400 1.0

WEST20 .80 63 .60 LH FC=.04 UD .94
64 .40 GIA=.4
400 1.0 SAI=.3

BEXP=1.4
LOSTBS .36 62 .5 LU STRTL-.3 UC TC-.8

63 .5 CNSTL-.04 R-1.2
400 1.0

EAST10 .66 61 .6 LE STRKR=.6 US TP-1.3
62 .3 DLTKR=1.0 CP-.8

63 .1 RTIOL=1.0
400 1.0 ERAIN=O.O

REDRI .82 60 .75 LS CRVNBR=80 UD 1.47
61 .25
400 1.0

Defining Routing Parameters

Routing parameters are defined in a similar fashion as basins. For the Red
Ri ver model channel routing needs to be defined from RED 10 to RED20
(lOT020) and from RED20 to RED30 (20T030). This can be done with the
following steps:

1. If the Edit HEC-l Parameters is still active select the outlet E.DAM.
If you have closed it already select E.DAM and then select the Edit
HEC-l Parameters command from the HEC-l menu.

2. Select the Routing Data button or click on the RN card in the text
window.

3. Select the Storage (RS) routing option.

4. Set the nsteps to 1, the type to FLOW and RSVIC to -1.0.

5. Leave the channel button selected and click on the Define button.

6. Select the Modified Puls option and click on the Define Volume
button. The XY Series editor can now be used to define the volume
table.

7. Change the Current XY Series Name to "RED20 Volume" .

8. Starting with the first table field enter the following values: 0, 17, 42,
67,100,184,274,386,620.

9. Click on the OK button.
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11. Select the New button.

12. Change the Current XY Series Name to "RED20 Outflow".

13. Starting with the first table field enter the following values: 0, 500,
1000,1500,2000,3000,4000,5000,7000

14. Click on the OK button of all three dialogs.

15. Select the outlet RED 10.

16. Select the Routing Data button or click on the RN card in the text
window.

17. Select the Storage routing option.

18. Set the steps to 1, the type to FLOW and RSVIC to -1.0.

19. Leave the channel button selected and click on the Define button.

20. Select the Modified Puis option and click on the Define Volume •
button. The XY Series editor can now be used to define the volume
table.

21. Select the New button.

22. Change the Current XY Series Name to "REDIO Volume".

23. Starting with the first table field enter the following values: 0, 18, 36,
54,84, 110, 138, 174,228,444.

24. Click on the OK button.

25. Click on the Define Outflow button.

26. Select the New button.

27. Change the Current XY Series Name to "REDIO Outflow".

28. Starting with the first table field enter the following values: 0, 500,
1000,1500,2150,2600,3000,3450,4000,6000.

29. Click on the OK button of all three dialogs.

•



•

•

18.9

Creating Topologic Models for HEC-1 18-15

Defining Diversion Data

Both an inflow and outflow table must be defined to set up the diversion data.
This is done by following the steps below:

1. If the Edit HEC-l Parameters is still active select the diversion arrow
named DIVERT. If you have closed it already, select DIVERT and
then select the Edit HEC-l Parameters command from the HEC-l
menu.

2. Select the Diversion Data button or click on the DR card in the text
window.

3. Click on the Define DI button. The XY Series editor can now be used
to define the inflow table.

4. Change the Current XY Series Name to "Divert DI".

5. Starting with the first table field enter the following values: 0, 100,
300, 600, 900.

6. Click on the OK button.

7. Select the Define DQ button. The XY Series editor can now be used to
define the outflow table.

8. Select the New button.

9. Change the Current XY Series Name to "Divert DQ".

10. Starting with the first table field enter the following values: 0, 25, 100,
180,270.

11. Click on the OK button of both dialogs.

•

18.10 Defining a Reservoir

As seen in Figure 18-2 to Figure 18-4 a reservoir can be defined in a couple of
different ways: 1) by using the storage-reservoir routing method, or 2) by
explicitly creating a reservoir and defining the storage parameters. For the
model in this tutorial we have chosen to represent it using the second
alternative.

1. If the Edit HEC-l Parameters is still active select the outlet E.DAM.
If you have closed it already select E.DAM and then select the Edit
HEC-I Parameters command from the HEC-I menu.

2. Select the Reservoir Data button.
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3. Select the Storage (RS) routing option.

4. Set the nsteps to I, the Initial condition type to ELEV and RSVRIC to
851.2.

5. Select the reservoir button and click on the Define button.

6. Select the known volume option.

7. Select the SV toggle and click on the Define button. The XY Series
editor can now be used to define the volume table.

8. Select the New button.

9. Change the Current XY Series Name to "E.DAM Volume".

10. Starting with the first table field enter the following values: 21, 100,
205, 325, 955.

11. Click on the OK button.

12. Select the SE toggle and click on the Define button. The XY Series
editor can now be used to define the volume table.

13. Select the New button.

14. Change the Current XY Series Name to "E.DAM Elevation".

IS. Starting with the first table field enter the following values: 850,
851.5, 853.3, 856.5, 858.

16. Click on the OK button.

17. Select the Compute Weir Spillway button.

18. Select the SL toggle and define the parameters as follows:
ELEVL=851.2, CAREA=12, COQL=.6, EXPL=.S.

19. Select the SS toggle and define the parameters as follows: CREL=856,
SPWID=60, COQW=2.7, EXPW=1.5.

20. Click on the OK button for both dialogs.

21. Click on the Done button of the Edit HEC-l Parameters dialog.

18.11 Running and Saving HEC-1 Files

You have now completed the definition of the Red River watershed model and
are ready to run the analysis (If you haven't done all the work outlined in the

•

•

•



•

•

•

Creating Top%gie Mode/s for HEC-1 18-17

previous section you can read in the already defined model redri.hc 1). HEC-l
is a stand-alone program, but can be launched from within WMS using the
following steps:

1. Select the Check Model option from the HEC-I menu.

This will perfonn a check on the data and try to determine problems
that should be addressed before HEC-l can be successfully run. If you
followed the steps in the preceding sections correctly there should be
no problems. If you discover some potential problems you should
correct them before moving on.

Just because the model checker does not find any errors, does not
insure that HEC-l will compute the correct result, but it should help.

2. Select DONE.

3. Select the Run HEC-I option from the HEC-I menu.

HEC-l needs the names of three files: 1) the input file. 2) an ASCII
output file outlining the processes used and the final results. 3) a
TAPE22 solution file containing hydrograph information which can be
read back into WMS for display.

4. Enter redriv in the prefix for all files edit field and select the Update
all prefixes button.

5. Select OK.

When running HEC-I the input file is automatically saved before
HEC-I is launched.

The View File command in the File menu can be used to examine the ASCII
output file should problems occur. On PC's the view file command brings up a
simple view only program, whereas on UNIX operating systems you can
specify an editor (vi by default) to bring the file up in.

18.12 Displaying Hydrograph Results

The TAPE22 file generated by HEC-l, and stored in the third file specified
when running HEC-I from within WMS contains hydrographs for each basin
of the watershed, for the routed hydrographs from outlet points, and for the
combination of basin and routed hydrographs at each outlet. You can read this
file and display the hydrographs in the hydrograph window. To read the
hydrograph file, do the following:

1. Select the Show Hydrograph Window from the Display menu (If the
hydrograph window is already mapped you won't need to use this
command).
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2. Select the Open command from the Hydrographs menu.

3. Find and Open the TAPE22 file (it should be named redriv.sol if you
actually ran HEC-I as outlined above). If you did not actually run
HEC-I, or are having difficulties you can read in redri.sol.

After you have successfully read the hydrograph file, you should see several
small hydrographs displayed in the upper right corner of each outlet and basin
in the HEC-I Tree Window. You can examine the hydrographs in greater
detail by selecting them for display in the hydrograph window. Two
hydrographs for some of the outlets will be displayed representing the
hydrograph before and after channel routing. To view the hydrographs in the
hydrograph window, do the following:

I. Select one of the hydrographs by clicking on the miniature.

2. Hold the SHIFf key down while selecting more hydrographs. All
currently selected hydrographs should be displayed in the hydrograph
window.

3. Select the Display Options command from the Display menu.

4. Select the Plot Options button.

5. Turn on the Display X grid option.

6. Turn on the Display Y grid option.

7. Set any other parameters you wish to experiment with.

8. Click on the OK button for both dialogs.

•

•

•
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Supplementary Excerise for HEC-1-Session 10

The following set of exercises builds on the previous supplementary exercises. If you haven' t completed those
exercises you can skip to step two and use the sf.tin file.

All files for this exercise are located in the Supplimentary 10 directory.

1. Delineate the South Fork watershed using a TIN created from two dems: bridal.dem and wallsrdg.dem

The key data needed to create a boundary polygon and streams prior to creating a TIN are:

a) The watershed outlet should be at the UTM coordinates (451340, 4467015). Remember the base units
for UTM coordinates are meters.

b) You should use the contours, shading, etc. to define streams for South Fork. Bunnells Fork, Left Fork,
Middle Fork, and Right Fork as indicated on the accompanying map. You may add additional stream
branches if you wish, but these must be included.

c) After creating the TIN and delineating the watershed you should tum in a printout showing the
watershed boundary, the polygon boundary used to create the initial TIN, and the area of the watershed
(as a single basin) in sq. miles .

2. Assume that a 150 meter high dam is at the outlet point of the basin. Compute the reservoir surface area, in
acres, for each 10 meter elevation increment and plot the elevation-area curve. Compute the reservoir
storage, in acre feet, for each elevation increment and plot the elevation-storage curve. Tum in a plot of the
two curves. What are the area (acres) and storage (acre-feet) values when the reservoir is completely full
(at 150 meters)?

a) Area ---,-_

b) Storage, _

3. Divide the watershed into two sub-basins by creating a second outlet at the junction of Left Fork and the
combined Middle Fork and Right Fork. If necessary merge the sub-basins together so that only a single
basin exists upstream of the newly created outlet. What are the areas of the upper and lower sub-basins in
sq. miles. Tum in a printout of your basins.

a) Upper Basin Area _

b) Lower Basin Area _

•
4. Using the gage data location in the table below to enter three gages for your watershed.

Set up an HEC-l rainfall runoff simulation (without snowmelt) using the Gage method and Thiessen
polygons for your two basins. The SCS type II 24-hr precipitation distribution should be used. Use a
CN=75 for the upper basin and a CN=82 for the lower basin. Use the SCS Unit Hydrograph method
for both basins. computing the lag time with the Tulsa Rural method. What is the peak flowrate and
time to peak at the basin outlet?



Gage Location 24 hr. rainfall

457650,4469140 2.1 inches

461775,4463230 1.3 inches

450675,4460845 1.1 inches

a) Peak flowrate

b) Time to peak

5. Modify your HEC-l simulation to route the hydrograph from the upper basin through the lower basin along
the South Fork. Use the Muskingum method of routing where x =0.2 and K is detennined from the stream
reach length and an average stream velocity of 3.5 fps. What values for K and NSTPS did you use? What
are the peak flowrate and time to peak at the basin outlet?

a) K (AMSKK) _

b) NSTPS _

c) Peak flowrate _

d) Time to peak _

6. If the watershed were in the wet condition (Wanielista, Table 4.6 attached) when this storm occurred and the
CN values were changed appropriately, what would the peak flow rate and time to peak at the outlet be?

a) Peak flowrate _

b) Time to peak _

7. What is the percent change in composite CN and what is the % change in the outlet flow rate?

a) % change composite CN _

b) % change flowrate _

8. Use the Degree-Day Method to determine snowmelt runoff from the total basin for 3 days. The minimum and
maximum temperatures are 38, 65, 42, 75, 38, 63, 35 F. respectively. The lapse rate is 3 F/300 meters.
The elevation increments (zones) are each 300 meters. The weather station is located at the outlet. The
watershed is covered with at least 5 inches of snow water equivalent. Use the Uniform Loss Method with
an initial loss of .2 inches, and a loss rate of . I. For the snow loss rate (STRKS) use a value of .04 inch / he.
The snowmelt coefficient should be 0.07. You will also need to enter a very small amount of rainfall (as we
had to with the homework problem) and define a lag time for the SCS Unit Hydrograph method with the
Tulsa Rural method to compute the lag time. What is the peak flowrate during the simulation period? What
is the time to peak? Tum in a printout of your hydrograph.

a) Peak flowrate _

b) Timeofpeak _

•

•

•
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WhatiflDon'~Have Digital
Terrain ~ ta?

•.WMS allows you to define top ic
models without having a TIN pres
- from scratch

- reading existing files
• Not all options for different models supported

TopologicTre~s from TINs

• Topologic representation'~
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T~~09i<rrees
• Can be created without the pre
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• Reservoirs

• Diversions

• All areas and geometric parameters ill

defined manually

•

•
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• Developed by the NRCS (S"-' ....,..,-..

• Uses SCS dimensionless hydrogr

• Uses SCS curve number for rainfall

• Precipitation defined from synthetic or
natural events

• Lumped parameter, event based model

• Typically used more often in the eastern U

• Subset ofHEC-l options

----- ..--- ..._--. ----.......... .........
.................

-',

How Does TR2:2<J Work in WMS?
",

1 Delineate a watershed
- Create a topologic model without a

2 Define basin (RUNOFF) values

3 Define routing (REACH) values

4 Add diversions/reservoirs etc.

5 Compute hydrograph
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• Developed by the NRCS S)

• Uses a "tabular" hydrograph m
Hydrographs were initially camp
routed using TR-20

• Uses SCS curve number for rainfalllo

• Precipitation defined using Type I, lA, I
III synthetic rainfall distributions and tota
precipitation for a 24-hour storm

• Extremely fast and easy

--_.__._--_...._-_.__._._~._---

Cap'abfH~ies
"",

• Fully implemented in WMS 5.

• Number of sub-basins and outlets
only by computer's memory

• Computes and routes basin and sub-bas
hydrographs

• Computes a peak flow and several other
sub-basin parameters without computing a
hydrograph

•

•

•



•

•

•

.._---------
,.,------.

-'...........

Lim~ons
"""

• Limited to a certain range 0 alues for
Time of Concentration, Travel e, and
Curve Number:

• Tc should be less than 3.1 hours (less than
if no hydrograph is computed)

• Tt should be less than 2.1 hours

• eN should be greater than 40

• One of four 24-hour rainfall distributions
may be used. There can be no user-defined
rainfall distribution

-~~------.
._---- -..--......

Done
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US~g~TH,,~5 in WMS

" ",

1 Delineate a watershed
• Create a topologic model without a

Or, use a TIN, DEM, or Feature objec
your model.

2 Define basin values (Online help
messages are available)

3 Define outlet travel time values
• Time computation coverage

4 Compute the hydrographs

•

•

•
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CHAPTER 19

Creating Topologic Models For TR-20

This chapter, if you are familiar with TR-20, will help you understand how
WMS compares to and how it differs from traditional TR-20 modeling. It is
useful for new users of TR-20 as well, since it will help you become familiar
with what types of structures can be modeled with TR-20, and how they are set
up in WMS.

The example problem illustrated here is the Red River watershed. It is chosen
since it illustrates many of the basic capabilities available in TR-20. This
tutorial will not lead you through every step to completely set up the model.
Instead you will be shown how to create and enter data for each type of object
(i.e. basins, outlets, reservoirs, diversions) and then data for other similar
objects will be provided so that you can repeat the steps. A completed model
of the Red River watershed is provided in the tutorial directory. If you don't
wish to enter all of the necessary data, or if you want to skim through this
section and look at the results, you can read this file in using the Open TR-20
File command in the TR-20 menu.

The Red River watershed demonstrates the following capabilities available in
TR-20:

• Calculating hydrographs using base flow, losses, and unit hydrograph
methods.

• Flood hydrograph routing.

• Reservoir routing.

• • Diversions.
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19.1 The Topologic Tree Representation

The schematic shown in Figure 19-1 illustrates how different components in
the Red River watershed are modeled using TR-20. Figure 19-1 shows a
completed tree diagram for the same watershed created using WMS. A few
important differences need to be noted.

• Names for all hydrograph computation units (outlets, basins, etc.)
must be unique.

• Reservoirs are defined with separate icons (triangles) in the
traditional TR-20 schematic, whereas in WMS they are defined at
outlet points.

•

llEOnI
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•

Figure 19-1 Traditional TR-20 Topological Tree Diagram For Red River
Watershed

•



•
Creating Topologic Models for TR20 19-3

Figure 19-2 puts the E.DAM reservoir at RED20, since there is no need to
have the outlet at LOSTBR. The reservoir can be placed at the RED20 outlet.

Figure 19-2 LOSTBR Outlet Eliminated with EDAM Reservoir at RED20.

The tree defined in the remaining sections of this tutorial will correspond to
the one in Figure 19-2.•

LEGEND

~
L:J

®
®

I
IOTOIO

I

t

Basin Hydrograph Station

Outlet Hydrognph Station

Re~rvoir

Rooting Station

Diversion

•

19.2 Creating the Tree

Switch to the Hydrologic Modeling Module i~l. If you are running the Demo
version turn it off now. The following commands can be used to create the
topological tree for the Red River watershed as shown in Figure 19-2. All
commands are in the Tree menu.

I. Select the Default Model command and change the current model to
TR-20. Select the OK button.

2. Select the Add Outlet command. The base outlet will be created and
highlighted meaning that it is currently selected. Each time you create
a new outlet it becomes the selected outlet.

3. Select the Add Basin command. Don't worry that the names don't
match those in Figure 19-2, you can change them later.

4. Select the Add Outlet command.

5. Select the Add Reservoir command.
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6. Select the Add Basin command.

7. Select the Add Basin command.

8. Select the Add Outlet command.

9. Select the Add Basin command.

10. Select the Add Basin command.

11. Click on the Outlet named 3C to select it.

12. Select the Add Diversion command.

Except for the names, your tree should now look like the one in Figure 19-2.
If it does not you can start over by selecting the New command in the File
menu, or you can use a combination of the Delete and Add commands in the
Tree menu to correct your tree.

•

19.3 Changing Hydrograph Station Names

WMS requires that all hydrograph stations have a unique six character
maximum identification name. In order to help avoid this problem default
names are provided whenever an outlet, basin, diversion, or reservoir is
created (i.e. lC, 2C, lB, 2B, etc.). You can change the name of these stations
to make them more identifiable, however you must remember these two
limitations:

• Names can not be longer than 6 characters.

• Names must be unique.

To change the outlet names do the following:

1. Click on the outlet point lC and select the Edit TR-20 Parameters
command from the TR-20 menu, or double-click on the outlet point
(this automatically brings up the Edit TR-20 Parameters dialog).

The Edit TR-20 Parameters dialog contains several buttons which can be used
to define/edit data for hydrograph stations. Only the buttons which pertain to
the selected hydrograph station are active, all others are dimmed. You can
define/edit data by clicking on the appropriate button.

I. Select the Routing Data button.

2. Change the Routing combine name from 1C to RED30 and cl ick on
the OK button.

•

•
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3. Select the next upstream outlet 2C. You may wish to reposition your
Hydrologic Modeling Window and/or the Edit TR-20 Parameters
dialog so that you can see both the tree and the dialog. You don't need
to quit the Edit TR-20 Parameters dialog. Data for the next selected
outlet point will now be displayed.

4. Select the Routing Data button.

5. Change the Routing combine name from 2C to E.DAM. Toggle the
Define reach routing toggle box. There is routing from this outlet so
change the routing name from 2R to 20T030.

6. Click on the OK button.

7. Repeat the last four steps changing 3C to REDlO and 3R to lOT020.
Be sure to turn reach routing on for outlet 3C so that the resulting
hydrograph may be routed downstream from this point.

To change Basin names do the following:

1. Click on the basin lB. If you accidentally closed the Edit TR-20
Parameters dialog then double-click on 1B to bring it back up.

2. Select the Basin Data button.

3. Change the basin name from IB to RED30B and click on the OK
button.

4. Click on basin 2B.

5. Select the Basin Data button.

6. Change the basin name from 2B to WEST20 and click on the OK
button.

7. Repeat the last three steps changing 3B to LOSTBS, 4B to EASTIO,
and 5B to REDRI.

To change the di version name do the following:

1. Click on the diversion arrow D I.

2. Select the Diversion Data button.

3. Change the Diversion name from D I to DIVERT and click on the OK
button.

4. Select the Done button.
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19.4 Creating the Tree with Feature Objects

In more recent versions of WMS, the hydrologic modeling tree can be created
directly from feature arcs (streams), and polygons (basins) (see chapter 4).
This means that a tree can be created even without a map from which actual
stream networks and watershed boundaries are digitized. In such cases the
feature objects represent a "picture" or "drawing" of the watershed and are not
used to calculate areas and lengths. However, the drawing itself may be much
more instructive to clients and reviewers than just the modeling tree. If you
want you can read in a map file that contains the same watershed definition
you have just created by following these three steps:

1. Select the New command from the File menu.

2. Select the Open command from the File menu.

3. Find and open the file named redri.map.

If you choose to do this your model will replace (but be equivalent to) the one
you have just defined and should look like Figure 19-3.

Figure 19-.1 Red River Watershed Defined from Feature Objects.

•

•

•
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Job Control Data

Job control data includes computational starting time and data, interval, and
length, general output specification and other custom features of TR-20. To
modify this data do the following:

1. Select the Job Control command from the TR-20 menu.

2. Change the main time increment to 0.25.

3. Select the Define Precipitation button.

4. Select Use _standard SCS rainfall distribution for the precipitation
distribution and Emergency spillway and freeboard design for the SCS
rainfall table type.

5. Toggle the options to define rainfall depth and rainfall duration on.

6. Enter 5.0 inches for the rainfall depth.

7. Enter 4.0 hours for the rainfall duration.

8. Select the OK button on both dialogs.

Defining Basin Parameters

TR-20 requires that all basins have an appropriate area, curve number, and
time of concentration defined. This tutorial will describe how these
parameters can be defined for one basin and then a table of values will be
provided so that the parameters can be defined for the remaining basins.

1. Click on the basin named RED30B.

2. Select the Edit TR-20 Parameters command from the TR-20 menu.
Once again you may wish to reposition windows.

3. Select the Basin Data button.

4. Change the area to .19.

5. Input 79 for the SCS Curve number.

6. Input 1.73 for the time of concentration.

7. Select the OK button.
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Basin parameters for RED30B should now be defined. You can now select the
other basins one at a time and repeat the above steps for defining area, curve
number, and time of concentration using the data given in Table 3.1

Table 3.1. Basin Parameters for the Red River Watershed.

Name Area Curve Number Time of Concentration

RED30B .19 79 1.73
WEST20 .80 75 1.57
LOSTBS .36 75 0.80
EAST10 .66 75 1.96
REDRi .82 80 2.45

•

19.7 Defining Routing Parameters

Routing parameters are defined in a similar fashion as basins. For the Red
River model channel routing needs to be defined from RED IOta E.DAM
(10T020) and from E.DAM to RED30 (20T030). This can be done with the
following steps:

1. If the Edit TR-20 Parameters is still active select the outlet RED 1O. If
you have closed it already select RED 10 and then select the Edit TR
20 Parameters command from the TR-20 menu.

2. Select the Routing Data button.

3. Select the option to Define reach routing.

4. Enter 3000 feet for the reach length.

5. Notice that there are two methods for defining reach routing. We will
use the second (x and m) method. Keep the default x and m values.

6. Click on the OK Button.

7. Select the outlet E.DAM.

8. Select the Routing Data button.

9. Select the option to Define reach routing.

10. Enter 2000 feet for the reach length.

II. Click on the OK Button.

•

•
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Defining Diversion Data

Diversion data can be defined by following the steps below:

Diversions cannot be saved with feature objects (TINs, or DEMs either) so
after creating a watershed using feature objects diversions still need to be
entered using the commands in the Tree menu of the Hydrologic Modeling
Module.

1. Select the Hydrologic Modeling module icon ,~~.

2. Select the Select Basin icon tool ;.111
3. Click on the basin named EASTl 0 to select it.

4. Select the Add Diversion command from the Tree menu.

5. Click on the Outlet point named E.DAM to select it.

6. Select the Retrieve Diversion command from the Tree menu.

To change the diversion name do the following:

1. If the Edit TR-20 Parameters is still active select the diversion icon
named D 1. If you have closed it already, select D 1 and then select the
Edit TR-20 Parameters command from the TR-20 menu.

2. Select the Diversion Data button.

3. Change the name from D I to DIVERT.

4. Enter 860 for the constant discharge above which the flow will be
diverted.

5. Click on the OK Button.

Defining a Reservoir

In WMS, a reservoir is defined in TR-20 by adding a reservoir at an outlet.. In
this section, we will define the reservoir data at the E.DAM outlet.

I. If the Edit TR-20 Parameters is still active select the outlet E.DAM. If
you have closed it already select E.DAM and then select the Edit TR
20 Parameters command from the TR-20 menu .

2. Select the Reservoir Routing button.
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3. Toggle Define reservoir routing to "on".

4. Select the Define Reservoir Data button.

5. Select the New button.

6. Enter the following values for elevation, discharge, and storage:

Table 3.2 Reservoir Data

Elevation Discharge Storage

850.00 0.00 21.00
851.50 15.00 100.00
853.30 54.00 205.00
856.50 200.00 325.00
858.00 496.00 955.00

• Click on the OK button for both dialogs.

• Click on the Done button of the Edit TR-20 Parameters dialog.

19.10 Running and Saving TR-20 Files

You have now completed the definition of the Red River watershed model and
are ready to run the analysis (If you haven't done all the work outlined in the
previous section you can read in the already defined model redri.dat). TR-20
is a stand-alone program, but can be launched from within WMS using the
following steps:

1. Select the Check Model option from the TR-20 menu.

This will perform a check on the data and try to determine problems
that should be addressed before TR-20 can be successfully run. If you
followed the steps in the preceding sections correctly there should be
no problems. If you discover some potential problems you should
correct them before moving on.

If the model checker does not find any errors, it does not insure that
TR-20 will compute the correct result, but it should help.

2. Select Done.

3. Select the Run TR-20 option from the TR-20 menu.

TR-20 needs the names of the TR-20 input file, the ASCII output file,
and the solution file containing hydrograph information which can be
read back into WMS for display.

•

•

•
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4. Enter redriv in the prefix for all files edit field and select the Update
button. If necessary select a directory to save the TR-20 files in by
clicking on the file browser button. When running TR-20 the input
file is automatically saved before TR-20 is launched.

5. Click on the OK button. TR-20 will run and the hydrographs will be
read in at the hydrograph stations.

The View File command in the File menu can be used to examine the ASCII
output file should problems occur. On PC's the view file command brings up a
simple view only program, whereas on UNIX operating systems you can
specify an editor (vi by default) to bring the file up in.

19.11 Displaying Hydrograph Results

The ".THY" file generated by TR-20, and stored in the third file specified
when running TR-20 from within WMS contains hydrographs for each basin of
the watershed, for the routed hydrographs from outlet points, and for the
combination of basin and routed hydrographs at each outlet. You can read this
file and display the hydrographs in the hydrograph window. To read the
hydrograph file, do the following:

I. Select the Show Hydrograph Window command from the Display
menu (if the hydrograph window is already mapped you will not need
to do this).

2. Select the Open command from the Hydrographs menu.

3. Find and Open the ".THY" file (it should be named redri. THY if you
actually ran TR-20 as outlined above). If you did not actually run TR
20, or are having difficulties you can read in redri.thy.

After you have successfully read the hydrograph file, you should see several
small hydrographs displayed in the upper right corner of each outlet and basin
in the TR-20 Tree Window. You can examine the hydrographs in greater
detail by selecting them for display in the hydrograph window. Two
hydrographs for some of the outlets will be displayed representing the
hydrograph before and after channel routing. To view the hydrographs in the
hydrograph window, do the following:

I. Select one of the hydrographs by clicking on the min iature.

2. Hold the SHIFT key down while selecting more hydrographs. All
currently selected hydrographs should be displayed in the hydrograph
window.

3. Select the Display Options command from the Display menu.
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4. Select the Hydrologic Modeling tab.

5. Select the Plot Options button.

6. Turn on the Display X grid option.

7. Turn on the Display Y grid option.

8. Set any other parameters you wish to experiment with.

9. Click on the OKbutton for both dialogs.

•

•

•
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Urban Dr~in'aRe in WMS

• Uses geographic data but allo
following to act as "streams"
- Roads

- Railroads

- Canals

- Any feature which "channels" water

• Interface to the rational method
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Insertin~oads

• Currently created as "stream"

• Future versions will contain a higH
feature arc type
- it will act like a stream

• "Underground" pipes may also be placed
a TIN

.........................................

• Background elevation data pro .~"

overland flow characteristics

• Roads, railroads, canals, etc. provide
flow

• You do not have to have the roads slopin \
downstream along every segment
- BE CAREFUL!
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Top~e for Rational
Metl10
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Rational M'elhQ,g Equation

• Q= CiA
C - runoff coefficient (between 0.0 an

• Typical values can be found on 12-2 of
Reference Manual

i-rainfall intensity (determined using tc)

A - drainage area in acres



• Basins should be smaller than
- Analysis of larger regions can be do

effects of routing are properly consider

• All catchment losses are incorporated
through C
- Area weighted runoff coefficients can be use

- No catchment will have a constant loss, but
works well for impervious regions (urban)
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.......

Creating 'Hydrographs
",

• Rational

• Modified

• Universal

• Dekalb

• User defined

•

•
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Sd - Storm duration
r - Falling limb coefficient
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o 0.00
1 0.16
2 0.19
3 0.27
4 0.34
5 1.00
6 0.45
7 0.27

0.00
0.04
0.08
0.16
0.32
1.00
0.30
0.11

/
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8 0.19
9 0.12
10 000

0.05
0.03
0.00
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User DefineCt'~ydrograph

• Number of ordinates specified

• Values for t/te and Q/Qp defined
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How Dos's""Rational Method
Work i~"'W S?

1 Delineate a watershed

2 Initialize a Rational method analys

3 Define runoff coefficients

4 Define rainfall intensities
- Hydro 35, NOAA Atlas 2

- tc

5 Compute Q

6 Generate a hydrograph
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Rational Method Interface

12

•

•
12.1

The Rational Method is one of the simplest and best known methods routinely
applied in urban hydrology. Peak flows are computed from the simple
equation:

Q= kCiA

where:

Q- Peak flow

k - conversion factor

C - Runoff coefficient

1 - Rainfall intensity

A - Area

In this tutorial you will learn how to solve problems using a digital terrain
model and the Rational Method.

Reading in Terrain Data

The terrain model used in this tutorial is for a small portion of a city. The
elevation data was obtained by digitizing a contour map.

I. Select the TINs module icon~.
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2. Select Open from the File menu.

3. Find and Open the TIN file named "afpts.tin".

4. Select the Triangulate command from the TINs menu.

5. Select the Display Options command from the Display menu.

6. Tum off Vertices and Triangles.

7. Select OK.

•

12.2 Creating a TIN for Basin Delineation

The TIN that has been read in and triangulated will be used as a background
elevation map for the creation of a TIN that will be used for basin delineation.

12.2.1 Opening a DXF file

1. Select the Map module icon 1111.
2. Select the Import command from the DXF menu.

3. Find and Open the file named "afdxf'.

•
12.2.2 Converting DXF Data to Feature Objects

The DXF data represents a small street network and a boundary for the study
area. In order to use the DXF data to help create a TIN it must be converted to
feature objects.

1. Select the DXF->Feature Objects command in the DXF menu.

2. Turn off Feature points from dxf points.

3. Select OK.

4. Select the Delete command from the DXF menu.

5. Confirm that you want to delete the DXF data by selecting OK.

12.2.3 Preparing the Feature Objects to Create a TIN

The way line segments are connected in DXF files is often random. However,
in order to create a network of stream feature arcs, line segments must be
connected from downstream to upstream. WMS can automatically reorder
feature arcs by:

•



•

•

•
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1. Select the Select PointsINodes tool III.
2. Select the point indicated in Figure 12-1.

Figure 12-1 Location of Watershed Outlet Used for Stream Reordering.

1. Select the Reorder Streams command from the Feature Objects menu.

Now that the arc segments are properly ordered they can be converted to
stream arcs. First, you must make the coverage in which you are working a
Drainage coverage (right now it is a General coverage).

1. Select Coverages... from the Feature Objects menu.

2. Make sure the coverage named "default coverage" is selected in the
window in the upper left of the dialog.

3. Select Drainage from the Attribute Set drop-down box in the lower
right area of the dialog.

4. Select OK.

Now that the coverage is a drainage coverage, you are ready to convert the
arcs to streams and basins.

1. Select the Select Network tool~.

2. Select any arc that is part of the stream network.

3. Select the Attributes command from the Feature Objects menu.

4. Select Stream.
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5. Select OK.

6. Select Refresh from the DispLay menu.

12.2.4 Redistributing Arc Vertices

The vertices along the arcs need to be redistributed in order to create a TIN
more suitable for basin delineation.

1. Select the SeLect Arc tool

2. Select the SeLect ALL command from the Edit menu.

3. Select the Redistribute command from the Feature Objects menu.

4. Specify the Subdivide each edge uniformLy option.

5. Use a specified spacing of 100 (feet in this case).

6. Select OK.

12.2.5 Creating the TIN

1. Select Build PoLygon from the Feature Objects menu.

2. Select OK to use all feature arcs.

3. Select the Select Polygon tool

4. Click anywhere inside the boundary polygon so that it becomes
selected.

5. Select the Create TIN. .. command from the Feature Objects menu.

6. Select No when asked if you want to save your data.

7. Make sure the option to Interpolate from existing TIN is selected.

8. Select OK.

•

•

12.3 Defining Catchment Areas

Catchment areas need to be defined in order to determine areas. The
computed areas will later be used in the Rational Method equation. •
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Adding Outlets and Assigning Triangles to Basins

1. Select the TINs module icon 9.
2. Select the Smooth Pits command from the TINs menu.

3. Using the Select Vertices tool ill and while holding the SHIFT key
down select the four TIN vertices at the stream branching points
indicated in Figure 12-2.

•

Select These Vertices

•

Figure 12-2 Location of Outlet Vertices.

1. Select the Add Outlets command from the Streams menu.

2. Select the Define Basins command from the Drainage menu.

Because of the way vertices are connected by triangle edges, locations where
flow splits may occur. If you receive a message about triangles belonging to
more than one basin you need to do the following two commands.

1. Select the Correct Split Flow command from the Drainage menu.

2. Repeat the Define Basins command from the Drainage menu.

Since basins are defined based on flow from triangle centroids you will need
to split triangles which straddle basin boundaries. After refining boundaries
you will also want to eliminate triangles which do not belong to any of the
catchment areas.

1. Select the Refine Boundaries command from the Drainage menu.

2. Select the Delete Null Basin Triangles command from the Drainage
menu.
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3. Select OK to verify deletion.

12.3.2 Merging Catchment Areas

By default WMS creates a separate catchment area (basin) for each upstream
branch of the stream. However, we only want to consider a single basin
upstream from the outlet points so we must merge the pairs of adjacent basins
together.

1. Select the Display Options command from the Display menu.

2. Select the tab labeled Drainage.

3. Turn off the Stream networks.

4. Select OK.

5. Select the Select Basin tool

6. While holding down the SHIFT key select both basins labeled A in
Figure 12-3.

7. Select the Merge Basins command in the Drainage menu.

•

•
o

Figure 12-3 Delineated Catchment Areas Before Merging.

1. Repeat the last two steps for basins labeled B, C, and D.

2. Select the Display OpTions command from the Display menu.

3. Select the Drainage tab. •



•
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4. Tum Stream networks back on.

5. Tum on Fill drainage basins.

6. Select OK.

12.3.3 Defining Basin Data

Now that the delineation of catchment areas is complete you can compute the
contributing area (as well as many other parameters) for each.

1. Select the Compute Basin Data command in the Drainage menu.

2. Set the Basin Areas option to be Acres.

3. Select OK.

Running a Rational Method Simulation

The areas computed from the TIN can now be used in setting up a Rational
Method simulation of the urban development. Each of the outlet points
represents an inlet to a storm drain.

1. Select the Hydrologic Modeling module icon lilt
2. Select basin "Basin 5" as labeled in Figure 12-4 by clicking on the

basin icon inside the basin.

3. Select the Run Simulation command from the Rational menu.

The Rational Method dialog should appear. While this dialog is up you can
continue to interact with the menus, tools, and windows of WMS. As you
select different basins, the current parameters will be updated in the dialog.
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Basin 2
Basin 1

Figure 12-4 Final Delineated Basins.

Basin 3

Basin 5

•

12.4.1 Defining the Runoff Coefficients and Time of Concentration

The runoff coefficient, C, is used to account for losses between rainfall and
runoff. The more developed a catchment is, the higher the C value it will
have. The WMS reference manual contains a table of typical C values for •
different land use conditions.

1. Enter a value of .60 for C.

2. Enter a value of 35 for Time of Concentration.

3. Select the basin labeled "Basin 4" in Figure 12-4 by clicking on its
square icon in the HydroLogic Modeling Tree Window.

4. Enter a value of .75 for C.

5. Enter a value of 14 for Time of Concentration.

6. Repeat this process for the other three basins, using the table below to
fill in values for C and te•

Basin Name Runoff Coefficient C Time of Concentration t

Basin 1 .85 22
Basin 2 .85 20
Basin 3 .8 18
Basin 4 .75 14
Basin 5 .6 35

•
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•
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12.4.2 Defining the Rainfall Intensity (i)

As part of the WMS interface to the Rational Method you can compute IDF
curves using either HYDRO-35, NOAA, or user defined data. For this tutorial
we will use HYDRO-35 data and a recurrence interval of 10 years.

1. Select the "Basin 5" once again.

2. Select the IDF Curves button from the basin section of the RationaL
Method dialog.

3. Make sure the HYRO-35 radio group button is selected and select the
Define Data button.

4. Enter the following values to defme IDF curves using HYDRO-35

Time Intensity

2 yr. 5 min. .47
2 yr. 15 min. .97
2 Yr. 60 min 1.72
100 yr. 5 min. .81
100 yr. 15 min. 1.75
100 yr. 60 min. 3.60

1. Select the OK button after correctly entering the rainfall values .

The IDF curves for the 2, 5, 10,25, 50, and 100 year recurrence intervals will
be drawn, and values listed for selected times given in the windows on the
right of the IDF Computation dialog.

1. From the text window in the upper right hand part of the dialog click
on the line of data for the 1O-yr recurrence interval as shown in Figure
12-5.
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Figure 12-5 IDF Computation Dialog with the 10-yr Recurrence Interval
Selected.

The rainfall intensity is determined from the selected interval by using the
previously defined value for time of concentration.

1. Compute i by selecting the Intensity button.

2. Select the Done button. The value of i computed using the IDF
Computation dialog will be placed in the edit field for this basin.

3. Note also that the input for this basin is complete and a value for
runoff Q has been computed. a summary of the rational equation and
results is in the upper right window of the dialog.

The HYDRO-35 data only needs to be entered once (unless different data is to
be used for different basins), so the rainfall intensity for the remaining basins
can be defined using the following steps.

1. Select the icon for "Basin 4".

2. Select the IDF Curves button.

•

•

•
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3. Select the line of text for the lO-yr recurrence interval.

4. Select the Intensity button.

5. Select Done.

6. Repeat these steps for Basins 3, 2, and 1.

12.4.3 Defining Hydrographs

As the data entry for each basin is completed, a peak flow (Q) is computed and
listed in the text display window. The Rational Method equation does not
produce a hydrograph. However, several different unit-dimensionless
hydrographs can be used to distribute the peak flow through time to create a
runoff hydrograph.

1. Select the Show Hydrograph Window command from the Display
menu (unless the hydrograph window is already visible).

2. Select the basin labeled "Basin 5" in Figure 12-4.

3. Select the Define Hydrographs... button.

4. Select the Universal hydrograph method from the drop down list.

5. Select DONE.

6. Click on the small hydrograph box of Basin 5 in the Graphics window.

You should see the hydrograph displayed in the Hydrograph Window. You
may want resize this window to inspect the chart.

12.4.4 Combining Runoff from Multiple Basins

WMS allows you to define lag times (time of travel) in order to compute
runoff from multiple upstream basins and account for the time of travel
between sub-basin outlets. Once the lag times have been defined, a single
runoff hydrograph for the entire watershed can be computed using one of two
different methods.

1. Select one of the upper-most outlet icons.

2. Enter a value of 5 minutes for the Routing lag time.

3. Select the other upper-most outlet.

4. Enter a value of 5 minutes for the Routing lag time.

5. Select the next downstream outlet.
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6. Enter a value of 7 minutes for the Routing lag time.

7. Select the next downstream outlet.

8. Enter a value of 6 minutes for the Routing lag time.

The last or bottom-most outlet does not need to have a Routing lag time
defined since the hydrograph accumulations will occur at this point.

1. Select the bottom-most outlet point. Note the results for this outlet
and all upstream outlets and basins are displayed in the window in the
upper right of the dialog.

2. Select the Define Hydrographs ... button.

3. Choose the Route by summing method.

4. Choose the UniversaL hydrograph method.

5. Select DONE.

6. Select the hydrograph box for the bottom-most outlet.

7. Inspect the hydrograph displayed in the Hydrograph Window.

12.4.5 Defining Rainfall Intensities at the Outlet to Compute Runoff
Hydrographs

Besides the method of summing hydrographs at an outlet and then lagging to
the next outlet by the lag time, WMS can also be used to determine composite
rational method parameters at the outlet for computing hydrographs. With this
method, the time of concentration is defined as the longest flow time from
upstream basins (times of concentration) combined with any lag times from
channels. The area is the cumulative upstream area, and the runoff coefficient
is determined as an area weighted value from the upstream basins. With the
time of concentration at the outlet defined you will need to determine the
appropriate rainfall intensity. Then instead of summing the upstream
hydrographs to develop the hydrograph at the outlet, WMS will use the
rational method equation to compute a peak flow and multiply this peak flow
by the selected hydrograph method (the same as is done for basins) to
determine the hydrograph at the outlet. To do this:

1. Select one of the upper-most outlet icons in the Hydrologic Modeling
Tree window.

2. Select the IDF Curves button (for outlets).

3. Select the line of text for the lO-yr-recurrence interval.

4. Select the Intensity button.

•

•

•
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5. Select Done.

6. Repeat these steps for the remaining outlets.

The last or bottom-most outlet does not need to have a Routing lag time
defined since the hydrograph accumulations will occur at this point.

1. Select the bottom-most outlet point.

2. Select the Define Hydrographs... button.

3. Choose the Traditional method.

4. Choose the Universal hydrograph method.

5. Select DONE.

6. Select DONE in the Rational Method dialog also.

7. Select the hydrograph box for the bottom-most outlet.

You should get some kind of an idea about the difference in the resulting
hydrographs from the two methods. You may want to inspect other
hydrographs at different locations. Just click on the box in the Graphics
Window to do so.

Adding a Detention Basin

If you compute runoff using the route by summing method then you can route
hydrographs through detention basin structures defined at any of the outlet
locations.

1. Select the outlet that defines Basin 5 in Figure 12-4.

2. Select the Run Simulation command from the Rational menu.

3. Select the Define Reservoir button.

You will now define a hypothetical detention basin facility from approximate
geometric parameters. WMS can compute a storage capacity curve for a
rectangular basin. You could also use a TIN to develop a storage capacity
curve, if the TIN had sufficient resolution to accurately define the storage
depth relationship. Further, you could enter a pre-computed storage capacity
curve.

4. Select the Define... button in the Storage Capacity box .

5. Select the Known Geometry option.
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6. Enter 500 feet for Length.

7. Enter 500 feet for Width

8. Enter a Depth of 30 feet.

9. Enter a Side slope of 2

10. Leave the Base elevation at 0.0 (It will be assumed on-grade at the
outlet location).

11. Select OK.

You will now define a standpipe and spillway (weir) for outlet structures and
WMS will compute the elevation-discharge relationship automatically. In
addition to standpipes and weirs you can defme low-level outlets, or you can
enter a pre-computed elevation-discharge relationship.

1. Select the Define... button in the Elevation Discharge box.

•

2. Select the Discharge Structures option.

3. Select the Add Standpipe button.

4. Set the pipe diameter to 4 feet. •5. Set the Standpipe elevation to 15 feet.

6. Select the Add Weir button.

7. Set the Weir width to 20 feet.

8. Set the Weir elevation to 25 feet.

9. Select OK.

10. Select OK.

You have now defined a detention facility that has a standpipe and a spillway
for control structures. The incoming hydrograph to this outlet point will be
routed through the detention facility before being routed downstream and
combined with the hydrographs of other basins.

1. Select the bottom-most outlet point.

2. Select the Define Hydrographs ... button.

3. Choose the Route by summing method.

4. Choose the Universal hydrograph method. •
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5. Select DONE.

6. Select the hydrograph box for the bottom-most outlet.

Conclusions

In this tutorial you have learned some of the options available for using the
rational method in WMS. You will want to continue experimenting with the
different options so that you can become familiar will all the capabilities in
WMS for doing Rational Method simulations.
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- Manning's Equation
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• Convenient for moving graphics fi
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- Paint Shop Pro

• Downloadable from ECGL web pages
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•

•

•



• .~-------.. ._-
....--

Fil~Tw?es
"

•

• WMS native file types
- opened using the File Open command

- exceptions
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DEM files

• Hydrologic model input files
- opened/saved from respective menus

• Other file types
- opened using the File Import command

- some exceptions
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- Some advice from Alan
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- AutoCAD release 13 compliant (most cases)
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The Scattered Data module and Grid module can be used in combination to
visualize any set of scalar values which can be assigned to unique x-y
positions. The scalar value used in this tutorial is rainfall intensity generated
from NEXRAD radar files, but they could just as easily represent rain gages or
other locations for which rainfall intensities or accumulatiol~sare known.

•

16.1 Objectives

In this tutorial you will learn how to import scattered data with an
accompanying data set and interpolate from the scattered data to a grid for
visualization by:

• Reading a scattered data file.

• Creating a bounding grid around the scattered points.

• Interpolating from scattered data.

• Contouring a grid.

• Mapping scalar values to elevations.

• Using virtual gages to examine the time variance of the data.

• Animating the transient rainfall data.
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16.2

16.3

Reading the Data File

The scattered data file and data points used in this tutorial were derived from a
portion of a NEXRAD radar scan. After reading the scattered points, a data
set representing rainfall intensities will be imported. To read the file, do the
following:

1. Select the Scattered Data module icon ~.

2. Select Open from the File menu.

3. Use the file browser to find and open the file "rainfall.xy". This file
should be found in the tutorial directory.

4. Select the Data Browser command in the Data menu.

5. Select the Import button, and accept the default of generic scalar file.

6. Use the file browser to find and Open the file "rainfall.sci". This file
should be found in the tutorial directory.

This file contains a transient (values for multiple times) data set of
rainfall intensities.

7. Select the data associated with time step 15.00. You may need to use
the scroll bar to locate this time step in the data browser dialog.

8. Select the Done button.

Interpolation from Scattered Data to a Grid

In order to contour or animate the rainfall data set, the values must be
interpolated to a grid. To interpolate to a grid do the following:

1. Select the Bounding Grid command in the Data menu.

2. Specify 25 cells in both the x and y directions, and a mesh centered
grid type. All other fields can be left as defaults.

3. Select the OK button.

4. Select OK for the default z value.

A grid will be created which just bounds the scattered data points.

5. Select Interpolation Options from the Interpolation menu.

6. Select the Data Set button.

•

•

•
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7. Turn the All time steps toggle on.

8. Select the Select button.

9. Turn on the Truncate values toggle.

This will keep the interpolation functions from assigning values
outside the absolute minimum and maximum of the data set.

10. Select the OK button.

11. Select Interpolation to Grid from the Interpolation menu.

12. Accept the default name for the data set being created for the grid.

WMS will now interpolate the values for each time step from the
scatter points to the grid nodes. The progress dialog box informs you
of the progress for interpolation.

Contouring the Grid

The interpolation process created a new transient data set for the grid. In this
section options for contouring individual time steps will be explored.

1. Select the Display Options command from the Display menu.

2. Turn off the scatter point symbols and select OK.

3. Change to the 2D Grid module HIJ.

4. Select the Display Options command from the Display menu.

5. Turn off Nodes and Cells and tum on contours.

6. Select the OK button.

Linear contours of rainfall intensity are drawn for the grid for time
step 15.00. Since time value 15.00 was selected as the active time step
in the data browser for scattered data, it is also the active time step for
the data set of the grid.

7. Select the Contour Options command from the Display menu.

8. Select the Color fill between contours option.

9. Turn on the Display Legend option.

10. Select the OK button
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The contours are now drawn using a ramp of color intensities. A
legend is drawn in the upper left hand portion of the screen, displaying
the correlation between color and rainfall intensity.

11. Select the Contour Options... command from the Display menu.

12. Select the Color Ramp tab.

13. Select the reverse button.

14. Select the OK button.

•

16.5 Virtual Gages

A virtual gage can be used to show a two dimensional plot of a transient data
set for any point in the grid domain.

1. Select Show Hydrograph Window from the Display menu.

2. Select the Create Gage tool ~.

3. Click on any point within the boundary of the grid (the gage plot will •
be more interesting if the gage is in a region of the grid where the
rainfall intensity is high).

4. Click on another point to create a second gage.

By default a gage is selected immediately after being created (and all
other gages are unselected). Therefore the plot currently being
displayed corresponds to the second gage. Both gages can be
displayed simultaneously using multi-selection.

5. Select the Select Gage tool ~.

6. Select both gages, holding the SHIFf key down as the second gage is
selected.

The hydrograph window shows a plot of the selected gages. Several
options can be changed to control how gages are displayed. These
options are accessible by selecting the Gages command or Gage Plot
Manager command in the Data menu. You are encouraged to

experiment with these options as much as you want. When you are
finished delete the gages by:

7. Select the Select Gage tool ~ if it is not already selected.

8. Select both gages. •
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9. Choose the DELETE or BACKSPACE key.

Animations

Animation sequences can be generated from transient data sets. Animations
are comprised of a series of images of the current grid where all display
options remain the same while the time step is moved ahead.

1. Select the Film Loop command from the Data menu.

The Film Loop dialog comes up over the edit window and stays up
while you create and play your film loop animations. Icons are similar
to a VCR and can be used to run, stop, or step through an animation
sequence.

2. Select the Setup button.

3. Change the Size (% Screen) to 30%.

4. There are several other options which you may experiment with, but
for now select OK.

WMS will draw a contoured image of each time step in the data set,
saving the image after each one. Once an image for each time step is
created, the video buttons and other controls will undim and the
animation sequence can be replayed at a much higher refresh speed.

5. Select the play button (the VCR-like right arrow button).

6. Experiment with the speed setting.

7. Stop the animation by selecting the stop button (the VCR-like box).

8. Use the Frame scroll bar to move the animation forward/backwards in
time.

9. If you wish to save the series of images to a file so that they can be
replayed later without having to load data files or run through setup,
you can use the Save button to save an animation loop file. In a
subsequent session of WMS the Read dialog in the Film Loop dialog
can be used to reload and run the animation. In this case you would
not have to read in the grid, data set or run through the time
consuming process of setup.

10. Select the Done button.
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16.7

16.8

Mapping Elevations

Any function from a data set can be mapped to the elevations of the grid cells
so that the function can be represented as a 3-dimensional surface. This can be
done for the current grid and data set by doing the following:

I. Select the Display Options from the Display menu.

2. Turn on the display of Cells.

3. Select OK.

4. Select the Map Elevations command from the Data menu.

5. Select the data set created when interpolating from the scattered data
(rainfall_all would have been the default) and once again choose time
step 15.0.

6. Select the Select button.

7. Select the Oblique View macro :ill.
8. Select the Z Magnification command from the View menu.

9. Set the value to 250 (in order to better visualize the variations III

elevations) and select OK.

You may wish to rotate ~ or experiment with other display commands.

Conclusions

In this tutorial you have learned how scatter points and data sets can be used ta
interpolate sparse data ta a grid far visualization purposes. You should know
how grids can be contoured, and how virtual gages, animations, and mapped z
values can be used to display transient data.

•

•

•
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Several drainage calculation tools are included in WMS to aid in analysis and
design of hydraulic structures. These tools include Channel Calculator, a Weir
Calculator, a Detention Basin Calculator, a Curb and Gutter Calculator, and an
interface to HY-8, a culvert analysis program.

13.1 Channel Calculator

The channel calculator can use information (hydrographs) determined from a
hydrologic model, to design a channel capable of supporting a given flow. It
may also be used to find stage depth in an existing channel or in a natural
cross-section. An example of both of these scenarios will be given in this
section. In this section of the tutorial, we will use a HEC-I simulation file to

demonstrate the functionality of the channel calculator.

•

13.1.1 Using the Channel Calculator with Hydrologic Model Results

In this section of the tutorial, we will use the results from a HEC-l simulation
to demonstrate the functionality of the channel calculator.

I. Select New from the File menu.

2. Confirm that you want to delete everything.

3. Select the HydroLogic Modeling module icon j:.J.
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4. Select Open HEC-J File from the HEC-J menu.

5. Find and Open the file named "redri.hcJ".

6. Select Open... from the Hydrographs menu.

7. Find and Open the file named "redri.sol. ".

8. Select Show Hydrograph Window from the Display menu.

9. Select the hydrograph corresponding to the outlet "RED30" In the
Hydrologic Modeling window.

The hydrograph for the outlet point RED30 is now displayed In the
Hydrograph window.

Bring up the Channel Calculations dialog by going to the Calculators menu
and selecting Channels. Note the channel geometry options on the left side of
the dialog. You may want to click through them and note the different
parameters required for each. The trapezoidal channel option will be used for
this tutorial. To set up the channel calculator follow these steps:

1. Select the Trapezoidal channel option.

2. Enter 1.5 in the edit fields for Side slope 1 and Side slope 2.

3. Enter 5.0 in the Channel width box.

4. Enter 0.00 I for Longitudinal slope and 0.02 for Manning's roughness.

5. Make sure Enter Flow is selected above the channel diagram; note that
the maximum flow from the hydrograph selected above appears in the
edit field.

6. Select Calculate.

The calculated values for several channel parameters will appear on the left
side of the dialog. It may be useful to experiment with different channel
shapes to determine the channel that would best fit the given circumstances.
For example, you may want to try calculating the flow using a rectangular
channel with a depth of 12 feet. When done experimenting, select OK to close
the calculator.

•

•

13.1.2 Using the Channel Calculator with Cross-Section Data

In this section, you will learn how to use WMS to create a cross section of a
natural channel, then use the Channel Calculator to find stage (depth) in that
channel. •
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The cross section you will create is located immediately downstream from
Deer Creek Dam, Utah. To create this cross section:

1. Select New from the File menu.

2. Select the Map module icon!.

3. Select Open form the File menu. Find and open the deercrk.sup from
the tutorial directory.

This will read in and display a contoured DEM. You will note a red line in the
lower right of the DEM representing the location of Deer Creek Dam. By
tracing that line with a cross-section are, you will be able to create a natural
channel cross-section.

1. Select Coverages from the Feature Objects menu.

2. In the Coverages dialog, click on the New button to create a new
coverage (data layer).

3. Enter "Cross Sections" in the Name box to rename the coverage.

4. Select Cross-Section from the Attribute Set drop down box.

5. Click on OK.

You now have an active cross-section coverage. Any arcs created in this
coverage will represent cross sections and will derive station and elevation
information from the DEM or TIN in WMS. To create the cro,;:; section at the
dam:

1. Select the Create Arc tool.Ml.

2. Create an arc parallel to the red line representing Deer Creek Dam on
the DEM. Click to start at one end, click several times (9-10 times) as
you proceed to the other end, double-click to end. Your arc should
look similar to Figure 13-1.
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Figure 13·1 Cross section at Deer Creek.

Upon creating a cross section arc, WMS interpolates station and elevation data
to the cross section. To view and/or change this infonnation:

1. Select the SeLect Arc toolia

2. Double-click on the cross section arc to bring up the Cross Section
Editor.

In this dialog, you will see a profile plot of the cross section arc. You will also
see the station and elevation for each point (vertex) along the arc. Note also
that a Manning's roughness values may be set for each section of the arc.

You need not change any values in this dialog, but you may want to
experiment with the Z-scaLe option to view the cross section at a different Z
scale.

3. Enter "Deer Creek" in the Cross section name box.

4. Click OK.

You are now ready to use the Channel Calculator to analyze the Deer Creek
cross section.

4"'
1. Select the HydroLogic Modeling module icon2J.

2. Select ChanneLs ... from the CaLcuLators menu.

3. In the ChanneL Calculator dialog, select Cross Section from the
ChanneL type drop-down box.

4. Make sure that "Deer Creek" is the cross section selected in the Cross
Section drop-down box.

•

•

•
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Note that the cross section is plotted in the window in the lower right of the
dialog. This plot may be exaggerated in the Z direction for better visualization
if desired.

You will now determine the stage in the channel given the maximum spillway
and outlet capacity (12,000 cfs) of Deer Creek Dam.

1. Select the Enter Flow option in the upper right of the dialog. Enter
12000 in the corresponding box.

2. Ensure that English is selected in the Units box.

3. Enter 0.001 in the Longitudinal slope box.

4. Click Calculate.

Note in the window on the left of the dialog, the results of the calculation are
shown. The depth in the channel should be around 6 feet, which is acceptable
for this channel. Note that a blue line representing the water surface elevation
is plotted in the window in the lower right of the dialog. You may want to
change the Z-scale to view the plot better.

This concludes the section on using the Channel Calculator. However, you
may continue to experiment with different flows, depth, or channel types.

Weir Calculator

The weir calculator can be used to find the head over a weir at a given flow or
the flow over a weir given a head value. The following section will
demonstrate how to set up such a calculation. Following on the last example
of Deer Creek Dam, you will find out how much head is on the spillway at
peak capacity.

•

13.2.1 Using the Weir Calculator

1. Select Weirs... from the Calculators menu.

2. On the left side of the dialog, look at the options available and select
the Broad-Crested weir. Note that in the lower right comer, a default
weir coefficient for this weir type appears in the Weir coefficient edit
field. This value is a generally accepted coefficient for this weir type,
but may be edited.

3. Select Calculate head in the lower right of the dialog.

4. Enter 12000 in the Weir Flow box.

5. Enter 42.0 for the Weir length.
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6. Select Calculate.

Note the answer for the head is located in the lower right comer of the dialog
box (about 20 feet). It may be useful to experiment with different weir types
to see how they affect the head passing over the weir. For example, try a
Cipolletti with the same flow. It may also be of interest to calculate a flow
using a given head. Using the same weir type, select Calculate Flow and enter
head of 10.0. Select Calculate again to see the flow that would cause a 10.0 ft
head over the weir. Select OK to close calculator.

•
13.3 Detention Basin Calculator

The detention basin calculator may be used as purely a design tool or it may be
used to detennine the effects of a reservoir in a drainage unit. Storage
capacity curves andlor outflow hydrographs may be calculated using this tool.
In this example, the detention basin calculator will be used to find the effects
of a reservoir created in a drainage unit.

13.3.1 Opening a TIN file

I. Select New from the File menu.

2. Select the TINs module icon ~.

3. Select Open from the File menu.

4. Find and Open the file named "aspencal.tin".

13.3.2 Creating a Reservoir

We will create a reservoir to define detention basin geometry.

I. Select the Select TIN Vertices tool M.
2. Select the downstream most outlet of the TIN.

3. Select Create Reservoir from the Streams menu. The Reservoir dialog
will appear.

4. Enter 6190.0 in the Water surface elevation edit field, then click on
the feet radio button. Note that at the top of the dialog, the current
model units are shown to be meters; by clicking on the feet radio
button, you have indicated that the value you have entered is in feet
and that WMS will need to convert this value to be consistent with the
model units when doing computations. The option to select which
units you are entering allows you to work with whichever units you
desire. •
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5. Make sure the Create reservoir toggle is on, then select the Create
storage capacity toggle.

6. Enter 10 for the number of divisions.

7. Select the English units (acre-fr) radio button. This will instruct WMS
to create a storage capacity curve of acre-ft versus feet. The storage
capacity units options are meant to allow you to work with units which
you are most familiar.

8. Select OK.

You will see the Detention Basin Calculator dialog come up with a plot of
your storage capacity curve. You will now need to open a hydrograph file to
get the inflow to the reservoir.

9. Select OK in the Detention Basin Hydrograph Routing dialog.

13.3.3 Opening the Hydrograph File

An inflow hydrograph, to be used in conjunction with the detention basin
geometry, must also be imported for detention basin calculations.

1. Select the Tree module icon .:r1.
2. Select Open from the Hydrographs menu.

3. Find and Open the file named "aspencal.sol".

4. Select Show Hydrograph Window from the Display menu.

Hydrographs will appear on the TIN. Select the hydrograph corresponding to
the lowest outlet on the tree, where the reservoir was created. It will appear in
the Hydrograph window.

13.3.4 Using the Detention Basin Calculator

Now that a reservoir has been created and the hydrograph has been selected,
the Detention Basin calculator may be opened again.

1. Select Detention Basins ... from the Calculators menu.

The storage capacity curve should now be plotted in the dialog. To change
the format of the plot, click on the Plot Options button. You may then format
the plot as desired. If a hard copy of the curve is needed, the Print button will
allow you to print to a file or to a printer.

The next step is to define a discharge relationship for the reservoir:
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2. Select the Define button from the Elevation Discharge area on the
right side of the Detention Basin Hydrograph Routing dialog.

3. Select the Discharge Structures option.

4. Select the Add weir button; this will add spillway-type discharge
component.

5. Enter 10.0 in the Weir width box. (This represents the width of the
spillway).

6. Enter 3.367 in the Weir coefficient box (typical for a Cipolletti weir).

7. Enter 6185.0 in the Weir elevation box.

8. Select the Add Outlet button; this will add a low-level outlet discharge.

9. Make sure the outlet is selected in the Discharge structures window.

10. Enter 50.0 in the Outlet area box.

11. Enter 6100.0 in the Outlet elevation box.

12. Click OK.

You should now see and elevation-discharge curve plotted in the Detention
Basin calculator. You are now ready to perform the hydrograph routing
through the reservoir.

1. Click on the Compute Outflow Hydrograph button.

You should now see the routing hydrograph plotted on top of the original
hydrograph in the Hydrograph Window. Note that the reservoir has cut the
peak off the hydrograph and lengthened it. You may want to experiment with
different initial storage values (between 0.0 and 200.0) to see how that might
affect the outflow hydrograph.

This concludes the section on the Detention Basin calculator.

•

•

13.4 Culvert (HY-8) Calculator

In this section you will learn how to design a culvert using the Federal
Highway Administration Culvert Analysis computer program HY8. The
following example will guide you through the interface that permits easy data
entry, editing and computation.

Problem Statement •



•
Drainage Calculation Tools 13-9

Given the following site conditions, find a reinforced concrete box culvert that
will pass the 50-year flow rate of 400 cfs with a design headwater elevation of
195 ft and with a maximum discharge of 500 cfs.

The natural stream channel consists of a main channel in rock having a
Manning's roughness of 0.03 and overbanks having a roughness of 0.08. The
channel is on a 5% slope. A typical cross-section is shown below:

I·
LellOverba.k

l
Mai. Cba••el

l
Ri~hl Overbank

• = 0.08 • = O.OJ • = 0.08 ·1

Figure 13-2 Sample cross section.

The cross-section can be described by the following coordinates:

•
Horizontal Station (ft)

12
22
32
34
39
41
51
61

Elevation (ft)

180
175

174.5
172.5
172.5
174.5
175
180

The roadway profile near the culvert is a sag vertical curve. The road is paved,
with an embankment width of 50 ft. The following is a list of coordinates
which describe the vertical curve:

A profile of the culvert with the culvert invert data is shown below:

•

Horizontal Station (ft)

o
100
200
300
360
400
500
600
720

Elevation (ft)

199.2
197.5
196.5
196.0
196.0
196.2
197.0
198.5
201.0

I
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Elev: 196.0

Elev: 195.0 -/-g.><--/

Elev: 117.5 _l~I~~"~':================:::::~~~:~:~=======~=~~~""~J-- s. : 0.05 (VI, -Elev: 1l1.1
I

S": 400

Agure 13-3 Culvertprofile.

As an initial size estimate a 5'x5' box concrete culvert assuming a
conventional inlet with 1: 1 bevels and 45 degree wingwal1s.

•

13.4.1 Entering Culvert Information

1. Select the HY8 CuLvert AnaLysis command from the CaLcuLators menu.
This will bring up the HY8 Culvert Analysis dialog.

2. Change the Discharge data, minimum to 0.0, maximum to 500 and
design to 400.

3. Click on the Create/Edit cuLvert data button. This will bring up the
HY8 Culvert Data dialog.

4. Make sure that the CuLvert invert data option is selected.

5. Enter culvert data for upstream. Change Station to 100 and Elevation
to 187.5.

6. Enter culvert data for downstream. Change Station to 400 and
ELevation to 172.5.

7. Choose Box-Concrete from CuLvert Shape selection list.

8. Change Span to 5 and Rise to 5.

9. Accept the default Number of barreLs i.e. I.

10. Accept the default Manning's n, which would be 0.012.

II. Click on the InLet data button. This will bring up the HY8 Culvert
Inlet dialog.

12. Choose conventional inlet type.

13. Choose I: I bevels with 45 degree wingwalls from the fillet

Condition/Edge selection list.

•

•
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14. Click on the OK button to close the HY8 Culvert Inlet dialog.

15. Click on the OK button to close the HY8 Culvert Dat~ dialog.

Entering the Tailwater Channel Information

1. Click on the Create/Edit tai/water data button. This will bring up the
HY8 Tailwater Data dialog.

2. Select the Irregular Channel rating curve option.

3. Click on the Irregular Channel button to specify the irregular channel
properties. This will bring up the HY8 Irregular Channel dialog.

4. Change channel slope to 0.05.

5. Change number ofcross-section coordinates to 8.

6. Choose Lt_Rt over banks and main channel as the subchannel option.

7. Change left overbank coordinate to 3.

8. Change right overbank coordinate to 6.

9. Change Manning's roughness for left section to 0.08.

10. Change Manning's roughness for main section to 0.03.

11. Change Manning's roughness for right section to 0.08.

12. Click on the Define/Edit Cross-Section button to specify the irregular
channel geometry. This will bring up the Cross Section Editor.

13. Enter 8' pairs of station-elevation values. The values are (12,180),
(22,175), (32,174.5), (34,172.5), (39,172.5), (41,174.5), (51, 175), and
(61, 180).

14. Click on the OK button to close the Cross Section Editor.

15. Click the View rating curve data button to compute the rating curve
and display the information.

16. Click the Save tailwater file button to bring up the file manager.
Specify hy80 l.tw as the file name and save the file.

17. Click on the OK button to close the HY8 Irregular Channel dialog.

18. Click on the OK button to close the HY8 Tailwater Data dialog.
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13.4.3 Entering the Roadway Information

I. Click on the Create/Edit roadway data button. This will bring up the
HY8 Roadway Data dialog.

2. Choose irregular profile option.

3. Change the number ofcoordinates to 9.

4. Change the roadway top width to 50.

5. Click on the Profile button to specify the irregular roadway profile.
This will bring up the Cross Section Editor.

6. Enter 9 pairs of station-elevation values. The values are (0,199.2),
(l00,197.5), (200,196.5), (300,196.0), (360,196.0), (400,196.2), (500,
197), (600, 198.5) and (720, 201.0).

7. Click on the OK button to close the Cross Section Editor.

8. Choose paved roadway surface.

9. Click on the OK button to close the HY8 Roadway Data dialog.

13.4.4 Performing Culvert Analysis

The data already entered in the previous sections must be sav.::') in order to
perform any computation.

1. Click on the Save input file button. This will bring up the file manager.
Specify hy80 l.inp as the file name and save.

2. Choose Full Flow option for outlet control.

3. Choose Single culvert output table for computation.

4. Click on the Compute button.

5. Click on the View button to display the result.

In the result, find the headwater elevation at 400 cfs and compare with the
design value of 195 feet. It may turn out that the 5'x5' culvert is inadequate for
the site conditions. You are encouraged to test with different sizes, suppose a
6' x6' culvert or larger in order to determine the required culvert size.

•

•

•
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Conclusions

This tutorial has demonstrated the basic functionality of the drainage
calculators in WMS. Design and/or modeling of channels, weirs, detention
basins, and culverts is possible using these calculators.
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Flood Plain Delineation
14

•

•

Estimated Time: 25 minutes.

In addition to drainage basin analysis, WMS also contains flood plain
delineation features that can be used to define flood plain boundaries on any
TIN. Flood plains are delineated from stage values that are entered at various
locations on a TIN. Stage values are defined as the difference between the
flood water surface elevation and the normal TIN elevation.

This tutorial will guide you through the steps for entering, saving, and reading
stage values from a file. It will also show how to delineate flood· plains from
stage values, adjust the flood plain delineation parameters, and save or read
stage values from a file

14.1 Delineating Flood Plains

In this tutorial you wi11learn the steps for entering stage values at points on a
TIN and then how to delineate the flood plain boundary represented by these
stage values. The topics covered include the following:

• Editing the stage value at TIN vertices.

• Reading stage values from a file.

• Using the Interpolate Stage command.

• Delineating a flood plain from TIN stage values.

• Comparing stream-based and flat flood plain delineation.
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• Changing the flood plain delineation parameters.

• Saving and reading stage values to and from files. •
14.2 Editing Stage Values

To begin editing stage values, do the following:

1. Select the TINs module icon a.
2. Select Open from the File menu.

3. Locate and select the file called "ding.tin". It is located in the tutorial
directory by default.

4. Select the Display Options command from the Display menu.

5. Be sure that Triangles, Vertices, and Boundaries are toggled on, and
everything else is off.

6. Select the Drainage tab.

7. Make sure that the display of Outlets and Stream networks are on.

8. Select OK.

With the TIN file read in and the display of vertices and stream networks on,
you are ready to define stage values on the TIN. Stage values can be defined
by selecting vertices on the TIN and entering a stage value, as shown by the
following example:

1. Click on the Select Vertices i,ll tool.

2. Click on the outlet of the stream network. By default, outlets are
displayed as a black circle with a yellow center.

3. Select the Edit stage command from the Flood menu.

4. Enter the value 4.0 in the Enter new vertex stage field.

5. Select OK.

6. While holding the SHIFf key down, select four or five additional
vertices on the stream.

7. Select the Edit stage command from the Flood menu.

8. Enter the value 3.5 in the Enter new vertex stage field.

•

•
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9. Select OK.

For each stream node that was given a stage value, a vertical red bar will be
drawn with a length proportional to the stage value at that node.

Interpolating Stage Values

When stage values are defined at locations on a stream, stage values for other
locations on the stream can be linearly interpolated. By editing the stage
values at the outlet and branching nodes, we have entered stage values for
points that are on the stream network.

1. Select the Interpolate Stage command from the Flood menu.

The interpolated stage values for stream nodes that lie between stream nodes
where stage was defined will now be displayed with a pink bar. Note that this
interpolation can only be applied to stream nodes that lie along a stream
between two stream nodes where stage has been defined.

Flood Display Options

A display option can be set to view both fixed and interpolated stage values by
following these steps:

1. Select the Display Options command from the Display menu.

2. Select the Flood tab.

3. Turn on the display offixed and interpolated stage values.

4. Click on the OK button.

This allows you to check the values that will be used in the delineation of the
flood plain. If any value is incorrect, that node can be selected and the stage
value edited as described above.

With display of both fixed and interpolated values, it is often hard to read all
of the stage values since the values overlap each other. The zoom tool can be
used to inspect the values on the stream a portion at a time. Additionally,
viewing the display of fixed and interpolated values separately may eliminate
the overlapping problem.

The flood display options dialog box allows many additional changes to be
made in the display of the stage values, including line thickness, style and
color. This can be done by clicking on the color box next to each display
option.. The relative height of the stage bars in terms of # of pixels/unit of
stage value can also be changed. You are encouraged to experiment with these
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parameters until you feel comfortable with the different display options that •
are available to you.

14.5

14.6

Delineating Flood Plains

Once stage values have been defined on a TIN, you are ready to delineate the
flood plain. To delineate the flood plain, do the following:

1. Select the Display Options command from the Display menu.

2. Select the Flood tab.

3. Turn off the display offixed and interpolated stage values.

4. Select OK.

5. Select the Delineate Flood command from the Flood menu.

The flood plain was delineated using the· stage values found at the stream
nodes where stage values were input, or stages that were interpolated along the
stream. Using streams to help define the flood plain gives the best results. In
order to be able to perform stream-based flood plain delineation, WMS must
have at least two stream nodes with defined stage values. If there are vertices •
on a stream without stage values defined andno downstream stream vertex has
a defined stage value, no stage values for these stream nodes can be
interpolated. The closest upstream stage value is assumed to represent the
water surface elevation for the downstream remainder of the TIN. To see an
example of this effect, do the following:

1. Select on the Select Vertices. tool.

2. Click on the outlet of the TIN (black circle with yellow center).

3. Select the Remove Stage command from the Flood menu.

4. Select the Delineate Flood command from the Flood menu.

The flood plain will look similar to the previous flood plain, except for the
portion of the stream near the outlet are omitted.

Reading and Saving Stage Files

Stage values can be saved to and read from files.

1. Select the Remove Stage command from the Flood menu. Confirm •
that all stage values will be removed.
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2. Select. the R.eCfd. Stage command from the Flood menu. Locate and
Open the file called "ding.stg".

Stage values that you define can be saved to a file using the Save Stage
command in the Flood menu.

Reading a Super File with Pre-Defined Flood Files

The blackriv.sup file is a WMS super file that contains a TIN file, a stage file,
and a map file. The TIN is a portion of a watershed in the western Adirondack
Mountains. The stage file contains several key locations along the Black
River for which stage is known during a flood event. This file can be read in
by doing the following:

1. Select the New command from the File menu.

2. Confirm that you want all data deleted.

3. Select the Open command from the File menu.

4. Using the file browser find and Open the "blackriv.sup" file.

This model shows a basin delineation of the Black River in northwestern New
York on the western slopes of the Adirondacks. The polygon identified as the
flats is subject to flooding during spring runoff. A separate, more detailed TIN
of the flats was created and used for flood plain delineation. To see this TIN:

1. Select the New command from the File menu.

2. Confirm that you want all data deleted.

3. Select the Open command from the File menu.

4. Using the file browser find and Open in the ''flood. sup " file.

In addition to the TIN, a map file is read in which shows the main channel as
well as major roads and railroads in the flood plain. Once the flood plain has
been delineated you will be able to see the portions of the road and railroad
endangered by the high waters.

1. Select the Delineate Flood command from the Flood menu.

Display Options

So far, only an outline of the flood plain has been shown. Besides drawing the
boundary you can also have the flood plain filled with a solid color or
contoured according to depth.
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1. Select the Display Options command from the Display menu.

2. Select the Flood tab.

3. Turn on the Flood plain color filled option.

4. Select OK.

Besides showing the extents of the flood plain, you can also display it using
contours.

1. Select the Display Options command from Display menu.

2. Select the Flood tab.

3. Turnoff the Flood plain color filled option.

4. Turn off the Fixed and Interpolated stage options.

5. Turn on the display option for Flood plain contours.

6. Select the Contours... button to access the Contour Options dialog.

7. Make sure the Color/ill between contours is mrned on.

8. Select OK.

9. Select OK.

•

•
14.9 Conclusions

This concludes the Flood plain delineation tutorial. You are encouraged to
experiment with all of the commands explained in this section until you feel
comfortable with the tools available to you for delineating flood plains.

•
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